#debian-kernel Meeting

Meeting started by carnil at 19:00:12 UTC (full logs).

Meeting summary

  1. Interest to look into ITS mitigation patches for 5.10.y (carnil, 19:02:10)
    1. https://lore.kernel.org/stable/20250610-its-5-10-v1-0-64f0ae98c98d@linux.intel.com/ (carnil, 19:02:40)
    2. ACTION: bwh will review and test ITS mtiigation backport to 5.10 (bwh, 19:04:10)
    3. ACTION: bwh will look at feasibility of mitigated BHI in 5.10 (bwh, 19:06:56)

  2. #1088522: nouveau: Unable to boot with 3 monitors on Nvidia GPU (carnil, 19:07:23)
  3. #1100153: linux: hangs on resume from suspend or hibernation with 6.12-6.13 on ThinkPad X1 Carbon Gen 10 (carnil, 19:08:04)
  4. #1107142: linux-image-6.12.27-amd64: mpt3sas LSI SAS2008 [1000:0072] probe failure - BAR 1 reservation error (carnil, 19:09:14)
    1. ACTION: ukleinek will ping Bjorn again in irc regarding #1107142 and the provided boot logs (carnil, 19:11:10)

  5. #1107521: linux-image-6.12.27+bpo-amd64: ath12k_pci errors and eventual kernel panic starting with linux-image-6.12.27+bpo-amd64 (carnil, 19:11:47)
  6. #1108082: linux-image-6.12.32-amd64: Crash (carnil, 19:14:14)
  7. #1108168: linux-image-6.12.32-amd64: black screen, then crash in nouveau when rebooting (carnil, 19:16:56)
  8. #1108494: USB 3.2 connector Gen 1 port not working, kernel panics with mouse on right USB port (carnil, 19:19:59)
  9. #1108598: amdgpu: incorrectly redrawn screen after resuming from hibernation with Ryzen 5 2400G (carnil, 19:20:37)
    1. ACTION: carnil marks #1108598 as fixed with 6.12.32-1 (carnil, 19:23:15)
    2. ACTION: carnil tells reporter of #1108598 that if running bpo is fine for reporter we move on on the issue and close it with 6.12.32-1 (carnil, 19:24:15)

  10. #1108965: linux: Enable RTL8851BE module (carnil, 19:24:46)
  11. #1104269: linux-image-6.12.22-amd64: amdgpu flip_done and commit wait timeouts during normal use - causes session lockup (carnil, 19:26:46)
    1. ACTION: carnil follows up on #1104269 asking to still fill a new upstream issue and report back. (carnil, 19:29:36)

  12. #1108324: linux-image-6.15-rt-amd64: i915 module nonexistent (carnil, 19:32:25)
    1. ACTION: bwh will try to make progress on i915 vs PREEMPT_RT, possibly by proposing his own patch (bwh, 19:35:55)

  13. #1108860: linux-image-6.1.0-34-amd64: Wireguard fragmentation fails with VXLAN since kernel 6.1.0-34, causing network timeouts (carnil, 19:36:31)
    1. ACTION: carnil ask reporter of #1108860 to test additonally 6.1.y + revert of b88786ea2c8f3d5ca1c7c9a69c0b0b7befdfbae8 (carnil, 19:42:44)

  14. #1100105: linux-image-amd64: Issues with Framework audio module (carnil, 19:43:12)
    1. ACTION: ukleinek to follow up on #1100105 with systemctl daemon-reexec, stopping wireplumber before suspend ... (ukleinek, 19:50:36)

  15. #1108037: linux-perf: perf report --demangle only works on some(?) symbols (carnil, 19:54:35)
    1. ACTION: bwh takes care of following up on #1108037 (carnil, 19:55:56)

  16. #1108294: kernel 6.12 breaks cgroup awareness of openjdk 21 (carnil, 19:56:08)
  17. #1108496: linux-image-6.12.30+bpo-amd64: USB audio glitches: retire_capture_urb (carnil, 19:57:14)
  18. #1108609: Very often fails do detects external monitors connected via Dock and USB-C (carnil, 19:57:39)
  19. 851404: linux-image-4.8.0-2-amd64: Internal speakers don't work after standby on a Toshiba z20t-c-121 (carnil, 19:59:03)
  20. (carnil, 20:00:20)
    1. ACTION: bwh will forward #1109015 upstream (bwh, 20:00:42)

  21. (carnil, 20:01:08)
  22. #1108250: (n, M) firmware-intel-graphics: i915 timeout errors after firmware upgrad (ukleinek, 20:01:45)
  23. migration excuses + new upstream versions (carnil, 20:02:42)
  24. merge requests (carnil, 20:06:28)
    1. https://bugs.debian.org/release-critical/ says 157 rc bugs left (ukleinek, 20:06:48)

  25. AoB? (carnil, 20:11:29)
    1. ACTION: bwh will chair next weeks meeting (carnil, 20:14:43)


Meeting ended at 20:15:02 UTC (full logs).

Action items

  1. bwh will review and test ITS mtiigation backport to 5.10
  2. bwh will look at feasibility of mitigated BHI in 5.10
  3. ukleinek will ping Bjorn again in irc regarding #1107142 and the provided boot logs
  4. carnil marks #1108598 as fixed with 6.12.32-1
  5. carnil tells reporter of #1108598 that if running bpo is fine for reporter we move on on the issue and close it with 6.12.32-1
  6. carnil follows up on #1104269 asking to still fill a new upstream issue and report back.
  7. bwh will try to make progress on i915 vs PREEMPT_RT, possibly by proposing his own patch
  8. carnil ask reporter of #1108860 to test additonally 6.1.y + revert of b88786ea2c8f3d5ca1c7c9a69c0b0b7befdfbae8
  9. ukleinek to follow up on #1100105 with systemctl daemon-reexec, stopping wireplumber before suspend ...
  10. bwh takes care of following up on #1108037
  11. bwh will forward #1109015 upstream
  12. bwh will chair next weeks meeting


Action items, by person

  1. bwh
    1. bwh will review and test ITS mtiigation backport to 5.10
    2. bwh will look at feasibility of mitigated BHI in 5.10
    3. bwh will try to make progress on i915 vs PREEMPT_RT, possibly by proposing his own patch
    4. bwh takes care of following up on #1108037
    5. bwh will forward #1109015 upstream
    6. bwh will chair next weeks meeting
  2. carnil
    1. carnil marks #1108598 as fixed with 6.12.32-1
    2. carnil tells reporter of #1108598 that if running bpo is fine for reporter we move on on the issue and close it with 6.12.32-1
    3. carnil follows up on #1104269 asking to still fill a new upstream issue and report back.
    4. carnil ask reporter of #1108860 to test additonally 6.1.y + revert of b88786ea2c8f3d5ca1c7c9a69c0b0b7befdfbae8
  3. ukleinek
    1. ukleinek will ping Bjorn again in irc regarding #1107142 and the provided boot logs
    2. ukleinek to follow up on #1100105 with systemctl daemon-reexec, stopping wireplumber before suspend ...


People present (lines said)

  1. carnil (139)
  2. ukleinek (51)
  3. bwh (48)
  4. waldi (4)
  5. KGB (4)
  6. MeetBot (3)
  7. yunseongkim[m] (1)


Generated by MeetBot 0.1.4.