19:00:12 <carnil> #startmeeting
19:00:12 <MeetBot> Meeting started Wed Jul  9 19:00:12 2025 UTC.  The chair is carnil. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:12 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:00:19 <bwh> Hi
19:00:56 <carnil> hi all, welcome to todays meeting, first an apology had bit stressfull afternoon only finished some minutes ago ammending the meeting preparation
19:01:17 <carnil> #chair carnil bwh ukleinek waldi
19:01:17 <MeetBot> Current chairs: bwh carnil ukleinek waldi
19:01:23 <waldi> hi
19:01:40 <carnil> before we dig into the bug list, I have a slight offtopic question
19:02:10 <carnil> #topic Interest to look into ITS mitigation patches for 5.10.y
19:02:24 <ukleinek> ITS?
19:02:27 <carnil> a while back ITS mitigations were applied to various stable kernel series, but not back to 5.10.y
19:02:35 <carnil> context: https://lore.kernel.org/stable/aEQHkmGXOel3BcOF@eldamar.lan/
19:02:40 <carnil> https://lore.kernel.org/stable/20250610-its-5-10-v1-0-64f0ae98c98d@linux.intel.com/
19:02:51 <bwh> I meant to look at this but I think I forgot
19:03:05 <carnil> questions goes maybe mainly to bwh: is there interest to look into these or should we state we do not have the capacities?
19:03:38 <ukleinek> Pawan wrote to look into that
19:03:40 <bwh> I can spend some time to review and do a little testing
19:04:10 <bwh> #action bwh will review and test ITS mtiigation backport to 5.10
19:04:10 <carnil> ukleinek: he did and posted a RFC series, but would explicitly want some feedback before submitting for real and Greg accepting them
19:04:17 <carnil> ack thanks bwh
19:04:23 <carnil> so ready to go to the buglist?
19:04:28 <bwh> I think you mentioned another mitigation that was missing for 5.10?
19:04:31 <KGB> 03initramfs-tools 05debian/latest 06Benjamin Drung * [update] merge request !172: Draft: Use 3cpio for unmkinitramfs/lsinitramfs if available * 14https://salsa.debian.org/kernel-team/initramfs-tools/-/merge_requests/172
19:05:17 <carnil> bwh: yes
19:05:34 <carnil> the Native BHI vulneraility mitigations were as well not backported
19:05:47 <carnil> so the question was if it is worth at all since it's in similar class
19:06:01 <bwh> right
19:06:15 <bwh> well I can look at that too and see if it's feasible
19:06:24 <carnil> many thanks Ben
19:06:43 <bwh> I have done some of these backports myself before, but just haven't been "in the loop" regarding recent CPU mitigations
19:06:56 <bwh> #action bwh will look at feasibility of mitigated BHI in 5.10
19:06:59 <carnil> yes same for me, I was not included neither this time
19:07:23 <carnil> #topic #1088522: nouveau: Unable to boot with 3 monitors on Nvidia GPU
19:07:35 <carnil> @ukleinek pinged the reporter about further debugging, waiting for reply. -> i.e. wait
19:07:47 * ukleinek nods
19:08:01 <bwh> OK
19:08:04 <carnil> #topic #1100153: linux: hangs on resume from suspend or hibernation with 6.12-6.13 on ThinkPad X1 Carbon Gen 10
19:08:18 <carnil> Some incosistent results from bisect. ukleinek sked back to test three commits explicitly to narrow down if the bisect is correct respetively to gather a better understanding.
19:08:36 <carnil> I think here as well there is at the moment nothing more we can do until hearing back that the bisect was done correctly
19:08:36 <ukleinek> no reply :-\
19:08:48 * ukleinek nods again
19:09:01 <carnil> the next one at least is actionable :)
19:09:14 <carnil> #topic #1107142: linux-image-6.12.27-amd64: mpt3sas LSI SAS2008 [1000:0072] probe failure - BAR 1 reservation error
19:09:28 <ukleinek> I would have hoped that upstream chimes in
19:09:31 <carnil> we got boot logs with the requested variants booting with pci=realloc=off and not
19:09:57 <carnil> (upstream is as well in the loop on that)
19:10:41 <ukleinek> I'll ping Bjorn again in irc, where we talked before and he requested the two bootlogs
19:10:43 <carnil> ukleinek: would it help sorting out the differnces and re-iterate them into a reply to gather the attention of the upstream people on the linux-pici list?
19:11:10 <carnil> #action ukleinek will ping Bjorn again in irc regarding #1107142 and the provided boot logs
19:11:25 * ukleinek was about to type something similar
19:11:47 <carnil> #topic #1107521: linux-image-6.12.27+bpo-amd64: ath12k_pci errors and eventual kernel panic starting with linux-image-6.12.27+bpo-amd64
19:12:16 <carnil> we asked here the rporter to bisect IIRC, but reporter when the other way and started to cherry-pick patches
19:12:25 <carnil> Reporter said he continues to test his patched branch to make sure it is not a false positive with the applied patches
19:12:57 <carnil> I would suggest we wait maybe one more week and then ask back on the status (and tag it moreinfo then)
19:13:02 <carnil> other ideas welcome :)
19:13:40 <ukleinek> ack for waiting
19:14:14 <carnil> #topic #1108082: linux-image-6.12.32-amd64: Crash
19:14:23 <bwh> Love the subject line
19:14:40 <carnil> another waiting task. Reporter sucessfully set up a netconsole, now waiting that the crash occures to gather the logs
19:14:46 <carnil> bwh: ack, yes maybe we should retitle it
19:15:09 <carnil> but so far we do not even know where it crashes
19:15:37 <carnil> we hoped to gather more actionable information by getting the logs through the netconsole
19:15:46 <bwh> right
19:15:56 <carnil> so I have no idea what to write into subject
19:16:23 <ukleinek> It's ok to keep the (technically correct) subject for now IMHO
19:16:36 <carnil> in any case, action is "wait"
19:16:44 * ukleinek nods once more
19:16:56 <carnil> #topic #1108168: linux-image-6.12.32-amd64: black screen, then crash in nouveau when rebooting
19:17:25 <carnil> thanks bwh for digging into it. bwh asked back to Vincent if he can reliably reporduce which would help for further debugging afater the analysis.
19:17:27 <ukleinek> +1 for `bts tag 1108168 + moreinfo`
19:17:55 <ukleinek> ah, already happend
19:17:55 <bwh> It is...
19:18:16 <ukleinek> ..ooOO(Even in the agenda! :-)
19:18:33 <carnil> yes my fault
19:18:49 <ukleinek> In die Ecke mit Dir!
19:18:59 <ukleinek> :-)
19:19:30 <carnil> so wait ...
19:19:51 <carnil> while we wait we can do some more useful things ;-)
19:19:59 <carnil> #topic #1108494: USB 3.2 connector Gen 1 port not working, kernel panics with mouse on right USB port
19:20:12 <carnil> Waiting for reporter to do the additional requested testing.
19:20:15 <bwh> right
19:20:35 * ukleinek nods
19:20:37 <carnil> #topic #1108598: amdgpu: incorrectly redrawn screen after resuming from hibernation with Ryzen 5 2400G
19:20:41 <KGB> 03initramfs-tools 05pipeline 06Ben Hutchings 890166 * [27 minutes and 16 seconds] 03success (shellcheck: success; blhc: success; missing-breaks: failed; piuparts: success; extract-source: success; build i386: success; build source: success; build: success; test-build-all: success; reprotest: success; test-build-any: success; lintian: success; autopkgtest: success)
19:20:46 <carnil> this one might benefit from some input.
19:21:03 <carnil> the repoter (AFAIU) said he would be fine to just run the backports kernel
19:21:18 <carnil> not sure if we should be satisfied with that or try to invest more time
19:21:39 <carnil> OTOH we have so many amdgpu related bugs
19:22:01 <carnil> we can mark the issue fixed with the bpo kernel version and it moves away from our radar
19:22:32 <ukleinek> sounds good. If only all amdgpu bugs were fixed on 6.12 ....
19:22:55 * ukleinek agrees that our time is better spent elsewhere
19:23:13 <bwh> I don't have any suggestion
19:23:15 <carnil> #action carnil marks #1108598 as fixed with 6.12.32-1
19:23:22 <carnil> ^^ so let's do that
19:23:35 <ukleinek> maybe also tell him that we spend our energy elsewhere
19:24:15 <carnil> #action carnil tells reporter of #1108598 that if running bpo is fine for reporter we move on on the issue and close it with 6.12.32-1
19:24:25 <carnil> ukleinek: ^^ better?
19:24:46 <carnil> #topic #1108965: linux: Enable RTL8851BE module
19:24:58 <ukleinek> sure, I would have trusted you about that even without explict statement
19:25:30 <carnil> bwh: prepared merge request. Intended to take it for merging, as I intent to upload 6.12.37 once released with the new TSA mitigations.
19:25:42 <carnil> (along with the other one bwh assigned already to me)
19:25:59 <KGB> 03linux 05debian/latest 06Uwe Kleine-König * [approved] merge request !1570: rtw89: Enable RTW89_8851BE, RTW89_8852BTE as modules * 14https://salsa.debian.org/kernel-team/linux/-/merge_requests/1570
19:26:04 <carnil> if that's fine with everybody obviously.
19:26:15 <bwh> OK
19:26:28 <ukleinek> +1
19:26:46 <carnil> #topic #1104269: linux-image-6.12.22-amd64: amdgpu flip_done and commit wait timeouts during normal use - causes session lockup
19:26:56 <KGB> 03linux 05debian/latest 06Uwe Kleine-König * [approved] merge request !1571: rtw88: Enable RTW88_8821AU, RTW88_8812AU, RTW88_8814AE, RTW88_8814AU as modules * 14https://salsa.debian.org/kernel-team/linux/-/merge_requests/1571
19:27:06 <carnil> there is a legtimate question from the reporter:
19:27:33 <carnil> he finds there are so many flip  related issues upstream in amdgpu, is it still worth reporting a separate issue?
19:27:57 <ukleinek> from the reporter's POV I'd claim yes.
19:27:59 <carnil> I awas not able to find an exact duplicate, but have not spend a lot of time last week on it
19:28:44 <carnil> ukleinek: then we suggest the reporter to still fill an issue, ok?
19:28:50 <bwh> I think so
19:28:53 <ukleinek> yupp
19:29:08 <carnil> should I since I was already in contact.
19:29:35 <bwh> The issue linked is reported as present up to and including 6.15.3, while the reporter says 6.15.4 is stable. So *maybe* it is the same and is fixed in 6.15.4, but it could well be different.
19:29:36 <carnil> #action carnil follows up on #1104269 asking to still fill a new upstream issue and report back.
19:30:01 <ukleinek> For upstream having active reporters/testers is also beneficial
19:30:59 <carnil> I just realize again, it's not the same reporter, but we discussed that last time I think already
19:32:10 <carnil> so let's do as with action above and let him report upstream a new issue
19:32:15 <bwh> OK
19:32:25 <carnil> #topic #1108324: linux-image-6.15-rt-amd64: i915 module nonexistent
19:32:33 <carnil> Progress: https://lists.debian.org/debian-kernel/2025/07/msg00098.html
19:33:24 <bwh> Right. There's enough information there that I could consider writing a patch myself. But I wouldn't be able to test until I get home.
19:34:07 <ukleinek> the reporter of that bug should be a willing tester
19:34:44 <ukleinek> (Without implying anything about the timeframe for a patch)
19:35:08 <carnil> bwh: want to formulate this as an action?
19:35:55 <bwh> #action bwh will try to make progress on i915 vs PREEMPT_RT, possibly by proposing his own patch
19:36:12 <carnil> bwh: thanks!
19:36:31 <carnil> #topic #1108860: linux-image-6.1.0-34-amd64: Wireguard fragmentation fails with VXLAN since kernel 6.1.0-34, causing network timeouts
19:36:34 <bwh> ukleinek: As this is going to be quite a big change I think I would feel bad about asking someone else to test it when I can do so
19:36:59 <ukleinek> bwh: fair
19:37:16 <ukleinek> ..ooOO(beta tester then)
19:37:48 <carnil> reporter confirmed they are going to try to bisect, but will need time as servers are in production. So we have to wait here, but I expect we will get back with a result of finding offending changes.
19:37:51 <bwh> Hmm, I saw a recent kernel fix related to PMTU discovery but I don't know if it could be related t othis
19:38:15 <carnil> bwh: in version after 6.12.35 and 6.15.4?
19:38:24 <bwh> actually not that recent but I saw it recently
19:38:57 <ukleinek> funny, I think some freifunk people also do vxlan over wireguard, they might be affected, too.
19:39:57 <carnil> bwh: the one change I see related to PMTU would be b88786ea2c8f3d5ca1c7c9a69c0b0b7befdfbae8 tunnels: Accept PACKET_HOST in skb_tunnel_check_pmtu().
19:40:06 <carnil> and that falls exactly in the range the reporter claims it breaks
19:40:29 <carnil> above is in 6.1.134, and reporter said 6.1.133-1 was fine and 6.1.135-1 broke
19:40:37 <bwh> That is much more likely to be it
19:40:56 <yunseongkim[m]> s/DevCamp/DebCamp/
19:41:06 <ukleinek> So let's ask them to test 6.1.$new with b88786ea2c8f3d5ca1c7c9a69c0b0b7befdfbae8 reverted?
19:41:54 <carnil> that would make sense indeed and would shortcut a bit the testing
19:42:09 <carnil> I think I would just ask that
19:42:17 <ukleinek> 👍
19:42:44 <carnil> #action carnil ask reporter of #1108860 to test additonally 6.1.y + revert of b88786ea2c8f3d5ca1c7c9a69c0b0b7befdfbae8
19:43:04 <carnil> oh we are progressing fast timewise
19:43:12 <carnil> #topic #1100105: linux-image-amd64: Issues with Framework audio module
19:43:29 <carnil> Feedback from the reporter arrived. Removing moreinfo tag to put it back on our radar.
19:43:55 <carnil> ukleinek: do you have ideas on that?
19:44:51 <ukleinek> hmm, no, not even an idea if this is a software or hardware/firmware problem.
19:46:10 <ukleinek> it's strange that 1 out of (at least) 3 usb devices has problems that cannot be cured by neither replugging nor bus driver reload.
19:46:25 <bwh> yes
19:47:19 <ukleinek> is kexec easy to do for the reporter? That could give a hint if it's software or hardware related
19:47:52 <bwh> kexec brings its own set of driver bugs
19:48:19 <ukleinek> or might it be related to userspace somehow? Then a systemd restart? (There was something like that, wasn't it?)
19:49:09 <bwh> Maybe restart the wireplumber service?
19:49:22 <bwh> (assuming that's being used)
19:50:05 <carnil> ukleinek: do you mean systemctl deamon-reexec?
19:50:36 <ukleinek> #action ukleinek to follow up on #1100105 with systemctl daemon-reexec, stopping wireplumber before suspend ...
19:50:45 <bwh> It's not totally clear to me now whether the kernel is detecting the sound device or not...
19:51:44 <ukleinek> carnil: no, that's not it. IIRC there was something that does the userspace-part of system shutdown and then make systemd start all services again.
19:52:14 <bwh> systemctl soft-reboot, I think
19:52:25 <ukleinek> yes, just found that, too.
19:52:50 <bwh> That does seem worth trying
19:52:55 <carnil> ack
19:53:35 * ukleinek will take care
19:53:52 <carnil> have you still enough energy? we are approaching 22:00 so either skip the remining bugs or conclude the list and move to MRs and AoB
19:54:35 <carnil> #topic #1108037: linux-perf: perf report --demangle only works on some(?) symbols
19:54:39 <bwh> I'm OK to continue through the list
19:54:50 * ukleinek is still ready to tackle more, but won't argue if we complete the meeting soon
19:55:02 <carnil> reporter commented today with further information. bwh I saw you re on it, correct?
19:55:07 <bwh> This looks like Clang introduced an extension that the GNU toolchain doesn't yet support
19:55:21 <bwh> I will continue to take care of this
19:55:56 <carnil> #action bwh takes care of following up on #1108037
19:56:08 <carnil> #topic #1108294: kernel 6.12 breaks cgroup awareness of openjdk 21
19:56:35 <carnil> MR from ben, ready to go, will merge after the meeting. Side-question was if we should report regression upstream, with some doupts though
19:56:44 <carnil> (which I see ben as well already did :))
19:57:14 <carnil> #topic #1108496: linux-image-6.12.30+bpo-amd64: USB audio glitches: retire_capture_urb
19:57:24 <carnil> waiting for user feedback after questions from Ben
19:57:39 <carnil> #topic #1108609: Very often fails do detects external monitors connected via Dock and USB-C
19:57:53 <carnil> issue is reported upstream, https://gitlab.freedesktop.org/drm/amd/-/issues/4384 but so far no action there
19:57:58 <carnil> -> wait?
19:58:15 * ukleinek nods (and considers creating a macro for nodding)
19:58:18 <bwh> OK
19:58:54 <carnil> last src:linux issue
19:59:03 <carnil> #topic 851404: linux-image-4.8.0-2-amd64: Internal speakers don't work after standby on a Toshiba z20t-c-121
19:59:38 <carnil> questions back from ukleinek, no reply from reporter so far, tagged moreinfo until getting a reply
19:59:39 * ukleinek did `bts tag 851404 + moreinfo`
19:59:56 <ukleinek> dang, already was tagged
20:00:20 <carnil> #topic
20:00:20 <carnil> #1109015: (G, ) Wifi not working anymore with new atheros firmware from experimental
20:00:27 <carnil> this is new from today
20:00:35 <carnil> but only affecting experimental
20:00:42 <bwh> #action bwh will forward #1109015 upstream
20:01:06 <carnil> thanks :)
20:01:08 <carnil> #Topic
20:01:08 <carnil> #1108250: (n, M) firmware-intel-graphics: i915 timeout errors after firmware upgrade
20:01:21 <carnil> dang, sorry for typo
20:01:43 <carnil> waiting for more information from reporter (questions from bwh)
20:01:45 <ukleinek> #topic #1108250: (n, M) firmware-intel-graphics: i915 timeout errors after firmware upgrad
20:01:46 <bwh> I think this is actually driver flakiness because the GPU doesn't use firmware, but I may be mistaken. I asked for more info including the PCI ID
20:02:01 <carnil> i.e. wait now
20:02:04 <bwh> yes
20:02:25 <carnil> bwh: we skip the two initramfs-tools issues, as you are on them, correct?
20:02:31 <bwh> OK
20:02:42 <carnil> #topic migration excuses + new upstream versions
20:03:04 <bwh> All of the new upstream versions are either in experimental or in an MR (linux)
20:03:21 <carnil> as mentioned above would like to to a 6.12.37 upload once it is out. 6.12.35-1 is now 6 days in unstable, wonder if I should ask release team first to migrate to testing then only go for 6.12.37
20:03:27 <bwh> or irrelevant (firmware-free)
20:03:28 <carnil> or just superseed 6.12.37
20:03:38 <carnil> (superseed with)
20:04:03 <ukleinek> bwh: thanks for !1569 (the MR for 6.16-rc5)
20:04:29 <carnil> bwh: yes correct
20:04:31 <bwh> carnil: I agree with getting the latest version into testing before superseding it
20:05:15 <carnil> bwh: then will ask release team to make migration time shorter (+ asking kibi for d-i plans)
20:05:26 <ukleinek> sounds good
20:05:43 <carnil> I have btw, no idea how we are approaching the full freeze or not, but maybe you have more insights from Debcamp :)
20:06:08 <bwh> I haven't talked to the release team so far
20:06:16 <carnil> ok
20:06:23 <carnil> so semi-last topic
20:06:28 <carnil> #topic merge requests
20:06:37 <carnil> any particular outstanding there to look at?
20:06:48 <ukleinek> https://bugs.debian.org/release-critical/ says 157 rc bugs left
20:07:14 <bwh> Review of the 6.16 update would be appreciated
20:08:07 <ukleinek> I think I missed to look into the arm64 MRs that I promised to handle last week. Luckily they don't appear in the list, so nobody notices
20:09:03 <carnil> ukleinek: you get a new chance this week :)
20:09:10 <ukleinek> bwh: I'll try 6.16 on my mediatek board, wanted to test that anyhow
20:09:25 * carnil looks at the ones related tagged 6.12 backport needed along with the next upload
20:10:10 <ukleinek> ..ooOO(But the PWM is broken on that board, have to care for that first for some reasons)
20:11:15 <carnil> I think we are almost through then
20:11:29 <carnil> #topic AoB?
20:11:37 <carnil> how is Debcamp, bwh + waldi?
20:11:41 <carnil> ;-)
20:12:16 <waldi> not yet, i'll be there in friday
20:12:18 <bwh> We should maybe discuss the RFC about debug packages, but not in this meeting - either on the list or at next week's meeting
20:12:38 <bwh> DebCamp is pretty nice and relaxed from my point of view
20:12:54 <carnil> bwh: ok (re the RFC on debug packages)
20:13:45 <carnil> fwiw, since the next meeting is on jitsi, I might not be able to attend, not sure 100% yet
20:14:02 <waldi> can we please stop full quotes in bug reports? just today i found several instances of hundreds of lines of log, just to say that i have nothing to say about the quoted log
20:14:23 <bwh> I need to go catch a bus now, but I am willing to be chair next week if it's my turn
20:14:26 <carnil> who is taking care of chairing next week?
20:14:31 <waldi> i might also be in transit, not sure when i'll be home
20:14:43 <carnil> #action bwh will chair next weeks meeting
20:14:50 <carnil> bwh: ok catch the bus!
20:14:58 <carnil> i will end the meeting then
20:15:02 <carnil> #endmeeting