#debian-ruby Meeting

Meeting started by utkarsh2102 at 16:53:21 UTC (full logs).

Meeting summary

  1. roll call (utkarsh2102, 16:53:36)
  2. rails 6 transition (utkarsh2102, 16:55:13)
    1. GitLab is stuck in NEW because of binary change (utkarsh2102, 16:58:26)
    2. for Rails 6 transition, we either wait to GitLab to clear NEW or OBS/redmine gets rails 6 support (utkarsh2102, 16:59:24)
    3. rails 6 transition: status: blocked temporarily (utkarsh2102, 17:00:08)
    4. https://salsa.debian.org/ruby-team/rails/-/wikis/Transition-to-Rails-6-for-Debian-Bullseye (PiratePraveen[m], 17:03:53)
    5. ACTION: Utkarsh to send mail for RFH: testing rails reverse dependencies (utkarsh2102, 17:07:09)
    6. https://salsa.debian.org/ruby-team/rails/-/wikis/Transition-to-Rails-6-for-Debian-Bullseye (utkarsh2102, 17:07:35)
    7. https://salsa.debian.org/terceiro/mass-rebuild (utkarsh2102, 17:07:52)
    8. https://wiki.debian.org/Teams/Ruby/Packaging#Updating_packages_with_API_breaking_changes finalize it as team policy (PiratePraveen[m], 17:09:28)

  3. API breaking changes (utkarsh2102, 17:10:39)
    1. https://wiki.debian.org/Teams/Ruby/Packaging#Updating_packages_with_API_breaking_changes (utkarsh2102, 17:10:53)
    2. given general consensus, we agree to the draft proposition about API breaking changes upgrades/uploads (utkarsh2102, 17:14:51)
    3. ACTION: kanashiro to send an email about new policy of API breaking changes upgrades/uploads (utkarsh2102, 17:17:33)
    4. ACTION: Pirate ‍ Praveen to add some details about handling bigger transitions to the proposition (utkarsh2102, 17:19:52)
    5. Pirate ‍ Praveen is very quick and added the proposed line already :) (utkarsh2102, 17:21:47)
    6. ACTION: ruby2.7 transition (utkarsh2102, 17:23:38)

  4. ruby2.7 transition (utkarsh2102, 17:24:09)
    1. kanashiro uploaded 2.7.1 on 6th May (utkarsh2102, 17:25:55)
    2. we should try to get it shared by the publicity team as well (utkarsh2102, 17:28:22)
    3. ACTION: <someone> should write a blog post for the 2.7 migration (utkarsh2102, 17:30:04)
    4. ACTION: kanashiro to start a draft blog and share on the list (utkarsh2102, 17:35:21)
    5. ACTION: Once the blog post is done, <someone> or utkarsh to coordinate with the publicity team for sharing and announce this on d-d-a (bits from the Ruby team) (utkarsh2102, 17:36:56)

  5. next meeting (utkarsh2102, 17:45:40)
    1. AGREED: next meeting will be held on Friday, June 5th, 1630 UTC (utkarsh2102, 17:46:06)


Meeting ended at 17:46:54 UTC (full logs).

Action items

  1. Utkarsh to send mail for RFH: testing rails reverse dependencies
  2. kanashiro to send an email about new policy of API breaking changes upgrades/uploads
  3. Pirate ‍ Praveen to add some details about handling bigger transitions to the proposition
  4. ruby2.7 transition
  5. <someone> should write a blog post for the 2.7 migration
  6. kanashiro to start a draft blog and share on the list
  7. Once the blog post is done, <someone> or utkarsh to coordinate with the publicity team for sharing and announce this on d-d-a (bits from the Ruby team)


Action items, by person

  1. kanashiro
    1. kanashiro to send an email about new policy of API breaking changes upgrades/uploads
    2. kanashiro to start a draft blog and share on the list
  2. UNASSIGNED
    1. Utkarsh to send mail for RFH: testing rails reverse dependencies
    2. Pirate ‍ Praveen to add some details about handling bigger transitions to the proposition
    3. ruby2.7 transition
    4. <someone> should write a blog post for the 2.7 migration
    5. Once the blog post is done, <someone> or utkarsh to coordinate with the publicity team for sharing and announce this on d-d-a (bits from the Ruby team)


People present (lines said)

  1. utkarsh2102 (69)
  2. PiratePraveen[m] (32)
  3. kanashiro (29)
  4. peoplesmic (8)
  5. boutil[m] (5)
  6. terceiro (4)
  7. MeetBot (2)
  8. uwabami (2)
  9. srud (2)


Generated by MeetBot 0.1.4.