16:53:21 <utkarsh2102> #startmeeting
16:53:21 <MeetBot> Meeting started Fri May  8 16:53:21 2020 UTC.  The chair is utkarsh2102. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:53:21 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:53:36 <utkarsh2102> #topic roll call
16:53:51 * utkarsh2102 waves o/
16:53:58 <PiratePraveen[m]> rails 6 transition
16:54:44 <boutil[m]> o/
16:55:13 <utkarsh2102> #topic rails 6 transition
16:56:02 <PiratePraveen[m]> gitlab is stuck in NEW since I moved gitlab-common binary from src:gitlab to src:gitaly
16:56:25 <PiratePraveen[m]> so its not much useful from gitlab perspective to have rails 6 in unstable till it clears NEW
16:57:02 <PiratePraveen[m]> so I think we should wait for one of these conditions 1. gitlab clears NEW 2. open build system or redmine gets rails 6 support
16:57:02 <utkarsh2102> kanashiro, Duck, what's the status of OBS?
16:58:26 <PiratePraveen[m]> I think help is still welcome to fix packages for rails 6
16:58:26 <utkarsh2102> #info GitLab is stuck in NEW because of binary change
16:59:11 <PiratePraveen[m]> so other than that we can defer the decision to upload rails 6 to unstable
16:59:24 <utkarsh2102> #info for Rails 6 transition, we either wait to GitLab to clear NEW or OBS/redmine gets rails 6 support
16:59:30 <kanashiro> utkarsh2102: OBS with rails 6 support was not release yet
16:59:34 <PiratePraveen[m]> rails 6 transition: status: blocked
16:59:46 * kanashiro waves
17:00:08 <utkarsh2102> #info rails 6 transition: status: blocked temporarily
17:00:48 <utkarsh2102> Pirate ‍ Praveen, srud: do we have any other blockers other than that?
17:01:53 <PiratePraveen[m]> we have not tested all reverse dependencies
17:02:18 <PiratePraveen[m]> which can still be done while we are waiting for unstable upload
17:02:44 <utkarsh2102> Any volunteers for that? :)
17:03:44 <kanashiro> PiratePraveen[m]: we have been using mass-rebuild (https://salsa.debian.org/terceiro/mass-rebuild) for ruby transitions, idk whether it is good for you
17:03:45 <peoplesmic> Antonio Terceiro / mass-rebuild · GitLab (at salsa.debian.org)
17:03:52 <kanashiro> in the rails transition
17:03:53 <PiratePraveen[m]> https://salsa.debian.org/ruby-team/rails/-/wikis/Transition-to-Rails-6-for-Debian-Bullseye
17:03:55 <peoplesmic> Transition to Rails 6 for Debian Bullseye · Wiki · Debian Ruby Team / rails · GitLab (at salsa.debian.org)
17:04:35 <PiratePraveen[m]> these were manually categorized by Jongmin
17:04:51 <PiratePraveen[m]> for some we just need to update to new upstream release
17:06:20 <utkarsh2102> Okay, I think it's better to ask in the list
17:07:09 <utkarsh2102> #action Utkarsh to send mail for RFH: testing rails reverse dependencies
17:07:09 <kanashiro> utkarsh2102: I am not sure but I think you can use #action for action items
17:07:18 <kanashiro> :)
17:07:35 <utkarsh2102> #link https://salsa.debian.org/ruby-team/rails/-/wikis/Transition-to-Rails-6-for-Debian-Bullseye
17:07:37 <peoplesmic> Transition to Rails 6 for Debian Bullseye · Wiki · Debian Ruby Team / rails · GitLab (at salsa.debian.org)
17:07:49 <PiratePraveen[m]> utkarsh2102 thanks
17:07:52 <utkarsh2102> #link https://salsa.debian.org/terceiro/mass-rebuild
17:07:53 <peoplesmic> Antonio Terceiro / mass-rebuild · GitLab (at salsa.debian.org)
17:08:12 <utkarsh2102> Any other topic?
17:08:54 <srud> utkarsh2102: one person testing all reverse deps is not feasible.. We need as many hands as possible
17:09:08 <PiratePraveen[m]> API breaking changes: I think we need to make the process more visible
17:09:28 <PiratePraveen[m]> https://wiki.debian.org/Teams/Ruby/Packaging#Updating_packages_with_API_breaking_changes finalize it as team policy
17:09:29 <peoplesmic> Teams/Ruby/Packaging - Debian Wiki (at wiki.debian.org)
17:09:36 <PiratePraveen[m]> last meeting we did not get much time to discuss it
17:10:24 <utkarsh2102> srud: right
17:10:39 <utkarsh2102> #topic API breaking changes
17:10:53 <utkarsh2102> #link https://wiki.debian.org/Teams/Ruby/Packaging#Updating_packages_with_API_breaking_changes
17:10:54 <peoplesmic> Teams/Ruby/Packaging - Debian Wiki (at wiki.debian.org)
17:12:14 <utkarsh2102> I concur with the proposal, it makes sense and looks good to me :)
17:12:20 <kanashiro> PiratePraveen[m]: thanks for writing the draft, IMHO it reflects well what we have been discussing since the last sprint
17:12:27 <utkarsh2102> Others, opinions?
17:12:46 <utkarsh2102> Can we remove the "draft" headers if we have consensus for that?
17:13:00 <kanashiro> +1 from me
17:13:06 <boutil[m]> I agree with the proposition
17:13:16 <uwabami> +1
17:13:58 <srud> +1
17:14:13 <PiratePraveen[m]> may be rephrase it if something is not clear?
17:14:51 <utkarsh2102> #info given general consensus, we agree to the draft proposition about API breaking changes upgrades/uploads
17:15:01 <kanashiro> we can remove the "draft" and announce this new policy via email
17:15:14 <utkarsh2102> Pirate ‍ Praveen: I think we can do that as and when we find a need to?
17:15:49 <PiratePraveen[m]> I prefer we send it soon so people are aware
17:16:04 <PiratePraveen[m]> especially new people
17:16:04 <utkarsh2102> Can someone remove the "draft" header and send an email as kanashiro said?
17:17:16 <kanashiro> okay, I can do that
17:17:22 <PiratePraveen[m]> probably add something about big transitions like ruby and rails?
17:17:33 <utkarsh2102> #action kanashiro to send an email about new policy of API breaking changes upgrades/uploads
17:18:04 <PiratePraveen[m]> which we will have to handle as a team and we may upload to unstable first and fix things later
17:18:22 <utkarsh2102> Pirate ‍ Praveen: can you do it?
17:18:48 <PiratePraveen[m]> okay
17:18:53 <kanashiro> PiratePraveen[m]: I think we can consider ruby and rails as exceptions, tell people to discuss first in the mailing list with the team
17:19:52 <utkarsh2102> #action Pirate ‍ Praveen to add some details about handling bigger transitions to the proposition
17:20:02 <utkarsh2102> kanashiro: yeah, that makes sense
17:20:33 <utkarsh2102> Any more details on this?
17:20:44 <PiratePraveen[m]> I added a line there
17:20:55 <kanashiro> thanks!
17:21:02 <utkarsh2102> wow!
17:21:47 <utkarsh2102> #info Pirate ‍ Praveen is very quick and added the proposed line already :)
17:22:03 <utkarsh2102> Can we move to the next topic?
17:22:24 <kanashiro> I think so
17:22:37 <terceiro> hello everyone, I just found out I had my the meeting on the wrong day in my agenda :-/
17:23:38 <utkarsh2102> #action ruby2.7 transition
17:23:42 <kanashiro> we messed up actually it should have been last Friday :P
17:23:56 <utkarsh2102> Oh crap, not action
17:24:08 <kanashiro> ruby 2.7 finally migrated to testing \o/
17:24:09 <utkarsh2102> #topic ruby2.7 transition
17:24:24 <utkarsh2102> Yay and many thanks to everyone who participated
17:24:36 <utkarsh2102> 2.7 has finally migrated
17:24:40 <PiratePraveen[m]> kanashiro thanks for the lead and thanks to everyone
17:24:57 <kanashiro> a minor release with a couple of security fixes was uploaded yesterday
17:25:12 <kanashiro> it FTBFS in i386 but I am already working on it
17:25:20 <utkarsh2102> Do you think we should add a blog on the Ruby team page?
17:25:36 <kanashiro> utkarsh2102: that would be great :)
17:25:55 <utkarsh2102> #info kanashiro uploaded 2.7.1 on 6th May
17:25:58 <kanashiro> give visibility for our work
17:26:20 <utkarsh2102> Yeah, someone needs to do that :)
17:26:40 <utkarsh2102> dleidert: we need you ^^ \o/
17:26:57 <kanashiro> I wrote a blog post for Ubuntu some time ago: https://discourse.ubuntu.com/t/ruby-2-7-in-focal/15020
17:26:58 <peoplesmic> Ruby 2.7 in Focal - Server - Ubuntu Community Hub (at discourse.ubuntu.com)
17:27:09 <kanashiro> we can do something on those lines
17:27:47 <PiratePraveen[m]> we can try to get it shared by publicity team as well
17:27:47 <utkarsh2102> kanashiro: that's nice, can you tweak that a bit and write one for us, too?
17:27:58 <utkarsh2102> Pirate ‍ Praveen: good point
17:28:11 <kanashiro> if someone has time also collect some data, number of packages worked on by the team, bug fixes and so on
17:28:22 <utkarsh2102> #info we should try to get it shared by the publicity team as well
17:28:53 <utkarsh2102> kanashiro: ok, let's discuss this on the list maybe? Someone might have the data already?
17:29:07 <utkarsh2102> Thanks to the tags we used on those bugs :)
17:29:54 <kanashiro> who is the volunteer to start this email thread? and also start a draft :)
17:30:04 <utkarsh2102> #action <someone> should write a blog post for the 2.7 migration
17:30:12 <boutil[m]> We already have a blog syndicated on planet.d.o
17:31:15 <boutil[m]> Why have another one? (Maybe I missed something)
17:31:30 <kanashiro> utkarsh2102: an action item with no one assigned is not actionable I believe :)
17:31:40 <PiratePraveen[m]> no, like publicity team share our blog post
17:31:46 <PiratePraveen[m]> not start another blog
17:32:14 <boutil[m]> Ah! Thanks
17:32:17 <PiratePraveen[m]> they have a mastodon account through which they could share this - bullseye will have ruby 2.7 or something like that
17:32:28 <utkarsh2102> kanashiro: I don't know where should that go then? It's under the team's action item. Up for grabs for anyone who wants to work on this :)
17:32:39 <PiratePraveen[m]> we can try asking them
17:33:02 <utkarsh2102> Pirate ‍ Praveen: like bits from Ruby team, maybe?
17:33:28 <PiratePraveen[m]> ah yes that is a good idea too
17:33:40 <utkarsh2102> On -devel-announce
17:33:40 <PiratePraveen[m]> and post to debian-devel-announce
17:33:48 <utkarsh2102> yeah
17:34:08 <utkarsh2102> Should I add it as an info or an action item?
17:34:14 * utkarsh2102 is confused :)
17:34:28 <PiratePraveen[m]> action
17:34:39 <kanashiro> utkarsh2102: since I already have a ruby 2.7 blog post from Ubuntu I can start a draft and share it in the mailing list
17:34:41 <utkarsh2102> Alrighty
17:34:57 <utkarsh2102> kanashiro: ❤️
17:35:21 <utkarsh2102> #action kanashiro to start a draft blog and share on the list
17:36:56 <utkarsh2102> #action Once the blog post is done, <someone> or utkarsh to coordinate with the publicity team for sharing and announce this on d-d-a (bits from the Ruby team)
17:37:58 <utkarsh2102> kanashiro: I was wondering about those blockers which were skipped by elbrus during migration, won't they be blockers for 2.7.1's migration?
17:39:07 <kanashiro> utkarsh2102: we will know soon, but I think we need change the topic to get the meeting log well organized
17:39:29 <utkarsh2102> kanashiro: yeah
17:39:40 <utkarsh2102> Next topic?
17:39:59 <utkarsh2102> (anyone wants to discuss anything?)
17:40:59 <kanashiro> not a discussion but to let you aware that we might have some trademark issues with chef: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=959981
17:41:02 <peoplesmic> #959981 - Trademark issues with Chef/Cinc package included in Debian - Debian Bug report logs (at bugs.debian.org)
17:41:12 <kanashiro> terceiro is handling it
17:41:28 <terceiro> yeah not fun
17:42:34 <terceiro> but shouldn't be a big problem
17:43:52 <utkarsh2102> Thanks for taking care of this :)
17:44:03 <utkarsh2102> Do we have any other topic or should we wrap up?
17:45:31 <utkarsh2102> Okay, I'll wrap up then
17:45:33 <kanashiro> that's it for me
17:45:40 <utkarsh2102> #topic next meeting
17:46:06 <utkarsh2102> #agreed next meeting will be held on Friday, June 5th, 1630 UTC
17:46:28 <utkarsh2102> Hope that's good with everyone?
17:46:40 <terceiro> yeah sure
17:46:47 <uwabami> :)
17:46:50 <utkarsh2102> great!
17:46:54 <utkarsh2102> #endmeeting