16:03:32 <emmapeel> #startmeeting TBA l10n
16:03:32 <MeetBot> Meeting started Thu Mar 28 16:03:32 2019 UTC.  The chair is emmapeel. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:03:32 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:03:50 <sysrqb> where would you like to start?
16:04:01 <emmapeel> ok, so i was thinking we should compile where we are and see how to localize the interface
16:05:06 <emmapeel> i see that a lot of the strings are probably on the transifex memory so i see it a bit like a low hanging fruit from my point of view, but i wonder where we are with the code etc. also the playstore stuff, which i dont have clear
16:05:38 <GeKo> huh, we have a meeting here, good to know
16:05:42 <GeKo> hi!
16:05:47 <emmapeel> ey GeKo hi
16:06:05 <GeKo> did that get announced somewhere which i missed?
16:06:25 <emmapeel> GeKo: we are meeting with sysrqb to talk about TBA l10n.
16:06:32 <sysrqb> oh, i was just about to ping you GeKo, good good
16:06:38 <GeKo> yeah, great
16:06:41 <GeKo> carry on :)
16:06:46 <emmapeel> it was just the two of us but we did it here in hopes more people will read and participate
16:06:51 <sysrqb> no announcement, ad hoc
16:07:01 <GeKo> wfm
16:07:27 <antonela> < here
16:07:53 <sysrqb> o/
16:07:58 <sysrqb> right, okay
16:08:52 <emmapeel> 16:05 < emmapeel> ok, so i was thinking we should compile where we are and see how to localize the interface
16:08:53 <sysrqb> the code is still changing, but the UI strings shouldn't change much
16:08:54 <emmapeel> 16:06 < emmapeel> i see that a lot of the strings are probably on the transifex memory so i see it a bit like a low hanging fruit from my point of
16:08:57 <emmapeel> view, but i wonder where we are with the code etc. also the playstore stuff, which i dont have clear
16:09:03 <emmapeel> yeah that is what i think too
16:09:22 <emmapeel> also we should try to use the same strings as in TBB, right?
16:09:38 <sysrqb> yes, that would be best
16:09:39 <emmapeel> i had a file a while ago, i am not sure what happened
16:09:43 <emmapeel> i mean where i got it
16:10:26 <sysrqb> with all the strings?
16:11:15 <GeKo> i thought about moving the whole torbutton strings to the proper place while working on #10760
16:11:31 <GeKo> it's still a thing we should do i think
16:11:41 <GeKo> i looked at this in particular when working on #26782
16:11:50 <GeKo> and it should not be that hard
16:12:16 <emmapeel> let me post it somewhere. https://share.riseup.net/#aYF0WhJd6NC-BcEXtgIsIA
16:12:36 <GeKo> it should save us from having string duplicated at different locations
16:13:06 <GeKo> and given that we want to have torbutton directly in tor-browser with 9.0a1 that should be fine
16:13:13 <emmapeel> i agree with trying not to have duplicated strings
16:14:36 <sysrqb> yes, i also made some small progress on #26782 some weeks ago
16:14:46 <emmapeel> the file i uploaded has duplicated strings tho :D i mean, they are part of torbutton-onboarding or something
16:14:49 <sysrqb> but it needs some mroe work
16:14:59 <sysrqb> yes
16:15:18 <sysrqb> those should be translated automatically, correct?
16:15:28 <emmapeel> so, i want to have the .dtd/.properties file if there is any, but also the description.xlif file or whatever it is that we upload to the play store
16:15:45 <emmapeel> so we can translate the description of the software etc. that i think neds a ticket too
16:15:52 <emmapeel> 16:16 < sysrqb> those should be translated automatically, correct?
16:15:56 <emmapeel> i think so...
16:15:59 <antonela> that was my next question emmapeel
16:16:03 <antonela> is there any chance to have localized graphic assets at the gplaystore? maybe for TBA 9.0
16:16:13 <antonela> graphic assets + description
16:16:24 <emmapeel> there is a chance yes, but we should do #26844
16:16:55 <GeKo> emmapeel: which .dtd/.properties files do you mean?
16:17:22 <emmapeel> GeKo: i mean whatever translations the android app needs, apart of the ones TBB has
16:18:13 <GeKo> ah, okay, so just the strings that are not duplicates?
16:18:25 <GeKo> because we don't have those separated yet
16:18:29 <emmapeel> that would be the ideal yes
16:18:38 <emmapeel> but i can live with duplicated strings
16:18:48 <GeKo> i can look at that tomorrow
16:18:59 <GeKo> and probably next week
16:19:09 <antonela> fastlane seems interesting
16:20:03 <sysrqb> also, something we should keep in mind is how much effort/time we want to spend on any of these tasks if we will move to fenix in the not-too-distant-future
16:20:27 <sysrqb> and i don't know how localization and string-sharing between fenix and desktop will work
16:20:34 <sysrqb> antonela: indeed, it is
16:21:01 <sysrqb> all-in-one package, if you configure it correctly and turn all the correct dials
16:21:07 <antonela> ye
16:21:13 <GeKo> i am not so worried about that for desktop/mobile string sharing as we want to have torbutton properly in tor-browser anyway
16:21:23 <antonela> do you think fenix will happen this year sysrqb?
16:21:28 <antonela> i mean, our moving
16:21:34 <GeKo> i don't think that having mobile in mind will create a lot of extra work
16:21:42 <GeKo> antonela: no
16:21:43 <emmapeel> agreed with GeKo !
16:22:39 <antonela> okey
16:22:51 <sysrqb> antonela: assuming mozilla don't kill fennec before next year
16:22:57 <sysrqb> but that seems unlikely
16:23:03 <antonela> yep
16:23:08 <emmapeel> back to the palystore description: i dont know how it is done with the play store, are they looking at a repo we have? where is that description file located?
16:23:36 <antonela> https://support.google.com/googleplay/android-developer/answer/3125566?hl=en
16:23:39 <sysrqb> emmapeel: no file, stephw or isa pasted that text
16:23:59 <sysrqb> in the web interface
16:24:39 <emmapeel> i see
16:24:54 <sysrqb> when we get fastlane working
16:25:00 <sysrqb> i think we'll wanta repo for it
16:25:22 <sysrqb> i am thinking we could include it within tor-browser-build
16:25:35 <emmapeel> that would be lovely
16:25:35 <sysrqb> but maybe we want a separate repo for this info
16:26:02 <GeKo> why tor-browser-build?
16:26:21 <sysrqb> it goes with the other tor-browser admin stuff
16:26:22 <emmapeel> i would not mind a separate repo
16:26:47 <GeKo> "tor-browser admin stuff"?
16:26:53 <sysrqb> but i'm not opposed to creating a separate repo, too
16:27:11 <sysrqb> under tools/
16:27:37 <sysrqb> but this isn't too important right now, we can decide this later
16:28:42 <sysrqb> emmapeel: for the description
16:28:43 <emmapeel> so, are we doing fastlane then?
16:28:57 <sysrqb> yes, using fastlane would be ideal, i think
16:29:09 <sysrqb> in terms of having an easy workflow
16:29:13 <emmapeel> #agreed: we use fastlane
16:29:18 <emmapeel> ok
16:29:25 <sysrqb> :)
16:29:46 <emmapeel> then, what do we need? i can ask for some description files
16:30:03 <emmapeel> i thin kthere are some examples in the f-droid repo. btw the fastlane will also work with f-droid i think
16:30:23 <sysrqb> that would be excellent
16:30:34 <emmapeel> that is what _hc told me a while ago
16:30:55 <sysrqb> should i copy the current description on gplay and give you a file for localization?
16:31:08 <sysrqb> or, what is the best process for that right now?
16:32:04 <antonela> i dont think there is a process right now :)
16:32:47 <emmapeel> well, for localization there is a process, i rather have the file on a repo
16:33:01 <emmapeel> so i can hook it up and when you make changes, those changes are sent to translate again
16:33:06 <antonela> i mean, for the tba description
16:33:24 <sysrqb> hrm, okay, so maybe deciding where we want this info stored should be discussed now?
16:33:46 <emmapeel> so, if you create a repo for the fastlane setup, the file will be there
16:33:53 <GeKo> yep
16:34:01 <GeKo> that sounds about right
16:34:29 <sysrqb> yes, i thin that is the easiest
16:34:29 <GeKo> (which is why i think it should not be in tor-browser-build)
16:34:36 <GeKo> (among other reasons)
16:34:39 <sysrqb> okay :)
16:34:59 <sysrqb> okay,i can open a request for this
16:35:10 <GeKo> i think something clean for our fastlane things is a good idea
16:35:58 <emmapeel> yes, i kind of agree :D
16:36:12 <emmapeel> #action: sysrqb opens request for new repo
16:36:40 <antonela> we will need to freeze description' strings a few weeks before the release, to have it done for the release, not sure what is the best way to sync it with steph
16:38:06 <sysrqb> GeKo: for bridgedb, we have project/bridges/bridgedb-admin, should we create project/tor-browser/fastlane ?
16:38:35 <sysrqb> GeKo: or, there is tor-browser/user-manual, would tor-browser/fastlnae be better?
16:38:56 <GeKo> let me think about it
16:39:03 <emmapeel> i think tor-browser/user-manual should be put in the attic, cause it is the mallard, right?
16:39:12 <sysrqb> the former is under "Infrastructure and Administration" on gitweb, and the latter is a generl repo
16:39:15 <sysrqb> okay
16:39:29 <sysrqb> i think user-manual is old
16:39:48 <sysrqb> GeKo: let me know if you decide :)
16:39:57 <sysrqb> or, you can open the ticket ifyou want
16:42:22 <emmapeel> cri cri
16:43:07 <GeKo> sysrqb: that's a ton of repos :)
16:43:21 <GeKo> so i think project/tor-browser/fastlane is not unreasonable
16:43:36 <sysrqb> emmapeel: okay, so we'll add the currrent text in that repo when it is created
16:43:59 <GeKo> given that other tor browser stuff is already there (under infra and admin)
16:44:00 <emmapeel> great!
16:44:03 <sysrqb> GeKo: yep, okay, sounds good
16:44:41 <GeKo> tor-browser/fastlane would work for me, though, as well :)
16:44:47 <emmapeel> once you have it i can add it to transifex and give you a branch with the transltions fo the texts. not sure how to go about the screenshots, but we need the app localized for that
16:45:59 <sysrqb> the app should be 80% localized already (or high percentage), except for our tor browser strings
16:46:38 <emmapeel> yes, true
16:46:50 <sysrqb> but yes, i agree
16:46:57 <emmapeel> i have some strings in spanish but the onboarding and that are not in spanish
16:47:05 <emmapeel> and also in the playstore there is no translation
16:47:10 <sysrqb> yes
16:47:17 <emmapeel> the people in indonesia that didnt spoke english noticed
16:47:40 <sysrqb> yeah, that's not surprising :/
16:48:03 <sysrqb> okay, so we'll translate the gplay description
16:48:13 <sysrqb> one thing i don't know how we should solve-
16:48:42 <sysrqb> with every release, we add a small changelog summary
16:48:49 <sysrqb> that should be localized, as well
16:49:08 <sysrqb> but usually we only have a few days between finalizing the changelog and releasing
16:49:10 <emmapeel> yeah that is hard to get localized in time
16:49:13 <antonela> that is what i mean
16:49:39 <sysrqb> ah
16:49:40 <antonela> if we can have a human-friendly version of the change-log a week before, maybe we can arrive to the localization then
16:49:56 <emmapeel> but you can see several different changelogs, maybe you read the previous releases changelogs that are already localized
16:50:20 <emmapeel> also, some stuff will be localized in the homepage maybe... not sure about changelogs tho
16:50:23 <antonela> that can be more vague than the proper changelog, for instance we don't need to link tickets at the description
16:50:48 <sysrqb> yes. on gplay the changlog is limited to 500 characters
16:50:58 <sysrqb> so i usually deleting a lot of detai
16:51:02 <antonela> yes
16:51:07 <sysrqb> and only publish the high-level important things
16:51:12 <antonela> exactly
16:51:15 <sysrqb> so we could localize that ahead of time
16:51:20 <sysrqb> i agree :)
16:51:31 <sysrqb> but we should add that to the release-prep process
16:51:42 <sysrqb> GeKo: ^ do you tihnk we can do this?
16:51:50 <sysrqb> obviously we can't for security releases
16:51:51 <antonela> a possible workflow is having it for review at the previous release meeting
16:51:57 <sysrqb> but for point release?
16:52:20 <sysrqb> antonela: ah, smart :)
16:52:45 <antonela> and then emmapeel has one week for translations and then voila, release
16:52:54 <antonela> could that work emmapeel?
16:52:55 <GeKo> sysrqb: what exactly?
16:53:32 <sysrqb> decide on a changelog for gplay (and f-droid) one week before the release date?
16:53:47 <sysrqb> it won't be the same changelog as the one included in tor-browser-buid
16:53:48 <GeKo> hm.
16:53:55 <sysrqb> but a higher-level summary of the important changes?
16:54:16 <GeKo> we could try that
16:54:25 <GeKo> for every point release?
16:54:36 <GeKo> i can see the benefit for major releases
16:54:58 <emmapeel> well, i think it is ok to get translated as much as possible
16:55:15 <emmapeel> and the importante phrases may have been translated somewhere else in the meantime... it depends on the languages for sure
16:55:31 <antonela> agreed
16:55:45 <sysrqb> i guess it depends on what we think our users should know about this release
16:55:58 <sysrqb> in particular those users who aren't fluent in engish
16:56:09 <sysrqb> if there aren't any major changes
16:56:15 <GeKo> yep
16:56:22 <sysrqb> then we could have a default changelog for all languages except english
16:56:29 <emmapeel> yeah maybe the release notes can contains some formulae for the known issues etc
16:56:41 <GeKo> i mean there is likely "update to fennec x.y.z"
16:56:47 <GeKo> and maybe a tor update
16:56:56 <GeKo> and probably extension updates
16:57:02 <GeKo> but that's about it
16:57:02 <emmapeel> yep, but the transifex AI is not so clever. someone should go one by one
16:57:31 <sysrqb> but maybe users don't need to know that we updated noscript in this release
16:57:37 <GeKo> no , i was not meaning we need to automate that
16:57:38 <emmapeel> (weblate is nicer tho with deepL support)
16:57:58 <GeKo> just to give an overview what  might happen between *stable* point releases
16:59:12 <sysrqb> can we simply say something like: This update provides security and usability improvements
16:59:17 <sysrqb> and link to the blog post for it?
16:59:29 <GeKo> but, yeah, i could see us checking something in to the fastlane repo a week before releasing
16:59:32 <emmapeel> regarding l10n, you can have a repo with the template file and update it there, or i can also upload files to transifex without repo, so we can send it earlier to translate without altering the fastlane thingie
16:59:50 <GeKo> although, that measn *two* weeks before releasing
16:59:57 <GeKo> *means
17:00:06 <emmapeel> i see
17:00:09 <GeKo> because we'll start building like a week before
17:00:32 <sysrqb> hrm,, but this won't be included with this build
17:00:48 <GeKo> so we should avoid mentioning extension updates as they may change on shorter notice
17:00:59 <GeKo> like noscript
17:01:23 <GeKo> yes, but it should match what we ship
17:01:50 <sysrqb> yes, that would be good
17:02:42 <sysrqb> okay, well, we can work on this process
17:02:45 <GeKo> so, i think we could try that
17:02:47 <GeKo> yeah
17:03:00 <GeKo> being sufficiently high-level that it matches :)
17:03:19 <sysrqb> we're reaching one hour now, shouldwe discuss any other topic?
17:03:24 <sysrqb> GeKo: yep
17:05:47 <sysrqb> did ilose all of my friends to the other meeting? :)
17:06:05 <antonela> hahaha
17:06:12 <GeKo> haha
17:06:13 <antonela> anything else here?
17:06:26 <GeKo> i am still with you, no worries :)
17:06:37 <sysrqb> thanks :)
17:06:41 <sysrqb> emmapeel: ^ :)
17:09:13 <emmapeel> sorry got distracted
17:09:46 <emmapeel> i think we've got a plan now! thanks for coming! there are drinks on the other room and pizze :D
17:09:56 <sysrqb> yay!
17:10:04 <GeKo> :)
17:10:07 <sysrqb> okay, great, we're making some progress
17:10:08 <emmapeel> shall i kill the bot?
17:10:13 <sysrqb> thanks emmapeel
17:10:14 <sysrqb> yah
17:10:17 <emmapeel> or you want to agree on something more
17:10:18 <sysrqb> i think yes
17:10:33 <sysrqb> no, i think imgroot
17:10:38 <emmapeel> #info: things are moving!
17:10:44 <emmapeel> ok then #endmeeting
17:10:55 <emmapeel> #endmeeting