17:00:23 <ahf> #startmeeting network team meeting 20 may
17:00:23 <MeetBot> Meeting started Mon May 20 17:00:23 2019 UTC.  The chair is ahf. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:23 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:00:27 <asn> o/
17:00:29 <ahf> o/
17:00:39 <catalyst> o/
17:00:50 <nickm_fallback> hi all!
17:01:15 <emmapeel> ok!
17:01:33 <nickm_fallback> Pad is https://pad.riseup.net/p/tor-netteam-2019.1-keep
17:01:43 <gaba> o/
17:02:12 <nickm_fallback> I hear that dgoulet has a holiday today. Teor should be back later this week.
17:02:20 <nickm_fallback> mikeperry: you here?
17:02:23 <mikeperry> yep
17:02:39 <nickm_fallback> woo
17:03:39 <nickm_fallback> let's start with some intermittent CI failures. We have a few...
17:04:01 <nickm_fallback> should we talk about them as partof the CI handoff?
17:04:45 <ahf> isn't that where it makes the most sense?
17:04:53 <nickm_fallback> yeah; let's move that in the pad
17:05:00 <nickm_fallback> next is 0.4.1 status
17:05:31 <nickm_fallback> first off, here are the tickets that are stopping me from 0.4.1.1-alpha release:
17:05:34 <nickm_fallback> https://trac.torproject.org/projects/tor/query?status=accepted&status=assigned&status=merge_ready&status=needs_information&status=needs_review&status=needs_revision&status=new&status=reopened&keywords=~0411-alpha&milestone=Tor%3A+0.4.1.x-final&group=status&col=id&col=summary&col=owner&col=type&col=priority&col=component&col=version&order=priority
17:06:08 * asn looks
17:06:08 <nickm_fallback> A couple of those are dgoulet, so we'll talk tomorrow
17:06:39 <ahf> ok
17:07:38 <nickm_fallback> huh. Actually I think all of them are dgoulet-related. So unless I'm wrong there, let's move on to 041 status in general:
17:07:51 <nickm_fallback> https://trac.torproject.org/projects/tor/wiki/org/teams/NetworkTeam/CoreTorReleases/041Status
17:08:59 <nickm_fallback> Has everybody has a chance to look at that?
17:09:08 <nickm_fallback> We have two big tasks to do there:
17:09:31 <nickm_fallback> 1) figure out what to do with the tasks at the bottom of the page. Some are 041-must or -should; others will get deferred
17:09:52 <nickm_fallback> 2) look at the stuff at the top of the page without an owner; see whether there is a local owner for each item there
17:10:13 <nickm_fallback> and of course: look at the stuff that _does_ have an owner, and see fi it's really should/must and if the owner can do it on the soon side
17:10:14 <ahf> hm, i think one of mine isn't on there anymore. i had planned on looking at it this week
17:10:29 <nickm_fallback> do you remember which one?
17:10:37 <ahf> was related to some 100% cpu usage on windows where we should move to a condition variable for windows 7+
17:11:01 <ahf> ahh, is #30187
17:11:09 <ahf> was moved to 042-proposed
17:11:10 <ahf> ok
17:11:15 <nickm_fallback> That was in 040, and I moved it out. we could do it in 041, I guess, but 042 seems more likely to me
17:11:17 <ahf> never mind :-)
17:11:22 <ahf> agreed
17:12:17 <gaba> Do we discuss tasks 1) and 2) now?
17:12:36 <nickm_fallback> I think we should.
17:13:15 <nickm_fallback> Also we should remember that once we have an alpha release, we will learn about more bugs
17:13:24 <nickm_fallback> so this isn't all the problems there are
17:13:43 <nickm_fallback> Does anybody see anything in the triage list at the bottom that we should really do in 0.4.1?
17:13:46 <gaba> It seems to me that any of those tickets in 1) could be deferred... unless is almost ready to be included.
17:14:28 <nickm_fallback> I agree; that's the default if nobody pulls anything there into the release.
17:14:36 <gaba> ok
17:15:36 <asn> i dont se anything in (1) that i would want to keep
17:15:36 <ahf> hm, i don't see anything related to the things i'm thinking of right now
17:15:58 <nickm_fallback> ok
17:16:12 <nickm_fallback> mikeperry, catalyst: you see anything there we should try to slip in?
17:16:17 <mikeperry> I am not seeing anything either
17:16:43 <catalyst> some of them look somewhat easy but not terribly important to rush to get in
17:17:01 <nickm_fallback> on 2: I am concerned about #29875 and #24367. TBB wants them, and they've been there for a while
17:17:14 <nickm_fallback> but I know we've tried before and gotten somewhat frusterated
17:17:28 <catalyst> oh. those sounds like significant usability issues
17:19:49 <catalyst> i've personally experienced something similar, but i don't remember the details or how reproducible it is
17:19:54 <nickm_fallback> asn: I think you and teor have both looked at them before, but that doesn't mean you should have to fix them at this point. Your thoughts would be useful though
17:20:12 <nickm_fallback> I'm bringing them up for attention because they fall nicely under S19.
17:20:20 <gaba> mmm, those tickets seems something that should be fixed soon. Not sure why we do not have it in the roadmap.
17:20:23 <nickm_fallback> and S19 runs out in 11 days.
17:20:24 <gaba> yes to s19
17:21:51 <nickm_fallback> ahf: I don't know whether your recent work on PT stuff would help here or not.
17:22:02 <catalyst> oh the #24367 history looks kind of messy
17:22:26 <nickm_fallback> My main problem here personally is that it's hard for me to reproduce this stuff; if somebody could help with that and investigate what is really going on, I could help work on a fix maybe
17:22:56 <nickm_fallback> It looks like I wrote patches in https://trac.torproject.org/projects/tor/ticket/24367#comment:33 that we never merged because they didn't help completely, but maybe we should look again
17:22:57 <ahf> hm
17:23:02 <ahf> i wonder if #24367 is a duplicate
17:23:12 <nickm_fallback> of #29875?
17:23:13 <GeKo> #29867 is pretty easy to reproduce with tor browser
17:23:17 <GeKo> err
17:23:24 <ahf> hm, no, it's not
17:23:27 <GeKo> #29875
17:23:28 <ahf> i was thinking of another bug
17:23:39 <GeKo> #24637 is harder
17:23:45 <GeKo> blech
17:23:46 <ahf> i don't know how much work those two are, if they are reproducible on linux it makes life a lot easier to debug
17:23:51 <GeKo> #24367
17:24:23 <ahf> i have a lot of S19 things on my plate this week, but i think next week maybe i could look at it if it can wait till then? :-/
17:24:26 <nickm_fallback> I don't see anything on the tickets about them being windows-only , so maybe they do happen on windows
17:24:45 <ahf> yeah, the bug i was thinking of with startup issues was only windows, that was the one i thought it might have been a duplicate of
17:24:50 <GeKo> both are reproducible on linux
17:24:54 <ahf> ok
17:25:03 <nickm_fallback> ahf: ok. I'll try to make some progress if I can, I guess
17:25:22 <nickm_fallback> #action nickm take on #29875 / #24367 stuff and see if I can make progress
17:25:25 <ahf> nickm_fallback: can we split it ? if i take #24367 and you take the other one?
17:25:38 <ahf> i might not make progress this week, but then i will next week
17:25:43 <nickm_fallback> Let's check in once you're not busy?
17:25:47 <ahf> oki!
17:25:50 <nickm_fallback> Maybe I'll figure them both out tomorrow :)
17:26:01 <ahf> sounds good. i wont take ownership of either of them on trac then
17:26:04 <ahf> ok!
17:26:29 <nickm_fallback> GeKo: I see that there are reproducing instructions for #24367, but I don't see them for #29875. If you could add them to the ticket, that would rock
17:27:02 <GeKo> will do
17:27:16 <nickm_fallback> last thing on the 041 ticket list: can everybody confirm that the tasks that they are currently assigned for 041 under "owner action tickets" are reasonable do do and/or defer in the next week or three?
17:27:38 <ahf> yes
17:27:45 <nickm_fallback> Getting these done or deferred, and S19 resolved, are our prerequisites for opening the 0.4.2 merge window
17:28:02 <asn> hmmm
17:28:19 <asn> i got 3. checking them out.
17:28:40 <nickm_fallback> ?
17:28:53 <asn> i mean im checking out the "owner action tickets".
17:29:06 <nickm_fallback> ah
17:30:45 <asn> i want to move #21600 to 042
17:30:59 <asn> its 041-should but i dont think we have the resources to do it properly
17:31:09 <asn> or that it even counts as a bugfix
17:31:31 <nickm_fallback> asn: ok; please make a comment and defer it then
17:32:13 <asn> i think the other two tickets are possible for the 041 bugfix timeline
17:32:24 <nickm_fallback> Currently, ahf, mikeperry, catatlyst, teor have the fewest 041-must and 041-should tickets, so please do what you can on S19 and on any 041 tickets where you think you can make progress
17:32:28 <nickm_fallback> asn: great
17:32:36 <ahf> yes
17:32:52 * catalyst can help ahf with the TB/PT tickets if needed
17:32:53 <nickm_fallback> I am currently on track to do all mine, except maybe for #27530 which I think we should maybe defer or wontfix
17:33:09 <nickm_fallback> catalyst: thanks!
17:33:40 <nickm_fallback> ahf, catalyst: please coordinate as needed :)
17:34:01 <ahf> yes!
17:34:42 <nickm_fallback> on to the roadmap...?
17:34:58 <nickm_fallback> gaba: any questions on the roadmap this week?
17:35:19 <gaba> no questions, I just added the 2 tickets we mentioned from s19-must
17:35:28 <gaba> #24367 and #29875
17:35:34 <nickm_fallback> ahf: do you need me for anything on #29283? Otherwise I'm going to remove myself from it on the roadmap, since you seem to have it under control
17:35:52 <ahf> you can remove yourself, but i hope you will do the review of the code
17:36:09 <ahf> i hope dcf gets back this week with my updates from the weekend to the spec. i have the code patch semi-ready'ish to follow the spec change and then we can review it
17:36:18 <ahf> so i might ask for a review on thursday/friday
17:36:33 <nickm_fallback> gaba: please assign them to me+ahf, with the understanding that I'll give them a try first
17:36:39 <gaba> ack
17:36:40 <nickm_fallback> ahf: yes, please set me to the reviewer :)
17:36:51 <ahf> nickm_fallback: cool!
17:36:55 <nickm_fallback> gaba: and please call them both "in progress" :)
17:37:04 <gaba> done
17:37:04 <nickm_fallback> anything else on the roadmap?
17:37:45 <nickm_fallback> ty
17:37:58 <gaba> one thing, we updated the roadmap last week with s2 from mike
17:38:22 <gaba> things in the icebox from s2 may not be done as they are not must
17:38:34 <nickm_fallback> ack
17:39:50 <nickm_fallback> I think there is a S19 item that is also not happening for me, like #29267. We have some of the prerequisites written, but it won't get finished by end-of-may. It might be better to pass the tools I'm writing
17:40:06 <nickm_fallback> on to the anticensorship team and let them decide whether they make a good basis for CI
17:40:17 <nickm_fallback> since they're the PT maintainers thesedays
17:40:20 <nickm_fallback> *these days
17:41:01 <gaba> ok. I can mention this to phw and cohosh on the meeting on Thursday.
17:41:18 <nickm_fallback> right. I'm not proposing they should try to do this by end-of-may, fwiw
17:41:33 <gaba> ok
17:41:38 <nickm_fallback> just that if they _do_ want to use chutney for tor+pt integration tests, it will soon support it
17:41:46 <nickm_fallback> next up is reviews!
17:41:53 <nickm_fallback> the list looks fairly short this week
17:42:29 <nickm_fallback> asn: anything you want to pass on?
17:42:38 <asn> nope
17:42:41 <nickm_fallback> ok
17:42:43 <asn> wrt bug triaging?
17:42:55 <asn> i kept the queries clean
17:42:56 <nickm_fallback> I meant, is there any review that you want to give to somebody else this week
17:43:01 <asn> aaah sorry
17:43:08 <asn> no
17:43:09 <asn> ill do them
17:43:12 <nickm_fallback> wrt triaging, though, that's good to know. thanks!
17:43:54 <nickm_fallback> mikeperry: You'll need to talk to douglet tomorrow about CI/coverity handoff, and see how that is going
17:44:06 <nickm_fallback> catalyst: it looks like asn has left triage clean for you; woot.
17:44:14 <catalyst> nickm_fallback: yay, thanks asn!
17:44:31 <nickm_fallback> On reminders: Retrospective on Thursday at 20:00 UTC
17:44:41 <nickm_fallback> gaba has a questino about how we should talk
17:45:17 <nickm_fallback> so please add +1s
17:45:55 <nickm_fallback> the other discussion topic is something we talked about last week...
17:46:06 <nickm_fallback> I have boldface items, but it looks like we already did them...
17:46:46 <nickm_fallback> juga wants to give us the opportunity to freak out if bastet _shouldn't_ start running sbws...
17:46:58 <nickm_fallback> any other discussion topics?
17:47:34 * ahf has none
17:48:46 <nickm_fallback> ok, hearing none, would you like to #endmeeting?
17:49:01 <ahf> yep
17:49:04 <ahf> #endmeeting