23:01:39 <nickm> #startmeeting network team meeting, 23 April 2019
23:01:39 <MeetBot> Meeting started Tue Apr 23 23:01:39 2019 UTC. The chair is nickm. Information about MeetBot at http://wiki.debian.org/MeetBot.
23:01:39 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
23:01:43 <nickm> how goes?
23:01:44 <catalyst> hi
23:01:50 <nickm> hi catalyst!
23:01:53 <nickm> anybody else around?
23:01:59 <mikeperry> hi
23:02:21 <nickm> hi mikeperry !
23:02:32 <nickm> dgoulet is not on channel; I've pinged him on #tor-dev
23:02:36 <nickm> we expecting anybody else?
23:03:07 <teor> ahf has gone to sleep, asn may also be sleeping
23:03:12 * meejah lurks
23:03:28 <nickm> I think it's 0100/0200 for them :)
23:03:43 <nickm> as usual our pad is https://pad.riseup.net/p/tor-netteam-2019.1-keep
23:04:42 <nickm> going down the standard items -- there are no currently unaddressed tickets on the CI list.
23:05:05 <nickm> ahf suggests that #29930 doesn't hve to be 040-must, and I concur
23:05:13 <teor> I agree
23:05:39 <nickm> in theory we should look at the kanban now, but it isn't loading for me. Can anybody else see it?
23:06:13 <gaba> hiro sent me a workaround about the board
23:06:25 <gaba> click an 'all boards' and then in the board... then it loads
23:06:27 <nickm> oh?
23:06:30 <gaba> it seems it is the bug with the new wekan
23:06:34 <gaba> new version
23:06:52 <gaba> 'all boards' is a link at the top
23:07:24 <nickm> wow
23:07:29 <nickm> software is great :)
23:07:33 <teor> yeah, it works
23:07:56 <nickm> we have a _lot_ of things in backlog right now
23:08:07 <nickm> gaba: should we talk about prioritizing?
23:08:22 <gaba> ok
23:08:33 <gaba> the backlog should be sorted out by priority
23:08:45 <gaba> if it is not then we should sort it out by priority
23:09:01 <gaba> mmm, actually. nickm: do you want to talk about it now?
23:09:04 <nickm> teor: when do you disappear?
23:09:15 <nickm> gaba: yes, let's
23:09:19 <gaba> ok
23:09:50 <teor> nickm: at the end of today, in ~8 hours time
23:09:53 <gaba> the onion services tickets are still not integrated into the backlog. asn and dgoulet will look at the priorities for it and then we integrate them (right now they are in its own column)
23:10:12 <nickm> teor: cool
23:10:21 <teor> gaba, nickm: I have sorted my backlog tickets by priority
23:10:28 <gaba> there are a lot of tickets that were "planned" for march/april that are in the backlog.
23:10:31 <gaba> nice teor. thanks
23:10:34 <nickm> gaba: IIUC that sponsor has a much later due date than the other stuff...
23:10:41 <gaba> yes
23:10:49 <gaba> the next one ending is s19 at the end of may
23:11:20 <mikeperry> is the canonical backlog we are supposed to sort in the kanban? my workflow would be faster if I could just update priorty fields on trac
23:11:29 <mikeperry> for wtf-pad tickets, at least
23:11:36 <nickm> teor: looking at my backlog for S19, the chutney-PT stuff seems high priority. I'd like to know your thoughts on how you think I should procede there, so that when I try to do it I have the benefit of your suggestions
23:11:57 <gaba> mikeperry: how do you sort it out in trac?
23:12:30 <mikeperry> gaba: this query https://trac.torproject.org/projects/tor/query?status=!closed&keywords=~wtf-pad&order=priority
23:12:31 <nickm> teor: is chat or email most convenient there?
23:12:32 <catalyst> mikeperry: i find that trac isn't fine-grained enough to really prioritize things
23:12:51 <teor> mikeperry: I agree. I would rather use trac and ignore the kanban. The kanban does not update automatically, so it gets out of sync.
23:13:01 <mikeperry> catalyst: it depends. I like to group by tag or topic and then priortize
23:13:13 <teor> nickm: let's talk in tor-dev?
23:13:15 <mikeperry> otherwise there's too many other high priorty things in the way I don't care about
23:13:17 <nickm> one problem with the trac approach is that it has so darn much
23:13:29 <nickm> and it doesn't restrict itself to the roadmapped stuff
23:13:36 <gaba> yes, we need a subset of tickets for the team, that are the onews being worked on
23:13:43 <teor> My best experience with trac is mikeperry's grouping then prioritising method
23:13:44 <mikeperry> nickm: yes this is why tags, milestones, and other filters on queries ar essential
23:13:54 <gaba> i agree that integration trac/kanban would be the best but we do not have it right now
23:14:12 <teor> gaba: no, I just want to use trac, sorry
23:14:13 <nickm> teor: sure. I will try to be around after but I need to do bedtime for the kid tonight, so I may not have a lot of time
23:14:22 <teor> nickm: email also works
23:14:43 <nickm> ok. if we run out of time, email me what you think some time in (your) today?
23:15:22 <teor> gaba: "Having too many tickets on the one page" is a process failure. "Having different statuses in different tools" is another.
23:15:37 <teor> I really do think we can use trac better, so we avoid both these issues.
23:16:09 <teor> nickm: sure, I haven't read your updates on the sponsor 19 tickets yet
23:16:22 <nickm> so here's a problem about the "different statuses" that makes it harder to use trac as "source of truth".
23:16:31 <nickm> Maybe we can come up with a solution
23:16:50 <nickm> today gaba and I tried to figure out which of the roadmapped items we had done and which we did not have done
23:16:56 <nickm> for a couple of sponsors
23:17:19 <nickm> a lot of the "SponsorX-must" items had gotten that label after Brussels, based on one person's judgment.
23:17:39 <nickm> and so it's hard to figure out which items of that kind are actually our contracted deliverables
23:17:46 <nickm> and which are just things somebody found to be really important
23:18:26 <teor> We also have a similar problem with the release milestones
23:18:51 <nickm> Whatever we use as our sponsor-tracking roadmap, maybe it needs not be world-writable.
23:19:08 <nickm> Or maybe it needs to have a propose-change/actual-change process
23:19:15 <mikeperry> the kanban will have these miscategorization issues too, if we all have to update it... at least trac has the changelog updates of these things emailed, archived, searchable, etc
23:19:21 <teor> +1
23:19:34 <gaba> trac is where the community and everybody brings issues/bugs to. we need a place where we can filter and sort out more specifically that is related with the sponsor work that the team decides to do.
23:19:51 <teor> gaba: I don't think that's a solution
23:20:17 <teor> Now we have two places that are out of sync
23:20:34 <nickm> FWIW, I really don't like it how every time we have a procedural "and now we update X to match Y" thing, we need to have a discussion about whether to have X and/or Y
23:20:37 <mikeperry> don't get me wrong, I like the idea of kanbans; I will be proposing using one on Friday in the scalability meetings.. but it's going to be used differently; it can't ever replace trac. I think it has to have much less granularity than trac, inherently
23:20:56 <nickm> Maybe we should have a rule about separating meta-discussion and non-meta-discussion?
23:21:46 <teor> nickm: I think you're right. We can't change our use of trac and kanban in this meeting. Let's talk about it in July at the in-person meeting?
23:21:51 <nickm> +1
23:21:56 <nickm> +lots in fact
23:22:12 <gaba> +1
23:22:21 <nickm> Looking at my own issues for the kanban ... #29210 is still in progress; I'm blocked on catalyst finshing their review
23:23:05 <nickm> for my backlog items, I want to take on #29267 next, based on advice from teor
23:23:15 <catalyst> nickm: was in the middle of writing up a comment on that :)
23:23:29 <nickm> I can't to #28878 until #29732 is reviewed
23:23:32 <nickm> catalyst: great!
23:23:48 <nickm> #29283 and #29263 are less important than #29267 imo
23:23:52 <teor> #agreed We will use the kanban and trac until the July meeting. Then we will talk about it in July at the in-person meeting.
23:25:38 <nickm> teor: I also want to talk at some point about what I can do for privcount while you're away
23:26:09 <mikeperry> the kanban is still not lading for me
23:26:20 <nickm> did you try the workaround above?
23:26:23 <mikeperry> loading either. maybe that is non-meta
23:26:30 <gaba> mikeperry: https://github.com/sandstorm-io/sandstorm/issues/3132#issuecomment-485948463
23:26:43 <nickm> (click on "all boards"; then click on the roadmap)
23:27:35 <teor> nickm: ok, we have a lot to talk about. Let's try to start handovers earlier next time.
23:28:16 <nickm> shall we move on to the next item?
23:28:35 <mikeperry> I am fryustrated to have to update two places when I work on a ticket that takes less time than to update either
23:28:54 <teor> mikeperry: we're going to talk about that at the July meeting.
23:29:11 <nickm> Indeed, let's talk about it then?
23:29:13 <mikeperry> that's nice. I still prefer to only use one of these systems
23:29:18 <mikeperry> until then
23:29:28 <nickm> It is also frusterating to talk about this every single time we have a meeting
23:29:57 <nickm> Did the page load for you after you tried the workaround?
23:30:17 <teor> mikeperry, nickm: I understand and share your frustration, but we need to cover other things in this meeting. If it's urgent, let's do it by email on the network-team list?
23:30:36 <mikeperry> yes.. I havce filtered on my sponsor.. I have a lot of data entry to do apparently.. we created like 4 small subtickets of #28683 last week
23:30:53 <mikeperry> it's frustrating to have to do all that when these items are small.. maybe I should merge my tickets first?
23:31:08 <mikeperry> #28634
23:31:10 <nickm> we don't need a kanban item for every ticket
23:31:21 <nickm> if that's in-progress, just set it to "in progress"
23:31:54 <mikeperry> (by merge I mean combine)
23:32:05 <nickm> can we go on to reviews?
23:32:47 <teor> I have just updated the list of stalled reviews on the pad
23:33:08 <teor> (I will turn it into a trac wiki page eventually, so it updates automatically)
23:33:40 <teor> catalyst, mikeperry: do you need help with your old reviews?
23:34:07 <mikeperry> if they are uent, yes. I need to task switch to tor-performance meeting stuff tomorrow
23:34:12 <mikeperry> *urgent
23:34:23 <nickm> The expectation is that we work on reviews the same week we get them
23:34:36 <nickm> IIUC
23:35:14 <teor> mikeperry: can you do all your reviews this week?
23:35:19 <catalyst> teor: #27130 should probably be needs_information or needs_revision because there are tricky things, but i haven't had time to comment and it didn't seem urgent
23:35:20 <mikeperry> no
23:35:34 <nickm> catalyst: ok, please pass it over to me or mark it needs_information?
23:35:40 <gaba> mikeperry: can you expand your no?
23:36:32 <mikeperry> no, I don't have time to get through all of those reviews; I need to task switch to tor-performance meeting stuff tomorrow
23:36:49 <nickm> Do you need help with the tor-performance stuff?
23:36:49 <mikeperry> as it says on the pad, I want to write up a wiki page of the experiments we discussed for the meeting on Friday
23:36:52 <mikeperry> and work on other things
23:36:53 <catalyst> teor: also #29732 could go to someone else
23:37:44 <nickm> mikeperry: am I being naive when I choose to review your code the same week that I get assigned the review?
23:37:47 <nickm> Am I being a chump?
23:38:18 <catalyst> nickm: #27130 reassigned to your review
23:38:21 <nickm> sorry, that was unkind
23:38:22 <mikeperry> I try to do reviews that are coming in an upcoming release soon first
23:38:35 <nickm> mikeperry: But please understand: everybody's workflow depends on their code getting reviewed and merged
23:38:36 <gaba> mikeperry: maybe we can drop roadmap work for this week and do the reviews?
23:38:48 <nickm> the ability for us to put Tor out depends on all reviews happening in a timely way
23:38:53 <nickm> We are trying to share this work as a team
23:39:13 <mikeperry> I also got to the end of the week and realized I had to choose between self-performance review, booking travel, code review, my temportary bug triage role, vanguards issues, and some other things
23:39:30 <nickm> If you put this work no to all the other people, then those people have less time to help you with stuff that you do evaluate as important
23:39:42 <mikeperry> I dropped several of those things. I didn't expect the self-performance review to take so long; I chose bug triage and that, though
23:40:03 <catalyst> hey folks this sounds like classic overwork; could we please not try to assign blame?
23:40:12 <catalyst> overwork from process issues, that is
23:40:18 <nickm> sorry, I am having a hard time today
23:40:58 <nickm> gaba: could you run the meeting for a few minutes?
23:41:01 <ahf> hey o/ - reading backlog
23:41:04 <gaba> ok
23:41:39 <gaba> so, reviews from mike, let's talk about it later so we continue
23:41:59 <gaba> sorry that you are feeling overwhelmed with all the stuff
23:42:19 <teor> it has happened to all of us. It is not anyone's fault.
23:42:25 * gaba trying to see which part of the meeting is next
23:42:28 <gaba> yep
23:43:06 <teor> We are here to help you, but we need to know what you need help with.
23:43:13 <gaba> review assignmetns for this week
23:43:33 <gaba> anybody else need to drop some reviews this week? or are peole ok with their reviews
23:43:42 <gaba> any blocker from reviews from last week?
23:44:11 * catalyst could use someone else to take review of #29732
23:44:22 <teor> asn and dgoulet aren't here, so let's just leave the reviewer for #29732 blank, and shift it to next week?
23:44:35 <ahf> i only have 2 and one is a shellcheck one, so i could take one more if that helps anybody
23:44:40 <gaba> ok
23:44:47 <gaba> ahf: can you take #29732 ?
23:45:08 <ahf> yes
23:45:11 <ahf> assigning it to me
23:45:12 <gaba> thanks
23:45:21 <teor> I didn't have any review capacity this week, because I had 4 peer feedbacks. I know that increases the load on the rest of the team, and I am sorry about that.
23:45:34 <catalyst> ahf: thanks!
23:45:45 <ahf> np!
23:45:58 <gaba> mikeperry: if you have an idea which ones you can't do please bring them to dgoulet and asn tomorrow
23:46:05 <nickm> I'm also happy to take on what reviews I can; I'm done with my reviews for the week, and can pick up stuff, so long as I didn't write it.
23:46:12 <gaba> next topic is rotation updates.
23:46:37 <nickm> I'm bug triage this week; what's the status, mike?
23:47:00 * ahf is CI+coverity and i've seen there was a small new coverity CID opened today/yesterday
23:47:20 <ahf> teor: very nice description on the meeting pad for the handover btw, thank you for doing that
23:47:27 <mikeperry> gaba: ok, I can do that by EOD tomorrow (depending on state of experiments wiki page)
23:47:34 <teor> ahf: I hope it isn't too much info.
23:47:54 <mikeperry> gaba: (by which I mean I'll work on the wiki page tomorrow, and let you know how it looks and take a guess at how many reviews I can do
23:48:00 <ahf> teor: i think it's good, gives a much better overview than i've felt i had before
23:48:07 <mikeperry> gab: on Thursday
23:48:18 <gaba> thanks mike
23:48:40 <gaba> mikeperry: do you have any status on the bug triage from last week?
23:48:47 <gaba> there is a lot of comments int he pad about it
23:49:04 <mikeperry> gaba: yeah it's in the pad
23:49:27 <gaba> ok, is that enough nick for this week?
23:49:42 <nickm> nick?
23:49:46 <mikeperry> I mean I feel like this role transition is forcing us to do role-knowledge-transfer each weeek.. I leanred that I wasn't sure what our current preffered support page is
23:49:50 <gaba> and about CI is from teor to ahf
23:49:53 <mikeperry> I guessed tor.stackexchange.com
23:49:59 <mikeperry> and that is noted on the pad
23:50:03 <mikeperry> among othere things
23:50:06 <nickm> I think we don't have a great one. We could ask the community team what they recommend
23:50:15 <gaba> yes, it seems there is always a learning :)
23:51:04 <gaba> next is 0..0 status
23:51:18 <gaba> 0.4
23:51:39 <gaba> mm, did I miss coverty?
23:51:55 <ahf> coverity and CI is same
23:52:00 <gaba> ohh, hehe
23:52:01 <gaba> ok
23:52:03 <ahf> :-)
23:52:14 <gaba> same person
23:52:15 <gaba> nice
23:52:16 <nickm> ahf: ping me tomorrow about coverity status ? I have ideas about the newer coverity issue.
23:52:23 <nickm> The other old coverity issues are waiting for code review
23:52:36 <ahf> hey, would anybody think it would be OK if i spend some time this week trying to do a thing where i create a ticket automatically on trac when i see appveyor, travis or jenkins fail?
23:52:45 <gaba> everybody ok about what needs to be removed from 0.4.0
23:52:52 <nickm> ahf: how do you mean?
23:52:55 <ahf> nickm: i will, there was a new item yesterday too
23:52:56 <gaba> +1 ahf, that seems good
23:52:56 <teor> mikeperry: I have been trying to make transitions easier by creating wiki pages for each role. But I can only do one wiki page every week or two.
23:53:12 <ahf> nickm: like pull info in a cron from appveyor/travis/jenkins and create a ticket once one of them goes red
23:53:15 <catalyst> ahf: that sounds like a great idea! as long as it doesn't make too much noise on transient failures
23:53:15 <teor> mikeperry: let's talk about roles on the network-team list, or at the July meeting?
23:53:27 <ahf> catalyst: agreed
23:53:44 <gaba> july meeting +1
23:53:48 <catalyst> ahf: or maybe that will be a reason for us to shut up or fix the nondeterministically failing tests?
23:54:01 <mikeperry> teor: ok
23:54:09 <ahf> catalyst: hah, maybe :-S let's brainstorm a bit about this over the weekend, i think you will have some good feedback for this
23:54:59 <teor> ahf, catalyst: I tried creating a ticket or ticket comment every time I saw a transient CI failure. There should be 1-2 per week right now. A few weeks ago it was one daily.
23:55:00 <catalyst> ahf: sure, i'd be happy to talk more about it later (though why the weekend?)
23:55:13 <ahf> teor: yeah, i actually think this is a good idea
23:55:22 <ahf> catalyst: err, sorry, i'm very tired. i meant over the week :-S
23:55:35 <nickm> treating intermittent failures as bugs was really helpful
23:55:54 <nickm> we tag them with "tor-ci", I think? So we don't accidentally re-create?
23:56:03 * gaba needs to run to get kid from school...
23:56:16 <nickm> gaba: see you tomorrow! Say hi to the kid!
23:56:29 <ahf> good idea with a keyword also for handover
23:57:10 <teor> nickm, ahf: tor-ci-fail
23:57:13 <nickm> #action talk to community team about what to say to people who put support requests on trac
23:57:17 <nickm> teor: thanks
23:57:32 <ahf> teor: ack
23:57:34 <teor> tor-ci has been used for every CI feature and ticket, so it doesn't help in queries
23:58:28 <teor> #action talk about roles and role transitions at the July meeting (or on the network team list)
23:59:01 <nickm> looks like we talked about reviews
23:59:12 <nickm> teor makes a good point about splitting up the pad
23:59:38 <nickm> I think that's somethign we could do via trial-and-error -- would everybody be okay with me just trying to do it for next week, and we see how it works?
23:59:44 <teor> +1
00:00:32 <nickm> Since teor is about to go away, let's use the rest of this meeting for their most important handover stuff.
00:00:51 <nickm> teor: (when are you planning to be back? My apologies; I have bad memory for that stuff)
00:00:52 <ahf> nod
00:01:10 <teor> May 21
00:01:13 <nickm> ack
00:01:40 <ahf> teor: have a very nice leave! hope you can relax and re-charge all the batteries :-)
00:01:45 <teor> Thanks!
00:01:57 <nickm> yeah; I hope you have a great time and many awesome days
00:02:27 <teor> Here are my high priority things:
00:02:40 <teor> I talked with juga about blocking sbws merges until I get back. Because we really need a stable sbws, now it is deployed on 1-2 directory authorities.
00:03:01 <teor> I can't see any other way to do a handover and make it work right now.
00:03:20 <nickm> Is it "stable enough for now"?
00:03:23 <nickm> what's the status?
00:03:33 <teor> Yes, it is stable and functional.
00:03:56 <teor> We need to improve the number of measured relays before we deploy to a 3rd authority.
00:03:59 <teor> But that is delicate work.
00:04:04 <nickm> proposal: let's try to find a couple of people to work on sbws stuff, but not merge unless emergencies come up.
00:04:09 <teor> +1
00:04:24 <nickm> #action let's try to find a couple of people to work on sbws stuff, but not merge unless emergencies come up.
00:04:42 <teor> I don't think adding more load to the team is a good idea right now, so our best option is slowing sbws and other non-funded work.
00:05:42 <teor> Next item
00:05:45 <teor> Who will do urgent CI backports?
00:06:02 <teor> I think that's nickm?
00:06:03 <teor> We can just block other backports until I get back.
00:06:07 <nickm> As in, "0.2.9 CI is broken, we must backport?"
00:06:11 <teor> Yes.
00:06:29 <teor> Which should only happen if Travis changes.
00:06:34 <nickm> I think that's me, though I would also consider not backporting anything but critical security issues
00:06:49 <teor> I agree
00:07:06 <teor> 0.3.5 and later are affected by the stem failures, if we fix the tor_mlockall() bug, we should backport that to 0.3.5
00:07:31 <nickm> ack
00:07:34 <teor> But maybe we should test it first, so that might mean disabling stem in 0.3.5 and 0.4.0?
00:08:45 <nickm> I think it will depend on what the issue turns out to be.
00:08:52 <teor> Fair enough
00:09:03 <nickm> I'll try to muddle through?
00:09:10 <teor> As we all do
00:09:25 <nickm> As I told Roger once, the cost of delegating to others is that they will not do it the same way as you would. :)
00:09:34 <teor> I think you'll be better at mlockall() than I will be
00:09:37 <teor> Indeed. And that's ok.
00:09:59 <teor> I don't want to do reviews or rotations until the week of 27 May, because 21 May is a short week filled with backlog.
00:10:14 <nickm> makes sense
00:10:23 <teor> And that's about it, apart from PrivCount. Which I think nickm and I should talk about in tor-dev.
00:10:28 <nickm> ok
00:11:34 <teor> Do we have anything else to talk about? It's 10 minutes past the hour.
00:11:56 <nickm> It looks like there are no other discussion topics, other than juga's questions. I'll try to answer them if you don't get to them before you go?
00:13:00 <nickm> hearing no other topics?
00:13:23 * ahf is good
00:13:23 <nickm> thanks, everybody! It's stressful times, but we're awesome programmers and we'll make it through together.
00:13:30 <ahf> o/
00:13:33 <nickm> There's nobody else I'd rather be working with
00:13:36 <nickm> #endmeeting