22:58:16 <nickm> #startmeeting network team meeting, 8 Jan 2019
22:58:16 <MeetBot> Meeting started Tue Jan 8 22:58:16 2019 UTC. The chair is nickm. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:58:16 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
22:58:20 <nickm> hello!
22:58:34 <nickm> We're using a NEW PAD URL: https://pad.riseup.net/p/tor-netteam-2019.1-keep
22:58:43 <nickm> happy new year!
22:58:45 <dgoulet> yello
22:59:19 <nickm> who is here tonight?
22:59:22 <catalyst> hi
22:59:34 * teor
22:59:38 * gaba
23:00:08 <nickm> cool! looks like we've got australia and the Americas, but Europe has gone to bed.
23:00:14 <nickm> Sweet dreams, europe.
23:00:34 <nickm> mikeperry: ping
23:00:40 <teor> Europe was awake when I went to bed last night
23:01:14 <nickm> so, our first order of business is to update the roadmap!
23:01:24 <nickm> We are officially _over_ with sponsor 8, except for the reporting
23:01:39 <teor> \o/
23:01:52 <gaba> yeah!
23:01:59 <nickm> now sponsor 19 gets focus, with a little diversion into sponsor 31 (modularization)
23:02:06 <mikeperry> heyo
23:02:16 <teor> And Sponsor V?
23:02:19 <gaba> report and closing/moving tickets :) on s8
23:02:33 <gaba> yes, sponsor V too
23:02:34 <nickm> teor: yup, gotta wrap that up too
23:03:11 <nickm> (sponsor 31 is not a full modularization, since it's only like 1.5 person-years of funding. We need to be parsimonious with what work we do there)
23:03:34 <catalyst> so no ocean-boiling?
23:03:34 <nickm> gaba: (is that accurate?)
23:03:43 <gaba> yes
23:04:01 * teor looks up parsimonious: "very unwilling to spend money or resources"
23:04:05 <nickm> catalyst: we have to pick the very best bucket of oceanwater to boil
23:04:25 <catalyst> artisanal oceanwater warming
23:04:26 <gaba> about the roadmap, is everything people are working on in the DOING stack ?
23:04:28 <nickm> teor: i meant that we need to stretch our resources here :)
23:04:53 <nickm> gaba: good question
23:05:51 <nickm> gaba: I had been planning to revise my pubsub branch this week too, if time permits; that's not in the doing stack though.
23:06:08 <gaba> can we add it there? is that part of s31 work?
23:06:11 <nickm> yes
23:06:18 <gaba> ok
23:07:27 <teor> Do we need someone else on sbws apart from juga? Or is the review process enough?
23:08:00 <gaba> that is in the list for discussion. we need somebody to review sbws (or suspend reviews until february). mabye dgoulet?
23:08:00 <nickm> teor: I think the review process is working, but I don't have a huge amount of visibility into sbws
23:08:17 <teor> Let's just do sbws reviews for January, and then talk about how it's going at the team meeting?
23:08:19 <dgoulet> we assign reviewers so sbws so what is needed more?
23:08:27 <dgoulet> you mean dev.?
23:08:31 <nickm> btw, for the "TODO" items for sponsor19: I moved #25601, #29024, #21314, and #25483 to the top. They are the ones that we identified as blockers
23:08:36 <nickm> when we had that snowflake meeting
23:08:37 <gaba> we need somebody else that is not teor to do the reviews in january
23:08:53 <gaba> perfect, thanks nickm!
23:09:04 <teor> we are already sharing the sbws reviews around the team
23:09:21 <gaba> ahh, ok!
23:09:23 <gaba> great!
23:10:33 <teor> I used to try to do sbws tasks and review the overall design. I think we're ok there, and sbws can slow down a bit.
23:10:44 <gaba> ok
23:11:09 <nickm> Also, everybody please remember that 0.4.0 feature-freeze is in 7 days
23:11:17 <gaba> We need people to get the blockers on snowflake :)
23:11:29 <teor> We will find out if there is anything missing for sbws once I stop doing those things :-)
23:11:56 <teor> Which open features do we expect to have in 0.4.0?
23:12:04 <nickm> The one I have no idea about is the multiplexing one (#25601)
23:12:06 <teor> Do we have a (short) list of tickets?
23:12:31 <teor> (For 0.4.0)
23:12:42 <nickm> teor: I think wtf-pad is the big remaining one, though there are a couple of performance improvements in needs_review
23:12:49 <nickm> I don't think there's a short list of tickets like you mention though
23:14:00 <teor> I put some Sponsor V bugs and enhancements in needs_review in 0.4.0 yesterday, but there's no reason for them to be in 0.4.0
23:15:24 <nickm> maybe we should ask everybody to look through the 0.4.0 milestone this week, and send up a signal flare if something important isn't happening, feature-wise?
23:15:35 <gaba> ok
23:15:56 <nickm> #action -- everybody looks over the 0.4.0 milestone
23:16:31 <teor> We still put way too much in the 0.4.0 milestone.
23:16:36 <teor> Let's try to do things differently for 0.4.1?
23:16:39 <nickm> teor: yup.
23:17:13 <nickm> teor: the 0.4.1 mere window closes on 15 may
23:17:30 <nickm> maybe we should actually assign points to tasks this time and kick out anything that doesn't fit
23:17:47 <teor> Let's actually talk about every ticket we add to 0.4.1?
23:18:20 <teor> Let's list tickets we want to add in the meeting pad, and review the list at the meeting.
23:18:23 <gaba> take some space once a month on a weekly meeting to talk aobut the tickets that go into 0.4.1?
23:18:28 <gaba> +1 teor
23:18:34 <nickm> okay, let's try that
23:18:35 <teor> No, once a month is too late
23:18:46 <nickm> I agree with the weekly thing
23:18:47 <gaba> ok
23:18:59 <nickm> and let's use 041-proposed judiciously to track those tickets too?
23:19:04 <teor> And let's run a report to find tickets that were accidentally added to 0.4.1 in the last week
23:19:42 <gaba> ok, I can help with some of this stuff to have before the weekly meeting
23:19:50 <teor> There are currently no tickets in 041-proposed
23:19:52 <gaba> maybe the pad to talk about those tickets at the meeting?
23:20:50 <teor> Can we try it now?
23:20:58 <nickm> teor: all sounds good. Do you have tim to write this up in a wiki page somewhere?
23:21:01 <nickm> *time
23:21:20 <gaba> we have a few things in the list for today. can we do it for the next meeting?
23:21:42 <teor> nickm: here's my draft: https://pad.riseup.net/p/network-team-triage-2018
23:22:06 <nickm> #action -- let's all look at that draft this week
23:22:18 <nickm> next item for this meeting is looking at the review assignments
23:22:30 <gaba> ok
23:22:32 <teor> gaba: sure, let's leave it until next week, so we can prepare
23:22:37 <gaba> ok
23:22:46 <nickm> wow, there is sure review backlog here
23:23:09 <nickm> I hope it isn't too hard to review this stuff, or we won't get these things into 0.4.0
23:23:46 <gaba> anybody thing they will need more time/help with reviews?
23:24:50 <catalyst> maybe i could use someone to talk with about #27130 who knows more about the finer points of Rust dependency management?
23:25:44 <nickm> catalyst: that's a good idea; maybe ping komlo?
23:26:28 <catalyst> nickm: thanks, good idea!
23:26:46 <mikeperry> asn and I are considering trying to get #28780 and #28634 into 0.4.0 btw (wrt talking about proposed tickets). it seems tight though
23:27:38 <nickm> ok
23:28:04 <nickm> it would be good to have those, esp #28634, even if #28634 is just "send one cell an hour" so we get a little testing
23:29:11 <teor> I would like to focus on PrivCount before the hackfest, so I'm going to prioritise 0.4.0 reviews, and leave any other reviews (or give them away)
23:29:19 <gaba> yes
23:29:29 <nickm> ok
23:30:07 <teor> I am stalled on some of the IPv6 reviews, the code or tests are broken in some subtle way, and I already tried to debug them for a few hours.
23:30:46 <nickm> Hm. So if that's the case it might be okay to defer some to 0.4.1 or something
23:31:03 <nickm> or you can just describe the brokenness and have that be your review
23:31:45 <teor> I have already described the brokenness, unfortunately, it might be chutney or some other code that's broken. But that's ok.
23:33:21 <nickm> next agenda item is rotations. I see mikeperry on bug triage and teor on ci/coverity
23:33:55 <nickm> and if that's okay, I think this brings us on to discussion.
23:33:58 <nickm> we taked about reviews
23:34:10 <nickm> *talked
23:34:12 <nickm> we talked about sbws
23:34:17 <nickm> next is 31. Gaba?
23:34:39 <gaba> yes, we need tickets for s31 and start planning in january
23:35:37 <gaba> maybe dgoulet and/or ahf and catalyst can help on that?
23:35:54 <gaba> do we need a meeting to kickoff that work? not sure how you want to start it
23:36:01 <nickm> i'd be happy to do some but I shouldn't do it alone
23:36:28 <nickm> teor and catalyst and I shared some good ideas in Mexico City
23:36:31 * catalyst looks at the sponsor31 sheet
23:37:41 <catalyst> this fuding goes through November?
23:37:49 <gaba> yes
23:37:58 <gaba> and there is a possibility of an extension if needed then
23:38:10 <gaba> we should start with 1. and 2. now
23:38:15 <gaba> and discuss in brussels
23:39:13 <teor> Some of my work on Sponsor V will benefit from modularisation, we can put it in either sponsor
23:39:41 <gaba> like which part teor?
23:39:41 <nickm> so right now we're in the planning stages, but we should come to brussels with good ideas
23:39:46 <gaba> yes
23:40:49 <teor> gaba: #29008 is the obvious one
23:41:37 <gaba> ok, that would benefit from modularization but is not part of that
23:41:44 <teor> #29005 needs bandwidth events / pubsub / or a hook into rephist
23:41:49 <gaba> ok
23:41:58 <teor> the noise in #29006 needs to know when the relay's consensus weight changes
23:42:05 <nickm> does anybody want to come up with modularization ideas in particular with me, or should we come back to this next week?
23:42:23 <nickm> teor: what's the schedule on needing pubsub for those?
23:43:31 <teor> I can write a proof of concept with timers and direct function calls
23:43:31 <dgoulet> nickm: I can help with mod. :)
23:43:57 <nickm> teor: sounds okay if it doesn't eat a huge amount of time
23:44:17 <nickm> dgoulet: ok, let's loop back to talk about that tomorrow then? ping me?
23:44:25 <dgoulet> sounds good
23:44:30 <dgoulet> tomorrow is good
23:44:30 <nickm> #action nickm and dgoulet talk modularization some time on wednesday
23:44:31 <teor> If we are going to create a nice template for an optional module, I would delay #29008 to benefit from it
23:44:43 <mikeperry> I think we should prioritize modularization around some high level ideas/criteria rather than line items. Like "1. Things that will make it easier to do multithreaded networking and crypto. 2. Things that will make it easier to make Rust implementations. 3. Things that will make it easier to switch components out (like TLS connections)"
23:44:52 <catalyst> nickm: you've already heard many of my ideas, but if you start accumulating stuff in a more organized way i'll contribute text
23:45:12 <mikeperry> but I don't have cycles for that now. seems like a good in-person discussion for Brussels
23:45:16 <teor> 4. Things that will make it easier to create optional compile-time or runtime modules
23:45:49 <nickm> mikeperry: if you want to brain-dump stuff like that, it will rock
23:45:57 <nickm> even if you don't have time to flesh it out
23:45:58 <dgoulet> mikeperry: +1
23:46:41 <teor> 1b. Things that will make it easier to do multithreaded path selection and other CPU-heavy consensus operations?
23:46:54 <mikeperry> I think agreeing on an ordering on some high-level criteria like 1-4 will make it easier to in/out the line items.. where should I put such a brain dump?
23:47:14 <teor> (Or did we optimise those operations already?)
23:47:49 <dgoulet> anyone who wants to braindump, a pad or email and then we can aggregate
23:48:00 <dgoulet> I bet asn and/or ahf as well could have ideas there
23:48:06 <dgoulet> (who aren't here)
23:48:18 <gaba> can you send a mail to all of us and i collect them into a pad.
23:48:19 * teor has tagged all 0.4.1 milestone items with 041-proposed-on-roadmap, anything that isn't on the roadmap should get 041-proposed (and then we'll remove the tags after the next meeting)
23:49:23 <nickm> sounds great!
23:49:27 <mikeperry> gaba: ok I'll try
23:50:00 <nickm> gaba: want to talk about closing tickets and moving/removing s8 tickets?
23:50:15 <gaba> yes
23:50:17 * catalyst has questions about guidelines for that
23:50:31 <teor> (We have 8 minutes left before 0000 UTC)
23:50:55 <gaba> I would like us to close tickets. If there is antyhing that we still need to do we can open a new ticket for that and reference it back to the ticket that we were working on. Would that work?
23:51:08 <catalyst> gaba: ok so you prefer closing to moving?
23:51:19 <gaba> and move all the tickets from s8 with an idea of priorityfor them
23:52:07 <catalyst> how about parent tickets with some children that are already closed?
23:52:09 <teor> Let
23:52:12 <teor> Oops
23:52:15 <gaba> closing tickets if possible. if there is a ticket under s8 that we didn't work on then we move it out of s8, not need to close.
23:52:46 <gaba> for the parent tickets with some tickets still open then we move it out of s8
23:53:40 <gaba> does that sound ok?
23:54:18 <catalyst> ok
23:54:49 <gaba> that is it.
23:55:11 <gaba> The next would be the hackweek agenda. I would like us to be prepare for it :)
23:55:12 <nickm> I think that the other stuff under discussion is mostly "please check out this link and act accordingly"
23:55:16 <gaba> yes
23:55:31 <gaba> hackweek agenda is filling up the poll to choose a day to meet and discuss agenda for the hackweek
23:55:36 <gaba> and how is going to be organized
23:55:39 <gaba> I have a proposal
23:56:12 <gaba> About the retrospective for s8 is to have an idea of what worked and what didn't work for improving the work we are doing.
23:56:37 <gaba> And the last item is the one about funding proposal. We have two opportunities that we can send proposals to
23:56:44 <gaba> but we need priorities and ideas
00:00:31 <teor> I have a question:
00:01:18 <teor> Does anyone have time to help with PrivCount before Brussels? (I think asn will help after padding is done)
00:01:42 <nickm> I can chat and look at stuff and maybe revise code, but I can't promise too much
00:02:44 <teor> fair enough
00:02:44 <mikeperry> I will probably have to switch back to vanguards stuff after padding is merged. and do more padding stuff. :/
00:04:00 * catalyst can look at mathy stuff but doesn't promise to catch everything that could be a problem
00:04:32 <teor> Turns out that some noise is better than no noise :-)
00:04:55 <catalyst> and clamping to zero isn't always a great idea?
00:05:21 <teor> More precisely: our initial proof of concept uses stats that are already public, so we don't need to worry too much about precision
00:06:26 <catalyst> sorry, we should try to wrap up this meeting i guess
00:07:00 <gaba> yes, any question about hackwee, s8 retrospective or funding needs and priorities?
00:07:11 <nickm> Additionally, Anything else that we need to talk about tonight?
00:08:31 <gaba> It seems that we are ok for today
00:08:54 <nickm> okay. then let's call the meeting. Thanks, everybody!
00:08:57 <nickm> #endmeeting