16:59:31 <nickm> #startmeeting weekly network team meeting, 9 Oct 2018
16:59:31 <MeetBot> Meeting started Tue Oct  9 16:59:31 2018 UTC.  The chair is nickm. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:59:31 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:59:45 <nickm> https://pad.riseup.net/p/tor-netteam-2018.1-keep is our pad
17:00:02 <nickm> hi, folks!
17:00:06 <ahf> hello hello
17:00:10 <nickm> We have a lot to do in this hour!
17:00:35 <nickm> mikeperry and catalyst are sick and might not be able to attend
17:00:36 <dgoulet> hello
17:00:43 <gaba> hi!
17:00:47 <nickm> it's the middle of the night for teor
17:00:51 <dgoulet> asn I believe is at 35k feet in the air as well
17:01:21 <ahf> i might drop out the last 5 min. towards 18 UTC since we have a phone call for sysadmin screening there
17:01:41 <nickm> gosh. so we have nickm, dgoulet, ahf, gaba.
17:02:00 <gaba> oh
17:02:14 <ahf> yep
17:02:18 <nickm> well, let's see what we can get done
17:02:24 * catalyst is kind of here
17:02:28 <nickm> hi catalyst !
17:02:31 <nickm> I hope you feel better soon
17:03:03 <nickm> how do reviews look?
17:03:19 <nickm> It looks like teor4 has a lot of stuff...
17:03:37 <dgoulet> assigned... teor has many but they aren't big and the ASan + Rust ones have been discussed by teor
17:04:08 <ahf> i think i could take his #27197, i think it's related to one of mine
17:04:09 <nickm> hm, okay. I'll ask them tonight if they're online and I can take more stuff if they don't want it
17:04:15 <ahf> and i would like to get some rust review experience too
17:04:18 <dgoulet> so either I split them up randomly or teor can tell us how much he can take? ... I didn't know who else could handle them because they seemed based on Mexico meeting
17:04:18 <nickm> *their
17:04:26 <ahf> their! yes
17:04:44 <nickm> #action nickm asks teor if review load is okay
17:04:55 <nickm> everybody else okay with review load?
17:05:11 * ahf good
17:05:42 <nickm> let's skip right to the discussion stuff, since it will touch roadmaps and rotations
17:06:00 <nickm> First issue is prioritizing the next week or two.  We have a week left before the 0.3.6 merge window is open
17:06:05 <gaba> ok
17:06:30 <nickm> I'd really like to get all of the 0.3.5 "Very High" and "High" issues fixed -- those should all be CI and regression/release-blocker issues
17:07:23 <nickm> right now teor has 3 assigned; dgoulet has 3 accepted...
17:07:31 <nickm> but we have a bunch of issues left in "new"
17:07:50 <nickm> I'll make a query---
17:08:26 <dgoulet> huh the Milestone field is broken it seems
17:08:29 <dgoulet> (or being changed...)?
17:08:34 <nickm> https://trac.torproject.org/projects/tor/query?priority=%5EHigh&priority=%5EVery+High&status=new&status=reopened&milestone=Tor%3A+0.3.5.x-final&group=status&col=id&col=summary&col=owner&col=type&col=priority&col=component&col=version&order=priority
17:08:46 <nickm> dgoulet: works for me...
17:08:48 <ahf> dgoulet: my milestones was broken recently because of some permission changes
17:08:58 <dgoulet> ah! I'm not logged in! lol...
17:09:03 <ahf> if you get that it is sort of a clickable link but you can't click it then you need a milestone_view permission
17:09:06 <ahf> ah
17:09:39 <ahf> oh wow, a netbsd bug
17:09:56 <nickm> I bet it isn't netbsd only
17:10:04 <ahf> yeah
17:10:11 <nickm> Anybody have a suggestion for how we should split these up?  My first thought is that people could take some, and I'll assign the ones that are left over tomorrow?
17:10:20 <dgoulet> nickm: hmmm so all of mine in Accepted are "long term" that is we are running diagnostics right now to try to catch it with more informations... so I guess I should put them in needs_info ?
17:10:36 <ahf> i think that would be fine
17:10:43 <nickm> dgoulet: or put them in 036 with 035-backport
17:10:51 <nickm> that would be fine too
17:11:30 <dgoulet> nickm: I might use needs_info because there is potentially a reality where the fixes won,t qualify for our backport policy
17:11:35 <dgoulet> ok good.
17:11:54 <nickm> makes sense
17:12:03 <nickm> we can always change our mind on an 035-backport :)
17:12:08 <nickm> okay,
17:12:33 <dgoulet> nickm: I'm also good with "lets grab ticket and else we'll assign them" :)
17:12:46 <nickm> #action everyone look over the tickets in https://trac.torproject.org/projects/tor/query?priority=%5EHigh&priority=%5EVery+High&status=new&status=reopened&milestone=Tor%3A+0.3.5.x-final&group=status&col=id&col=summary&col=owner&col=type&col=priority&col=component&col=version&order=priority , accept some you think you can fix.
17:12:53 <dgoulet> at some point, we kind of have to put names on ticket else they will stay there forever so nothing like a good old auto-assignment :)
17:12:53 <gaba> +1
17:13:05 <nickm> #action nickm tomorrow, assign the ones that haven't been grabbed. Probably to teams of 2 if they look hard
17:13:16 <dgoulet> \o/
17:13:24 <nickm> If we fix all of these, then IMO we will be out of 0.3.5-blockers
17:13:28 <nickm> though we should look again
17:13:37 <nickm> next discussion topic -- we need to finish up our roadmap
17:13:49 <nickm> we made a good start in Mexico City, but there are gaps and bugs
17:13:58 <nickm> gaba: do you want to talk about what we are missing?
17:14:25 <gaba> and we have people with too many things and people with not much. So if you want to take any of the things or leave some please do.
17:14:38 <gaba> Yes. I added stuff on the reports although is not much time needed for those.
17:14:53 <gaba> And some stuff coming from the UX roadmap. Not sure if it is something already considereded.
17:15:09 <gaba> "Include onion service client-side auth into tor browser (#14389, #19757) (anto, network team [OTF])"
17:15:18 <ahf> what does the different symbols mean?
17:15:21 <ahf> "!" and "..." ?
17:15:21 <nickm> I think we need everybody to help with estimates on things -- especially ...
17:15:36 <gaba> "Improve onion service related client-side error messages (anto, network-team [OTF])" I would think this is already related to teh stuff that catalyst was working on.
17:15:38 <nickm> #action teor please see if the privcount point estimates on the roadmap are plausible
17:15:41 <gaba> Yes. Please about estimates.
17:15:57 <nickm> #action mikeperry and asn please see if the wtf-pad estimates on the roadmap are plausible
17:16:07 <gaba> The idea is also that people will add the actual points once you are done as it will help us to do better estimations and not overload anybody.
17:16:19 <nickm> #action dgoulet can you see if the authenticated-sendme estimates on the roadmap are plausisble?
17:16:29 <gaba> One thing I'm worry about is that the sponsor8 stuff is down on the roadmap.
17:16:33 <nickm> ahf: looking now...
17:16:45 <gaba> It ends at the end of the year and needs to be priority for the roadmap starting.
17:16:58 <nickm> gaba: we can certainly move it up...
17:17:04 <gaba> yes please :)
17:17:19 <dgoulet> nickm: I do not see any sendme work in the roadmap pass Oct 15th :S ...
17:17:22 <nickm> ahf: okay, for the symbols...
17:17:35 <dgoulet> nickm: it was deferred but not added pass that date
17:17:46 <gaba> yes, dgoulet, let's move it
17:17:49 <gaba> we need it for sponsorv
17:18:04 <nickm> ahf: ! means "this is the person who understands this and needs to at least be involved in the planning. They might be completely required, but we should diversify if we can"
17:18:13 <ahf> ack
17:18:16 <dgoulet> gaba: ok I can move it
17:18:28 <nickm> I don't see a ... right now?
17:18:36 <gaba> the data after column N is what people said they wanted to do
17:18:40 <nickm> gaba: I disagree that we need it
17:18:45 <gaba> :)
17:19:02 <nickm> it would be a good-dto-do, but it will depend on the effort required
17:19:08 <nickm> *good-to-do
17:19:42 <nickm> gaba: I don't think that the ordering on the roadmap within 0.3.6 is currently significant; we can rearrange things as needed
17:19:43 <ahf> nickm: row 84, your name
17:19:48 <gaba> ok, there is more time for sponsorv so we can talk about it later.
17:19:59 <nickm> ahf: okay, I have no idea there :)
17:20:02 <ahf> ack!
17:20:19 <dgoulet> gaba: row 79 is the SENDME item, I'll go through it to get an estimate
17:20:41 <gaba> ok
17:21:01 <ahf> can one add ones name to more things or have these things been assigned?
17:21:04 <dgoulet> another question for the non Mexico people :P ... "M" and "C" ?
17:21:30 <nickm> I don't know :)
17:21:31 <gaba> Must and Can. Sorry if I didn't understand the letters you were using
17:21:31 <ahf> i'm very interested in both of the #25502 tickets
17:21:49 <gaba> ahf: things not assinged yet. we can change
17:21:54 <dgoulet> (actually, a small caption maybe would be nice to have for all those symbols :)
17:22:07 <dgoulet> gaba: ack, thx.
17:22:09 <ahf> so one can write oneself up in the sheet?
17:22:11 <gaba> I'm trying to add that to the metadoc
17:22:22 <ahf> i've added myself in () for now
17:22:22 <dgoulet> gaba: need
17:22:24 <dgoulet> gaba: neat*
17:22:31 <nickm> yes, please add yourself in () if you like
17:22:44 <nickm> we need to try to spread work, and make sure that the stuff nobody wants actually happens
17:23:09 <gaba> snowflake needs people's love :)
17:23:16 <nickm> In addition to the points estimation...
17:23:40 <nickm> gaba: we're going to need to put several people on it, since it's totally not fair to make one person be the Snowflake Technician
17:23:44 <gaba> and mike has a lot on his plate
17:23:52 <gaba> yes, agree
17:23:52 <ahf> a lot of the 19 are empty
17:24:07 <ahf> hm, did we forget to get PQ stuff in our roadmap?
17:24:10 <gaba> 19 is finishing at the end of may and it has snowflake
17:24:14 <nickm> ahf: nobody is paying for PQ
17:24:16 <gaba> PQ?
17:24:24 <ahf> gaba: post-quantum crypto
17:24:28 <ahf> nickm: ah!
17:24:28 <gaba> oh
17:24:35 <gaba> :(
17:24:42 <nickm> I hope we can squish it in, but V is already full and it doesn't fit in 2.
17:25:09 <ahf> the snowflake facilitator is the service that snowflake nodes connect to?
17:25:23 <nickm> In addition to the points estimation... we need to make sure the tickets are right.  Some of the tickets listed on the roadmap are correct for the deliverable items.
17:25:23 <ahf> the NAT meet-in-the-middle service?
17:25:29 <nickm> (I think some of them are out-of-sync)
17:25:39 <nickm> ahf: I think so?  but we are low on snowflake experts
17:26:01 <ahf> ok, i've added myself to the spec one there
17:26:09 <gaba> snowflake is a wonderful opportunity to learn a new language people :)
17:26:10 <nickm> cool
17:26:32 <ahf> both do a backup PT design + implementation before may is gonna be interesting
17:26:43 <nickm> #action everyone please add yourself, on the roadmap, (in parentheses), to under-subscribed items that you are interested in :)
17:26:49 <ahf> could be interesting for a hackfest :-)
17:26:59 <nickm> ahf: well, the goal is to have it "in the pipeline"
17:27:04 <ahf> true
17:27:14 <gaba> the one that says !mike doesn't mean that mike is going to take it. please, feel free to add yourself there
17:27:37 <nickm> and it definitely doesn't mean mike will do it all himself
17:27:38 <nickm> :)
17:27:39 <ahf> 'get snowflake working with TBA' is a task where we work on issues together with the application team, but they have the primary integration task?
17:27:47 <nickm> I think so
17:28:05 <ahf> ok, added myself there too
17:28:16 <nickm> Would anybody like to help me making sure the tickets on the roadmap are correct?
17:28:28 <nickm> (and create tickets as needed)
17:29:11 <nickm> ok, well, I'll get started, and see how far I get. Please ping me if you feel inspired
17:29:18 <nickm> #action nickm makes the tickets on the roadmap accurate
17:29:58 <nickm> next topic is rotations ...
17:30:06 <ahf> does everything up to row ~105 have to be done by january?
17:30:17 <ahf> or is this right now a list for things to do until *may* for s19?
17:30:21 <ahf> for s8 we have until end december
17:30:28 <nickm> s8 is end-of-dec
17:30:39 <gaba> s8 for sure
17:30:51 <nickm> s19 is end-of-may; all we need to do between now and jan for them is to report progress... but if we wait till jan, we will be in trouble
17:30:54 <gaba> but yes, do you think is not doable?
17:31:23 <ahf> i think it's doable if it's until may for s19 :-) it just looks like in the sheet that they are all grouped for before january
17:31:36 <ahf> in january there is the bugfix on 0.3.6 entry
17:32:03 <nickm> We might need to _some_ move s19 stuff to 0.3.7; I don't think we have the division solid
17:32:17 <gaba> yes, we could move 19 to after december
17:32:33 <nickm> gaba: some of 19, you mean?
17:32:41 <gaba> yes
17:32:43 <gaba> some of 19
17:32:44 <gaba> sorry
17:32:49 <nickm> oh, another action for everybody...
17:33:19 <ahf> yeah, some of it should probably be shuffled around
17:33:23 <nickm> #action everybody look at the stuff on the roadmap with your name or initials on it.  You won't necessarily be doing all of that, but please me and gaba know if you're currently listed for anything you really don't want
17:33:28 <gaba> do we go to rotations now?
17:33:37 <nickm> sure!
17:34:05 <gaba> 1 more thing on roadmap, can somebody check that the stuff that the UX needs is in our roadmap?
17:34:34 <gaba> ahf: you were working on stuff with UX?
17:35:01 <nickm> gaba: I don't have access to the UX grain  that you link from the pad. Maybe you need a "share" link?
17:35:06 <gaba> About rotations: https://pad.riseup.net/p/team_rotation
17:35:11 <gaba> ohh! ok
17:35:18 <dgoulet> gaba: iirc, there is a TB + .onion UX thing
17:35:24 <ahf> gaba: i'm not i think?
17:35:33 <nickm> gaba: or copy the network team things onto the pad?
17:35:40 <gaba> yes, just a sec
17:35:55 <gaba> in february: Improve handling of incorrect .onion addresses (anto, network-team [OTF])
17:35:58 <gaba> Improve onion service related client-side error messages (anto, network-team [OTF])
17:36:07 <gaba> In January:
17:36:07 <gaba> Include onion service client-side auth into tor browser (#14389, #19757) (anto, network team [OTF])
17:36:11 <gaba> Improve handling of incorrect .onion addresses (anto, network-team [OTF])
17:36:13 <gaba> Improve onion service related client-side error messages (anto, network-team [OTF])
17:36:30 <gaba> easier: https://storm.torproject.org/shared/Nq1x5v7uezVMmqjfYy7IZI-YneEFhqs1juqEVMgQg2l
17:36:36 <gaba> that is the link to view the roadmap
17:36:38 <nickm> gaba: okay, we should talk w antonela about those then
17:36:51 <gaba> ok, I can talk with her
17:36:57 <ahf> gaba: asn have been helping out a lot with some of the onion UX
17:36:58 <nickm> I don't know what work is needed on our side for that, so we should figure out what she needs
17:37:02 * antonela is around
17:37:03 <gaba> ok
17:37:23 <dgoulet> seems also TB is quite involved on the onion ones :)
17:37:25 <nickm> antonela: you need us to do anything specific for those tickets above?
17:38:00 <antonela> mmm yes
17:38:11 <nickm> On rotations ... https://pad.riseup.net/p/team_rotation reflects our thoughts about "how can we define a minimal version of the rotations, so they don't eat your whole life for a week."
17:38:24 <antonela> not in all of them, but we need a network team people to work on those. I think asn is that person.
17:39:00 <gaba> ok, we need to check with asn on how much time he needs
17:39:09 <nickm> antonela: could you 1) define which you need a network-team person for, 2) make sure there is a ticket for the network-team part of those, and 3) ask gaba to put them on our roadmap?
17:39:13 <nickm> that will help us plan
17:39:29 <dgoulet> gaba, antonela: I can be a second if we ever need to offload asn a bit so feel free there
17:39:38 <gaba> ok
17:39:50 <nickm> asn, dgoulet : you should also consider pairing with other people on HS stuff, so that more people learn it :)
17:40:03 <dgoulet> that is very true
17:40:25 <antonela> dgoulet yes, thanks
17:40:34 <nickm> wrt rotations: I tried to phrase things so that no rotation requires more than a short daily check.
17:40:35 <dgoulet> if anyone is interested, ping us! We can start right away of moving tickets around and collaborating on .onion fixes for now :)
17:40:52 <antonela> nickm yes, GeKo put those items in TB roadmap as part of OTF
17:41:16 <nickm> antonela: ok, but if there are tor changes, they need to be in the network-team roadmap too
17:41:54 <antonela> nickm: yep, gaba and pili will sync on that
17:42:10 <gaba> About PR for code reviews we talked about doing a checklist on what things needs to happen when doing the code review (like maybe checking that it passes CI... or it has tests if it is new code). It is something for code reviewer and not assigner.
17:42:28 <gaba> (like 68 eply)
17:42:28 <nickm> ok
17:42:36 <nickm> 68 eply?
17:42:44 <nickm> ah
17:42:47 <nickm> reply
17:42:51 <gaba> reply to line 68 on team rotation pad
17:43:29 <nickm> let's all comment on that pad with thoughts
17:43:40 <nickm> I think we have too many things under "things everybody should be doing each week"...
17:43:40 <gaba> ok
17:43:44 <nickm> but we can edit more
17:44:21 <dgoulet> hmmm well "assigners of reviews" should be probably out of this section :)
17:44:28 <gaba> yes
17:45:00 <dgoulet> \o/
17:45:23 <nickm> for this week I see I'm on triage, ahf on community guide, catalyst on design meetings, mikeperry on ci
17:45:38 <ahf> ack
17:45:39 <nickm> for next week, let's go with whatever we wind up with on this pad
17:45:42 <nickm> sounds ok?
17:45:47 <gaba> ok
17:46:02 <dgoulet> +1
17:46:05 <ahf> yep
17:46:15 <nickm> ok. last discussion topic seems to be proposal to change one meeting per month to a time more convenient for Australia
17:46:33 <nickm> I think that's reasonable.  It will mean that we lose some other time zone for that meeting time, but that can't be helped
17:46:40 <dgoulet> +1
17:46:43 <nickm> There is no time that works for Berlin+Brisbane+Boston
17:46:55 <dgoulet> BBB connection!
17:46:56 <gaba> Yes. They would really appreciate this.
17:47:33 <gaba> patch-party time for that once every 4 weeks meeting?
17:47:41 <nickm> I suggest that we pick either 1st, 2nd, or 3rd week each month.
17:47:48 <ahf> i'm happy to have that
17:48:02 <ahf> but could it maybe be an additional meeting or should it be a movement of this meeting?
17:48:04 <nickm> gaba: yes, but i'm not sure that the day is perfect.
17:48:20 <gaba> not additional meeting but a movement of the meeting
17:48:25 <ahf> ok
17:48:36 <gaba> each 1st week of the month for example
17:48:49 <nickm> I'd be fine if , on those weeks, we do a "meetup" at the same time we would do the regular meeting, for people who can't make the alternative time
17:48:57 <gaba> and asn can attend his yoga class :)
17:49:04 <ahf> ah, yeah, that is a good idea nickm
17:49:25 <gaba> but have the main meeting at the other time?
17:49:32 <nickm> Right
17:49:36 <gaba> +1
17:49:47 <nickm> we can also rename the patch party :)
17:49:50 <nickm> anyways
17:50:13 <mikeperry> I am alive. what units are we using for points in the estimates?
17:50:13 <nickm> I suggest that we let teor nominate a few times that work for them, and we see when we can get a lot of people?  I'd prefer earlier in the week
17:50:21 <nickm> mikeperry: points is about 1 day
17:50:22 <gaba> ok
17:50:31 <nickm> mikeperry: also I need to beg you for timesheets
17:50:46 <gaba> 1 day is 8 hours and we are considering 3 days a week
17:51:06 <ahf> i'm gonna check out and try to get into the phone interview conference room :o
17:51:09 <nickm> that is, the assumption is that a person has 3 good hacking days a week, and 2 days of etc
17:51:12 <ahf> gonna check the last minutes of backlog afterwards
17:51:22 <gaba> is everybody ok on moving the team meeting for the 1st week of the month?
17:51:42 <nickm> gaba: I would be, but let's check in with teor4 ?
17:51:46 <gaba> ok
17:51:56 <nickm> gaba: no point doing it for the first week if (say) the 3rd week works better
17:52:11 <gaba> yes
17:52:12 <gaba> true
17:52:14 <nickm> #action nickm or gaba checks with teor about preferred meetings to move
17:52:16 <dgoulet> +1
17:52:48 <nickm> ok, that was busy.  are there any pending topics or questions?
17:53:17 <mikeperry> for estimate updates, should I just change the fields of !mike things?
17:53:21 <nickm> if not, I'll be hanging out on #tor-dev for a few hours more today, feeling helpful.
17:53:39 <nickm> mikeperry: I'd like you to change the fields for the wtf-pad stuff especially
17:53:45 <mikeperry> yah ok
17:53:45 <dgoulet> nickm: not sure if you noticed in the rotation pad about the "stable maintainer", probably your opinion there could be useful especially that someone volunteered! :D
17:53:55 <gaba> and mike, feel free to remove yourself from stuff
17:53:56 <nickm> oh. somebody volunteered?
17:54:20 <dgoulet> nickm: yes!
17:54:25 <nickm> mikeperry: except, "!mike" means "we think only mike understands this fully".  If that's not true, then great.  If it's true, we need to switch it around
17:54:28 <nickm> dgoulet: who?:)
17:55:04 <dgoulet> nickm: it is on the pad, teor is willing :)
17:55:07 <nickm> oh!
17:55:13 <nickm> then I should talk to them tonight about that too
17:55:13 <dgoulet> (and I +1 that )
17:55:25 <nickm> #action nickm talk with teor about stable release stuff
17:55:31 <nickm> ok.  What a meeting!
17:55:34 <nickm> thanks, everybody.
17:55:43 <nickm> I'll be on #tor-dev if there's more stuff to talk about
17:55:45 <gaba> thanks!
17:55:59 <nickm> for now, let's give our tb friends their space
17:56:01 <nickm> #endmeeting