17:01:17 <nickm> #startmeeting network team meeting, 16 July
17:01:17 <MeetBot> Meeting started Mon Jul 16 17:01:17 2018 UTC. The chair is nickm. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:17 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:01:18 <dgoulet> yello!
17:01:25 <Phoul> \o
17:01:28 <ahf> o/
17:01:31 <nickm> pad is at https://pad.riseup.net/p/xoBCOyzTwLtY
17:01:32 <asn> hello!
17:01:55 <nickm> how's everybody doing today?
17:01:59 <haxxpop> hi all!
17:02:21 <ahf> pretty good!
17:02:39 <nickm> let's start with the roadmap, per usual :)
17:03:11 <nickm> I think we're on track for 034 stable in mid-august, which is good.
17:03:19 <isabela> !!!
17:03:22 <isabela> buenas
17:03:25 <dgoulet> yes
17:03:26 <nickm> I wonder if we've ever had a release become stable on time before...
17:03:34 <nickm> (like, on schedule)
17:03:42 <ahf> nice
17:04:14 <nickm> If anybody's working on anything that isn't on the roadmap, and it's going to take more than a single day, we should really add it to the roadmap...
17:05:09 <nickm> also, soon, we should schedule some meetings to revise our plans for 035, since we have a bunch of 035-roadmap-proposed items, AND some things we might need to reschedule since we don't have people working on them
17:05:15 <ahf> i'm messing around with the sandboxing stuff when my brain stops working and i think i'm above a day on that so far, but i have no idea if we have a sponsor for that
17:05:20 <nickm> err, as many people working on
17:05:25 <ahf> i have kept track of the hours in a notebook for it
17:05:44 <nickm> ahf: ok, so first thing to do is see if it's billable, and see if there's a roadmap-proposed ticket for that
17:06:02 <ahf> there is no roadmap ticket for it, this was just something i picked up myself
17:06:13 <ahf> arma2: maybe you have an idea about this, we have been talking a bit about it every now and then ^^
17:06:54 <nickm> Should we try to get our roadmap reconfigured at this meeting today, or schedule a meeting where we can talk through the issues?
17:07:10 <nickm> mikeperry: you are on "scheduling meetings" rotation this week; there are a few for you
17:07:20 <nickm> (I'm getting ahead of the agenda, I guess)
17:07:27 <arma2> ahf: i mostly pay attention to the sandboxing question at the browser level (but i still haven't read the huge great sysrqb thread)
17:07:49 <dgoulet> nickm: if we plan to spend more than 30 minutes, I would say new meeting
17:07:51 <ahf> arma2: ack. i think this was more whether any of this was billable for core tor right now
17:08:34 <nickm> dgoulet: I tend to agree it will be more than that, given how many 035-roadmap-proposed items and how many items with strikethrough on the roadmap
17:08:43 <dgoulet> indeed
17:08:44 <nickm> isabela: do you agree we should try to schedule a meeting for thist?
17:08:47 <nickm> *this
17:09:00 <isabela> yes
17:09:06 <nickm> great
17:09:07 <isabela> the thing is
17:09:13 <arma2> ahf: i think we might want to change that heuristic to something more like "is a sponsor asking for it or expecting it". because "could we fit it into one of the nsf things" is always answered with a yes, but that yes doesn't create more nsf money.
17:09:23 <isabela> if i am to participate it will only happen around first week of august
17:09:25 <isabela> cuz of my vacation
17:10:06 <ahf> arma2: okay
17:11:26 <arma2> ahf: the flip side being that yes we should prioritize sponsor deliverables, but the big goal there was to have that list be a subset of what we have time for, and then put our own prioritized items into the remaining time. which involves picking our own prioritized items. which we started doing in seattle.
17:11:29 <nickm> I think we're going to need you, so we should probably aim for the 1st week in august then
17:11:46 <ahf> arma2: aye
17:11:53 <nickm> Next up is reviewer assignments. Is everybody okay reviewing the tickets they have this week?
17:12:04 <nickm> (Do we know if mikeperry is here today?)
17:12:25 <ahf> he wrote out of band that he might miss the meeting
17:12:38 <isabela> nickm: ack (first week of august)
17:12:41 <arma2> ahf: so, tl;dr "yes it's billable but i think that might not be the right question" :)
17:13:06 <nickm> ahf: ah
17:13:07 <nickm> ok
17:13:26 <ahf> arma2: i think my question was "i have 16 hours of this that tor may or may not be able to get some money for, is there someone i should put it in harvest"
17:13:59 <isabela> hmm of what? :) sorry i missed it
17:14:15 <ahf> isabela: it was just some stuff i did some weekends ago that was unrelated to s8
17:14:22 <isabela> ahh
17:14:27 <ahf> isabela: related to sandboxing on different platforms
17:14:32 <ahf> isabela: after we spoke with the mozilla people in SF
17:14:37 <isabela> cool
17:15:10 <ahf> and i'm unsure where to bill it to and if we don't have any place that is fine too. i just don't want tor not to get the money from a sponsor if we can get it. if not, then it's cool too
17:15:28 <isabela> so if this is nothing that fits any nsf stuff (i need to review it to remember) then is network team work category on harvest
17:16:03 <isabela> i will need to review the other stuff going on with nsf - maybe you send the tickets to me and arma and we figure it out?
17:16:29 <ahf> yeah, let's do it that way. i am very close to finishing this one for review then i can send it to you with some number of hours and you can figure out where it fits in
17:16:31 <isabela> tx for pointing it out :) is always good
17:16:32 <ahf> that sounds good
17:16:47 <arma2> we've been trying to avoid putting nsf hours for people not in the US, because of the mess with that one program manager. so yes, network team work category sounds like a good choice.
17:17:07 <arma2> (in other news the early signs from heather are that we're actually in good shape on filling up our nsf things. so yay.)
17:17:25 <isabela> nice
17:17:44 <arma2> that is, M, Q, and 3 are now full, and V and 2 don't end until next summer or later
17:18:14 <isabela> yes
17:18:20 <arma2> in theory her next step is to reflect that in harvest, by locking certain categories.
17:18:26 <arma2> but this is a network team meeting so i will let it continue :)
17:18:32 <isabela> hahaha
17:18:56 <nickm> arma2: Does "full" mean that we should rnot be doing the things we had planned to do between now and 1Sep for Q or 3?
17:19:07 <nickm> (I see no M, but we had planned on putting privcount on Q)
17:19:08 <ahf> isabela: are we behind with s8 HS data collection?
17:19:29 <isabela> HS?
17:19:57 <ahf> err, the performance evaluation
17:19:59 <ahf> sorry
17:20:06 <isabela> nickm: privcount could also fit V (if i recall correctly)
17:20:06 <ahf> with all the people doing network measurement
17:20:15 <isabela> ahf: !! yes we are behind :(
17:20:30 <ahf> ok, i worried that i had missed some emails or something
17:20:35 <nickm> isabela, arma2: If so, we should move it into V on the roadmap and on trac.
17:20:38 <isabela> i failed on it a bit cuz of traveling
17:20:43 <arma2> nickm: no, we should continue to do the things.
17:20:43 <ahf> ahhh, of course
17:20:55 <arma2> i still am going to need to write about the amazing things we did for each of them
17:22:19 <arma2> it just means we don't need to stress about whether we're getting enough hours put into the right buckets
17:22:25 <nickm> #agreed move privcount to sponsorV
17:22:26 <arma2> it doesn't mean we must not work on the topics :)
17:22:49 <nickm> well, if we're doing them, we should have an accurate plan of how we're labelling them
17:22:59 <nickm> let's see
17:23:04 <nickm> next is rotations?
17:23:34 <nickm> I see catalyst on triage, dgoulet on community, mikeperry on scheduling meetings, and me on CI+Coverity
17:23:44 <nickm> Everybody (who is here) cool with that?
17:24:31 <nickm> any community handoff from catalyst->dgoulet?
17:25:14 <catalyst> not really anything ongoing to hand off
17:25:38 <nickm> the roadmap-proposed tickets are: https://trac.torproject.org/projects/tor/query?status=accepted&status=assigned&status=merge_ready&status=needs_information&status=needs_review&status=needs_revision&status=new&status=reopened&keywords=~035-roadmap-proposed&max=200&col=id&col=summary&col=milestone&col=status&col=type&col=priority&col=component&order=priority
17:26:21 <nickm> I suggest that we revisit those in early august, unless there is anything super-urgent where we need a decision right now?
17:26:44 <nickm> at the same meeting where we revise the 035 roadmap together.
17:26:47 <ahf> i think that is a good idea
17:26:53 <nickm> any objections? anything super-urgent?
17:27:05 <isabela> nickm: agreed
17:27:29 <nickm> Okay, discussion phase.
17:27:48 <nickm> but see announcements: I see HOPE is this week, and PETS is next.
17:27:58 <nickm> so please expect higher latency from folks than usual
17:28:07 <nickm> and use email if you can't find somebody on IRC :)
17:28:28 <nickm> discussion stuff:
17:28:48 <nickm> what is the next steps on prop#295? Do we need a meeting to figure that out?
17:30:40 <nickm> I think we might need such a meeting.
17:31:23 <nickm> or I could try to figure it out on my own? :/
17:31:38 <catalyst> nickm: i'm willing to take a look at it again
17:31:43 <nickm> ok
17:31:49 <nickm> I think teor was interested too
17:32:01 <nickm> if we can talk about it tomorrow evening that might be a good start
17:32:51 <catalyst> ok i'll make some time to reread background material then
17:32:58 <nickm> me too
17:33:04 <nickm> let's see if we need to schedule something else after that
17:33:23 <nickm> second item looks like it's somewhat discussed already.
17:33:44 <nickm> so does anybody object to using the same pad week after week?
17:33:56 <nickm> if not, I'll make a long/term pad this week, for use in the future
17:34:01 <nickm> *long-term
17:34:03 <ahf> i can't remember why we stopped doing that after some time? i think we did it at some point?
17:34:08 <ahf> not too long ago
17:34:34 <nickm> not sure; I thought we were worried about teh vandalz
17:34:44 <nickm> but we can give it a try and see how it goes a
17:34:44 <dgoulet> there will be a time when the pad will be kind of _big_ and will take a while to load (especially on TB)
17:34:58 <nickm> I think we should delete stuff that's more than N weeks old...
17:35:05 <ahf> agreed
17:35:08 <dmr> iiuc, tbb-team does maintain a pretty long pad, and it seems ok
17:35:08 <nickm> will that be enoug
17:35:20 <dmr> can also rotate to a new pad every so often
17:35:23 <nickm> sure
17:35:36 <tjr> Ours is 3500 lines long
17:36:07 <nickm> so let's give it a try?
17:36:15 <dgoulet> sure
17:36:21 <nickm> #agreed let's try a persistent pad url, and see how it works for us
17:36:56 <nickm> next, I had a question: I started working on our NSS conversion. I'm doing this solo now, so I'm wondering if anybody would like to be my sounding-board
17:37:26 <nickm> I'm also wondering if it's worthwhile merging _partial_ NSS support, or if I should hold off until I have a version of Tor that doesn't need OpenSSL at all
17:37:40 <nickm> That second one might take a while, I'm afraid.
17:37:55 <ahf> i think it will look good on our s8 deliverables if we get the entire thing in and can avoid openssl entirely on android
17:38:02 <nickm> anybody else excited on this stuff? Any thoughts on logistics?
17:38:04 <ahf> it's a part of the sponsorship we haven't measured a lot on
17:38:16 <ahf> (like, how much we actually reduced the size)
17:39:02 <ahf> how much is roughly missing right now? where tor still needs openssl?
17:39:03 <nickm> I bet most of the DL size is firefox...
17:39:09 <nickm> though I could be wrong
17:39:15 <ahf> yes
17:39:16 <nickm> I guess "every little bit helps"
17:39:27 <ahf> this wont help our orbot size for sure :-)
17:40:23 <nickm> So a) is this worth doing? I'm having fun, but we should decide if I forge ahead.
17:40:37 <nickm> b) If it's worth doing, should I work with anybody else?
17:40:53 <nickm> c) Should we merge it in pieces, or all at once?
17:41:59 <catalyst> for (c) i think if we can merge it in pieces without it making a mess, we should
17:42:10 <nickm> hm, ok.
17:42:11 <ahf> i'd like to help, but i don't want to take on more s8 stuff until i've closed the two items i have left :-/
17:42:21 <nickm> I think I can do it as a multistage thing
17:42:24 <nickm> I'll make subtickets
17:42:24 <ahf> i'd like to review things and stuff like that if you need help with that
17:42:44 <nickm> ack
17:43:12 <nickm> I'd also like to see if we have anybody who has reviewed NSS code before who can have a look at it -- some of the APIs are underdocumented.
17:43:32 <nickm> I've frequently had to look at the NSS source code to understand how something is supposed to be called
17:43:39 <ahf> yikes, ok
17:44:22 <nickm> ok
17:44:23 <catalyst> nickm: yeah i've had to resort to that before as well. to be fair i've also had to do that with OpenSSL
17:44:44 <nickm> catalyst: do you think I could also rope you in as a second reviewer here?
17:45:23 <nickm> let's see, what other questions...
17:45:27 <nickm> asn has questions for mikeperry ...
17:45:28 <catalyst> nickm: sure. i'm not too familiar with NSS but i've dealt with some fallout of NSS support integration before elsewhere
17:45:54 <asn> nickm: yeah im assuming that mike will get back to me when he reads the pad
17:45:55 <nickm> catalyst: you have more NSS and PKCS11 experience than I did a week ago :)
17:45:58 <asn> not expecting reply right now
17:46:03 <nickm> ack
17:46:18 <nickm> isabela has a note on modularization and planning...
17:46:29 <nickm> anything you need feedback on there?
17:46:39 <nickm> Also, did you get the info you needed from last week's sponsor8 pad?
17:46:57 <nickm> dgoulet wants to switch for bug triage next week; anybody else available to do it?
17:47:06 <nickm> and dmr needs a mirrored nyx repo on github...
17:47:21 <isabela> nickm: yes i have a thought around modularization
17:47:26 <dmr> well, I don't need it, but atagar mentioned he'd like it, so I'm just pushing that bit forward :)
17:47:53 <isabela> nickm: there is an opportunity for a grant that could pay for 1 year work of 2 ppl on modularization (we could organize a 'phase 1' work plan) if we are to move w/ it
17:48:05 <isabela> the thing is that this would have to be done in a rush
17:48:32 <nickm> dmr: Okay. I think Isabela knows the current state of our github mirroring stuff. It might be in flux right now, since we're gathering info
17:48:34 <isabela> so i am not sure if we would be able to get it done on time
17:48:38 <nickm> isabela: define rush here?
17:48:57 <isabela> by july 31st
17:49:01 <nickm> isabela: And would it be the same amount of work we had planned with more people and more time?
17:49:10 <nickm> July 31, 2019?
17:49:22 <isabela> yes
17:49:29 <isabela> this is the proposal deadline
17:49:45 <nickm> "this"?
17:49:52 <isabela> july 31
17:50:01 <nickm> oh
17:50:04 <isabela> the amount is what i mentioned above
17:50:08 <isabela> 12 months / 2 ppl
17:50:15 <nickm> so it wouldn't be "do the work in a rush", but "write the proposal in a rush"
17:50:18 <nickm> ah
17:50:31 <nickm> I think it could be worth doing -- I still want us to get paid for modularization
17:50:33 <isabela> that can be break down in any way we want tho, like 4 ppl working 1/2 of their time or rotate the people
17:50:45 <nickm> I can help cut down the previous list of deliverables to be more appropriate for the reduced resources
17:50:54 <isabela> nice
17:50:55 <isabela> ok
17:50:57 <isabela> that is good to know
17:51:01 <isabela> i can follow up on that offmeeting
17:51:02 <isabela> :)
17:52:18 <nickm> dmr: wrt tor-spec improvements: I'd suggest making tickets on trac? It's okay to put trivial fixes (grammar, typos, labeling, style, etc) all in one branch, but for changes of substance there should be separate branches, if that's ok. Sound plausible?
17:52:35 <dmr> sounds good
17:52:50 <dmr> I'll probably have a few different branches then, but I'd guess no more than 5
17:53:04 <dmr> should I just collect all the trivial fixes into a single ticket?
17:53:16 <nickm> sure
17:53:23 <dmr> alright, will do
17:53:33 <nickm> 5 minutes left. Anything else for this meeting?
17:53:43 <dmr> I'll open a ticket but keep it as "assigned" until near the end of the project, and then bump it to "needs_review"
17:54:06 <nickm> ok, cool
17:54:28 <nickm> Oh, btw, everybody who is going to HOPE: Have fun!
17:54:46 <dgoulet> Tor has a booth and a talk, great stuff
17:54:58 <isabela> \o/
17:55:19 <nickm> oh, and: I might take Friday off this week, to give myself extra time to rest up for PETS.
17:55:29 <nickm> And I might have a hard time making next week's meeting, for the same reason
17:55:30 <dmr> ^ FYI: it sounds from the community meeting that flexlibris and/or stephw (and/or others) will collect some HOPE info into a single place :)
17:56:55 <nickm> okay, we're out of time. Thanks for the hour, everyone!
17:57:00 <dgoulet> \o/
17:57:02 <nickm> I'll see you on IRC!
17:57:04 <nickm> #endmeeting