14:29:35 <karsten> #startmeeting metrics team meeting
14:29:35 <MeetBot> Meeting started Thu May  3 14:29:35 2018 UTC.  The chair is karsten. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:29:35 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:29:45 <karsten> I believe that iwakeh is still sick. :(
14:29:58 <karsten> that leaves you and me.
14:30:19 <irl> oh dear ):
14:30:27 <irl> ok
14:30:40 <karsten> https://storm.torproject.org/shared/5h1Goax5eNusxjXJ_Ty5Wl7hFR1uqCReUiN8xdlBG8T <- agenda pad
14:30:48 <karsten> at least we have a few topics!
14:30:59 <karsten> shall we start?
14:31:01 <irl> yep. making up for last week. (:
14:31:12 <karsten> heh
14:31:26 <karsten> okay, starting.
14:31:29 <karsten> * Metrics glossary (irl)
14:31:42 <irl> for the context for this, there is this mail:
14:31:45 <irl> https://lists.torproject.org/pipermail/tor-dev/2018-May/013147.html
14:32:02 <karsten> makes sense. what are the suggested next steps?
14:32:28 <irl> probably that we make a torspec patch for the terms used in our glossary that are not already in the torspec glossary
14:32:49 <irl> later, we should then take all the relay search tooltips and convert these into glossary items, and make sure they agree with torspec
14:33:29 <irl> onionoo fields may also be something to look at reconciling with torspec
14:33:45 <irl> but the first step is a patch to sync up our glossary
14:34:02 <karsten> how would we link to definitions in torspec?
14:34:28 <karsten> for example, https://metrics.torproject.org/userstats-relay-country.html,
14:34:35 <irl> we would maintain the glossary as it is now, we would just ensure that the definitions are the same with torspec being the canonical source
14:34:40 <karsten> the graph description contains links to clients, bridges, etc.
14:34:45 <karsten> ah!
14:34:48 <irl> we would treat disagreements with torspec as a bug
14:34:58 <karsten> okay, yes, that would work.
14:35:13 <karsten> yes, sounds like a fine idea.
14:35:38 <irl> the community glossary part of that mail is probably out of scope for this meeting
14:35:52 <karsten> so, hmm,
14:36:01 <karsten> are the audiences of these glossaries the same?
14:36:21 <irl> the community glossary definitely isn't the same
14:36:27 <karsten> I could imagine that the network team needs a different level of detail than a tor user reading something on the website (including ours).
14:36:31 <irl> metrics and torspec are more closely aligned
14:36:48 <irl> we don't necessarily need the exact same wording, but the general definition should be the same
14:36:55 <karsten> alright.
14:37:03 <irl> for example, if we defined something to not include overheads but torspec did include overheads, that would be a bug
14:37:14 <karsten> agreed.
14:37:40 <irl> ok, i'll take an action to file a ticket (but not necessarily work on it straight away)?
14:37:48 <karsten> sounds great!
14:38:05 <irl> #action irl file a ticket to make a torspec patch to include the metrics glossary terms
14:38:23 <irl> ok, we can go to the next topic
14:38:23 <karsten> next is related, I guess?
14:38:25 <karsten> * Terminology for "uptime" (irl)
14:38:33 <irl> context: https://lists.torproject.org/pipermail/tor-relays/2018-May/015132.html
14:38:56 <irl> when onionoo says uptime, i think really it is actually talking about MTBF?
14:39:13 <irl> no, i mean fractional uptime
14:39:27 <irl> as opposed to absolute uptime, which is what relay search means when it says uptime
14:39:40 <irl> i just noticed this as an example of an inconsistency, there are probably others
14:39:51 <irl> i was wondering how much effort we might put into fixing these
14:39:52 <karsten> "Uptime documents contain fractional uptimes of relays and bridges."
14:40:14 <karsten> so, yes, I see the point.
14:40:37 <karsten> but, what's the suggested fix there?
14:40:48 <irl> uptime vs reachable time
14:40:52 <irl> suggested by teor
14:41:00 <karsten> ah, yes.
14:41:10 <karsten> reachable is more accurate.
14:41:26 <irl> this could be a docfix with a note about the conflicting terminology, it doesn't have to be an endpoint change
14:41:53 <karsten> in the sense of renaming the document type?
14:41:58 <irl> yes
14:42:14 <irl> well, there's renaming the java and renaming the http endpoint, which again are different
14:42:21 <karsten> agreed. I'm not so much worried of the code change, but that would require a major protocol update, and it might break clients.
14:42:32 <irl> network team is currently looking at this for onion vs hidden and where to draw the line for effort
14:42:40 <irl> we could take inspiration from their choices
14:42:41 <karsten> ok.
14:42:44 <karsten> yes!
14:43:09 <irl> how much do you think we should change?
14:43:17 <irl> i think probably just the documentation is ok
14:43:32 <karsten> sounds fine as a start. we can always change more later.
14:43:42 <irl> ok, i shall file a ticket?
14:43:46 <karsten> yes, please.
14:44:02 <karsten> I vaguely recall a related ticket. let me find it...
14:44:06 <irl> #action irl file a ticket for a docfix explaining terminology used for the uptime documents
14:44:14 <irl> ok, next topic?
14:44:25 <karsten> give me 1 min.
14:44:53 <karsten> https://trac.torproject.org/projects/tor/ticket/11430
14:45:36 <karsten> maybe make a note that this ticket exists, in the new ticket.
14:45:40 <karsten> not sure if it matters.
14:45:50 <irl> aah, i didn't know this about the bridges
14:45:57 <irl> i'll mention it in the new ticket
14:46:41 <karsten> okay, great!
14:46:51 <karsten> yes, next topic.
14:46:52 <karsten> * Tor bandwidth measurements document format (karsten)
14:47:01 <karsten> this is about juga's document.
14:47:18 <karsten> I said I'd read it to make sure we'll be able to archive it in collector, but then I didn't get to that yet
14:47:33 <karsten> did you read it? and do you see any problems with archiving it in collector?
14:47:59 <irl> for archiving it, do we need to parse it?
14:48:14 <karsten> to give a random example for documents that are difficult to archive: microdescriptors are particularly hard, because they don't contain a published timestamp.
14:48:32 <karsten> I guess we should be able to parse it, yes.
14:48:37 <irl> ah ok, no they do have timestamps
14:48:59 <irl> parsing should be able to either reuse code from the existing format, or code from descriptor parsing
14:49:08 <karsten> parsing is not required for archiving, but I think we should also support it in metrics-lib, because we support all formats that collector has.
14:49:49 <karsten> I mean, if it's similar to tor descriptors, we're pretty much on the safe side.
14:50:11 <karsten> just saying, if you saw/see anything that makes you wonder whether we'll be able to handle the document later on, let us know!
14:50:20 <irl> i think it's currently leaning towards being more similar to the older format
14:50:29 <irl> using = instead of spaces for seperators and such
14:50:38 <irl> nothing looks too scary though
14:50:43 <karsten> (we do not support the old format, either.)
14:50:59 <karsten> if you're not scared, that's good! :)
14:51:05 <irl> my biggest concern so far was the naming of the fields
14:51:25 <irl> i've seen good responses to my comments though
14:51:28 <karsten> saw that. makes sense to give that some thoughts.
14:51:56 <karsten> okay, great!
14:52:04 <karsten> works for me.
14:52:08 <karsten> moving on?
14:52:10 <irl> ok
14:52:16 <karsten> * Statistics-related tickets in need of discussion/review (karsten)
14:52:22 <karsten> #25383, #26002, #26015
14:52:30 <karsten> you already commented on #26002.
14:53:01 <karsten> I brought up #25383 last week. and #26015 is new.
14:53:11 <karsten> as in: from a few minutes ago.
14:53:32 <karsten> if you could make a note to look at these over the next few days, that would be awesome.
14:53:37 <irl> i commented on #25383 2 months ago (:
14:53:48 <karsten> also trying to get iwakeh to look when they're back.
14:53:51 <irl> but then you went and had more thoughts...
14:53:59 <irl> ok, i will put that up my priority list
14:54:13 <karsten> yes, I came back with a new idea, and I'm curious what you think.
14:54:24 <karsten> and what others think (joss, dcf, others.)
14:54:58 <irl> quickly reading comment:10 that seems a good idea
14:55:34 <karsten> good to hear!
14:56:19 <irl> #26015 seems like a definitions problem
14:56:20 <karsten> (maybe comment on the ticket if you still think that it's a good idea after the meeting.)
14:56:34 <irl> yep ok
14:57:10 <karsten> okay, moving on to the last topic.
14:57:11 <karsten> * Monthly report for April (karsten)
14:57:24 <karsten> I started a short list of things where we made progress on the pad.
14:57:45 <karsten> but I only spent like 5 minutes on that.
14:58:01 <karsten> I'll go through my inbox and might find more.
14:58:09 <karsten> anything that comes to your mind that we also did?
15:00:32 <irl> I think that's about it. Mostly I've been on mailing list threads and triaging tickets, but not actually getting to finish any coding tasks.
15:00:56 <karsten> okay, great!
15:01:20 <karsten> if you think of something else, please let me know.
15:01:24 <irl> will do
15:01:28 <karsten> I'll send a draft in the next couple days.
15:01:48 <karsten> okay, I guess that's all for today!
15:02:01 <irl> yep (:
15:02:09 <karsten> cool! thank you, and bye! :)
15:02:18 <irl> bye!
15:02:21 <karsten> #endmeeting