17:59:17 <nickm> #startmeeting weekly network team meeting, 26 Feb 2018
17:59:17 <MeetBot> Meeting started Mon Feb 26 17:59:17 2018 UTC.  The chair is nickm. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:59:17 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:59:19 <nickm> Hi all!
17:59:22 <asn> hello :)
17:59:40 <isabela> buenas
17:59:53 <nickm> The pad is at https://pad.riseup.net/p/DP6HmRXvVW6w
17:59:58 <asn> im checking out pad
18:00:21 <nickm> Only a couple of quick announcements from me:
18:00:40 * isabela is writing
18:00:41 <ahf> hello
18:00:44 <nickm> 1) I'm on call for jury duty tomorrow.  In 3-4 hours I find out whether they need me to come in.  If so, I'm offline tomorrow, maybe more.
18:01:17 <nickm> 2) Please let me know if anything should go into the upcoming releases that I have not already merged, other than the TROVE-2018-001 patches under discussion
18:01:36 <nickm> I'm planning to release between now and wednesday
18:01:39 <nickm> s/planning/hoping/
18:03:18 <isis> o/
18:03:27 * isis is writing
18:03:49 <nickm> ahf: should I expect more data coming from the wakeup experiments you did, or should I write my tickets with that in mind?
18:04:44 <ahf> nickm: there is more coming, this is the start. i'm trying to do one with some active data being downloaded and then the stacks. i have the stacks from "entering a system call" and when we get taken off the CPU by the scheduler
18:05:02 <ahf> but i'm trying to do the fanout data which is "just" the stacks that were around right before we returned back to the event loop
18:05:14 <nickm> ok
18:05:16 <ahf> if you can flesh out some tickets from what is there now, i think that is good, but there is more on its way
18:05:25 <nickm> I think I know a bunch of those, based on the code and on the data you have
18:06:07 <ahf> ok!
18:06:14 <nickm> second_elapsed_callback and refill_callback should account together for about 11 wakeups per second = 660 wakeups per minute
18:06:41 <ahf> yes, they pop up frequently in my sampled traces
18:06:52 <nickm> ahf: is there a master ticket i should make items for those under?  If you don't remember, I'll look for one.
18:06:53 <ahf> i don't think there is, no
18:06:59 <ahf> there is for CPU performance, but that is unrelated
18:08:27 <mikeperry> (I am here, I keep getting disconnected from the pad; will cut+paste update as soon as I am connected long enough)
18:10:01 <nickm> announcements: everybody please read the announcements, and fill out the spreadsheets
18:10:13 <nickm> #action please do the heat-mapping exercise today if you haven't already
18:10:28 <nickm> #action please do the subsystem maintainer comfort exercise today if you haven't already
18:11:16 <nickm> (who are we still missing on those?)
18:11:25 <asn> eveyrone has done heat-mapping
18:11:36 <asn> isis is the only one who still hasnt done subsystem maintainer
18:11:48 <nickm> isis: ^
18:11:58 <asn> so we pretty good but not 100% yet
18:12:18 <isis> k, will do
18:12:28 <nickm> I don't see pastly and armadev on the heatmap thing.
18:12:34 <isis> arg this pad is determined to keep me disconnected, lol
18:12:37 <ahf> isabela: the ping is the email today, right? or did i overlook something?
18:12:50 <nickm> #action isis does subsystem maintainer thing
18:12:50 <isabela> ahf: today :)
18:12:55 <ahf> good, good
18:12:57 <nickm> #action armadev does the heat-mapping spreadsheet, if he wants.
18:13:00 <isabela> sorry i left the comment on the last week item
18:13:04 <nickm> #action pastly does the heat-mapping spreadsheet, if he wants.
18:13:05 <isabela> but it was done today :) the email
18:13:17 <ahf> thought i had missed something. last week asn had to ping me because i had overlooked one of the sheets :-S
18:13:19 <ahf> thanks, good to know
18:13:48 <catalyst> after dgoulet asked us to be more willing to score stuff as 3 in the subsystem sheet, i'm wondering if i should change my answers
18:14:46 <asn> catalyst: being more bold miht be a good idea
18:15:05 <asn> also because this spreadsheet might help us assign reviews/etc. in the future
18:15:11 <nickm> isis: maybe wrt the rust sha2 thing, put up the code you have on the ticket, share the errors, and take a break to see if anybody can help figure it out?
18:15:19 <ahf> i was close to writing 2.5 many places, but then i know how developers dislike floats
18:15:35 <asn> so if you care about a subsystem and you are not sure if you are 3 yet, but you could be or you want to be, perhaps putting 3 is fine!
18:15:41 <dgoulet> +1
18:16:04 <dgoulet> the idea is to be a PoC about the subsystem not the massive line-by-line expert
18:16:18 <dgoulet> (but enough also to be able to do reviews ofc :)
18:16:21 <isabela> isis: ping on the subsystem spreadsheets -> https://docs.google.com/spreadsheets/d/1Ufrun1khEo5Cwd6OwngERn829wU3W3eskdrriaYfUBQ/edit#gid=1974867547
18:16:26 <catalyst> re roadmapping, are we supposed to ignore the older roadmap spreadsheet that was standalone (not consolidated with the latest heatmap and subsystem stuff)?
18:16:46 <isabela> isis: and check the tabs for the areas of work one too - so you can add your votes
18:17:28 <isabela> catalyst: yes, we will build a new one for march-nov - the email i sent to you and ahf and nick today is related to that
18:17:59 <isabela> catalyst: and another one where is focus on 2019-2021
18:19:05 <nickm> isabela: would you like to talk about what you need from people for roadmapping and other stuff between now and Rome?
18:19:45 <isabela> yes!
18:20:02 <isabela> my goal is to get as much of the 6 months roadmap done before rome
18:20:16 <isabela> so we can leave more of our f2f interactions to answer those questions for the other roadmap:
18:20:28 <isabela> how the network team will look like in jan 2019
18:20:38 <ahf> cool
18:20:38 <isabela> and what this team will do from jan 2019 till dec 2021
18:21:18 <isabela> the heatmap should guide us on these stuff - but of course wont be the only factor, we are doing exercises now
18:21:22 <isabela> so we learn what others are thinking
18:21:27 <isabela> and understand where others are coming from
18:21:35 <nickm> so the idea is to come to rome with our roadmaps begun -- at least the sponsor-driven parts?
18:21:39 <ahf> will we get some info about this before rome? if we have any grants send out that we are waiting to get a response on and so on?
18:21:49 <isabela> this way i hope our discussions are more productive with these contexts of where folks are at
18:21:53 <ahf> (for the 2019 to 2021 part)
18:22:15 <isabela> regarding sponsor related work
18:22:27 <isabela> we will only plan for it for the shorter roadmap
18:22:41 <isabela> i would prefer the second (longer one) we plan in a different way
18:23:05 <isabela> more vision/priorities focus - independented of sponsor
18:23:12 <ahf> neat
18:23:29 <isabela> this will guide us
18:23:59 <isabela> as we continue to have 6months roadmaps (or roadmaps we create every tor meeting)
18:23:59 <nickm> how are we doing so far on the roadmapping?  I filled out what I could for the sponsor8 stuff that I know most about.  What should I and others still do, and when should we do it by? :)
18:24:28 <isabela> nickm: yes! let me give a short report on that
18:24:57 <isabela> right now i am asking forlks involved with sponsor work to drop what they think the work for those deliverables should be in the 6 months roadmap
18:25:02 <asn> (lol at no one having a '3' on the rust subsystem)
18:25:17 <isis> oh wow, there _are_ tabs, you were not kidding
18:25:23 <isabela> so if i ping you please follow up with me on that :)
18:25:24 <isis> i put 3 on rust…
18:25:40 <isabela> once i have this done i will ask folks to give me tickets related to the work they wrote in the pad
18:25:57 <asn> ok now we have one 3! nice
18:26:03 <isis> oh, it changed my answers? maybe i bumped the scroll wheel
18:26:09 <asn> we have at least one expert on every subsystem
18:26:12 <isis> it changed a bunch of my answers! grrr
18:26:18 <isabela> once we have tickets, they will be: 1. placed in the roadmap in the month we will work on them 2. have owners :)
18:26:29 <isabela> i will write this all out via email to the list too so everyone has it
18:26:52 <ahf> isabela: it's *future* work? so it's for the tickets for the next 6 month period, right?
18:26:55 <nickm> (sorry, what has tabs exactly? I worry that maybe I didn't see the tabs)
18:27:17 <isis> i kind of want to see the totals per column per developer? like to see if i feel as confident as other people
18:27:36 <dgoulet> isis: scroll horizontally?
18:27:45 <asn> isis wants to see the total per column
18:27:46 <isabela> ahf: yes, keep in mind that sponsor8 contracts ends in this period too
18:27:54 <asn> not per row
18:27:57 <ahf> yes, in november, right?
18:28:00 <ahf> or earlier?
18:28:01 <isabela> ahf: so we should be thinking what we want as a goal and what needs to be done to get there
18:28:09 <asn> i can do that easy, i've become an expert in google spreadsheets. ready for my accountant gig.
18:28:10 <ahf> i can't remember if it's november or august
18:28:14 <isabela> ahf: officially earlier but I already told them i will ask for extension
18:28:18 <ahf> ok!
18:28:20 <isabela> ahf: cuz mobile started late too
18:28:26 <isabela> :)
18:28:28 * ahf nods
18:28:29 <ahf> cool!
18:28:35 <isis> since i feel like i'm being pretty conservative and giving "1" in places where maybe i am a "2"?
18:28:45 <isis> asn: lol
18:28:57 <asn> isis: i just didnt want to give total numbers to people. might make people feel bad or sth.
18:29:04 <ahf> i will do this tomorrow morning - fits ok with going over where we are now to prepare for the mobile session in rome
18:29:06 <dgoulet> we have 3 for every subsystem so that is a good news
18:29:17 <asn> yes :D
18:29:48 <nickm> I should probably be lower on a lot of subsystems
18:31:41 <isabela> this is spreadsheet is very cool
18:31:49 <isabela> very very cool :)
18:31:49 <isis> asn: yeah, i also thought about that it might make people feel bad, but i don't think there's anything wrong with being less confident… i just want to know if i'm using the same relative scale of confidence i guess?
18:31:54 <nickm> it seems like we're in a pretty good place this week.  After everybody's done with the stuff we need to do for roadmapping, please remember to focus on getting 033 out the door: fixing 033-must bugs, reviewing code, etc...
18:32:02 <isis> yeah, this data is rad
18:32:10 <nickm> do we have more discussion things we haven't gotten to at this meeting?
18:32:10 <isis> i like how it's colour coded too
18:32:30 <catalyst> i would also be interested in seeing per-developer totals
18:32:39 <asn> ill do per-developer totals guys
18:32:39 <ahf> isis: i started out with 3 in compress, 2 a few places, 1 a lot of places and some zero's and have slowly bumped the values up every time i've looked at the sheet :-S
18:32:47 <catalyst> i guess we can kind of visually infer it because of the color coding
18:32:52 <asn> i cant stop writing google doc summations.
18:32:57 <isabela> hahaha
18:33:19 <ahf> need to create a twitch channel with google sheets advice for developers, asn
18:33:34 <isis> ahf: yeah same! i looked at other people's answers and was like "oh i guess if so-and-so is an expert on that, then i probably am not a '0' like i thought"
18:34:02 <isabela> asn: you should hang out with Sue from accounting in rome (spreadsheet master)
18:34:22 <asn> haha yes i have lots to learn
18:35:34 <isis> what are the third/fourth roadmapping tabs for? do i need to fill them out somehow?
18:35:51 <asn> there
18:36:10 <isabela> isis: just the areas of work and subsystem ones for now
18:36:14 <isabela> isis: you can ignore the rest
18:36:49 <isabela> isis: each person has 5 votes for priorities (in general) tor network has at the moment
18:37:09 <isis> ok cool
18:37:29 <isis> i did the vote thing last week, just didn't realise you could have tabs in a Google doc
18:37:49 <isis> :)
18:38:08 <isabela> coolio o/
18:38:47 <nickm> do we have more discussion topics for this week?
18:38:57 <nickm> more ideas / issues / generally interesting things?
18:39:05 <isis> i have a question about the build system
18:39:25 <isis> but that could be one on one with someone who knows the build system really well
18:39:39 <isis> (also build system is maybe an area of code that we forgot)
18:39:39 <nickm> i can try ... is this the rust thing you mentioned?
18:39:42 <isis> yeah
18:39:53 <mikeperry> I also have questiosn about control port+bw stats stuff
18:40:09 <isis> komlo's Rust code links to the C code to call the C function tor_version_as_new_as
18:40:29 <isis> which is built into libtor
18:40:35 * catalyst had a Q in the pad about prep for Rust stuff in Rome
18:40:51 <isis> my code links to crypto_digest.h, which is linked into libor-crypto
18:40:54 <mikeperry> I will ask in #tor-dev after, though, since it will require some code rummaging
18:41:19 <nickm> mikeperry: sounds cool
18:41:21 <isis> libor-crypto.a and libtor.a and libtor_rust.a all get linked together at the end
18:41:48 <nickm> does anybody know the answer to catalyst's rust question ?
18:41:50 <isis> i need libor-crypto to get built first, then made available to libtor-rust as it's getting built
18:42:27 <isis> idk about Rust stuff at rome, i won't be able to be there
18:43:03 <isis> last time i invited the Rust people, so i don't know if they got invited? i could ask komlo if she had plans
18:43:33 <nickm> komlo is on the wiki as a "yes" arriving 9 mar
18:43:53 <nickm> isis: is this a circular dependency thing?
18:44:30 <dgoulet> there is a thread on the net team list about pre-meeting hackfest in Rome on the 10th
18:44:32 <dgoulet> catalyst: ^
18:44:50 <dgoulet> I think last email was from teor responding to mine iirc
18:44:50 <isis> nickm: i am worried about that in general moving forward yes, but in this specific case i don't think the graph is circular
18:45:30 <dgoulet> catalyst: but it could benefit now for a bit more structure for the 10th
18:45:43 <nickm> it might be a good idea to ask our rust contacts how they handle this kind of thing.  Is the problem explained on a ticket anywhere?
18:45:46 <isis> unless there is something in libor-crypto calling some Rust code, but there shouldn't be (at least not yet)
18:45:55 <dgoulet> catalyst: oh it is an email for the 11th from isabela but blended in the 10th a bit
18:46:00 <nickm> or is this a build issue where we need to build some C stuff before rust and some C stuff after rust?
18:46:13 <isis> nope, i can explain it on #24659 and link to my code
18:46:27 <isis> yes, it is a problem of some C, then some Rust, then some C
18:47:06 <nickm> isis: that would be great.  We might need to change how our build system builds C and invokes Cargo.
18:47:29 <isis> okay, will explain everything i understand so far on the ticket! thanks!
18:48:25 <nickm> did we get to everything?  We have 10 min left :)
18:49:52 <nickm> hearing no additional topics, I'll call the meeting adjourned.
18:49:54 <nickm> Thanks, everyone!
18:50:01 <ahf> bueno
18:50:10 <isabela> o/
18:50:20 <nickm> please remember to poke me today about anything you need me to do ; I might not be online tomorrow
18:50:23 <nickm> peace!
18:50:24 <nickm> #endmeeting