16:59:45 <nickm> #startmeeting weekly network team meeting, 23 Oct
16:59:45 <MeetBot> Meeting started Mon Oct 23 16:59:45 2017 UTC.  The chair is nickm. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:59:45 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:59:53 <nickm> https://pad.riseup.net/p/QKh0bLHntAJ1 is the pad
16:59:56 <nickm> hello everybody!
17:01:12 <isabela> hello
17:01:15 <nickm> as usual, the meeting is logged on meetbot.  The notes are on pad https://pad.riseup.net/p/QKh0bLHntAJ1
17:01:48 <isis> o/
17:05:12 <nickm> so, here's a question.  Right now, our roadmap draft is on a google sheet we haven't shared with the world.
17:05:22 <nickm> probably having it be world-readable would be smart
17:05:37 <ahf> yes
17:05:45 <nickm> do we have a preferred way to do that with spreadsheets?
17:05:47 <isabela> i have an update on roadmaps sharing process
17:05:52 <nickm> oh, cool
17:05:57 <isabela> (for reference)
17:06:18 <isabela> would be nice to organize this - i like the format now but could be cleaned a bit
17:06:53 <nickm> ok. so one possibility is, we postpone export till we know what the desired sharing format is, some time in november?
17:07:21 <isabela> so
17:07:29 <isabela> i am trying to coordinate with all teams to share roadmaps
17:07:36 <isabela> so the inter-teams communication can be improved
17:07:45 <isabela> specially for identifying dependencies
17:07:55 <isabela> i added a link to my update for the timeline
17:08:00 <isabela> i am coordinating with vegas leads
17:08:18 <nickm> I think I'm up-to-date on that?
17:08:22 <isabela> would be good to have a format to share soon, so network can be aprt of it
17:08:39 <nickm> great.  Shall we wait for the format, then export, or do something else?
17:08:43 <nickm> Is there something we should be doing now?
17:08:45 <isabela> nickm: i presented it via email and it was on the discussion last vegas leads meeting
17:08:57 <isabela> yes
17:09:10 <isabela> deciding on how the team want to share it with other teams
17:09:12 <nickm> isabela: I saw it.  I thought that I was up-to-date on it, since I had done the stuff up through Oct 23?
17:09:43 <nickm> (said stuff being: put roadmap online, mark stuff that touches other teams)
17:09:55 <isabela> so to decide on the medium to share it is part of that
17:10:31 <isabela> also i moved the 23 deadline to 26 (because other ppl asked for more time)
17:10:47 <ahf> is there something missing from the format we have now?
17:11:00 <isabela> not really
17:11:09 <isabela> just one question -tbb-needs vs tbb-wants
17:11:12 <isabela> what that means?
17:11:25 <nickm> I think it's more or less the same
17:11:32 <nickm> it _could_ mean how important it is to TBB
17:11:41 <nickm> but I don't think we have been consistent about using the different to indicate anything
17:12:16 <isabela> ok
17:12:27 <isabela> can i change to be just tbb-needs?
17:12:32 <nickm> sure
17:12:36 <isabela> it will be less confusing for tbb team when they look at it
17:13:05 <isabela> (btw if you have tickets associated with that work i think that adding their numbers there is good)
17:13:08 <isis> may i see a copy/pic of the roadmap? i wanted to start making tickets for stuff, if that's okay
17:13:25 <nickm> everyone should have access; I'll send the link again
17:13:25 <isabela> https://docs.google.com/spreadsheets/d/1Ufrun1khEo5Cwd6OwngERn829wU3W3eskdrriaYfUBQ/edit#gid=0
17:13:31 <nickm> oh, or isabela can
17:13:35 <isabela> :)
17:13:37 <isis> thanks!
17:13:39 <nickm> (hey everybody, please don't mess up our roadmap)
17:13:45 <isabela> :)
17:14:11 <nickm> so, these people are mentioned in the october section:
17:14:24 <nickm> teor, asn, mikeperry, dgoulet, ahf, nickm, catalyst, dgoulet.
17:14:37 <nickm> if there's something listed for you which you won't finish in october, please postpone?
17:14:49 <nickm> if there are ticket numbers that aren't listed there, please add them?
17:14:59 <ahf> yep
17:15:00 <nickm> If there aren't tickets, but there should be tickets, please open tickets and add the numbers?
17:15:19 <isabela> i would also suggest to take a quick look at november
17:15:26 <isabela> the list is getting quite long there
17:15:31 <nickm> yes; doing the same stuff on november would rock.
17:16:36 <ahf> i think with the sponsor 8 work i will add tickets + numbers for all of the roadmap sheet for as far as nickm and i got when we went over the proposal and tried to turn it into tasks
17:16:52 <nickm> #action teor I hope teor can write up a design sketch for the privcount thing?
17:17:30 <nickm> The important thing for me is just to know how the shamir thing is going to work, exactly. I can probably do the rest of the proposals
17:17:52 * Samdney is watching
17:17:56 <nickm> isabela: probably it's logical for you and me to sketch out plans for a circumvention team if sponsor Bucket goes forward?
17:18:31 <nickm> dgoulet and isabela might want to help with that sketching, and we should reach out to other domain experts
17:18:37 <nickm> sounds plausible?
17:19:14 <isabela> nickm: i think we should ask armadev
17:19:29 <nickm> noted!
17:19:50 <nickm> so, everything for november is claimed except for #21394
17:20:08 <nickm> not bad
17:20:15 <isabela> catalyst: isnt this what you doing? ^
17:20:37 <nickm> #event after the meeting, everybody please add tickets and people to the roadmap, through november.
17:20:41 <catalyst> isabela: i'll have to take a look. it's something i'm interested in but the scope seems rather large
17:21:35 <nickm> let's start going through  updates!
17:21:41 <nickm> my main question is: releases!
17:21:41 <isabela> catalyst: but is it associated with sponsor8 work?
17:21:48 <isabela> catalyst: the stuff related to tor launcher
17:21:51 <isabela> or no?
17:22:18 <nickm> There are some issues waiting for backport to stable releases, and we're due for another 0.3.2.x alpha.
17:22:23 <catalyst> isabela: i think it's plausibly associated with sponsor8. it seems like the sort of problem that will be even more harmful to usability in a constrained network
17:22:48 <nickm> but should I delay for some of the #21969 fixes?  And will they be ready for 0.3.1.x and earlier, or will they need to stabilize in 0.3.2?
17:23:41 <nickm> asn: that might be a question for you...
17:24:00 <isabela> catalyst: do you mind letting me know once you learn more?
17:24:02 <dgoulet> nickm: I think the short term for #21969 is #23862 which is stalling tor client sometimes
17:24:21 <dgoulet> nickm: and that one asn seems to be confident to have it by the end of week, imo we should wait for that for the next 032 alpha
17:24:34 <dgoulet> (which will most likely require backport)
17:24:38 <nickm> Should 031 and others also wait for it?
17:24:55 <nickm> or will we want to let it bake in 0.3.2 for a while?
17:24:58 <dgoulet> I do think so because 031 is badly working because of it :S
17:25:27 <dgoulet> good point, maybe it won't fix the entire problem... that asn is the person to answer indeed
17:25:50 <nickm> ok.  asn, please let me know when you're back
17:26:02 <nickm> my current plan is to do one of these:
17:26:17 <nickm> #action nickm puts out stable releases early this week, and an alpha next week .... OR
17:26:55 <nickm> #action ... OR nickm puts out the alpha and stable at the same time, when the 23862 patch is ready.
17:27:02 <nickm> we'll see what asn says.
17:27:10 <ahf> you don't want to continue with the rotation of release duties?
17:27:19 <nickm> I'm fine taking every other rotation :)
17:27:24 <ahf> ack!
17:27:24 <catalyst> isabela: it looks like teor has opened new tickets (#21310, #21311) on the IPv6-related timeouts. it's unclear whether there are other kinds in #21394
17:27:30 <nickm> Somebody want to sign up for 0.3.2.4-alpha? :)
17:27:47 <nickm> any other comments on this week and next for releases?
17:27:51 <nickm> if not, moving on!
17:27:58 <nickm> isabela: did we answer all your questions?
17:28:37 <nickm> (ah, asn is maybe offline for dinner.)
17:28:46 <isabela> nickm: yes, ty
17:28:52 <dgoulet> yah he wasn't sure to make it but he'll show up after I think
17:28:57 <nickm> I don't see anybody else with an open question....
17:29:42 <nickm> isis: here is your regular reminder to wrap up moat soon even if it isn't fun as other stuff. :)
17:30:03 <nickm> ahf: shall we talk about the mobile stuff from montreal after this meeting, and other sponsor8 stuff for october?
17:30:25 * isabela would like to chat too
17:30:26 <nickm> catalyst: should #20532 still be in 0.3.1?
17:30:34 <nickm> isabela: I'll be around. Let's talk in #tor-dev
17:30:35 <isabela> i have some questions about how to measure the modularization efforts
17:30:41 <nickm> isabela: okay, I can try
17:30:41 <isabela> cool!
17:30:43 <isabela> sounds good
17:30:49 <catalyst> nickm: i think so, and should probably get back ported to supported releases
17:30:56 <ahf> nickm: yes, isabela and i talked about that the other day that we should speak about the new things after montreal
17:30:57 <nickm> is modularization maybe approved or probably approved or possibly approved
17:31:02 <nickm> catalyst: ok
17:31:39 <isabela> possibly
17:31:53 <nickm> ok, so i won't put modularization tickets into a sponsor yet.
17:31:54 <nickm> good
17:32:09 <nickm> So, here's another thing:
17:32:18 <nickm> #item review-group-24 is open!
17:33:01 <nickm> #link https://trac.torproject.org/projects/tor/query?status=accepted&status=assigned&status=merge_ready&status=needs_information&status=needs_review&status=needs_revision&status=new&status=reopened&keywords=~review-group-24&group=status&col=id&col=summary&col=owner&col=type&col=priority&col=component&col=version&order=priority here are the tickets in review-group-24
17:33:46 <nickm> dgoulet: I think there was another kind of foo-group that we were talking about doing. Do you remember what it was?
17:34:22 <dgoulet> hmmmm
17:34:37 <dgoulet> not sure
17:35:19 <nickm> ok. we can come back to that if we remember
17:35:28 <isabela> nickm: any update from the pt meeting?
17:36:04 <nickm> isabela: yes!  so, I've encouraged brandon to make some process changes to "PT 2.x" that will make the output more usable for us, I hope.
17:36:27 <nickm> first, I hope it will be split into separate sections, so that the part we implement (the IPC API) can stand on its own
17:36:46 <nickm> second, I hope that they will start using a public issue tracker to discuss changes, so that we can all keep an eye on which changes everyone else wants.
17:37:00 <nickm> third, I hope some part of the darn thing (ideally, the part we need) can get declared stable and unchanging soon.
17:37:42 <nickm> last thing from me: do we have too many rotations? Most usually go unclaimed.
17:38:04 <dgoulet> I do think so
17:38:13 <dgoulet> coverity/jenkins/ticket seems to me the important ones
17:38:22 <dgoulet> err... priority ones
17:38:35 <ahf> yeep
17:38:37 <nickm> I propose that we cut out everything but coverity and tickets?
17:38:38 <nickm> err,
17:38:43 <nickm> everything ut jenkins and tickets?
17:38:51 <ahf> and coverity?
17:39:00 <nickm> maybe leave coverity, but put me on it till further notice?
17:39:10 <nickm> I haven't noticed other folks fixing coverity issues for a while.
17:39:25 <catalyst> do we want to add hackerone to the rotations?
17:39:47 <nickm> I've gone ahead and edited https://trac.torproject.org/projects/tor/wiki/org/teams/NetworkTeam/TeamRotations.
17:39:58 <nickm> catalyst: I don't know. Let's work that out when asn is around? He'll have some thoughts, I bet
17:42:01 <nickm> fun coincidence: there are 24 tickets in review-group-24 :)
17:42:28 <nickm> any other issues for this week?  anybody want help with anything?
17:42:34 <nickm> any way I can be helpful to anybody?
17:42:52 * dgoulet is good
17:43:04 <nickm> isabela is visiting me on wed/thu, so we might be a little distracted then, or we might be extra-able to solve everyone's problems.
17:43:15 <isabela> :) yes
17:43:22 <isabela> also modularization deadline is this friday
17:43:24 <nickm> make sure we know in advance what we can try to do for you
17:43:27 <isabela> that is why i wanted to chat more later
17:43:41 <isabela> (after this meeting)
17:43:43 <nickm> yup. I'll move over to tor-dev after this meeting with ahf and isabela and whoever else is interested
17:43:55 <nickm> anything else for this week?
17:44:08 * ahf is good
17:44:38 <isabela> nickm: part1 of the roadmap sharing plan is due on thurs and modularization is due on friday (these are the only things related to this team that i know)
17:44:59 <isabela> but yes
17:45:03 <isabela> i am good to move on
17:45:03 <isabela> :)
17:46:18 <nickm> ok!  Thanks, everybody!  You all helped make Montreal especially productive and positive for me, and I hope you had a similar feeling too.  I'm looking forward to this next 6 month block up to Rome.
17:46:22 <nickm> peace, all
17:46:25 <nickm> #endmeeting