16:59:46 <nickm> #startmeeting network team meeting, 18 October 2017
16:59:46 <MeetBot> Meeting started Mon Sep 18 16:59:46 2017 UTC.  The chair is nickm. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:59:46 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:59:48 <nickm> hi everybody!
16:59:53 <pastly> hi!
17:00:06 <ahf> hello!
17:00:13 <nickm> ahf, pastly, catalyst, isis, dgoulet, asn: !
17:00:31 <dgoulet> hello
17:00:32 <catalyst> hi
17:00:34 <nickm> teor should be asleep; isabela may be running late; and komlo usually can't make this time.
17:00:42 <nickm> and if I missed you, my apologies
17:00:54 <nickm> the weekly pad is at https://pad.riseup.net/p/PC9bBHYwDb1j or its onion equivalent
17:01:06 <nickm> and it's a big week!
17:01:26 <asn> hello
17:01:27 <nickm> let's take a minute for everybody to get their updates in, and to read everyone else's updates over
17:01:33 <nickm> remember to boldface stuff to talk about
17:04:16 <nickm> ahf:  sorry, I want and did the coverity stuff from last week
17:04:23 <nickm> it needed to get solved before 0.3.2.x sould stabilize
17:04:52 <ahf> nickm: oh, that is no problem - i just had it in my notes that i had to do it
17:04:55 <ahf> i remove those
17:06:57 <isis> o/
17:07:11 <nickm> hi isis ! pad at https://pad.riseup.net/p/PC9bBHYwDb1j
17:07:13 <nickm> hi mikeperry !
17:07:21 <isis> got it, updating!
17:07:32 <flipchan> yoyo
17:07:37 <flipchan> the tor relay email list
17:07:50 <flipchan> the question never got awnser
17:07:58 <nickm> flipchan: we're doing a dev meeting here right now; maybe try #tor-project ?
17:07:59 <flipchan> whats the best isp for a tor exit
17:08:27 <flipchan> oh, sry for bothering, i'll try on that chan
17:08:33 <nickm> np; thanks
17:09:25 <nickm> catalyst, isis: have you (or has somebody) told the tor-launcher folks what we've got for them?  If so great; if not let's make sure they know what they have to work with now
17:11:21 <nickm> ahf: you seem to be focused on wakeup/sleep/battery stuff for sponsor8. should I take over some other segment, like binary size or memory usage or ...
17:11:22 <catalyst> not explicitly, but i think they've added themselves as CCs on some of the tickets
17:11:24 <nickm> ?
17:11:27 <nickm> ok
17:12:43 <isis> nickm: yes, i gave them specs for the backend APIs last week and they gave me feedback, i revised the spec a bit, and then i finished the implementation of #15967 (which is ~80% of #22871)
17:12:49 <nickm> great
17:13:14 <nickm> so, it looks like everybody's got an update in.
17:13:22 <nickm> quick announcements & requests from me:
17:13:41 <nickm> we have 3 weeks left before rust stuff in montreal.  Other folks have done a good job getting our schedule started; I have been swamped.
17:14:07 <nickm> I'd like somebody else who's been doing schedule things already to step in as the network-team schedule handler for montreal. Any takers?
17:14:54 <isis> i can take that
17:15:16 <nickm> thanks! much appreciated
17:15:44 <nickm> also, I think flexlibris et al still want our ideas for good sessions for non-team day; so if we have ideas for those, let's spread them.
17:15:53 <isis> i should probably coordinate with isabela since iirc there were some moz/FF things that the tor browser team wanted us to attend
17:15:59 <nickm> isis: great
17:16:12 <nickm> isis: also please let me/isa/anybody know if there's anything you need/want us to do to help
17:16:22 <isis> nickm: sure, of course
17:16:41 <nickm> next topic from me: 0.3.1.7 is stable; 0.3.2.1-alpha is feature-frozen! both release today.
17:17:17 <nickm> 0.3.3 window opens after the dev meeting.  Feel free to work on stuff for 0.3.3.x, and feel free to review it... but it won't get merged till after the dev meeting.
17:17:21 <ahf> sweet :-)
17:17:47 <nickm> We should spend a lot energy trying to stabilize 0.3.2.x, and trying to fix any bugs that turn up in 0.3.1
17:17:51 <nickm> *lot of energy
17:17:51 <isis> nice
17:18:08 <nickm> any ideas on how we can try to do that?
17:18:55 <nickm> In particular, I'm concerned about why it took so long to stabilize 0.3.1.x.  We meant to release it as stable at the start of august, but it took us till, well, now.
17:19:18 <nickm> I'd like to not repeat that with 0.3.2, so we can aim to have 0.3.2.x stable in december.
17:19:48 <nickm> any thoughts where we may have gone wrong with 0.3.1?
17:20:02 <dgoulet> prop224 was probably a big "slow down" there... took us so much work to get it in time for 032 so I expect 031 to have slow down because of our focus elsewhere
17:20:10 <isis> is it possible that we tried to do too much in one release?
17:20:32 <nickm> it's possible, but 0.3.1 actually feels fairly small to me.
17:20:39 <dgoulet> yeah 031 is small
17:20:45 <nickm> I think maybe we had most of our folks focused elsewhere, on 032 stuff
17:20:52 <catalyst> what were the immediate causes of the delay? open bugs with a 0.3.1 target?
17:20:57 <dgoulet> yah and thus review got hurt
17:21:04 <isis> yeah i meant too much in 032
17:22:03 <asn> maybe not enough periodic bug triage?
17:22:14 <asn> so too many tickets were left open in beginning of august and stopped us from staiblizing?
17:22:25 <isis> a lot of us took our vacations around the same time too
17:22:40 <asn> thats true august was slow
17:22:48 <nickm> catalyst: I think so.  Looking down the big list, most of the issues seem to be "bugfix on 0.3.1.1-alpha"
17:22:57 <isis> for the review part, i didn't hear as many people loudly clamouring for review, so i wasn't aware that review was holding things up
17:23:05 <nickm> I think we may also have put out alphas too infrequently
17:23:18 <nickm> I don't think we were stalled on review so much for 0.3.1
17:23:43 <nickm> we should plan our alphas to match up with the TB release plans, so we get as much testing as possible
17:24:17 <catalyst> yeah getting our prerelease code into TB would help a lot with testing
17:24:40 <nickm> they take whatever alpha we have when they put out an alpha TB release, so that's good
17:25:30 <nickm> but they only do alpha releases on the rapid release schedule, so we only have two TB-present alpha releases between now and our target stable date.
17:25:33 <nickm> ( see https://wiki.mozilla.org/RapidRelease/Calendar )
17:25:39 <nickm> and one of those will be 0.3.2.1-alpha
17:25:56 <asn> seems like we had a 2.5 month gap between 0.3.1.5-alpha and 0.3.1.6-rc
17:26:11 <asn> might be an issue with nickm being the only release engineer here
17:26:17 <asn> (https://gitweb.torproject.org/tor.git/refs/tags)
17:26:27 <nickm> also maybe an issue with us not having an actual "planned alpha release" schedule
17:26:55 <isis> how much work is it to tag an alpha? like in hours
17:27:02 <nickm> asn: hang on, I think 0.3.1.5-alpha was 2017-08-01 ?
17:27:10 <nickm> asn: and 0.3.1.6-rc was early september?
17:27:14 <asn> oh yes 7 weeks
17:27:19 <asn> misread the columns
17:27:24 <asn> and thought it's 3 months ago
17:27:30 <nickm> isis: putting out a source alpha release is a few hours for me.
17:27:47 <isis> hmm
17:27:47 <nickm> isis: doing packages takes the packagers much longer, in the TB case
17:28:04 <nickm> we could plan to do a certain number of alphas at certain times, if we think ahead
17:28:20 <dgoulet> +1 on that ^
17:28:53 <nickm> we could aim for ~1 every two weeks, give or take?
17:29:10 <nickm> or every three weeks?
17:29:13 <ahf> could we rotate on that such that it is not only you?  you tried it during the last couple of months where we had a session about what that needs to be done. that was useful, but i don't think we kept up with it after that
17:29:19 <dgoulet> which means ~6 after feature freeze
17:29:54 <catalyst> who is in our testing pipeline besides TB-alpha?
17:30:07 <nickm> ahf: huh. yeah, it probably is a good idea to get some experience with other folks doing alpha releases.
17:30:25 <nickm> catalyst: everybody who runs alphas from source. Various debian users, etc
17:30:34 <ahf> we did that for one of the alpha's recently, but we didn't keep up with it afterwards
17:30:39 <dgoulet> we have couple relay op. that run master religiously also
17:30:48 <catalyst> do we get our alphas into Debian unstable?
17:30:48 <isis> i dogfood the alphas in qubes
17:30:57 <ahf> where we tried to help out with some different parts of the process - i don't know if that took longer time than just you doing it though :o
17:31:15 <nickm> ahf: i think that if we're going to have more people do alpha releases, it will work better if 1-2 people other than me do it, and I just watch.
17:31:28 <nickm> or if I just double-check before sign-and-release.
17:31:42 <ahf> yep
17:32:04 <isis> is there any way to automate this process more, in a way we trust?
17:32:07 <nickm> #action release 0.3.2.x alphas every 2 weeks or so
17:32:21 <nickm> isis: Hm.  Have a look at ReleasingTor.md and see if you see anything we can stop or automate?
17:32:36 <nickm> it's already somewhat automated in terms of the tooling
17:33:01 <nickm> but i stopped doing automation once I no longer found the process annoying, so maybe we could make more progress
17:33:27 <catalyst> is changelog compilation automated?
17:33:42 <nickm> catalyst: yes, but there are hand-editing steps
17:33:55 <nickm> to get it to be in the right format, to make the prose nice, etc
17:34:11 <catalyst> maybe we could QC changes files as they come in? as part of the review process?
17:34:23 <nickm> sounds good.  or as part of the merge process?
17:34:54 <nickm> I think it's reasonable to ask that all of us write well-formed changes files, but too much to ask from outside contributors
17:34:54 <catalyst> either might work, but there's a larger pool of reviewers
17:35:15 <catalyst> we already do minor fixups when integrating outside contributions
17:35:18 <nickm> #action include changes review as part of review process
17:35:21 <nickm> catalyst: right
17:35:35 <nickm> any volunteer to lead the 0.3.2.2-alpha release process?
17:35:50 <nickm> it'll be fuuuun :)
17:35:55 <catalyst> like maybe we should make "changes file for this patch is release-ready" part of the review procedure
17:36:31 <nickm> if we can get the false positive rate for lintChanges to 0, we could make lintchanges part of 'make check'
17:36:33 <isis> nickm: ugh, mostly only the testing parts have some automatable steps :/
17:37:07 <isis> it looks like it's mostly "run around and do the thing"
17:37:26 <ahf> nickm: i'd be up for it - it's right before montreal then?
17:37:38 <isis> when are we doing 0.3.2.2-alpha?
17:37:47 <nickm> to be fair, it's not a major timesink.  I've been putting out 5 releases today, and it only took me this morning and a little of friday for prep
17:38:16 <nickm> isis: let's aim for some time early during the week of 2 october, before montreal?
17:38:22 <nickm> assuming there's something to put in it?
17:39:11 <isis> i'd take a crack at it, and ahf also sounds interested
17:39:26 <nickm> you two okay with working together on it?
17:39:34 * catalyst notices there's no changes file review step in HowToReview.md
17:39:35 <ahf> yep
17:39:38 <isis> yeah
17:39:49 <nickm> if you are, please ask me questions absolutely any time you run into anything
17:40:07 <isis> i can also sit on the sidelines and take notes if it's more of a one-person task
17:40:16 <nickm> And don't worry about minor screw-ups, or doing things in a way that's different from what I would do
17:40:51 <catalyst> it sounds like i could open a few tickets related to these things
17:40:59 <nickm> I do releases different from Roger, and that's the cost Roger pays for not having to do all the releases himself----
17:41:09 <nickm> ---- I am prepared to pay that cost too sometimes :)
17:41:22 <nickm> catalyst: excellent!
17:41:42 <nickm> yes, we should feel free to improve our doc/HACKING instructions as we go along; they probably don't all match reality
17:42:11 <nickm> #action ahf and isis will run the 0.3.2.2-alpha release, targetting early during the first week of october
17:42:44 <nickm> #action we'll try to do alpha releases once every 2-3 weeks, and plan in advance when thney come out
17:42:52 <nickm> #action nickm will look over ReleasingTor.md to make sure it's right
17:43:26 <nickm> one other thing we can do to try to get 0.3.2.x out on time is to triage the milestone fairly aggressively.  I'm aiming to do that this week too
17:43:34 <nickm> please let me know if i triage anything _too_ aggressively
17:43:46 <nickm> ok, i'm out of stuff
17:43:46 <dgoulet> regular triage also is what we should aim for imo
17:43:54 <nickm> anybody else got a topic for this week? :)
17:44:07 <dgoulet> prop224 is in 032, so please dog food it and report ANYTHING :D
17:44:17 <nickm> same with KIST
17:44:34 <isis> woah fancy
17:44:37 <pastly> yes please! tagging tickets with tor-sched
17:44:59 * dgoulet adding that keyword to our list
17:45:04 <nickm> pastly: please close the KIST tickets that should be closed now, btw
17:45:19 <dgoulet> pastly: yeah ^ have the honor to close it :)
17:45:22 <catalyst> do we have a "release engineering" type keyword to use in trac?
17:45:27 <pastly> :) on it
17:45:33 <nickm> catalyst: I don't think so but we could make one
17:45:45 <ahf> dgoulet: do we have a keyword list we maintain? we have a lot of new keywords for sponsor 8 things from our meeting last week
17:45:58 <dgoulet> https://trac.torproject.org/projects/tor/wiki/org/process/TorOnTrac
17:46:04 <ahf> thanks
17:46:09 <catalyst> nickm: how's "tor-releng"?
17:46:19 <nickm> sounds fine to me
17:47:38 <nickm> anything else for this week's meeting?
17:48:54 <nickm> asn, dgoulet: You can also probably close many tickets, including #12424
17:49:01 <nickm> okay, calling this meeting done.
17:49:08 <dgoulet> nickm: we are waiting in Montreal to close it lol
17:49:12 <nickm> thanks, everybody!  This team rocks.
17:49:20 <dgoulet> nickm: culmination of 3 years of work, we want to make it special :P :P
17:49:21 <ahf> <3
17:49:40 <nickm> dgoulet: then please close all possible child tickets, and assign that one to one of you?
17:50:06 <dgoulet> nickm: that's already done
17:50:34 <lattera> nickm: are you working on seccomp support?
17:50:53 <nickm> dgoulet: #12424 is "new" tho....
17:51:03 <nickm> okay.  much love to all. Peace!
17:51:05 <nickm> #endmeeting