16:59:51 <nickm> #startmeeting tor dev/network team weekly meeting
16:59:51 <nickm> hi all!
16:59:51 <nickm> oh , wow, no meetbot?
16:59:51 <asn> hello :)
16:59:51 <dgoulet> hi!
16:59:51 <nickm> #----------------------------------------------------
16:59:51 <nickm> there, that will be easy to grep for
16:59:51 <asn> (DIY meetbot I like)
16:59:51 <dgoulet> maybe there is an ongoing meeting that wasn,t ended :S
16:59:51 <asn> dgoulet: ~!
16:59:51 <nickm> #help
16:59:51 <MeetBot> Meeting started Mon Apr  4 16:59:51 2016 UTC.  The chair is nickm. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:59:51 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:59:52 <nickm> #info
16:59:52 <dgoulet> MeetBot: help
16:59:52 <MeetBot> dgoulet: Error: You don't have the misc capability. If you think that you should have this capability, be sure that you are identified before trying again. The 'whoami' command can tell you if you're identified.
17:00:04 <dgoulet> fun
17:00:13 <isabela> :)
17:00:18 <asn> mad lag?
17:00:19 <nickm> looks like it's just slow
17:00:22 <nickm> anyways!
17:00:57 <nickm> I spent last week scrambling to get sponsorS stuff done for EOM.  I got a bunch of modularity stuff done.  This week I have PETS reviews and I need to actually explain the modularity stuff well enough for others to understand it.
17:01:00 <athena> hello meeting!
17:01:10 <nickm> Also I have 9 meetings this week. This is #3.  :/
17:01:22 <athena> ouch
17:01:34 <asn> nickm POTUS style
17:01:43 <nickm> I hope I can get some code review in, but I bet that I'll leave this meeting with more jobs than I started it with, so we should get stuff reviewed by other people too.
17:01:54 <nickm> oh, was last week the alpha too?  Busy week if so.
17:02:04 <nickm> that's it for me.  What have others been up to?
17:02:07 <athena> i dug through a bunch of those backport tickets and did some merges
17:02:26 <athena> still a couple left, should nail them down next day or two - then going to hit the code review backlog
17:02:49 <nickm> anything you need to help figure those out?
17:02:58 <nickm> are there a fair number where we can say "no backport" ?
17:04:01 <isabela> athena: please look at the tickets for april that needs review and maybe add your name on reviewer for those you take to review?
17:04:05 <athena> okay
17:04:06 <isabela> athena: https://trac.torproject.org/projects/tor/wiki/org/teams/NetworkTeam
17:04:20 <isabela> ^^ has the query for the april keyword
17:04:26 <asn> i go nexts?
17:04:41 <nickm> FWIW I've put all pre-existing needs_review tickets for 0.2.9 into april. Hope I don't regret it.
17:04:48 <nickm> asn: sure
17:04:52 <asn> Hello. I was sick for most of last week. Was not particularly productive. Mainly did GSoC preparations, some prop259 stuff and discussed Tor with people over
17:04:53 <asn> IRC. Today though I'm better and life is pretty good! I did some prop224 design stuff today and wrote a [tor-dev] post about it: https://lists.torproject.org/pipermail/tor-dev/2016-April/010719.html
17:04:56 <asn> EOF
17:05:10 <asn> I'll also take a look at the tickets and mark myself for review
17:05:29 <isabela> tx
17:05:30 * dgoulet can go
17:05:33 <nickm> dgoulet, asn: will you still be around in 2 hours?  And/or again in 5 hours?  I have a couple of student groups I'm meeting with then and maybe I can talk them into IRC.
17:05:42 <asn> I don't think so :(
17:05:47 <nickm> ok; sleep well :)
17:05:51 <dgoulet> I should be yes
17:05:52 <asn> sorry!
17:06:17 <nickm> main thing I'd ask for in that case would be, is it solid what's changing in 224 and what isn't, or is that still fluid?
17:06:37 <asn> IMO it's still fluid
17:06:54 <nickm> hmm.
17:07:09 <nickm> can we mark the parts that are fluid, or is it the whole entire thing?
17:07:18 <dgoulet> fluid in some sense, it's not changing drastically I think and it's localized to some sections
17:07:19 <nickm> do we have a plan to get us to a solid spec?
17:07:22 <asn> maybe we can mark the stuff that dgoulet has implemented as much less fluid.
17:07:35 <nickm> I'm mainly thinking of the stuff that the students are working on.
17:07:50 <nickm> which is mainly section 3 iiuc
17:07:58 <nickm> I think some of that stuff is more nailed down than other parts
17:08:03 <asn> true!
17:08:13 <dgoulet> asn: your branch should have some solid fixes for that section I think
17:08:15 <asn> there was a big discussion about that section on the ML last month
17:08:26 <asn> yes indeed I have a branch that should solidify that section much more
17:08:45 <asn> Here it is: https://lists.torproject.org/pipermail/tor-dev/2016-April/010713.html
17:08:50 <asn> ehm  https://gitweb.torproject.org/user/asn/torspec.git/log/?h=prop224-fixes
17:08:54 <nickm> ok. should I be trying to review and merge that?  I worry that I'll be taking some parts and diverging from you
17:08:57 <asn> (i changed it today and updated tor-dev)
17:09:21 <nickm> (is there a ticket?)
17:09:26 <asn> I was waiting ACKs on the latest changes from you/dgoulet/special, and then I would merge to torspec.git .
17:09:46 <asn> (special has already ACKed)
17:09:51 <nickm> #nickm I'll try to get on reviewing asn/prop224-fixes rsn so that nobody is blocking on me
17:09:55 <nickm> #action nickm I'll try to get on reviewing asn/prop224-fixes rsn so that nobody is blocking on me
17:10:25 <asn> most cell formats should be quite stable after my patch (TM symbol)
17:10:42 <asn> (i can only imagine them changing due to engineering/implementation issues)
17:10:43 <dgoulet> oh, I'll review that branch asap then
17:11:13 <asn> (well maybe they will also change because not enough people have looked at my changes and they might suck)
17:11:27 <asn> nickm: would you like a ticket? we've been doing spec work on ML
17:11:49 <asn> nickm: basically my current plan is to keep on grooming the spec one step ahead of the implementation.
17:12:13 <asn> nickm: so dgoulet/special have been coding descriptor encoding/decoding. at the same time, we groomed the cell formats.
17:12:21 <nickm> either that or tell me which thread.  I think there are several? :)
17:12:34 <asn> nickm: now we will be implementing the cell formats. and we will be grooming the time period part of the spec.
17:12:41 <nickm> waaait please.
17:12:57 <dgoulet> students have been working on cell formats ^
17:12:58 <nickm> Please coordinate with the students here and don't just jump on them?
17:12:59 <dgoulet> (I think)
17:13:06 <nickm> yes in theory.  Or at least parts of it
17:13:19 <dgoulet> nickm: I'm at the point of looking into this so I can coordinate with them, np
17:13:24 <nickm> If we keep grabbing the stuff they want to work on, they'll be spending the all their time making up new projects.
17:13:31 <asn> have the students been writing trunnel?
17:13:38 <asn> *trunnel code
17:13:45 <nickm> asn: I hope so. I don't know how far they've gotten on it though.
17:13:48 <asn> (i'm a bit on the dark on what the students have been doing)
17:14:11 <asn> (partly my fault, but also I haven't seen any updates of theirs)
17:14:41 <asn> ---
17:14:46 <nickm> (I spent the first few weeks asking them to get in touch with you and dgoulet.  Recently I switched to insisting loudly.  We'll see how that goes.)
17:15:14 <asn> nickm: this is the thread that started the spec grooming: https://lists.torproject.org/pipermail/tor-dev/2016-March/010534.html
17:15:30 <asn> nickm: this is the post announcing the spec changes: https://lists.torproject.org/pipermail/tor-dev/2016-March/010561.html
17:15:39 <dgoulet> (I'll throw out my update here, one sentence, easy)
17:15:41 <nickm> asn: thanks!
17:15:46 <dgoulet> A bit of bug triage last week. Development and discussion on prop#224. That's it on the little-t tor side. Will work on tickets (review, patch) and continue development work on next-gen HS this week.
17:15:49 <dgoulet> ---
17:16:10 <nickm> who else?
17:16:11 * isabela can go
17:16:42 <isabela> I worked on figuring out the parents/child situation on our 029milestone
17:16:45 <asn> (fwiw, if the students have been writing trunnel code. I believe we might be able to put it to very good use.)
17:16:59 <dgoulet> asn: +1
17:17:05 <isabela> you can see my map here -> https://docs.google.com/spreadsheets/d/1ndnU4o0iMbXu0o02yTDurHIiGCDoIBV9hdV4YJQMWVs/edit#gid=557636391
17:17:44 <isabela> right now is hard to say how off the capacity count is due to parets/child tickets
17:17:55 <isabela> but I dont think it will be that off
17:18:19 <isabela> the most important thing for it right now is for me to have ok to remove the ticktets market as red from the milestone
17:18:26 <dgoulet> isabela: what is Red for ?
17:18:33 <dgoulet> ah :)
17:18:45 <isabela> i just mapped which ones that had parents and was also marked as red
17:19:41 <isabela> so yeah, maybe if we have time to discuss the red tickets and agree on those we disagree ;)
17:19:57 <asn> i already spotted some parenting mistakes!
17:20:00 <isabela> so I can remove them from the milestone it will be super helpful for moving forward
17:20:13 <isabela> asn: which ones/
17:20:25 <asn> 8782 Don't give up so easily on your guards if the consensus calls them Running
17:20:30 <asn> 5462 Clients should alert the user if many guards are unreachable
17:20:38 <asn> should _not_ be children of #11480
17:20:43 <asn> these things are not part of prop#236
17:20:53 <isabela> ah
17:20:58 <asn> and then the only tickets that remain as children of #11480 are red.
17:21:11 <asn> = "#11480 does not happen in 0.2.9" or something.
17:21:16 <asn> (if that's of any help)
17:21:23 <isabela> tx!
17:21:44 * asn fixes on trac
17:21:50 <isabela> another update is the other sheet named 'All 0.2.9'
17:22:29 <isabela> please review the red tickets there I need a green light from the team if I can remove all the red there from the 029 milestone
17:22:43 <isabela> I havent seem any names on the 'disagree' column
17:22:54 <isabela> so I dont know if ppl are cool with it or havent looked at it
17:23:28 <isabela> other than that last week i went to rightscon for a couple of days and was afk on friday
17:23:31 <isabela> [end]
17:23:58 <mikeperry> fyi I am around, sort of, but have been busy with rightscon, cloudflare, and slowly lurching forward on the firefox networking code review. I'm kind of a mess from all that, and need to do taxes and shit. still likely to be out of the tor-core loop for a bit longer.
17:24:11 <asn> i looked at the reds for the projects i'm involved with. i'm fine with them!
17:24:20 <nickm> #action everybody needs to read over all the red tickets to see if you disagree with deferring any
17:24:31 <dgoulet> isabela: what's orange?
17:24:38 <nickm> i should look again to see if anything became red since friday
17:24:49 <isabela> i didn't start using orange :) that is another question i had
17:25:00 <isabela> someone used it
17:25:05 <nickm> My bad.  I wish I could remember why I was using orange.
17:25:10 <nickm> let me see if I can reconstruct.
17:25:31 <isabela> :)
17:25:55 <nickm> ah, I sent email to network-team on March 30!
17:25:56 <dgoulet> #15621 is in need_review for instance so I wouldn't throw it out of 029 but it's "orange" so I'm guessing it was a "maybe" from nickm ? :)
17:26:10 <isabela> aha
17:26:21 <nickm> "I have started using orange for things that I don't really _like_ to make red, but which possibly should be red, and/or are not something we should be spending a long time on right now"
17:26:33 <isabela> (sorry things has been insane since last week)
17:26:46 <isabela> ok
17:26:49 <asn> (isabela: I want to throw #11480 outside of 0.2.9. Should I put it to 0.2.??.)
17:26:49 <nickm> IOW, "I would love to merge the code if you've secretly been writing it , or if it's way easier than I think, but I worry this could be a timesink in spite of how cool it is"
17:27:56 <dgoulet> isabela: all fine to throw out the red in there for now btw
17:28:26 <isabela> asn: for now
17:28:30 <isabela> dgoulet: cool
17:28:33 <dgoulet> #16558 could have been a contender  for 029 but we failed to come up with a consensus in VLC ...
17:28:42 <nickm> isabela: I'll take another look...
17:29:06 <isabela> ok
17:29:25 <dgoulet> isabela: where are we on the "merge_ready" state, should we add it?
17:29:29 <isabela> mikeperry and dgoulet do you disagree from nickm on the orange tickets that is assigned to you?
17:30:26 <dgoulet> #15621 should be considered because it has been in need_review for two months now
17:30:35 <dgoulet> but it's nickm calls at that point
17:30:43 <isabela> dgoulet: no one said anything on dev list, eail was sent around a week ago
17:30:53 <isabela> dgoulet: I think i can create a ticket for it to be added
17:31:02 <dgoulet> isabela: right but that email was just "here is what we are going to do, if you are against, speak" no?
17:31:18 <isabela> yes
17:31:18 <mikeperry> there's a lot of colors in each column on this spreadsheet. I am kind of confused by it. I don't see anything I was eyeing in orange. I see #10969 in red, though
17:31:38 <asn> dgoulet: isabela: yes that's also how i read that email. it seems like a potentially helpful workflow.
17:31:45 <isabela> dgoulet: that is what I mean, i will go ahead and open a ticket for it to be added, unless you has da power
17:31:55 <dgoulet> isabela: I might have the power!
17:31:58 <isabela> aha!
17:32:04 <dgoulet> (and I also really want it :P)
17:32:14 <isabela> lets do it!
17:32:19 * dgoulet on it
17:32:34 <mikeperry> oh, and weirdly #17592
17:32:47 <isabela> mikeperry: look at the sheet 'all 029'
17:34:50 <mikeperry> isabela: aha, yes, I was on the second sheet ('triage 029'). makes more sense now
17:35:59 <mikeperry> so when do we expect the code freeze dates for 029 to be again?
17:36:26 <nickm> I think it's freeze some time in august to release in september?
17:36:48 <nickm> The funded stuff is mostly due-in-september
17:36:58 <nickm> except for R , which works differently
17:37:19 <isabela> yes
17:38:04 <mikeperry> so yeah, I actually deferred the #8453 until November in the roadmapping session in valencia
17:38:16 <mikeperry> it can be done after the netflow stuff is deployed and we start getting some stats back from it
17:38:23 <mikeperry> which means after 0.2.9 now
17:38:33 <isabela> cool
17:39:32 <mikeperry> here, let me spam with my notes from stuff I picked in Valencia
17:39:35 <mikeperry> 1. Timing side channels (April)
17:39:36 <mikeperry> 2. Round robin bind addr (June)
17:39:36 <mikeperry> 3. Module Documentation #17292 (July)
17:39:36 <mikeperry> 4. Prop 259 help - #17262 (July/Aug)
17:39:36 <mikeperry> 5. IPv6 auto exits - July
17:39:38 <mikeperry> 6. 3->1 dirguards (#10969) (Oct)
17:39:47 <isabela> roadmap is on wiki
17:40:00 <nickm> mikeperry: which of those are funded ?
17:40:05 <isabela> https://trac.torproject.org/projects/tor/wiki/org/roadmaps/CoreTor
17:40:12 <mikeperry> #17292 is, as is #17262
17:40:28 <mikeperry> #10969 is, but not if it gets done after October
17:40:38 <isabela> dgoulet asn I will organize onion services roadmap like that as well
17:41:12 <mikeperry> case could be made that the timing side channels is also a guard node security issue
17:41:25 <mikeperry> (for OTF funding for Guard improvements)
17:41:27 <nickm> I don't think they'll buy that.  Do we have a proposal there?
17:42:03 <mikeperry> they are actually very flexible with stuff like that. I've been working with them for 3 years now
17:43:10 <mikeperry> I have the proposal text somewhere
17:44:00 <dgoulet> isabela: ack
17:44:07 <dgoulet> isabela: let me know if you need any help
17:44:16 <mikeperry> "Design and write at least one whitepaper on
17:44:21 <GeKo> tor browser meeting in 15 minutes
17:44:28 <mikeperry> guard node design and improvements."
17:44:53 <mikeperry> and then doment path selection, and then implement one or more designs from the whitepaper
17:45:12 <isabela> ok
17:45:13 <nickm> I think we'd planned that the acutal guard design changes would be that.
17:45:20 <isabela> I will propose we move this off meeting
17:45:21 <nickm> At least, I sure had.
17:45:25 <mikeperry> ok
17:45:27 <nickm> ack.
17:45:32 <asn> [BTW, we've done tons of work over the past year on a first draft of prop#247. That's definitely sellable as a guard-related sponsored project as well IMO]
17:45:35 <isabela> cuz TBB is meeting soon
17:45:44 <isabela> I will make sure to follow up, cool?
17:45:47 <nickm> ok.
17:46:31 <dgoulet> FYI, "merge_ready" state has just been added. You can transition from it from needs_review, needs_information, needs_revision --> merge_ready
17:46:44 <nickm> cool
17:46:47 <isabela> awesome
17:46:48 <dgoulet> nickm: that state is basically your cue to check it out and merge :)
17:46:52 <dgoulet> the "nickm-ready" :)
17:46:53 <isabela> I will document this on our wiki as well!
17:46:56 <dgoulet> woot
17:46:57 <nickm> please look over needs_review tickets to see if any should be merge_ready :)
17:47:09 <dgoulet> nickm: yeah I plan to do that!
17:47:15 <isabela> thanks a lot dgoulet !
17:47:20 <dgoulet> np
17:47:48 <nickm> more topics for this meeting?
17:48:05 <nickm> does everybody understand all the stuff that we're all supposed to be doing for triage? :)
17:48:17 <isabela> (tx nickm)
17:48:56 <isabela> i have a qq about the notes from these meetings
17:48:59 <nickm> sure!
17:49:16 <isabela> I got overwhelmed last week with rightscon etc and didn't send notes
17:49:42 <isabela> is ok to skip that one and just send today's meeting notes? I wonder if they are being useful somehow
17:49:49 <isabela> maybe I should ask in the list or something
17:50:04 <dgoulet> isabela: your best client for those notes is probably teor, ask him
17:50:09 <isabela> ok
17:50:10 <isabela> tx!
17:50:36 * nickm will endmeeting in 30 sec if  no more topics....
17:50:56 <asn> I'm taking #13239 for review.
17:51:11 * asn looks more
17:51:22 <asn> (feel free to kill the meeting btw)
17:51:26 <nickm> #endmeeting