13:29:04 <nickm> #startmeeting
13:29:04 <MeetBot> Meeting started Wed Feb 10 13:29:04 2016 UTC. The chair is nickm. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:29:04 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:29:12 <nickm> hello everybody! I'll start with my status update.
13:29:32 <nickm> I'm chugging away trying to make deliverables happy. I'm working on modularity and on ed25519 stuff. I am way behind.
13:29:47 <nickm> I should also be reviewing code and merging things. I am slow with that. I hope to be doing more with it.
13:30:28 <nickm> I have some MIT students who are picking a tor-related term project; I'm mentoring them; I hope that by tomorrow they'll know what they want to work on
13:31:03 <nickm> #action nickm I need to schedule the next proposal review meeting for tomorrow or friday
13:31:32 <nickm> For the rest of today I'll be writing designs and reading things and reviewing/merging code. If I feel great, I'll work on bugs.
13:31:38 <nickm> that's me; who's next?
13:31:41 <asn_> i can go
13:31:50 <asn_> hello
13:31:54 <nickm> hi!
13:32:01 <asn_> the past days i've been working with ola bini on new guard algorithms
13:32:14 <asn_> we are still not there, but progress is being done
13:32:43 <asn_> see https://lists.torproject.org/pipermail/tor-dev/2016-February/010388.html for an algorithm
13:33:02 <asn_> it's not The Algorithm yet, but we are getting there i thin
13:33:16 <nickm> great
13:33:19 <asn_> opinions from other tor folks would be appreciated
13:33:29 <asn_> other than that, i've worked a bit on the prop250 review by teor
13:33:36 <asn_> i should do some more of that today
13:33:47 <asn_> other than that, i've been strategizing about prop224 development with dgoulet.
13:34:25 <asn_> i also did a review or two yesterday.
13:34:32 <asn_> and that's that
13:34:39 <nickm> ok. if the s5tudents decide they want to do prop224 stuff, you might want to think what could be a good tiny piece for them to start with
13:34:44 <armadev> my update is that we got the next chunk of sponsorR money, so we can afford to have paid asn/dgoulet/karsten/me for the past few months (also, i am not really here)
13:34:47 <asn_> nickm: yes
13:35:56 <armadev> (i am excited to be the one to build 224, al gore style)
13:36:07 <asn_> nickm: i think we have identified the tor-keygen offline-keys functionality as something that we are going to leave for later
13:36:16 <asn_> nickm: and could be taken by ajn excited volunteer
13:36:27 <asn_> (talking about prop224 ^)
13:39:28 <nickm> anybody else today?
13:39:37 <athena> greetings meeting!
13:39:46 <nickm> asn_: I'll keep that in mind, but I'm requiring that it be something they are excited about.
13:39:49 <nickm> hi athena
13:40:00 * isabela has updates
13:40:03 <nickm> hi isabela
13:40:06 <athena> you have a #18116 fix to review, which probably covers #18251 too
13:42:01 <nickm> ok, I'll have a look
13:42:06 <nickm> what's next?
13:42:34 <athena> popping the stack to tie off #4581 next
13:44:11 <nickm> ack
13:44:15 <nickm> isabela: ?
13:44:55 <isabela> I am working on putting together an analysis of 0.2.8 for us to review
13:45:03 <isabela> I hope to send it around today
13:45:20 <isabela> I will also be sending stuff for us to review before valencia to help with the discussions there
13:45:48 <nickm> cool
13:45:57 <isabela> I am hopping we can have the network team retrospective, build our roadmaps for the next 6 months and work on our release process
13:46:27 <isabela> so when I send out stuff please take time to read before valencia and we can chat mroe next meeting as well
13:46:32 <nickm> sounds good
13:46:35 <isabela> [done]
13:46:40 <nickm> anybody else around this morning?
13:47:00 <nickm> highlighting dgoulet teor Yawning isis just in case.
13:47:07 <nickm> though some of them should really be asleep and/or moving
13:47:52 <nickm> ok! So, discussion time.
13:48:18 <nickm> Jsut a reminder that we're in the final stretech for 0.2.8, and asking folks to be realistic about what they can hack before deadline, and to help everybody else's tickets get reviewed.
13:48:33 <nickm> (If we're all hacking up till deadline and nobody is reviewing, then nothing will actually get in for 0.2.8)
13:49:02 <nickm> also reminding folks to keep the 'owner' and 'milestone' field accurate for tickets in accepted and assigned
13:49:10 <nickm> let's see
13:49:29 <nickm> I need to decide whether we're meeting about prop#264 and prop#266 on thursday or friday.
13:50:02 <nickm> On thursday, we can get roger. On friday, we can get teor and mikeperry . I would like more people's comment on this, but I really really want to know what Roger thinks here
13:50:44 <nickm> armadev: if you come to the 1500 UTC time, will you have at least skimmed those proposals?
13:51:27 <nickm> other topics?
13:51:55 <isabela> well
13:52:10 <armadev> i am still imagining i should read the proposals from the last discussion. it turns out i'm listed as an author of them after all. :)
13:52:42 <nickm> I should re-read the discussion. I was somewhere between distracted and absent for it, unexpectedly.
13:54:39 <nickm> isabela: ?
13:54:41 <isabela> so I have some random info about the 0.2.8
13:54:48 <nickm> great!
13:55:17 <armadev> i might be able to do tomorrow night too, for the 264/266 proposals. i am not doing well at sleeping so i don't want to make promises that will ruin my sleeping.
13:55:31 <isabela> one thing that will be hard is to know when a ticket started to be worked on
13:56:08 <nickm> isabela: it might be a good idea to also use this retrospective to figure out what extra data we should gather for 0.2.9
13:56:26 <isabela> yes
13:57:22 <isabela> but I think what goes down to is that we will have to be doing checks in what is on the release so its not inflated with tickets etc
13:57:39 <nickm> how do you mean?
13:58:29 <isabela> let me go back a little
13:59:26 <isabela> I think we need to make sure we select work we can do for the release, now we have around 200tickets that gets done per release
13:59:58 <isabela> and I see that the work increases on the last two months too (curiosity is that some tickets are 5 years old)
14:00:37 <isabela> I am saying that we should try to have monthly checks of what is in the release, what will get done etc to make sure we are calibrating it right
14:00:47 <isabela> https://docs.google.com/spreadsheets/d/1o2PtK8f2LbJ7fwRQyqM724HASV_zIFMTfV6qqvKykDk/edit#gid=1371282754
14:00:56 <isabela> if opens in the right chart
14:01:03 <isabela> it shows the tickets closed so far
14:01:17 <isabela> when they were created and when they were closed
14:01:25 <nickm> that could be useful
14:02:16 <isabela> if you see the line of dots going up?
14:02:26 <nickm> yes?
14:03:54 <isabela> looks like we created a lot of tickets after the triage, I assume it was small tasks breaking down from big ones
14:04:19 <nickm> yes. it might also be bugs.
14:04:35 <nickm> I would not be confident it was mostly task breakdown
14:04:47 <isabela> ok
14:05:35 <isabela> good thing is that the work is distributed between the months of the release (the last two ones are busier but that is normal too)
14:05:58 <isabela> and we have some crazy old tickets :) 5 years old
14:06:07 <nickm> I'm surprised nothing is older :/
14:06:28 <isabela> anw, some stuff I am looking at
14:07:33 <nickm> v interesting. I am kind of surprised by the idea that "200 tickets" is a reasonable metric, given how much variance there is among tickets.
14:07:43 <isabela> oh
14:07:46 <nickm> but perhaps the law of averages makes everything work out
14:07:56 <isabela> I dont think it is, it was what we did for 027 and 028
14:09:06 <nickm> ok
14:09:22 <nickm> anything we can do to help you gather info for this stuff?
14:09:31 <isabela> the right way to know is to caculate tickets points assigned to each team member and see if they are with a lot or a little
14:10:16 <isabela> I think for now is that we shoudl definetely be adding info to tickets, like points (size) and right person 'owning' it
14:10:21 <isabela> lots of tickets without info
14:10:46 <isabela> anw
14:10:50 <isabela> we can chat more in valencia
14:10:56 <nickm> +1
14:11:02 <nickm> more topics for today?
14:11:38 <nickm> armadev: I note above that you didn't actually commit to show up Thu _or_ Fri having read the proposals under discussion. :)
14:14:30 <nickm> ok, sounds like we finished!
14:14:32 <nickm> #endmeeting