#reproducible-builds: #reproducible-builds September 2022

Meeting started by rclobus at 15:06:50 UTC (full logs).

Meeting summary

  1. diffoscope on BSD (rclobus, 15:09:34)
    1. https://pad.riseup.net/p/rb-irc-meetings-keep (rclobus, 15:11:31)
    2. ACTION: neverpanic Synchronise MacPorts and diffoscope (rclobus, 15:13:53)
    3. ACTION: lamby Synchronise BSD and diffoscope (rclobus, 15:14:12)

  2. short time slots for checkins from various projects (rclobus, 15:15:37)
    1. https://reproducible.archlinux.org/api/v0/builds/343630/diffoscope will investigate later :) (jelle, 15:18:46)
    2. ACTION: jelle Investigate glibc on Arch Linux (rclobus, 15:19:13)

  3. Debian snapshot.d.o mirrors (h01ger, 15:22:25)
  4. general Debian status update (h01ger, 15:27:14)
    1. next NMU upload meeting, is thursday, october 6th, 16 utc on #debian-reproducible (h01ger, 15:29:31)
    2. https://udd.debian.org/bugs/?release=bookworm_and_sid&patch=only&pending=ign&merged=ign&done=ign&fnewerval=7&flastmodval=7&reproducible=1&sortby=last_modified&sorto=asc&format=html#results lists 245 such bugs (h01ger, 15:30:54)

  5. Debian: live-build (rclobus, 15:34:21)
    1. Monthly report https://lists.debian.org/debian-live/2022/09/msg00016.html (rclobus, 15:34:30)

  6. any other business (AOB) (h01ger, 15:40:06)
    1. https://github.com/coreinfrastructure/best-practices-badge/issues/1865 is the issue discussed (h01ger, 15:43:39)
    2. https://github.com/SCons/scons/pull/4239#issuecomment-1258941198 (the comment, and now with 2 answers) (rclobus, 15:44:19)
    3. https://etherpad.opensuse.org/p/scons-rb-argument (vagrantc, 15:45:17)

  7. AOB scons (rclobus, 15:46:56)
    1. https://tests.reproducible-builds.org/debian/history/scons.html (vagrantc, 15:51:55)
    2. ACTION: jelle Look at the Debian scons package (rclobus, 15:54:28)

  8. AOB best practices badge requirements (rclobus, 15:58:22)
    1. https://github.com/coreinfrastructure/best-practices-badge/issues/1865 (vagrantc, 15:58:47)

  9. AOB Do you have other topics for the meeting? (rclobus, 16:04:22)
    1. some topic were skipped, due people not being present. Next meeting, you'll have your chance to shine! (rclobus, 16:05:38)


Meeting ended at 16:06:21 UTC (full logs).

Action items

  1. neverpanic Synchronise MacPorts and diffoscope
  2. lamby Synchronise BSD and diffoscope
  3. jelle Investigate glibc on Arch Linux
  4. jelle Look at the Debian scons package


Action items, by person

  1. jelle
    1. jelle Investigate glibc on Arch Linux
    2. jelle Look at the Debian scons package
  2. lamby
    1. lamby Synchronise BSD and diffoscope
  3. neverpanic
    1. neverpanic Synchronise MacPorts and diffoscope


People present (lines said)

  1. h01ger (59)
  2. rclobus (50)
  3. vagrantc (38)
  4. lamby (13)
  5. jelle (13)
  6. MeetBot (3)
  7. neverpanic (2)
  8. rburton (1)
  9. Myon (1)


Generated by MeetBot 0.1.4.