19:29:20 <sumpfralle1> #startmeeting
19:29:20 <MeetBot> Meeting started Wed May 2 19:29:20 2018 UTC. The chair is sumpfralle1. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:29:20 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:29:38 <sumpfralle1> #chair TheSnide dipohl h01ger chteuchteu kenyon be0rn
19:29:38 <MeetBot> Current chairs: TheSnide be0rn chteuchteu dipohl h01ger kenyon sumpfralle1
19:29:53 <sumpfralle1> #topic review last meeting
19:30:33 <sumpfralle1> I took over two tasks: "review manpages packaging in Debian for 2.999" and "add build system details to the development documentation of the guide"
19:30:55 <sumpfralle1> The first one is done. I will explain a bit more later.
19:31:10 <sumpfralle1> The second one is still open. Thus I postpone it to next week.
19:31:31 <sumpfralle1> #action sumpfralle1 add build system details to the development documentation of the guide (in case it is missing)
19:31:52 <sumpfralle1> TheSnide: did you take a look at the old manpages to be recovered?
19:32:47 <dipohl> hi sumpfralle
19:32:55 <sumpfralle1> hi dipohl
19:33:25 <dipohl> I also wait for this (restore deleted content to the Guide)
19:33:46 <sumpfralle1> I assume, that TheSnide is not here right now. Thus I postpone the task.
19:33:50 <dipohl> before I will move more content to the Guide
19:33:59 <sumpfralle1> #action TheSnide recover the few removed munin-2.0-pages of the munin-guide
19:34:31 <sumpfralle1> #info dipohl will migrate more pages from the trac wiki, after the old manpages are restored
19:34:38 <sumpfralle1> good!
19:34:46 <sumpfralle1> next topic?
19:36:08 <sumpfralle1> #topic Manpages in Debian packages
19:37:16 <sumpfralle1> recently I proposed some changes to the packaging of munin 2.0 for Debian. This will add a few more manpages and it moves the manpages to the packages, with their respective programs. This will be published with the next release, I guess.
19:37:22 <sumpfralle1> Now I started the same for 3.0.
19:37:53 <sumpfralle1> Here the packaging of the documentation already looked quite good - just two more manpages were missing in the package. I added these.
19:38:13 <sumpfralle1> #topic Debian packaging for munin 3.0
19:38:14 <dipohl> fine!
19:38:18 <sumpfralle1> yes, it was fun
19:38:33 <sumpfralle1> meanwhile I went deep down into the packaging of munin 2.999
19:38:57 <sumpfralle1> there are loads of small things to be done (especially for the non-systemd setup)
19:39:07 <sumpfralle1> I think, I will be done soon.
19:39:25 <dipohl> It looks that on Epel side no one is preparing a release of the recent 2.0 version.. :(
19:39:45 <sumpfralle1> h01ger: there is no need to review my small changes right now, as I will add more. I will tell you, when I am ready.
19:39:56 <TheSnide> hi
19:40:01 <sumpfralle1> hi
19:40:01 <h01ger> ack
19:40:34 <dipohl> https://apps.fedoraproject.org/packages/munin/builds/
19:40:48 <dipohl> at least it is still included in Fedora 29..
19:40:49 <sumpfralle1> #topic EPEL packaging
19:41:04 <sumpfralle1> what can we do about this?
19:41:26 <dipohl> #action dipohl will file a bug on Fedora / Epel
19:41:27 <TheSnide> it was done by fenris01, which disapeared
19:43:01 <sumpfralle1> What is the maintenance model of EPEL? Do we need to inspire someone with upload rights? Or could we just proposed an updated packaging and hope for someone to publish it?
19:43:02 <dipohl> perhaps one of the left maintainers will pick up the task when I file a bug report..
19:44:21 <sumpfralle1> let us wait for the bug report and hope for enthusiasm from the packagers ...
19:44:37 <sumpfralle1> another topic?
19:45:07 <dipohl> what about the new munin homepage?
19:45:29 <sumpfralle1> #topic New Website
19:45:53 <sumpfralle1> what are the steps in the direction of the new website?
19:46:05 <sumpfralle1> finishing the move of trac pages?
19:46:09 <sumpfralle1> Or something else?
19:46:26 <sumpfralle1> (or maybe we do not need to wait for this)
19:46:29 <dipohl> you said chteuchteu offered help with the technology
19:46:33 <sumpfralle1> yes
19:46:42 <dipohl> but we do not have somebody who cares for the content yet..
19:47:14 <sumpfralle1> the same goes for the current trac pages
19:47:17 <dipohl> and the current content is outdated
19:47:24 <sumpfralle1> at least I will get an account for the new one, I hope :)
19:47:48 <dipohl> the trac wiki is sort of /freezed/ state
19:47:53 <sumpfralle1> yes, we should go through the list of documentation links, I guess
19:48:18 <sumpfralle1> frozen: yes, that's how it looks like :)
19:48:44 <sumpfralle1> right now I am immersed in the debian packaging of 2.999
19:49:12 <dipohl> I don't see high priority for the new homepage
19:49:29 <TheSnide> about the RH packaging, i think it would be much easier when 3.0 is out
19:49:39 <dipohl> but it would be very good to find a volunteer for that task
19:49:45 <dipohl> perhaps ask on the ML?
19:49:55 <sumpfralle1> website: yes, sounds good
19:50:30 <sumpfralle1> epel simplification: that would be nice improvement (the Debian package for 2.999 looks indeed much nicer than the 2.0 one)
19:50:46 <sumpfralle1> dipohl: will you as or should I?
19:51:01 <dipohl> TheSnide: 3.0 is not so easy, as there are dependencies to perl modules, that are not available in the distri yet
19:51:18 <sumpfralle1> oh - this could be a problem, indeed
19:52:08 <sumpfralle1> so we should first try to motivate someone with the 2.0 packaging, since it does not require a lot of work right now (based on the working state)
19:52:18 <dipohl> +1
19:52:47 <sumpfralle1> another topic?
19:53:04 <sumpfralle1> TheSnide: did you enjoy progress with munin-node-c?
19:53:06 <dipohl> #topic Munin Gallery
19:53:23 <sumpfralle1> ok - gallery
19:53:24 <dipohl> The new scripts are not yet implemented
19:53:29 <sumpfralle1> ah!
19:53:32 <sumpfralle1> right
19:53:43 <sumpfralle1> we needed access to the gallery server
19:53:53 <TheSnide> dipohl: which are ?
19:54:09 <sumpfralle1> I updated the scripts in the repository
19:54:20 <sumpfralle1> some small improvements and a good amount of cleanup
19:54:39 <dipohl> TheSnide: https://wiki.dipohl-kunden.de/munin_install-protokoll-2018-01-31
19:54:40 <sumpfralle1> I asked for access to the gallery server some weeks ago (for this)
19:55:12 <sumpfralle1> TheSnide / be0rn: was there something missing for access to the shiny new VM that we could maybe use?
19:55:24 <sumpfralle1> (which would be a great gift)
19:55:36 <dipohl> sumpfralle1: somebody (within that meeting) said you will get access soon
19:55:42 <be0rn> Last I heard was that my colleague Jimmy had been in touch with TheSnide
19:55:58 <be0rn> I can pursue this daytime tomorrow
19:56:10 <dipohl> be0rn: Thanks!
19:56:14 <sumpfralle1> great!
19:56:41 <sumpfralle1> #info be0rn will try to clarify access to our future gallery VM
19:57:22 <sumpfralle1> another topic? Otherwise I will jump into the packaging rabbit hole again :)
19:57:43 * dipohl is finished
19:57:51 * sumpfralle1 too
19:58:35 <sumpfralle1> could it be possible, that we finish "on time" (if we aim for a 30 minutes meeting)? yeah!
19:58:41 <sumpfralle1> we do it!
19:58:43 <sumpfralle1> #endmeeting