19:23:59 <TheSnide> #startmeeting
19:23:59 <MeetBot> Meeting started Tue Oct 21 19:23:59 2014 UTC.  The chair is TheSnide. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:23:59 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:24:10 <TheSnide> starting early.
19:24:43 <TheSnide> i'll be away for 30 min
19:25:22 <h01ger> lol
19:25:28 <h01ger> thats a start
19:25:37 <h01ger> #topic 2.0.24 ?
19:30:43 <TheSnide> #chair h01ger
19:30:43 <MeetBot> Current chairs: TheSnide h01ger
19:31:01 <TheSnide> #chair dipohl
19:31:01 <MeetBot> Current chairs: TheSnide dipohl h01ger
19:31:58 <h01ger> TheSnide: i think we should postpone the meeting to 22:00 CEST
19:55:52 <TheSnide> h01ger: ok
19:57:26 <h01ger> really? lets have it at 21:30 ;-p
19:58:00 <h01ger> so
19:58:03 <h01ger> #topic 2.0.24
19:59:08 * dipohl is listening
20:00:50 <TheSnide> ;à
20:01:53 <TheSnide> I think deb#675318 has been fixed too hastily
20:02:07 <TheSnide> so, i have to fixit again
20:06:21 <h01ger> was that the only one?
20:07:01 <TheSnide> also, tore's issue #1467 is annoying
20:07:36 <TheSnide> as said in the ticket, fb041130 might have to be reverted, or fixed properly
20:07:55 <h01ger> TheSnide: whats your timeline for 2.0.24?
20:08:15 <h01ger> ssm: will you be able to fix debian packaging bugs before/until the 25th?
20:08:36 <TheSnide> I'd like to release it ASAP, last would be Friday.
20:08:54 * h01ger nods
20:10:01 <TheSnide> nothing much here about .24
20:15:06 <TheSnide> #topic guide
20:15:36 <TheSnide> the guide got some deep love these days, thx to dipohl.
20:17:55 <dipohl> :)
20:18:04 <TheSnide> most of the content from the wiki should migrate to the guide.
20:18:55 <dipohl> I put links to the wiki articles on many pages of the Guide
20:19:08 <TheSnide> I find it much more manageable than the wiki. I agree that it isn't as easy to contribute, but editing RST and submitting a pull request isn't very hard also.
20:20:19 <TheSnide> And best of all, we can have a finite set of pages. That usser can read in order. It's very easy to get lost in a wiki.
20:20:31 * dipohl nods
20:20:59 <TheSnide> As a matter of fact, I had to learn a new tech, and I only had a wiki. It's _very_ difficult.
20:21:28 <dipohl> I would keep the wiki as sort of homepage though
20:22:05 <TheSnide> Hyperlinks are soo tempting, and it feels like a maze at the end. Which 1. looses the user, and 2. lots of content is hidden.
20:22:50 <dipohl> wiki = projekt homepage: this way all members of the team can make changes in that very easy (add news or ideas)
20:23:02 <TheSnide> The website will remain trac for the time being. I don't think having a fresh new website will be very useful anyway. Let's just disable user registration.
20:23:32 <dipohl> I thought it is already?
20:23:43 <dipohl> that you have to contact the IRC to get an account
20:24:02 <TheSnide> dipohl: being written doesn't mean being enforced.
20:24:55 <dipohl> I am not against disabling the user self registration
20:25:20 <dipohl> as long as we create accounts for interested users
20:25:25 <TheSnide> #action ssm should disable user registration. I can still do it manually by inserting the corresponding rows in the DB.
20:25:55 <TheSnide> ssm: sorry to mention you, tell me if you cannot. I'll try to do it myself.
20:26:06 * h01ger cheers dipohl and the guide!
20:26:12 <dipohl> :)
20:27:16 <TheSnide> I created a "guide" branch on my own munin.git github fork. RFC should be sent there as PR.
20:28:18 <TheSnide> you can also directly send your RFC as a PR to the devel guide. Be just careful to use "Part - Other"
20:29:27 <TheSnide> It makes it easy to discuss PR by github comments, or by successive commits.
20:29:44 <TheSnide> (successive commits would have my preference)
20:30:05 <dipohl> what do you mean by that?
20:30:38 <TheSnide> If you craft a new RFC, propose your amendements by PR.
20:31:09 <TheSnide> Or do you prefer to keep the Wiki for that ?
20:31:31 <TheSnide> --> I'd say that the PR way enable easy interaction with others.
20:32:24 <TheSnide> Besides, it would permit a very precise specification of what you think : the edition would be directly a diff :)
20:32:28 <dipohl> for software developers, yes
20:32:38 <dipohl> for "normal" users -> no
20:32:56 <TheSnide> for normal users, they could submit issues now.
20:33:04 <TheSnide> that's quite easy IMHO
20:33:28 <dipohl> you are a nerd ;-P
20:33:32 * dipohl too
20:33:32 <TheSnide> I ma.
20:33:35 <TheSnide> i am.
20:34:00 <dipohl> but there are more creatures in the universe
20:34:22 <TheSnide> i mean, I don't want to spend any time managing more than necesseray. but i also want to be accesible.
20:34:34 <dipohl> I would like to keep the wiki (at least for a while, until we found another way to contribute for "normal" users)
20:34:44 <TheSnide> _any_ mean will be accepted. Be it email, or even IRC.
20:34:55 <dipohl> but IRC is not logged..
20:35:14 <TheSnide> ... that comes to my next point. thx.
20:35:21 <TheSnide> #topic IRC
20:35:54 <TheSnide> As IRC did mostly replace mailing lists, it should get some love.
20:36:10 <dipohl> but logging is not love
20:36:19 <TheSnide> The + of IRC is that is feel much more lively.
20:36:19 * dipohl is against it
20:36:33 <TheSnide> The - is that it is very ephemeral.
20:36:58 <TheSnide> I'm also against blind IRC logging.
20:37:01 <dipohl> I am ok with logging the meetings
20:37:09 <dipohl> but not anything
20:37:38 * dipohl is for data retention only with good reason
20:37:54 <TheSnide> But I want to make it clear that we can copy/paste some things from IRC to somewhere persistant.
20:38:09 <dipohl> via meetbot command?
20:38:11 <TheSnide> we can /manually/ copy/paste ..
20:38:23 <dipohl> something liek /forthefiles
20:38:26 <dipohl> like
20:39:02 <TheSnide> nope, "by hand". but it still is a privacy risk.
20:39:39 <TheSnide> So, usual way is to ask permission prior pasting.
20:39:41 <dipohl> yes, you could copy the text of other speakers
20:40:25 <TheSnide> I just want to make the permission implicit, unless explicitly opt-out.
20:40:27 <dipohl> or make a new channel
20:40:31 <dipohl> munin-logs
20:40:37 <dipohl> logging on there
20:40:56 <dipohl> one goes to the channel and speaks there
20:41:10 <dipohl> or munin-forthefiles
20:41:47 <TheSnide> I think that the current way goes well enough. We just have to get the habit of "saving" chat snippets for future reference.
20:42:03 <TheSnide> And those would nicely fit the wiki.
20:42:24 <dipohl> but in the wiki you cannot delete versions or can you?
20:42:39 <TheSnide> _admin_ can.
20:42:41 <dipohl> if someone complaints against the quote
20:42:52 <dipohl> ok then
20:42:53 <TheSnide> (me & ssm)
20:43:21 <TheSnide> I think that some templates would be a nice to have.
20:43:27 <dipohl> ack!
20:43:53 <TheSnide> just go to some template page, copy the wiki source, and put it into a new one.
20:44:23 <dipohl> I have another topic "Contribute example graphs"
20:44:34 <dipohl> we have to find a simpler solution
20:44:36 <TheSnide> Or have one page that represents all the irc logs that where "extracted" because there were interesting.
20:45:06 <TheSnide> dipohl: could you think about something like that ?
20:45:21 <dipohl> a irc log collection in the wiki?
20:45:41 <TheSnide> yup (not automatic, manual. but with a nice lookting template)
20:45:47 <TheSnide> :)
20:46:18 <dipohl> how will you ask the paricipiants for commitment on the recording?
20:46:30 <TheSnide> commitment ?
20:46:48 <dipohl> there "yes" you may quote me
20:46:51 <dipohl> in public
20:46:59 <dipohl> their yes
20:47:12 <TheSnide> implicit. Just post the URL resulting
20:47:34 <dipohl> I don't like it, but if you insist and nobody else complaints
20:47:37 <TheSnide> if they complain, remove it via a version change, and ask me.
20:47:43 <dipohl> I can live with it
20:47:50 <TheSnide> I don't think it's a real issue.
20:48:14 * dipohl is a privacy protection knight ;)
20:48:23 <TheSnide> I'd say we should remove any sensitive info, such as timestamps.
20:48:31 <dipohl> Opt out is ugly
20:48:39 <dipohl> Opt in would be better
20:48:41 <TheSnide> dipohl: i'm googly :)
20:48:48 <dipohl> but difficult to handle
20:48:54 * dipohl no google account
20:49:00 <dipohl> nor facebook
20:49:02 <TheSnide> dipohl: opt-in will hand the same issue as gallery :)
20:49:11 <TheSnide> have*
20:49:18 <kenyon> my irssi logs everything. I'm probably not the only one.
20:49:23 <dipohl> we need authors allowance for the images
20:49:32 <dipohl> so we need a login or signature
20:49:33 <TheSnide> kenyon: it's _Very_ different
20:49:48 <kenyon> can't MeetBot be used for logging important things, like we're doing now?
20:49:59 <dipohl> kenyon: but you are not allowed to publish the logs
20:50:11 <TheSnide> kenyon: i don't mind to be logged privately. but opened publicly, not so much.
20:50:24 <dipohl> kenyon: that was my first proposal too
20:50:57 <TheSnide> kenyon: let's not overenginneering it. manual copy/paste.
20:51:03 <dipohl> use meetbot for "write my entry -> to the files"
20:51:32 <dipohl> TheSnide: 2 votes until now against your proposal ;-p
20:51:47 <TheSnide> dipohl: ...
20:52:19 <TheSnide> ok, forget it then. doing it as usual :)
20:52:21 <dipohl> TheSnide: Let's try your solution
20:52:34 <dipohl> and talk again with experiences
20:52:57 <dipohl> and let us setup some rules
20:53:05 <dipohl> for the "tothefiles" contents
20:53:15 <dipohl> so no beginner questions
20:53:35 <dipohl> they need a safe room
20:53:39 <dipohl> no logging
20:54:44 <TheSnide> #topic Contribute example graphs
20:54:50 <TheSnide> anyway.
20:55:02 <dipohl> the way per PR is too much work
20:55:17 <TheSnide> what would you suggest ?
20:55:20 <dipohl> I think we need a "mailbox" for contributors or a webinterface
20:55:20 <TheSnide> email ?
20:55:48 * TheSnide is fond of debian's BTS email interface.
20:55:49 <dipohl> signed mail would be ok to get "publishing allowed"
20:56:10 <dipohl> or register with email check at least
20:56:33 <dipohl> "verify authors email address"
20:56:44 <TheSnide> is sending a mail with a very specific format acceptable ?
20:57:23 <dipohl> I would like to have a KISS but legal confirmed contribution
20:57:41 <dipohl> I would say email verification is ok
20:57:44 <dipohl> what do you think?
20:58:12 <TheSnide> ok if no too much work technically
20:58:14 <dipohl> people can also use signed mail with graph attachment
20:58:23 <dipohl> but that is also difficult for "normal" users
20:58:37 <dipohl> and we should have an email address for that
20:58:57 <TheSnide> +1 to gallery@mmo.org
20:59:01 <dipohl> contribute.graph.images@munin-monitoring.org
20:59:08 <dipohl> or gallery is also ok
20:59:48 <dipohl> I left to your choice
20:59:53 <TheSnide> subject should be "screenshot: $plugin/name"
21:00:00 <dipohl> forward to ssm and me?
21:00:11 <TheSnide> attached image
21:00:30 <TheSnide> with the correct naming scheme
21:00:35 <dipohl> ack
21:00:53 <TheSnide> and formard to you & me (and ssm if he wants to
21:00:54 <TheSnide> )
21:00:56 <dipohl> this way at least the software people can contribute
21:01:13 <dipohl> ssm setup the gallery, therefore I thought it's him
21:01:20 <TheSnide> mail body isn't important
21:01:46 <dipohl> one sentence with the allowance to publish the pics in gallery
21:02:08 <TheSnide> sending email to that address means "allowance"
21:02:25 <dipohl> is that so?
21:02:39 <TheSnide> if we say so, it can be i think :)
21:02:43 <dipohl> I can send a fake mail
21:02:56 <dipohl> so email verification at least
21:03:11 <dipohl> auto-answer with the one sentence allowance?
21:03:13 <TheSnide> why would you send a fake email ?
21:03:42 <TheSnide> i mean. the addition *will* be _manual_ anyway.
21:04:10 <TheSnide> so any childporn will be deleted on sight :)
21:04:49 <dipohl> my thought was. Somebody could sent graph images, that he/she is not the owner of
21:04:52 <TheSnide> i don't think we'll have 1k email per day
21:05:16 <dipohl> and if the owner is not willing to show it to the public, we have a problem
21:05:40 <TheSnide> so, how can we know who's the owner ?
21:06:00 <dipohl> with "signing" the contribution in the answer-mail you have at least the email owner, who signs
21:06:19 <dipohl> I I faked the mail, you will not get a confirmation mail
21:06:38 <dipohl> so discard the contribution
21:06:52 <TheSnide> let's belive in ppl goot faith for now.
21:07:20 <dipohl> we can start simple and get up the level if needed
21:07:24 <TheSnide> and remove images upon formal removal request
21:07:33 <dipohl> ok
21:08:01 <TheSnide> i mean, if some legal body tells me to remove it, i will remove it.
21:08:19 * dipohl nods
21:08:28 <TheSnide> otherwise, i don't really care.
21:08:39 <dipohl> for the future, we hope that plugin contributions include graph contributions
21:08:59 <TheSnide> ... but i agree, we have to made that clear in the "terms of service" that are next to that email address
21:09:00 <dipohl> like it was in the munin-exchange days
21:09:37 <dipohl> I will add such a section in the wiki page about the gallery
21:10:05 <TheSnide> if you really want that, you can rewrite a front-end to easy-submit a plugin.
21:10:31 <dipohl> yes. but I have no time
21:10:43 <TheSnide> that builds a neat PR, with code & screenshot.
21:10:49 <dipohl> if you meet someone who want's to conttibute such a thing
21:10:57 <TheSnide> dipohl: same here, that's why i suggest : KISS /°
21:11:44 <dipohl> so for the start, we answer with a confirmation request
21:11:50 <dipohl> manually
21:12:04 <dipohl> and see how many contributions we get
21:12:25 <TheSnide> first we'll see how many contributions we get. then we think about it more :)
21:12:44 <dipohl> agreed
21:13:06 <TheSnide> #topic 2.1
21:13:12 <dipohl> why is ssm never in the meetings?
21:13:31 <TheSnide> dipohl: he doesn't like to be loggued ? ;-P
21:13:38 <dipohl> ;-P
21:13:56 <TheSnide> i think it's not a good timing for him.
21:14:05 <TheSnide> anyway.
21:14:19 <dipohl> perhaps we can look for a weekday, where he also is around
21:14:20 <TheSnide> I have 3 major subject I'd like to do
21:14:46 <TheSnide> #action poll for a new date/time for meetings
21:15:36 <TheSnide> 1. HTML5 interface. based on bootstrap + munin-json
21:16:06 <TheSnide> 2. Move to full SQL (no more datafile or storable)
21:16:54 <TheSnide> 3. Write more Guide things :)
21:17:27 <dipohl> :)
21:17:52 <dipohl> i would like to reduce that category set
21:17:59 <dipohl> the category set
21:18:20 <dipohl> in 2.1
21:19:22 <dipohl> http://munin-monitoring.org/wiki/graph_category_list
21:19:59 <dipohl> TheSnide ?
21:20:05 <TheSnide> +1 to have a "fixed" set of categories, even for contrib
21:20:46 <dipohl> with the gallery as demo
21:20:48 <TheSnide> dipohl: can you propose something to be discussed @ next meeting ?
21:20:59 <dipohl> we can show it to the users
21:21:07 <dipohl> before we release
21:21:10 <TheSnide> yup
21:21:41 <dipohl> no more topics at the time
21:21:53 <dipohl> I will continue moving wiki pages content to the guide
21:21:55 <TheSnide> i tend to agree that the categories should be generic.
21:21:58 <dipohl> and reduce category set
21:22:02 <TheSnide> yup
21:22:09 <TheSnide> thx for that :)
21:22:17 <dipohl> :-)
21:22:28 <h01ger> changing days/time so ssm can also attend would indeed be good i think
21:22:41 <TheSnide> do you replace the content on the wiki with a link to the relevant page in the guide ?
21:22:55 <dipohl> yes always set the link on top
21:23:12 <dipohl> didn't remove the content but set to "read only"
21:23:26 <dipohl> to compare it to the guides version after the move
21:23:32 <TheSnide> h01ger: i proposed that a couple of times, yet noone never answered. so i just picked times that are best for me :)
21:23:35 <dipohl> sometimes I change thing /on the flow/
21:23:54 <h01ger> TheSnide: maybe he will answer now..
21:23:57 <dipohl> and so you could make a diff
21:24:04 <TheSnide> dipohl: I'm trusting you on that
21:24:19 <dipohl> it's my art of work ;)
21:24:21 <TheSnide> (as you did a great job already)
21:25:49 <dipohl> gallery scripts will also need improvement in the future
21:25:57 <dipohl> but at the time it's sufficient
21:26:20 <dipohl> will have to be reworked, when you add subcategory schema
21:26:46 <dipohl> and also if someone sends .pod files for documentation
21:27:15 <dipohl> at the time the script only investigates the plugin scripts and doesn't look for .pod files
21:27:28 <TheSnide> is .pod still a good idea, or do you think we can also ask for .rst ?
21:27:54 <dipohl> munindoc needs POD
21:28:27 <dipohl> so it's the right thing for both purposes - gallery and munindoc
21:28:57 <TheSnide> is there a pod2rst tool ? so we can map it directly in the guide
21:29:14 * dipohl don't know
21:29:20 <dipohl> I am RST beginner
21:29:36 <TheSnide> (at least for core plugins, it makes sense to have them all in the guide)
21:29:52 <TheSnide> http://search.cpan.org/~dowens/Pod-POM-View-Restructured-0.02/bin/pod2rst
21:30:16 <dipohl> send it to ssm ;)
21:31:35 <dipohl> I have to leave the meeting
21:31:35 <TheSnide> #link pod2rst http://search.cpan.org/~dowens/Pod-POM-View-Restructured-0.02/bin/pod2rst
21:31:41 <TheSnide> ssm: ^
21:31:44 <TheSnide> same
21:31:46 <TheSnide> by
21:31:49 <dipohl> cu!
21:31:51 <TheSnide> #endmeeting