16:01:32 <ln5> #startmeeting snapshot #8
16:01:32 <MeetBot> Meeting started Mon Sep 23 16:01:32 2024 UTC.  The chair is ln5. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:32 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:01:41 <ln5> who are here for the meeting?
16:01:53 * weasel 
16:01:57 <ln5> here's a proposed agenda: status, old action items, aob, next meeting
16:02:07 <weasel> +1
16:02:18 <ln5> maybe h01ger wants to report back from the R-B summit?
16:02:55 <h01ger> the summit was great (i think) and people love(d) that snapshot.d.o is working again
16:03:23 * h01ger also managed to setup a debian rebuilderd but has torn it down since them to install on more powerful machines
16:03:27 <ln5> i enjoyed the summit a lot
16:03:37 <ln5> #topic status updates
16:03:43 <h01ger> thats a very high level summary
16:03:44 <ln5> rate limiting was removed, no sweat (so far)
16:03:48 <h01ger> \o/
16:04:18 <ln5> dev-01 setup: i've identified some more things requiring DSA -- missing tun/tap (see https://salsa.debian.org/linus/dsa-puppet/-/commit/4021f53f7f3ac2238e3985517bbc7497859a62e6), and also short on RAM (1G)
16:04:30 <h01ger> we should also put up a news entry for snapshot.d.o - i'd suggest writing it in a pad over the next days - today i'm mostly in low energy mode
16:05:03 <ln5> h01ger: i'm up for that, let's coordinate after meeting?
16:05:14 <h01ger> great & sure
16:05:18 <ln5> any other updates?
16:05:34 <axhn> Yes
16:06:20 <ln5> on update sponsor links, i've prepared https://salsa.debian.org/linus/snapshot/-/commit/2b737aacea284af9415cf59a46d4fd2760c22bea but not been able to render it properly so it'll have to wait a little bit more
16:06:23 <axhn> Finally working on the re-import of debian-ports. Will take a while as there's quite a huge amount of data to handle, and I want to do this in an efficient way, and good.
16:06:42 <ln5> axhn: sounds good
16:07:36 <ln5> ok, moving on
16:07:38 <ln5> #topic action items carry over
16:07:48 <weasel> - we finally switched over to the 10gigE interface on snapshot-mlm-01
16:07:57 <ln5> oh, right. wonderful.
16:09:17 <ln5> write a testsuite: no progress, but i'm interested in your all's ideas for how to do both unit testing in ruby and a decent tool for "end-to-end testing"
16:09:52 <ln5> the rest of the old points have been mentioned above under updates, i think
16:11:54 <weasel> (-dev is back with more ram and the module)
16:12:23 <ln5> re ldap updates, there's an email to dsa@ with a request for what to change
16:13:10 <ln5> weasel: that's so much better! :)
16:14:16 <weasel> re ldap update
16:14:20 <weasel> sponsor: Mullvad
16:14:21 <weasel> stays?
16:14:25 <ln5> ah, no
16:14:29 <weasel> ok
16:14:31 <ln5> forgot to say that
16:14:49 <ln5> TIL that to get a login session one should not just sudo -iu snapshot, but rather sudo -iu snapshot --preserve-env=SHELL -- systemd-run --user --scope --shell
16:14:57 <weasel> https://db.debian.org/machines.cgi?host=snapshot-mlm-01
16:15:25 <ln5> splendid
16:16:01 <weasel> export XDG_RUNTIME_DIR="/run/user/$(id -u)"; export DBUS_SESSION_BUS_ADDRESS="unix:path=${XDG_RUNTIME_DIR}/bus"   seems to do it for me mostly, after sudo -i
16:16:21 <ln5> i have no bus on that system
16:16:58 <ln5> and loginctl user-status refers to linus, not snapshot after a simple sudo -i
16:17:26 <weasel> does it matter?
16:17:32 <ln5> but it's not clear to me if i really need this session, only that podman stops complaining about cgroup when i do
16:17:45 <weasel> :)
16:18:01 <ln5> i still can not use cgroup-manager systemd though
16:18:28 <ln5> need to dig deeper! or just give up on understanding that particular detail :)
16:18:49 <weasel> so, anything else?
16:18:51 <ln5> #topic any other business
16:19:12 <ln5> doesn't seem like there's much more....
16:19:21 <weasel> next meeting?
16:19:23 <ln5> #topic closing
16:19:27 <ln5> next meeting 2024-10-21?
16:19:48 <h01ger> works for me
16:19:52 <weasel> ok
16:19:58 <weasel> 1600 again?
16:20:00 <ln5> 1600 UTC? or 1700?
16:20:29 <weasel> we can also do 1700Z
16:20:41 <ln5> let's do 2024-10-21 17:00 UTC
16:21:00 <ln5> #agreed next meeting 2024-10-21 17:00 UTC
16:21:13 <weasel> https://volatile.noreply.org/2024-09-23-zHUxPGZj2Zo/FD061AFC-2267-4331-A887-ADC2EA0EEA83.ics
16:21:18 <ln5> tnx
16:21:25 <ln5> ok i think we're done
16:21:31 <ln5> #endmeeting