16:00:00 <ln5> #startmeeting snapshot #7
16:00:00 <MeetBot> Meeting started Mon Aug 19 16:00:00 2024 UTC.  The chair is ln5. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:00 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:00:10 <ln5> hi all, proposed agenda: 1) status, 2) old action items, 3) rate limiting, 3) aob, 4) next meeting
16:00:57 <weasel> re 1), I don't think I managed to get much or anything done since last meeting.  plan on doing the 1gige -> 10gige switch this week, though.
16:01:20 <ln5> ok, let's do status updates
16:01:25 <ln5> #topic status updates
16:01:52 <ln5> i saw MR 11, new /mr/timestamp/ endpoint, was merged and deployed
16:02:09 <ln5> between aug 4 and 18, -mlm and lw07 together saw 729 timestamp requests
16:02:16 <weasel> nice
16:02:33 <ln5> re dev/test on dev-01, i think i need some realtime work together with a DSA person to get it to a point where it can be used as a dev/test system
16:02:42 <ln5> the two things i know is missing atm are /dev/sub*id entries for user snapshot and the slirp4netns package (see #debian-admin)
16:03:28 <ln5> and we didn't have any new actions last time iiuc so maybe go to next topic
16:03:37 <ln5> #topic action items carry over
16:03:59 <ln5> weasel already said something about 1g -> 10g above
16:04:11 <ln5> write a testsuite: no progress, keep
16:04:36 <ln5> updating sponsor links: i'm aware of web/app/snapshot/templates/{base/page.html,root/description.html,root/news.html} and LDAP (for https://db.debian.org/machines.cgi); are there more?
16:04:47 <weasel> I think that's it
16:05:27 <ln5> #action ln5 update sponsor links
16:05:46 <ln5> i'll take a stab, asking DSA for LDAP changes i suppose
16:05:59 <weasel> updating ldap should be quick and painless
16:06:10 <ln5> more old action items?
16:06:40 <ln5> weasel: re 1g->10g do you have the information you need for that?
16:06:58 <weasel> AIUI, it's on the same l2, so just moving the address should work, right?
16:07:17 <ln5> yes
16:07:28 <ln5> #action ln5 finish dev-01 setup, with help from DSA
16:07:44 <ln5> #action ln5 write a testsuite, using -dev-01
16:07:45 <weasel> and I need to work on making the oob accessible to more DSA, but nothing is blocking on that
16:08:17 <ln5> unless someone's scared of doing things w/o oob access :)
16:08:32 <ln5> #topic rate limiting
16:08:44 <weasel> I propose we drop the rate limiting in netfilter entirely
16:08:45 <ln5> weasel: what was your idea with skipping netfilter for rate limiting?
16:09:19 <weasel> and see how happy or unhappy we are after that and try to come up with other things if needed
16:09:28 <ln5> is th is on -mlm-01 only or on lw07 as well?
16:09:36 <weasel> all
16:10:09 <ln5> from my perspective that sounds good
16:10:45 <ln5> if the snapshot group can change apache config or other rate limiting things, that's good
16:11:00 <weasel> we can figure something out
16:11:00 <ln5> what's the prefered way of doing rate limiting, not using netfilter?
16:11:05 <weasel> no idea :)
16:11:14 <ln5> ok, then we figure it out
16:11:41 <ln5> should we ask DSA more, or someone else, before going ahead?
16:12:07 <weasel> we can ask #-admin for suggestions or any input they might have, but we shouldn't block on that
16:12:23 <ln5> #agreed drop the rate limiting in netfilter entirely
16:12:42 <ln5> weasel: will you be doing that?
16:12:48 <weasel> can do
16:13:20 <ln5> #action weasel ask #-admin for suggestions or input on rate limiting
16:13:28 <ln5> ok, sounds good. more on that?
16:13:55 <ln5> #topic any other business
16:14:56 <weasel> we are still waiting for the -ports import stuff with axhn.
16:15:04 <ln5> yes, correct
16:15:06 <weasel> nothing urgent, but it's still on the todo list.
16:15:20 <weasel> I think all the relevant people are aware that it's a thing too
16:15:34 <ln5> forgot to mention that, will add an action so it doesn't disappear
16:15:43 <ln5> seems everybody knows what to do, yes
16:16:14 <ln5> #action axhn -ports import
16:16:33 <ln5> ok, seems we don't have much more to say right now
16:16:47 <weasel> re netfilter and -dev: do you want to ping me thursday afternoon via signal to see if we can find a shared timeslot friday or next week?
16:17:09 <ln5> weasel: absolutely, will do!
16:17:22 <ln5> #topic closing
16:17:28 <ln5> i propose next meeting 2024-09-23
16:17:51 <weasel> might work, might not.  I can only tell closer to the date
16:18:02 <ln5> that's five weeks from now, just after the repro-build summit
16:18:19 <weasel> the time as such is such that it make it more likely it will work, though.
16:18:36 <ln5> i see. would you rather do it two weeks earlier, on the 9th?
16:19:11 <weasel> it's not clear that that's better, so let's try the 23rd
16:19:22 <ln5> good good
16:19:47 <ln5> #agreed next meeting 2024-09-23 16:00 UTC
16:19:58 <ln5> anything else before we close?
16:20:05 <weasel> no
16:20:15 <ln5> ok, thanks all
16:20:16 <ln5> #endmeeting