#debian-rust Meeting

Meeting started by werdahias at 16:58:32 UTC (full logs).

Meeting summary

  1. roll call, collecting (werdahias, 16:58:48)
  2. status updates (werdahias, 17:05:21)
    1. work for cargo 0.70 still underway (werdahias, 17:06:02)
    2. rustc 1.70 landed in unstable/testing (werdahias, 17:06:58)
    3. gtk-rs +libadwaita is on par with upstream and (mostly) regenerated code to comply with dfsg (werdahias, 17:08:29)
    4. f_g takes care of cargo 0.70 and a new debcargo release (werdahias, 17:10:45)

  3. transitions / packaging efforts / blockers (werdahias, 17:14:19)
    1. ACTION: capitol and kpcyrd take a look at hashbrown transition (werdahias, 17:21:27)
    2. work on magic-wormhole-rs is progressing slowly but steady (werdahias, 17:22:37)

  4. ITP for crates (werdahias, 17:24:51)
    1. https://salsa.debian.org/rust-team/debcargo-conf/-/merge_requests/524 (werdahias, 17:32:24)
    2. ACTION: learn which shorthands are provided by fe2o3bot (stappers_, 17:34:05)
    3. ACTION: werdahias take a look at the ITP script (werdahias, 17:34:40)

  5. miscellaneous (werdahias, 17:37:27)
    1. ACTION: stappers write a proposal for main-dev (stappers_, 17:41:27)
    2. https://bugs.debian.org/949163 (silwol, 17:45:55)
    3. https://bugs.debian.org/949163 (stappers_, 17:47:32)
    4. I plan on merging my src:cargo update to 0.70 MR and put that into experimental soonish, src:rust-cargo still needs a few deps to go through NEW (f_g, 17:49:39)
    5. ACTION: f_g explore merging of src:rust and src:cargo (werdahias, 18:00:49)
    6. ACTION: f_g file wishlist bug for discussing merge of src:cargo into src:rustc (f_g, 18:04:11)
    7. IDEA: next topic or closing the meeting (stappers_, 18:24:54)

  6. next meering (werdahias, 18:28:41)
    1. ACTION: next meet in ca. a month, date and orga tbd (werdahias, 18:37:08)
    2. ACTION: werdahias do a poll for a date (werdahias, 18:42:24)


Meeting ended at 18:44:19 UTC (full logs).

Action items

  1. capitol and kpcyrd take a look at hashbrown transition
  2. learn which shorthands are provided by fe2o3bot
  3. werdahias take a look at the ITP script
  4. stappers write a proposal for main-dev
  5. f_g explore merging of src:rust and src:cargo
  6. f_g file wishlist bug for discussing merge of src:cargo into src:rustc
  7. next meet in ca. a month, date and orga tbd
  8. werdahias do a poll for a date


Action items, by person

  1. capitol
    1. capitol and kpcyrd take a look at hashbrown transition
  2. f_g
    1. f_g explore merging of src:rust and src:cargo
    2. f_g file wishlist bug for discussing merge of src:cargo into src:rustc
  3. fe2o3bot
    1. learn which shorthands are provided by fe2o3bot
  4. werdahias
    1. werdahias take a look at the ITP script
    2. werdahias do a poll for a date
  5. UNASSIGNED
    1. stappers write a proposal for main-dev
    2. next meet in ca. a month, date and orga tbd


People present (lines said)

  1. werdahias (71)
  2. f_g (54)
  3. stappers_ (14)
  4. h01ger (13)
  5. capitol (12)
  6. fe2o3bot (8)
  7. jamessan (7)
  8. jbicha (5)
  9. MeetBot (2)
  10. silwol (1)
  11. ncts (1)


Generated by MeetBot 0.1.4.