16:37:56 <terceiro> #startmeeting
16:37:56 <MeetBot> Meeting started Fri Oct 2 16:37:56 2020 UTC. The chair is terceiro. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:37:56 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:38:43 <terceiro> #topic new rubocop-packaging check
16:40:05 <boutil[m]> do I understand well that utkarsh2102 is not completely available right now?
16:40:18 <terceiro> I don't know he didn't say anything
16:40:31 <boutil[m]> If yes, we could start with my naive and short questions about packaging workflow
16:41:29 <terceiro> #info nobody available who did any digging in the issue, let's move on
16:41:39 <terceiro> #topic ruby3.0 build failure
16:42:07 <boutil[m]> this is also a topic utkarsh wanted to raise.
16:42:46 <boutil[m]> I tried to build the 3.0 preview. I got an error about rdoc, something about a conversion from Array to Hash impossible
16:43:08 <boutil[m]> this is a recent change in rdoc, but I hadn't time to investigate more.
16:43:21 <utkarsh2102> ./miniruby -I./lib -I. -I.ext/common ./tool/runruby.rb --extout=.ext -- --disable-gems "./libexec/rdoc" --root "." --encoding=UTF-8 --all --ri --op ".ext/rdoc" --page-dir "./doc" --no-force-update "."
16:43:21 <utkarsh2102> uh-oh! RDoc had a problem:
16:43:21 <utkarsh2102> no implicit conversion of Array into Hash
16:43:36 <boutil[m]> I don't know if it is the same issue as the one utkarsh wanted to talk about
16:43:38 <boutil[m]> ah yes!
16:43:38 <utkarsh2102> cf: https://salsa.debian.org/ruby-team/ruby/-/jobs/1034610#L3765
16:45:44 <boutil[m]> ok. I just ran the command
16:45:49 <boutil[m]> ./miniruby -I./lib -I. -I.ext/common ./tool/runruby.rb --extout=.ext -- --disable-gems "./libexec/rdoc" --root "." --encoding=UTF-8 --all --ri --op ".ext/rdoc" --page-dir "./doc" --no-force-update "."
16:46:04 <boutil[m]> from a fresh checked-out exp-ruby3.0-preview branch
16:46:09 <boutil[m]> it succeeded...
16:46:29 <boutil[m]> (not doing any build before, clean tree)
16:46:47 <boutil[m]> (no. not clean of course...)
16:48:07 <boutil[m]> (but no changes in tracked file wrt the tip of the branch)
16:56:13 <terceiro> also works for me
16:56:36 <terceiro> #info terceiro and boutil are able to build just fine
16:56:54 <terceiro> #info the rdoc documenation build fails on salsa ci
16:56:55 <boutil[m]> I think it is the diff in lib/rdoc/rdoc.rb
16:57:03 <terceiro> ah
16:57:06 <boutil[m]> it asks to sort a file_list on line 321
16:57:15 <boutil[m]> but now in 3.0, this file_list is a hash
16:57:38 <boutil[m]> tyhe sort was probably added for reproducible builds
17:01:45 <boutil[m]> the gather_files function is already sorting the file_list keys, so if it is the only place that matters, we may be just fine to drop the .sort from line 321
17:02:23 <terceiro> nice, yes, that's it
17:02:39 <terceiro> #info out patch for reproducible rdoc builds is causing the failure
17:02:50 <terceiro> #action utkarsh2102 to update the patch
17:03:00 <terceiro> let's go on
17:03:51 <terceiro> #topic rubocop-packaging - Gemfile that uses gemspec
17:04:07 <terceiro> #link https://github.com/rubocop-hq/packaging-style-guide/issues/4
17:07:22 <boutil[m]> bundler is really causing us problems in some scenarios...
17:07:37 <terceiro> not bundler, but how people use bundler wrong
17:08:15 <boutil[m]> yeah
17:08:19 <kanashiro> if people are using it wrong we should try to warn them
17:09:55 <boutil[m]> by the way, are there some stats about the results of running rubocop-packaging-style-guide on code in Debian's archive?
17:09:56 <utkarsh2102> kanashiro: there's a cop already doing that.
17:09:59 <utkarsh2102> it also has an auto-corrector to fix it automatically! :D
17:10:31 <utkarsh2102> boutil: not particularly hte Debian archive
17:10:40 <utkarsh2102> but I've been sending patches a lot
17:10:48 <utkarsh2102> to upstream
17:10:51 <utkarsh2102> that are detected by rubocop-packaging
17:11:01 <utkarsh2102> interestingly, all of them got merged!
17:11:02 <kanashiro> utkarsh2102: good to know, good work :)
17:11:19 <utkarsh2102> boutil: rails and rack, both have started using rubocop-packaging :D
17:11:30 <boutil[m]> great!
17:12:27 <utkarsh2102> other 56 upstream repositories have started using rubocop-packaging in their Gemfile/gemspec -- and run them as their CI pipeline by default
17:12:34 <utkarsh2102> cf: https://github.com/utkarsh2102/rubocop-packaging/network/dependents?package_id=UGFja2FnZS0xMjY1ODQyMzQ1
17:12:51 <utkarsh2102> a list of repositories that are using rubocop-packaging^^
17:13:03 <utkarsh2102> we've got good feedback so far from the upstream
17:13:17 <boutil[m]> impressive
17:14:02 <boutil[m]> I would be curious to know how many of our patches we could drop if all upstream followed these recommendation
17:14:05 <boutil[m]> s
17:15:15 <boutil[m]> What would be the recommendation for the issue #4?
17:15:28 <boutil[m]> drop completely gemspec from the Gemfile?
17:18:08 <utkarsh2102> boutil: 3 months back, there were around 2064 patches total for all the repositories under the Debian Ruby team's salsa namespace.
17:18:22 <terceiro> we don't really have a solution, because we don't really understand the issue at depth
17:18:26 <terceiro> let's move on
17:18:31 <terceiro> boutil[m]: are you listening to the call?
17:18:38 <utkarsh2102> out of which, around ~700 can be for sure dropped with the help of rubocop-packaging.
17:18:49 <utkarsh2102> 700 at least, I think.
17:19:04 <boutil[m]> terceiro: I have no sound
17:19:07 <terceiro> ok
17:19:18 <terceiro> #topic packaging questions
17:19:25 <terceiro> boutil[m]: do you want to send a mail about that?
17:19:30 <boutil[m]> well in principle I could, but I couldn't hear anyone speaking...
17:19:44 <boutil[m]> you are all marked muted
17:20:01 <terceiro> ok there's something broken on your side then
17:20:07 <boutil[m]> about my packaging questions?
17:20:15 <terceiro> boutil[m]: no, about the call
17:20:20 <utkarsh2102> jitsi :P
17:20:31 <terceiro> my suggestion is to ask your questions in the ML
17:21:25 <terceiro> let's move on
17:21:30 <terceiro> #topic AOB
17:21:52 <boutil[m]> I am lost. Ask about jitsi call on the ML? (which one?)
17:22:08 <utkarsh2102> boutil: ask your questions about the ones that you put in the agenda on the list :D
17:22:23 <terceiro> #info kanashiro says ruby2.7 will FTBFS with the new glibc, there's already a patch from ubuntu
17:22:23 <boutil[m]> ok!
17:22:49 <terceiro> #endmeeting