#debian-reproducible Meeting

Meeting started by h01ger at 19:03:53 UTC (full logs).

Meeting summary

  1. discuss todays agenda (h01ger, 19:05:17)
  2. discuss todays agenda - and please say hi if you are there (h01ger, 19:06:23)
    1. agenda at https://wiki.debian.org/ReproducibleBuilds/Meetings (mapreri, 19:06:25)

  3. discuss meeting schedule (h01ger, 19:10:26)
    1. AGREED: lets start with a two weeks schedule, we can tune the frequency up and down as we find it useful... (h01ger, 19:12:51)
    2. if someone heavily disagrees with any #agreed statement anywhere, please speak up, we can then #agreed to disagree or discuss further or whatever. speaking up later is fine. (h01ger, 19:13:37)
    3. ACTION: deki will set up a dudl for the next meeting date _and_ a regular day+time (combined) (h01ger, 19:19:33)

  4. discuss default agenda (h01ger, 19:20:13)
  5. package/issue updates + r.a.d.o repo state (h01ger, 19:25:06)
    1. we lack a definition in a single place for usertags (h01ger, 19:28:59)
    2. there is no corelation between usertags and bugs (h01ger, 19:29:17)
    3. https://wiki.debian.org/ReproducibleBuilds/Contribute#How_to_report_bugs (mapreri, 19:31:38)

  6. package/issue updates + r.a.d.o repo state - gtk-doc.git (h01ger, 19:35:36)
    1. https://reproducible.debian.net/index_repositories.html says gtk-doc.git is unused but the sid changelog didnt tell me why (h01ger, 19:35:56)
    2. someone should file a bug against gtk-doc so our patch doesnt get lost. http://anonscm.debian.org/cgit/reproducible/gtk-doc.git/commit/?h=pu/reproducible_builds&id=aa2faf7883b528a63e5be88f6043b32c88fbc503 (h01ger, 19:38:42)
    3. gtk-doc might be fixed in sid. please someone see the irc log and follow up... (h01ger, 19:41:09)

  7. package/issue updates + r.a.d.o repo state - debbindiff (h01ger, 19:41:27)
  8. package/issue updates + r.a.d.o repo state - strip-nondeterminism (h01ger, 19:45:37)
    1. ACTION: discuss our postion about timestamps (purging vs normalizing) - also see #785742 and AGWA's mail from May 26th 2015 there (h01ger, 19:48:22)

  9. rp.d.n updates+issues (h01ger, 19:49:54)
    1. https://reproducible.debian.net/index_notify.html - please tell mapreri or myself if you want your packages to be added there (h01ger, 19:51:58)
    2. if you also think irc notifications for packages becoming reproducible, please say so. atm we believe they would be too much noise, but if you disagree, please tell us so we can change our minds (h01ger, 19:55:45)

  10. GSoC updates (h01ger, 19:56:03)
    1. https://lists.alioth.debian.org/pipermail/soc-coordination/2015-June/002473.html (h01ger, 19:59:31)
    2. Dhole is unable to reproduce umask issues on his machine. hints welcome. (h01ger, 20:05:07)
    3. maintainer are uncomfortable with these patches: (h01ger, 20:08:59)
    4. Debian#787126: nis: please make the build reproducible - https://bugs.debian.org/787126 (h01ger, 20:09:09)
    5. Debian#787122: xtrlock: please make the build reproducible - https://bugs.debian.org/787122 (h01ger, 20:09:29)

  11. any other business (h01ger, 20:11:45)
    1. upstream tar mail from Lunar^ http://article.gmane.org/gmane.linux.debian.alioth.reproducible-builds/1464 (h01ger, 20:13:49)
    2. talk by deki in karlruhe, germany, this sunday: https://entropia.de/GPN15:Reproducible_Builds (h01ger, 20:14:46)

  12. announce next meeting (h01ger, 20:15:03)
    1. AGREED: next meeting will be held when it's ready - but should be announced with due time in advance :) (h01ger, 20:17:16)


Meeting ended at 20:20:01 UTC (full logs).

Action items

  1. deki will set up a dudl for the next meeting date _and_ a regular day+time (combined)
  2. discuss our postion about timestamps (purging vs normalizing) - also see #785742 and AGWA's mail from May 26th 2015 there


Action items, by person

  1. AGWA
    1. discuss our postion about timestamps (purging vs normalizing) - also see #785742 and AGWA's mail from May 26th 2015 there
  2. deki
    1. deki will set up a dudl for the next meeting date _and_ a regular day+time (combined)


People present (lines said)

  1. h01ger (154)
  2. mapreri (68)
  3. deki (37)
  4. dkg (20)
  5. Dhole (19)
  6. helmut (8)
  7. AGWA (8)
  8. MeetBot (6)
  9. akira (6)
  10. Faux (5)
  11. lamby (3)
  12. ntyni (3)
  13. vagrantc (1)
  14. jumapico (1)


Generated by MeetBot 0.1.4.