19:01:56 <nthykier> #startmeeting
19:01:56 <MeetBot> Meeting started Wed Jun 26 19:01:56 2019 UTC. The chair is nthykier. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:56 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:02:37 <nthykier> #topic Admin
19:03:18 <nthykier> #info nthykier will send a mail to team@ to discuss whether we should move the monthly meeting to a new day/time (done; happened 2019-05-22)
19:03:45 <nthykier> #undo
19:03:45 <MeetBot> Removing item from minutes: <MeetBot.items.Info object at 0x11c52d0>
19:03:56 <nthykier> (correcting tempus)
19:04:14 <nthykier> #info nthykier had an action to send a mail to team@ to discuss whether we should move the monthly meeting to a new day/time (done; happened 2019-05-22)
19:05:08 <nthykier> #info nthkier had an action to propose some timeslots for clearning up the unblock queue (did not happen, but will be obsolete with the buster release)
19:05:41 <nthykier> elbrus: you had an action about following up on the pgoress of the installation guide
19:05:48 <nthykier> I think that happened, correctl?
19:05:49 <nthykier> correct*
19:05:51 <elbrus> correct
19:06:10 <elbrus> reply was it was releasable
19:06:12 <adsb> o/
19:07:10 <nthykier> #info elbrus had an action to follow up on the progress of the installation guide (done; the installation guide as in a releasable state)
19:07:16 <nthykier> perfect. :9
19:07:19 <nthykier> :)*
19:07:49 <nthykier> #info Previous meeting minutes are at http://meetbot.debian.net/debian-release/2019/debian-release.2019-04-24-19.04.html
19:07:57 <nthykier> I think that covers the admin part :)
19:08:43 <elbrus> ack
19:08:54 <nthykier> Next topic would be Transition, but it seems redundant 1½ weeks before the freeze
19:09:27 <nthykier> So I will skip ahead to Unblock queue unless we have something for Transition?
19:09:46 <nthykier> guess not :)
19:09:47 <nthykier> #topic Unblock queue
19:09:49 <elbrus> well, somebody started one, but I think we'll ignore it
19:10:10 <nthykier> truly, there is always an active transition somewhere :)
19:10:36 <kibi> elbrus: woops
19:10:44 * kibi waves
19:10:51 * elbrus waves back
19:11:53 <nthykier> We allegedly have about 18 unblock requests waiting for us (+1 confirmed) plus 9 in moreinfo
19:12:18 <elbrus> nearly all very recent, most after the deadline
19:12:29 <nthykier> :)
19:13:11 <elbrus> #930717 is waiting for ftp-master
19:13:23 <elbrus> or can I remove and than unblock?
19:13:34 <elbrus> or should we force?
19:13:50 <elbrus> if content is OK, not sure if I fully checked
19:14:02 <waldi> elbrus: is there an removal bug?
19:14:05 <elbrus> yes
19:14:12 <elbrus> #930717
19:14:16 <elbrus> oops
19:14:29 <elbrus> bug #930863
19:14:53 <nthykier> I think the options are waiting for ftp-master or force. Theoretically we can do it by hand, but there is a very strong preference to use the "official" methods (i.e. FTP master removal or force)
19:15:03 <elbrus> ack
19:15:10 <elbrus> will check the content tomorrow
19:15:33 <nthykier> thanks :)
19:15:40 * elbrus likes to note he didn't like the flood coming in after the deadline
19:15:51 <elbrus> but he expected that :(
19:16:14 <kibi> good^Wappropriate expectation
19:16:16 <nthykier> We cannot fix people :) But we can postpone them for the first point release of buster where they make sense
19:16:43 <elbrus> sure
19:16:44 <nthykier> them here being the unblock requests (we cannot postpone people either)
19:17:18 <elbrus> :)
19:17:32 <waldi> elbrus: gone
19:17:37 <elbrus> \o/
19:17:40 <nthykier> waldi: thanks :)
19:17:41 <elbrus> thanks
19:18:55 <nthykier> but mostly, it seems that we managed to keep the unblock queue under control. I think that is very positive - thanks to all you :) Notably elbrus and ivodd for handling rejections or more controversial requests :)
19:19:01 <elbrus> I also like to note gnupg2
19:19:12 <nthykier> elbrus: ack, go ahead :)
19:19:22 <nthykier> #931126
19:19:28 <elbrus> no unblock yet, but there's an RC open
19:19:47 <elbrus> didn't look at the details but the package is well known and important to us
19:20:00 <elbrus> #928963
19:20:03 <nthykier> #undo
19:20:03 <MeetBot> Removing item from minutes: <MeetBot.items.Topic object at 0x1362f10>
19:20:09 <nthykier> (sorry, had the wrong bug)
19:20:10 <kibi> from past experience, gnupg* likes to come with many upstream bugfixes that are supposed to be safe but we somtimes get some surprises…
19:20:24 <kibi> (plus it's usually late, which means we tend to be itchy about updating it…)
19:20:45 <elbrus> ok, so let's check carefully if the bug can be ignored for the first round of buster
19:20:46 <nthykier> #redo
19:21:23 * elbrus has more time tomorrow morning
19:21:38 <ansgar> Does Debian still have 64bit big endian? I thought there was only little endian left?
19:21:57 <kilobyte> s390x
19:22:03 <nthykier> elbrus: thanks :)
19:22:22 <ansgar> Ah, somehow thought s390x was modern and little endian as well.
19:22:33 <nthykier> (assuming you have time to look at it - I know I probably will not)
19:23:31 <elbrus> ack
19:23:58 <nthykier> Any other items for the unblock queue? Next item would have bene "Freeze progress" but I think that is covered as well with the release annoucement?
19:24:49 <elbrus> nothing worth mentioning here right now
19:25:18 <nthykier> The item after "Freeze progress" is """ ANBE asked "obsolete conffiles after stretch->buster upgrades" """ but that seems obsolete too (with the release being in 1½ week, it is defacto "ignore")
19:25:51 <nthykier> So the next item would be "AOB"
19:26:07 <nthykier> #topic AOB
19:26:13 <nthykier> Any AOB ? :)
19:26:21 <ansgar> Do we want InRelease for buster?
19:26:43 <nthykier> adsb: ^
19:26:58 <nthykier> (I presume you might have an answer for that)
19:27:22 <nthykier> ansgar: could you expand on the question (pros / cons of InRelease)?
19:28:13 <ginggs> ansgar: big-endian is modern :)
19:28:18 <adsb> if we can reliably combine the sigs, I guess it would be OK
19:28:29 <ansgar> Pro: It is just one file and cannot get out of sync; we have InRelease for other suites (consistency)
19:28:30 <adsb> but I will also poke jcristau in case I missed any other cons
19:28:43 <helmut> cons: parsing inline-signed gpg is hard to get right.
19:28:49 <adsb> jcristau: consider yourself poked ;)
19:29:09 <ansgar> Con: We didn't manage to merge signatures from ftp team / stable release managers. But I spend some time and gpg could be beaten to merge them.
19:29:16 <ansgar> So the con falls away ;-)
19:29:32 <adsb> afair the historical reason we didnt is that inline-signing a file with 2 keys when they are not both available in the same gpg invocation is... tough
19:31:06 <nthykier> I am not sure if jcristau is around. I think we will leave the question open for now and have it answered after the meeting :)
19:31:16 <adsb> yes, that was my intent
19:31:19 <elbrus> other AOB: golang build ordering script by Thorsten Alteholz; did anybody look at it or should we leave this to the security team?
19:31:29 <adsb> we dont need the answer right now, just to have the discussion
19:31:40 <adsb> (eating, will catch back up in a few minutes if need be)
19:31:44 <elbrus> Message-ID: <alpine.DEB.2.20.1906082337400.7570@jupiter.server.alteholz.net>
19:32:18 <nthykier> elbrus: I did not see it / know about it
19:32:48 <elbrus> https://lists.debian.org/msgid-search/alpine.DEB.2.20.1906082337400.7570@jupiter.server.alteholz.net
19:33:35 <nthykier> I think it is a promising start but the security team will need to be able to use it
19:34:03 <elbrus> ack, but I don't intent to follow up
19:34:10 <nthykier> IOW, I think the security team should respond to it
19:34:18 <elbrus> they were not in CC though
19:34:31 <elbrus> oops, they were
19:34:54 <elbrus> I'll ping carnil and jmm_ about it ^
19:34:57 <nthykier> elbrus: ack, we should probably let them know that we assume that mail is intended to them
19:35:01 <nthykier> perfect
19:35:14 <nthykier> #action elbrus to ping carnil and jmm_ about https://lists.debian.org/msgid-search/alpine.DEB.2.20.1906082337400.7570@jupiter.server.alteholz.net
19:35:39 <nthykier> ... which may just have happed ... >.>
19:35:44 <elbrus> full ack
19:36:03 <nthykier> Moving on :)
19:36:12 <nthykier> Any other AOB ? :)
19:36:37 <kibi> just a quick word: d-i seems on good tracks
19:36:50 <elbrus> \o/
19:36:52 <kibi> (a release may just have happened)
19:37:18 <nthykier> #info A new version of d-i was released today
19:37:21 <nthykier> \o/
19:37:26 <nthykier> kibi: excellent work :)
19:37:27 <kibi> as discussed on #-boot earlier, Sledge has more bugfixes, but some will wait until r1 or later.
19:37:56 <nthykier> :)
19:37:59 <kibi> (non-RC according to him, and at some point a line has to be drawn, but you know the drill)
19:38:04 * Sledge is summoned
19:38:31 * Sledge has the traditional late debian-cd unblock coming soon, of course... :-)
19:38:33 <kibi> I think we have an RC still, against base-installer
19:39:07 <kibi> I don't have anything else off the top of my hat; besides possibly some updates to the installation guide to point to the LUKS2 vs. /boot doc that cryptsetup maintainers have added.
19:39:45 <kibi> and as usual you know where to find me if you see something fishy regarding some RC bugs in the d-i area ;)
19:40:26 <elbrus> #929667 concerned?
19:40:39 <kibi> that's the one I was referring to
19:40:50 <elbrus> ok
19:41:15 <kibi> hopefully just a matter of git reverting a commit and double checking; it was mentioned by bwh but the d-i upload was already happening and I didn't want to wait
19:41:44 <kibi> current plan is performing an extra d-i upload somewhen around the “testing frozen” beginning, with that and possibly whatever stuff was unblocked by then
19:41:59 <kibi> should be an RC3-but-hopefully-final release as far as d-i goes
19:42:33 <Sledge> +1
19:42:34 <nthykier> #info We are expecting one more d-i release for buster
19:43:07 * Sledge would love a last linux upload too, don't know if bwh is up for it
19:43:16 <kibi> depending when that happens, it might make sense to announce it as usual, but mentioning that the real release and installation images for r0 are coming up a couple of days later
19:43:35 <kibi> I think we've done that last time
19:44:21 <kibi> This will be the last release candidate, and the next upload of the
19:44:22 <kibi> debian-installer package will be used for the final Debian 9.0 build,
19:44:22 <kibi> without a separate announcement for the installer.
19:44:29 <kibi> → https://lists.debian.org/debian-devel-announce/2017/06/msg00003.html
19:44:40 <nthykier> :)
19:45:35 <kibi> I will likely keep both -boot and -release posted any way; was just rushing RC 2 out to make sure we have a release out that could be used in the worst case scenario, and that would allow us to catch possible late regressions
19:45:51 <nthykier> ack - I appreciate that :)
19:46:49 <nthykier> Any final remarks or AOB before I move on to "Next meeting"? :)
19:46:55 <elbrus> AOB question, will we be marking all RC bugs? ie. buster-will-remove buster-can-defer, etc
19:47:36 <nthykier> ... and on that bomb shell, lets move on to ... ;)
19:47:47 <nthykier> seriously though, good question.
19:48:23 <elbrus> e.g. I marked dhelp as will-remove, but it got a fix yesterday
19:49:11 <elbrus> (not wanting to discuss dhelp here, but as an example)
19:50:00 <elbrus> am I correct in saying that everything without an unblock we want such a tag?
19:50:20 <elbrus> or is everything untagged -defer by default?
19:50:23 <elbrus> or somethign
19:50:24 <elbrus> *
19:51:21 <elbrus> if no answer comes, let's continue :)
19:51:32 <nthykier> Historically, we have been tagging remaining RC bugs as -ignore / -can-defer or removed them. I presume we will end up doing something similar this release as well once we sorted out the remaining unblock request :)
19:51:36 <nthykier> requsts*
19:51:37 <nthykier> ...
19:51:52 <nthykier> requests*
19:52:08 <elbrus> ack
19:52:33 <nthykier> Closing...
19:52:40 <nthykier> #topic Next meeting
19:54:05 <nthykier> As mentioned, I sent out an enquiry about whether we should move the meeting time. There was one reply (thanks elbrus!) and accordingly I have decided to keep the current timeslot for now.
19:54:23 <nthykier> If you want a new timeslot, feel free to answer my mail from May about this :)
19:54:31 <nthykier> #info Next meeting is 24th July at 19:00 UTC (import into your calendar via https://release.debian.org/release-calendar.ics)
19:54:58 <nthykier> at which point we will have released Buster and recovered if everything goes well!
19:55:03 <nthykier> #endmeeting