#debian-qa Meeting

Meeting started by h01ger at 19:02:15 UTC (full logs).

Meeting summary

  1. jenkins.debian.org monthly meeting - please say hi if you intend to participate - else thanks for being able to use this channel for a while :) (h01ger, 19:03:03)
  2. jenkins.d.n status (h01ger, 19:05:56)
  3. jenkins.d.n status - OOMs and how to fix/address them (h01ger, 19:09:41)
    1. AGREED: jenkins initscript (hosts/jenkins/etc/init.d/jenkins) should be modified to put heapdumps into /var/lib/jenkins/userContent/OOM/ and bin/maintenance.sh should them clean up after three days. the initscipt should also send mail to inform (more) people about restarts (h01ger, 19:16:00)
    2. the dumps could contain passwords so maybe better put the dumps in …userContent/OOMs/$(pwgen -s 16) and mail those urls to specific people (h01ger, 19:20:33)
    3. logs should be included near the heap dumps in the export (mapreri, 19:21:52)

  4. jenkins.d.o migration - next steps (h01ger, 19:31:57)
    1. so status is: we have jenkins installed, we can login into the UI and we have plugins installed (h01ger, 19:32:33)
    2. next step is to update update_jdn.sh to deploy scripts+configs on jenkins.d.o too (to a changed path, /srv/jenkins.debian.org/ so we need to deal with that…) and to tell us (to send patches to DSA) which packages are missing (h01ger, 19:40:24)
    3. after that, we can start with running 1 job on jenkins.d.o: self_maintenance (h01ger, 19:41:47)

  5. AOB (h01ger, 19:46:13)
    1. the logparser plugin has been removed from all 88 reproducible build jobs (which daily run ~6000 times) (h01ger, 19:52:15)
    2. many thanks to http://profitbricks.com for supporting jenkins.debian.net since 2012 - today with more than 120 cores and >300 GB RAM (h01ger, 19:58:48)


Meeting ended at 19:59:55 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. h01ger (76)
  2. mapreri (54)
  3. tnnn (22)
  4. helmut (10)
  5. fil (10)
  6. StevenC99_ (3)
  7. MeetBot (2)
  8. KGB-0 (2)
  9. KGB-2 (1)
  10. jcristau (1)


Generated by MeetBot 0.1.4.