12:07:00 <zack> #startmeeting
12:07:00 <MeetBot> Meeting started Fri Jan 23 12:07:00 2015 UTC.  The chair is zack. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:07:00 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
12:07:04 <zack> #chair matthieucan
12:07:04 <MeetBot> Current chairs: matthieucan zack
12:07:14 <zack> #topic debsources OPW - next meeting
12:07:25 <zack> so, I've a conflict next week, as I'll be at FOSDEM
12:07:34 <zack> matthieucan: will you be around for the weekly meeting, or shall we reschedule?
12:07:49 <matthieucan> I'll be around!
12:08:04 <zack> great!
12:08:09 <zack> sophiejjj: next week usual time is good for you?
12:08:14 <sophiejjj> sure.
12:08:21 <sophiejjj> FOSDEM cool.
12:08:28 <zack> #agreed next meeting next Fri, usual time, matthieucan & sophiejjj only
12:08:31 <zack> sophiejjj: it is ;)
12:08:38 <zack> #topic debsources OPW - weekly review
12:09:01 <zack> so, first item is test coverage
12:09:06 <zack> no progress on that, right?
12:09:25 <sophiejjj> dunno what's the coverage now.
12:09:36 <sophiejjj> but should be up a bit since I add some extra webstuff
12:09:49 <zack> right, please move to next week
12:09:52 <sophiejjj> (but I als add up some code, though)
12:09:56 <sophiejjj> done.
12:09:58 <zack> it would be useful, for next time, to do the computation before the meeting
12:10:03 <zack> so that we know where we stand, ok?
12:10:06 <sophiejjj> yes.
12:10:17 <zack> let's pick the last item of the list, since it's fresh :)
12:10:22 <zack> #761119 - suite-based navigation
12:10:25 <zack> that is done, right?
12:10:37 <sophiejjj> hmm. did you see my last mail?
12:10:42 <matthieucan> running on sources.d.n?
12:10:49 <zack> I've seen there *is* a last mail of yours
12:10:53 <zack> but I haven't yet looked at it
12:10:56 <zack> matthieucan: yes, I've deployed it
12:11:01 <matthieucan> cool :)
12:11:01 <sophiejjj> matthieucan: suite navigation
12:11:20 <zack> matthieucan: do you think you can review/apply the last patch from sophiejjj? I'll be busy for the rest of the day
12:11:37 <matthieucan> not before tonight
12:11:40 <matthieucan> but yes
12:11:49 <zack> ok, thanks, it's not super-urgent
12:11:56 <zack> just wanted to know if I had to keep it on my TODO list or not ;)
12:12:06 <zack> sophiejjj: how about the other 2 small feature requests by matthieucan?
12:12:11 <zack> do you want to work on those?
12:12:18 <sophiejjj> I was thinking, it's not that necessary.
12:12:41 <sophiejjj> since the suite? is shown in the url bar, and it must be triggered by the user.
12:12:41 <zack> yeah, I agree, it's in the "would be nice too" camp, but probably nothing more than that
12:13:00 <matthieucan> what about the no results situation?
12:13:22 <zack> matthieucan: it will be the same of searching 'asfgsafaafs' as package name, no?
12:14:00 <zack> oh, I think I see what you mean
12:14:21 <zack> in fact, I think *one* feature request would be enough
12:14:39 <sophiejjj> zack: the page is different.
12:14:42 <zack> we should just add below "Search: asfgjsahfgfsa" the mention "in suite: ..." if ?suite=... has been used
12:14:45 <matthieucan> zack: for things like http://sources.debian.net/src/libcaca/?suite=yo
12:15:11 <zack> matthieucan: yeah, same in that case, a single line after "Package" saying in "suite: ..." would be enough I think
12:15:20 <zack> so that the user will know that there are no packages *in the current suite*
12:15:21 <sophiejjj> so a simple line "no corresponding version found in suite yo" ?
12:15:27 <matthieucan> agreed!
12:15:36 <zack> sophiejjj: no, don't bother with checking if the result is empty
12:15:53 <zack> just add below the title a line saying "in suite..." if ?suite=... has been used
12:16:08 <sophiejjj> oh.
12:16:15 <sophiejjj> a simple modification.
12:16:40 <zack> yes, but in a few templates: /search, /srv, and /prefix I think
12:16:53 <sophiejjj> srv is ?
12:16:58 <zack> sorry: I meant /src
12:17:10 <sophiejjj> put it below the package name?
12:17:16 <zack> yes
12:17:31 <zack> e.g., at http://sources.debian.net/src/ocaml/, just add a line after "Package: ocaml"
12:17:40 <zack> well, only *if* ?suite=.. is being used
12:17:49 <zack> sophiejjj: make sense?
12:17:52 <sophiejjj> got it.
12:17:55 <KGB-0> 03Andreas Beckmann 05develop 8dd6507 06piuparts 10instances/piuparts.conf.anbe p.conf.anbe: [jessie-rcmd] --install-recommends
12:17:55 <KGB-0> 03Andreas Beckmann 05develop 4b54213 06piuparts 10instances/piuparts.conf.anbe p.conf.anbe: [stretch-rcmd] --install-recommends
12:17:55 <KGB-0> 03Andreas Beckmann 05develop 38c7df7 06piuparts 10instances/piuparts.conf.anbe p.conf.anbe: reorder flags for consistency
12:17:55 <KGB-0> 03Andreas Beckmann 05develop b25741e 06piuparts 10piuparts.py p: fix missing commas in recently added ignored_files
12:17:58 <KGB-0> 03Andreas Beckmann 05develop f5c0e58 06piuparts 10custom-scripts/scripts/pre_distupgrade_exceptions add distupgrade exception for dnscache-run
12:18:01 <zack> ok, please add a card for that for next week
12:18:02 <KGB-0> 03Andreas Beckmann 05develop 9d0ab95 06piuparts 10instances/piuparts.conf.anbe p.conf.anbe: [sid-plus] (failing on leftovers)
12:18:04 <KGB-0> 03Andreas Beckmann 05develop e3274c2 06piuparts 10instances/piuparts.conf.anbe p.conf.anbe: [wheezy2jessie-rcmd_i386]
12:18:07 <KGB-0> 03Andreas Beckmann 05develop 0719de5 06piuparts 10piuparts.py p: Chroot: add mkdir_p(path) method
12:18:11 <KGB-0> 03Andreas Beckmann 05develop 161ce76 06piuparts 10TODO 10debian/changelog 10piuparts.py p: mount /dev/pts into the chroot
12:18:14 <KGB-0> 03Andreas Beckmann 05develop ed44050 06piuparts 10debian/changelog 10piuparts.py p: fix schroot usage of chroot names without colon
12:18:16 <zack> (git notification flood!)
12:18:17 <KGB-0> 03Andreas Beckmann 05develop 6275963 06piuparts 10debian/changelog 10master-bin/generate_daily_report.in generate_daily_report: remove obsolete .html files after 30 days
12:18:30 <matthieucan> work is being done :D
12:18:33 <zack> perfect, thanks
12:18:41 <sophiejjj> done.
12:18:43 <zack> sophiejjj: also, please archive the suite-navigation card, it's done
12:18:44 <zack> \o/
12:19:07 <sophiejjj> done
12:19:11 <zack> next item, basic structure for copyright.d.n
12:19:14 <zack> any progress there?
12:19:16 <matthieucan> well done for that patch sophiejjj!
12:19:31 * sophiejjj has not done anything on copy.d.n yet.
12:19:38 <sophiejjj> but I think I should focus on that.
12:19:45 <zack> yes, agreed
12:19:56 <zack> sophiejjj: so, was it only a matter of time, or did you encounter some blocker?
12:20:17 <sophiejjj> currently nothing technical blocks me
12:20:32 <sophiejjj> should I have any question, I will consult you two on irc.
12:20:35 <sophiejjj> or email.
12:20:38 <zack> ok, perfect
12:20:45 <zack> so I think you should just move the 3 items from last week to the next one
12:20:49 <zack> as they were all about copyright.d.n
12:20:59 <sophiejjj> moved.
12:21:16 <zack> cool, I think they should be enough as a work plan for next week, right?
12:21:21 <sophiejjj> yes.
12:21:30 <sophiejjj> and I hope it could be archived next week.
12:21:39 <zack> *fingers crossed* ;)
12:21:44 <sophiejjj> lol.
12:21:45 <zack> #topic debsources opw - misc
12:21:56 <zack> anything else you'd like to discuss while we're all here?
12:22:16 <matthieucan> sophiejjj: what about a new blog post to present the recent patches you did?
12:22:17 <sophiejjj> currently nothing
12:22:22 <sophiejjj> oh.
12:22:24 <zack> matthieucan: ah, good point!
12:22:25 <sophiejjj> got it.
12:22:57 <zack> card added ;)
12:22:58 <matthieucan> great :)
12:23:19 <zack> anything else?
12:23:22 <sophiejjj> nothing.
12:23:39 <zack> ok, let's adjourn then
12:23:43 <zack> #endmeeting