17:05:35 <jipege1> #startmeeting
17:05:35 <MeetBot> Meeting started Mon Dec  2 17:05:35 2024 UTC.  The chair is jipege1. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:05:35 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:05:47 <highvoltage> jipege1: great, thanks!
17:05:55 <AndreasTille[m]> Andreas waving from Wernigerode.
17:06:13 <disaster2life> o/
17:06:23 <jipege1> Hi all, every one say hello to the recording
17:06:40 <AnupaAnnJoseph[m]> Hello o/
17:06:50 <disaster2life> hi anupa!
17:06:52 <jbr> hello
17:07:25 <AnupaAnnJoseph[m]> disaster2life: Hi o/
17:09:44 <jipege1> #topic Start the habit of bi-monthly team meetings
17:09:47 <disaster2life> before we begin, just wanted to ask, was there an email about this?
17:10:04 <disaster2life> oop- guess we are starting
17:10:20 <AnupaAnnJoseph[m]> disaster2life: yes
17:10:30 <AnupaAnnJoseph[m]> +1 for team meetings.
17:10:57 <disaster2life> weird, I don't remember getting an email, will have ot figure that out
17:10:59 <jipege1> https://salsa.debian.org/publicity-team/todo/-/blob/main/Meetings/December2024Meeting.md?ref_type=heads
17:11:04 <disaster2life> but yes mroe meetings good
17:11:20 <jbr> https://lists.debian.org/debian-publicity/2024/12/msg00000.html
17:11:24 <AnupaAnnJoseph[m]> https://lists.debian.org/debian-publicity/2024/12/msg00000.html
17:12:35 <disaster2life> whoa I seem to have just gotten that mail, think my email provider is being funky :/
17:12:42 <jipege1> So we can try to start by setting the week of the next meeting in January
17:14:28 <AnupaAnnJoseph[m]> Maybe second week?
17:14:29 <disaster2life> meeting within the first week of january? have a thursday and friday I think
17:14:45 <AnupaAnnJoseph[m]> 12.9 release on Jan 11th.
17:14:51 <jipege1> we could try at the begining of the week before the next point release
17:15:30 <disaster2life> that seems preferable
17:15:36 <jipege1> 6-8 January
17:15:36 <AnupaAnnJoseph[m]> +1
17:16:14 <disaster2life> have my last final on the 7th, so preferably 7th or 8th from me, though 6th works too
17:17:22 <AndreasTille[m]> I'd also prefer 7th or 8th.  6th is local holiday and I might come back from travel quite late.  (But please don't mind much about me!)
17:17:26 <jipege1> So we could fololow collectively the jobs our team needs to do for a point release
17:18:03 <AnupaAnnJoseph[m]> Yes!
17:18:38 <disaster2life> I think that follows into the later part of the agenda
17:18:42 <jipege1> so I'll propose a poll for this two days
17:19:19 <jipege1> any comment?
17:19:21 <disaster2life> two days, and should we decide the second meeting for the month inthat meeting?
17:20:21 <jipege1> for december ?
17:20:44 <disaster2life> wait bi monthly as in two meetings a month yes?
17:21:26 <jipege1> We can try
17:21:39 <disaster2life> okay
17:22:51 <disaster2life> but yeah meeting on 7th/8th is good then from me
17:22:55 <AnupaAnnJoseph[m]> jipege1: +1 for meeting poll with dates Jan 7 and 8.
17:23:20 <jipege1> but first, in think we can tray to do one meeting every month actually
17:23:38 <AnupaAnnJoseph[m]> Yes :)
17:23:55 <disaster2life> ah yes, I just assumed we were sure of bi monthly meetings because of the agenda name
17:24:20 <jipege1> #action jpege meeting poll Jan 7 and 8
17:26:08 <jipege1> #topic Review of the tasks assigned to the team
17:29:40 <jipege1> I don't really who in the team know the procedures for the tasks of our team. who is able to carry out these tasks like send micronews or bits to the publicity repository
17:30:58 <DonaldNorwood[m]> What do you mean?
17:31:09 <disaster2life> As in people who have access to the machine to be able to publish micronews and other news channels? I think Anupa and Donald have access?
17:32:54 <AnupaAnnJoseph[m]> I can push micronews and bits posts to repo and jipege1 showed me how to publish micronews during MiniDebConf Toulouse. I haven't tried publishing myself yet.
17:34:06 <AnupaAnnJoseph[m]> I believe Joost also has access to do that.
17:34:35 <disaster2life> I believe so yes, I have heard from 4 people about access
17:35:32 <jipege1> Yes, only delegate can publish the Micronews and the Bists and send the announce and News. But we are also in charge of maintening Debian timeline, and I don't knos how it works.
17:36:12 <AnupaAnnJoseph[m]> For release announcements?
17:36:25 <DonaldNorwood[m]> The timeline just sits under us. Similar to the listmail moderation. Anyone can do it but our team are the contact people for the tasks. :)
17:36:44 <AndreasTille[m]> If it make sense to delegate more people I'm open to extend the delegation.  I think the delegation of phls is pending anyway.  Just wanted to clarify whether there is someone else.
17:37:01 <DonaldNorwood[m]> Charles
17:37:09 <disaster2life> are we talking about timeline.debian.net?
17:37:59 <jipege1> Yes. I feed the last yeas on the repo, but the new data are not on line
17:39:15 <DonaldNorwood[m]> You mean the process?
17:39:32 <jipege1> exactly
17:39:52 <disaster2life> yeah the first time I am hearing of this, seems cool
17:40:06 <DonaldNorwood[m]> I'm not positive on that to be honest with you, someone did work on it some time ago but I do not know what/how it was done other than adding things manually.
17:41:32 <jipege1> We have to ask to our predecessor
17:41:34 <DonaldNorwood[m]> larjona (IRC): Has a lot of work done in that repo, perhaps ask her.
17:42:07 <DonaldNorwood[m]> I think Paul also.
17:43:19 <jipege1> I think we could try to have a "Sprint" online to learn the procedures on every of our media and complet the documentation
17:43:55 <DonaldNorwood[m]> I'd concern if that would spread us too thin.
17:44:20 <disaster2life> that would be cool, writing out documentation for all the stuff is probably very necessary
17:44:32 <DonaldNorwood[m]> Indeed.
17:45:56 <jipege1> A part is done but must be perhaps more explicit
17:46:04 <disaster2life> spread us too thin in what sense? too many projects we are dealing with?
17:46:08 <AndreasTille[m]> jipege1: Having a sprint sounds very sensible.
17:46:37 <Charles[m]> (sorry for the delay, timezone confusion) I'm here now
17:46:55 <AnupaAnnJoseph[m]> jipege1: +1 for the online sprint.
17:47:18 <jipege1> We try to do that  during the second part of January
17:47:35 <DonaldNorwood[m]> disaster2life: Yes. The idea is a good idea but despite the team size we don't have that many hands on keyboards to start another task. Our wiki for example needs updating as well. So I'd be onboard with it but just mention it may take away from more critical 'shiny' things.
17:47:35 <AnupaAnnJoseph[m]> Ok
17:47:53 <disaster2life> I would hopefully have time then, should be around the start of the new semester
17:48:58 <disaster2life> DonaldNorwood[m]: that's reasonable, I would hope we could just ensure everything under is documented enough where someone could pick it up, timeline doesn't even seem to have a readme file
17:49:14 <disaster2life> but yes wiki updation is also very key
17:50:01 <jipege1> DonaldNorwood[m]:  you are right but we have choices to make
17:50:19 <DonaldNorwood[m]> We can do both.
17:50:24 <jipege1> and to make them collectivelly
17:51:00 <DonaldNorwood[m]> Add it to the task list, but I would cement the task list completion which gives us ample time/people power to fix all the other stuff that needs to be attended to.
17:52:45 <jipege1> So maybe it is time to talk about our projects for 2025
17:53:11 <disaster2life> think so, action to have a sprint and updating the task list?
17:53:39 <Charles[m]> +1 too for online sprint!
17:54:44 <jipege1> action: organize a sprint online for the second part of january
17:55:01 <jipege1> action: organize a sprint online for the second part of january (jipege)
17:55:59 <jipege1> #topic Project(s) for 2025!
17:56:31 <jipege1> # action: organize a sprint online for the second part of january (jipege)
17:56:36 <Charles[m]> who wants to start this one?
17:58:29 <jipege1> I think we have to start publishing DPN again
17:59:37 <disaster2life> think DonaldNorwood[m] was working on a new direction for the DPN again yes?
17:59:48 <DonaldNorwood[m]> disaster2life (IRC): Yes.
17:59:52 <Charles[m]> DPN are general news about the project, right? Not only technical stuff that goes into developer news
18:00:08 <AndreasTille[m]> DPN would be great
18:00:57 <DonaldNorwood[m]> The DPN does general news, but the larger issue is that we tend to publish all of the news first via micronews or bits, so by the time the DPN is written it is just repeating what people have already ready. Having new items in the middle of things that were already seen would have the new items ignored.
18:01:39 <DonaldNorwood[m]> I was thinking of shifting it to an archive only issue which points back to the stuff we have covered, this is seen in the last few DPNS which share micronews links for prior coverage.
18:02:46 <jipege1> I think we could start preparing the next release for the news year?
18:02:47 <DonaldNorwood[m]> The other solution (cycling the same news twice) is to start to segregate some news items for DPN/DPB only.
18:03:56 <DonaldNorwood[m]> Project news would fit perfectly into that category, LTS updates, and other things that are newsworthy but too detailed for a bits post.
18:04:18 <Charles[m]> I think both could work
18:05:13 <disaster2life> I think both could work, but I also think that moving regular news items like LTS updates to DPN might be better?
18:06:03 <jipege1> I think that if we want to amend or improve the content of the DPN, the best way is to start a collective discussion on the debian publicity list
18:07:19 <Charles[m]> like the idea jipege1!
18:07:21 <DonaldNorwood[m]> The last change we did was the DPB which also fell to the wayside do to lack of material or firm direction. Perhaps assigning items to it as Charles and disaster2life (IRC) are saying (if I am correct) would work.
18:08:03 <AndreasTille[m]> Sorry, what is DPB?
18:08:29 <DonaldNorwood[m]> Debian Project Bits, which was supposed to be a DPN with a faster turnaround time.
18:08:54 <AndreasTille[m]> Thanks.
18:09:06 <jipege1> Its aborted clone of DPN on Bits (DEbian project Bits)
18:09:12 <DonaldNorwood[m]> https://bits.debian.org/2023/08/debian-project-bits1.html
18:11:15 <disaster2life> it might be my perspective of how I consume our news items, but I think bits and micronews are more of the stuff you read on social media from others discussiing it, while DPN (not that I experienced posts) is more the actual paper with a lot more meat to it?
18:12:58 <DonaldNorwood[m]> I think that is far. Some difficulty is the assumption that people do not want to read the news, so this could all be in error. Some prefer newletters to social media and other feeds. Though it seems overall that in publishing circles traditional news sources like newpapers and newsletters have been phased out.
18:13:25 <DonaldNorwood[m]> We don't have the metrics to really say who is reading the DPN other than the list stats, which we could review to make a better and informed decision.
18:13:34 <DonaldNorwood[m]> s/far/fair
18:13:36 <jipege1> The best thing is to take the time to read a sample of DPNs from the last 10 years to see the evolution that has taken place.
18:14:29 <disaster2life> that is true, and I think it would be a good idea to spend some time reading and analysing the feel of DPN more? I could use familiarising to it at least
18:14:32 <Charles[m]> I can help reading some issues of DPN from the past and come up with a short report on how it has evolve
18:15:03 <Charles[m]> maybe disaster2life and I could do it
18:15:10 <AndreasTille[m]> jipege1: I like the idea to review DPN
18:15:34 <jipege1> We can then start thinkWe can then start thinking about what we want.ing about what we want.
18:15:57 <jipege1> It's better if everyone It's better if everyone can get an ideacan get an idea
18:16:01 <disaster2life> I will mostly have a lot of time this month inbetween my finals, I would love to put that time to good use so yes I would love to help!
18:16:42 <jipege1> It's better if everyone can get an idea
18:17:41 <Charles[m]> after we read some old issues, we can start the thread on debian-publicity to define the format of the new DPN
18:17:53 <jipege1> ok
18:18:47 <disaster2life> a matrix thread?
18:19:24 <Charles[m]> let's set a deadline for starting the discussion on the mailing list? Maybe next meeting or before the january sprint
18:20:12 <Charles[m]> I was talking about debian-publicity@lists.debian.org :-)
18:20:24 <disaster2life> oh- yes good! makes sense
18:20:38 <jipege1> I prefer emails because it' possible to develop the points
18:20:51 <disaster2life> but yeah probably better to start a discussion on it as soon as we could?
18:22:09 <jipege1> Just read before some issues beetween 2015-2020
18:23:34 <jipege1> the time advances so we could act that and go on?
18:23:41 <Charles[m]> I've never read a DPN, so I need to catch up
18:23:51 <disaster2life> I think yeah, we should act that
18:23:55 <Charles[m]> yes!
18:24:48 <jipege1> It is a great idea :)
18:26:03 <Charles[m]> not sure how to write the action though
18:26:57 <disaster2life> "start to review and discuss the format of DPN"
18:27:03 <disaster2life> ?
18:27:04 <jipege1> #action Read some DPN and initiate reflection on the evolution of dpn  (Publicity Team)
18:27:32 <Charles[m]> nice!
18:27:36 <disaster2life> yay!
18:27:53 <disaster2life> point releases next?
18:29:11 <Charles[m]> yes
18:29:24 <jipege1> #topic Review procedures for monitoring point release announcements to clarify our relationship with webwml teams
18:32:36 <jipege1> I think we need to get back to a more cooperative operation with the webwml. We have to rely on the webwml team to accomplish the tasks that concern the website server.
18:34:17 <Charles[m]> you mean publishing the announcement and adding the new point release in all places of the main website?
18:35:21 <jipege1> This is what we did for the last two point releases and it worked very well. So I suggest we act this.
18:35:53 <disaster2life> don't really have anything to add, but a more cooperative relationship sounds good
18:36:59 <Charles[m]> agree
18:38:16 <jipege1> Charles[m]: yes : our tast is to prepare stuff (announce, amend some file in the release directory in the repo) and uplaod them on time.
18:39:11 <jipege1> s/tast/task
18:39:52 <jipege1> any comment?
18:39:53 <Charles[m]> ack
18:40:32 <AndreasTille[m]> ACK
18:40:41 <disaster2life> ack
18:41:31 <jipege1> the action could be "contact the webwml team to explicit the procedure"
18:41:51 <AnupaAnnJoseph[m]> ack
18:42:34 <Charles[m]> +1
18:43:00 <AndreasTille[m]> ack
18:43:34 <jipege1> #action "contact the webwml team to explicit the procedure"
18:44:04 <jipege1> #action contact the webwml team to explicit the procedure (jipege)
18:44:38 <disaster2life> thats good
18:45:14 <jipege1> #topic solve the problem of double posting from micronews on some feeds: how to have a post about Bits publication on Micronews
18:47:49 <Charles[m]> sorry, I don't have much context on this one
18:48:47 <jipege1> When a Bits post is published, a message (the title of the post) is sent automatically to the social media but not to Debian Micronews. And  often the micronews could be different from the title of the post on Bits
18:50:04 <jipege1> And when we write the message for the Debian Micronews, it is also relayed to social media
18:50:08 <Charles[m]> I see, and if we do a micronews, it's basically a double post
18:50:47 <DonaldNorwood[m]> Different audiences perhaps?
18:51:37 <jipege1> But the same social media
18:52:30 <DonaldNorwood[m]> I do not think I am following.
18:52:58 <Charles[m]> (I'm checking the messages on mastodon to understand what is published on a bits post)
18:54:21 <DonaldNorwood[m]> Bits blog posts post to socials. Micronews posts post to socials. Bits doesn't refer to micronews (longer blog posts), but a micronews could refer to a bits post, the latter was done away with since both push to social feeds.
18:54:28 <AnupaAnnJoseph[m]> Micronews gets relayed to Fediverse, LinkedIn and Twitter and so does Bits. So if we publish the a Bits post and a Micronews about the post, it becomes double in Fediverse, LinkedIn and Twitter.
18:54:29 <weepingclown[m][m]> oh meeting?
18:54:37 * weepingclown[m][m] slaps his head
18:54:40 <DonaldNorwood[m]> If a micronews referred to a bits post it would become the double post.
18:54:53 <DonaldNorwood[m]> Since the bits post was already posted socially.
18:55:03 <AnupaAnnJoseph[m]> Yes
18:55:23 <jipege1> It happened yesterday with the news abour Outreachy 2024
18:55:43 <DonaldNorwood[m]> That looked as though there was no oversight on the publishing.
18:56:02 <weepingclown[m][m]> yes, I wae quite surprised to see two *different* posts about the same thing, on linkedin
18:56:05 <DonaldNorwood[m]> Only one of them should have gone out, preferably the bits posting which had more information.
18:56:54 <DonaldNorwood[m]> I was thinking you meant double posts as in the same item twice, sorry.
18:57:03 <jipege1> Yes but some people read Bits only after they receive Deb Micronews
18:57:26 <Charles[m]> on a bits post, it puts the bits content (but truncates on mastodon limit - 500 chars)
18:57:52 <DonaldNorwood[m]> jipege1: How so? They are separate.
18:58:13 <Charles[m]> I guess the easiest way to solve is disable the automatic post of bits and we prepare a micronews to be published right after bits post goes live
18:59:02 <jipege1> +1
18:59:17 <DonaldNorwood[m]> Charles[m]: Or pick one medium since they both feed to the same networks.
19:00:32 <Charles[m]> you mean only letting the bits go through and not do a micronews or the other way around?
19:01:46 <DonaldNorwood[m]> no... I mean the issue here seems that the outreachy post went to bits and to micrnews. Which would seem like a repeat of a post, however they were 2 entirely separate posts. One was a micronews specific commit, the other was a bits article specific comment. 2 different authors pushed the same news across both services.
19:02:07 <Charles[m]> I see
19:02:23 <DonaldNorwood[m]> It was not a pipeline error, but rather an editorial error which should have stopped the micronews from going out.
19:02:38 <DonaldNorwood[m]> (not blaming anyone, just pointing out the manner this happened)
19:02:43 <Charles[m]> that's on us, we should have delayed one or the other
19:02:54 <Charles[m]> ack
19:03:21 <DonaldNorwood[m]> Correct.
19:03:34 <weepingclown[m][m]> what's the solution though, more thorough checking? better communication?
19:04:51 <Charles[m]> the good thing about disabling bits and adding the step of preparing a micronews to go together with it is that we probably would have caught that problem
19:05:19 <DonaldNorwood[m]> weepingclown[m][m]: Check the other repo before publishing would be my suggestion.
19:05:30 <Charles[m]> but it's a bit more work on our side than just let the bits go through automatically
19:06:37 <jipege1> As I said the time advances, so I suggest to close the meeting soon and to continue the discussion an on debipubliciy mailing list with examples
19:06:54 <DonaldNorwood[m]> We don't have a queue set up that would catch 2 separate posts even if they occurred on the same service. Bits would be caught because it requires a little more work. But it is very easy to accidentally publish 2 micronews within hours of each other.
19:07:22 <Charles[m]> jipege1 (IRC): +1 :-)
19:07:54 <weepingclown[m][m]> DonaldNorwood[m]: that'd be fine, but also potentially prone to error as forgetting to check is probably easier than remembering!
19:08:08 <weepingclown[m][m]> ah, it's indeed late :p
19:08:09 <DonaldNorwood[m]> I think that is a point also on the agenda: "Create a place where Teams..."
19:08:18 <DonaldNorwood[m]> haha
19:09:52 <Charles[m]> true
19:10:02 <jipege1> Before colisng the meeting, I want to thank Justyn for his text updated received few hours ago.
19:10:32 <jbr> oh ta!
19:10:40 <DonaldNorwood[m]> Wow!
19:10:49 <DonaldNorwood[m]> Nice work jbr
19:10:57 <AndreasTille[m]> Thanks to Justyn. :-)
19:10:59 <jbr> in fact I'd forgotten I hadn't committed it
19:11:02 <Charles[m]> 👏
19:11:03 <weepingclown[m][m]> o/
19:11:05 <DonaldNorwood[m]> Never seen you here before as I can fail with my memory.
19:11:13 <weepingclown[m][m]> thanks, jbr :)
19:11:22 <weepingclown[m][m]> DonaldNorwood[m]: once, I think?
19:11:40 <DonaldNorwood[m]> Today :)
19:12:05 <weepingclown[m][m]> well, I wasn't wrong in that case either xD
19:12:35 * weepingclown[m][m] is not around at all these days because of a lot of packaging work and bug fixes across teams, sorry
19:13:20 <weepingclown[m][m]> it's transition time for everyone as trixie freeze softly approaches :p I am handling a painful major version transition myself.
19:14:02 <AndreasTille[m]> weepingclown: Observed you in Debian Med Advent Bug squashing. ;-)
19:15:08 <jipege1> Thanks also for the work around the markdown failures on bits, it needs maybe some more explanation and improvemnt
19:15:22 <disaster2life> oop- sorry I had to take a call, think I missed a lot
19:15:29 <jipege1> I suggest we clos our meeting now
19:15:53 <AnupaAnnJoseph[m]> +1
19:15:58 <jipege1> s/clos/close
19:16:17 <disaster2life> it is indeed late, but yes I hope we addressed all we had to?
19:16:28 <weepingclown[m][m]> oh my bad for the OT, I already took it for closed
19:16:40 <Charles[m]> I'll prepare a mail to debian-publicity explaining about markdownlint, the CI work and what is my vision to it (and maybe a proposal to tackle "Create a place where Teams/DDs/contributors"
19:17:24 <disaster2life> interesting reading coming from charles, noted :)
19:17:24 <Charles[m]> and if you all like the idea, I'll do the work next year :-)
19:17:57 <disaster2life> sounds good to me
19:17:59 <AnupaAnnJoseph[m]> Thank you :)
19:18:13 <Charles[m]> :)
19:18:20 <weepingclown[m][m]> go ahead, and don't hesitate to ping if you need help, thank you for your work! <3
19:18:44 <Charles[m]> thank all of you for being here for the meeting!
19:18:56 <jipege1> +1
19:19:10 <Charles[m]> let's jipege1 do the honor of closing the meeting
19:19:22 <jipege1> #endmeeting