#debian-perl: Perl 5.20 transition
Meeting started by gregoa at 17:57:53 UTC
(full logs).
Meeting summary
- useful links (gregoa, 17:58:12)
  - https://bugs.debian.org/cgi-bin/pkgreport.cgi?tag=perl-5.20-transition;users=debian-perl@lists.debian.org
    bugs tagged perl-5.20.transition (gregoa,
    17:58:18)
 
  - https://release.debian.org/transitions/html/perl5.20.html
    transition page (gregoa,
    17:58:23)
 
  - https://lists.debian.org/debian-perl/2014/07/msg00046.html
    proposed agenda (gregoa,
    17:58:26)
 
  - http://meetbot.debian.net/debian-perl/2014/
    meetings logs (gregoa,
    17:58:48)
 
 
- Intro and welcome (gregoa, 17:58:52)
 
- review FTBFS and other mass-testing bugs (gregoa, 18:02:12)
  - uploading 5.20 to sid would introduce 45 new RC
    bugs (gregoa,
    18:03:33)
 
  - Of the 45 RC critical bugs, 37 have patches,
    and 2 are pending (hlieberman,
    18:04:31)
 
  - AGREED: swig bugs: we
    NMU with the patched generated files if there is no maintainer
    reaction (gregoa,
    18:08:30)
 
  - two unfixed bugs are "Perl 5.20: alternative
    dependencies" (Dom,
    18:15:56)
 
  - ACTION: ansgar to
    look into the swig bugs (trying to regenerate stuff during
    build) (gregoa,
    18:20:57)
 
  - ACTION: ntyni looks
    at embperl (gregoa,
    18:23:04)
 
  - ACTION: fsfs
    hopefully feels pinged as well for embperl :) (gregoa,
    18:23:17)
 
  - one of the debhelper patches is applied in git,
    not the other (gregoa,
    18:24:36)
 
  - #751684 in debhelper should probably be
    wishlist, and only has a minor effect if unfixed (Dom,
    18:26:16)
 
  - #751684 (gregoa,
    18:26:40)
 
  - ... is the one fixed in git (gregoa,
    18:26:50)
 
  - it would be nice to have #750021 fixed before
    the transition (gregoa,
    18:31:03)
 
  - ACTION: Dom to ping
    #750021 (gregoa,
    18:32:34)
 
 
- review bugs/work needed on perl package (gregoa, 18:33:15)
  - bug pinging covers the debian-policy bugs as
    well (gregoa,
    18:34:14)
 
  - check if something from 5.18 needs to be merged
    into 5.20 (gregoa,
    18:36:26)
 
  - s390x libc reversion and perl 5.20 transition
    should not be entangled (Dom,
    18:46:09)
 
  - ACTION: ntyni and Dom
    to review Depends/Recommends one last time with all their
    eyes (gregoa,
    18:50:12)
 
  - ACTION: Dom to review
    the build logs again (gregoa,
    18:51:09)
 
  - can also be improved after transition in case
    it becomes necessary (gregoa,
    18:52:14)
 
  - https://lists.debian.org/debian-perl/2014/05/msg00137.html
    ← rra and NEWS.Debian and CGI.pm (gregoa,
    18:55:02)
 
  - AGREED: someone
    drafts a release notes update for changes to perl for jessie
    (gregoa,
    18:57:19)
 
 
- actions/next steps (gregoa, 18:58:32)
  - ACTION: Dom will
    complete the rebuild of arch:any packages and send a report to
    debian-perl (gregoa,
    19:00:18)
 
  - current proposed date for upload to sid: August
    12th or thereabouts (gregoa,
    19:01:14)
 
  - ACTION: pochu to
    check with aurel32 about s390x libc (gregoa,
    19:04:59)
 
  - entangling perl and libc would be good
    (gregoa,
    19:05:20)
 
  - RT fine with either bumping to serious in
    advance or keeping at important and NMUing to DELAYED/5 (gregoa,
    19:08:12)
 
  - ACTION: dam to bump
    blocking bugs to serious asap (gregoa,
    19:10:00)
 
  - AGREED: start NMUing
    remaining bugs in a couple of days (gregoa,
    19:11:15)
 
  - ACTION: dam and
    gregoa NMU blocking packagaes, others welcome to join (gregoa,
    19:12:21)
 
 
- 5.20.1 timing (gregoa, 19:13:41)
  - http://www.nntp.perl.org/group/perl.perl5.porters/2014/07/msg217597.html
    (Dom,
    19:15:49)
 
  - anything super-urgent can be included from
    5.20.1, and anything else can wait until the dust settles
    (gregoa,
    19:16:52)
 
  - AGREED: plan A:
    5.20.0 in august, just in case of delays 5.20.1 if it's there
    (gregoa,
    19:19:00)
 
 
- AOB? (gregoa, 19:19:27)
  - it should be fine to do the revert [s390x libc]
    right before the perl transition (gregoa,
    19:20:45)
 
 
Meeting ended at 19:22:14 UTC
(full logs).
Action items
  - ansgar to look into the swig bugs (trying to regenerate stuff during build)
 
  - ntyni looks at embperl
 
  - fsfs hopefully feels pinged as well for embperl :)
 
  - Dom to ping #750021
 
  - ntyni and Dom to review Depends/Recommends one last time with all their eyes
 
  - Dom to review the build logs again
 
  - Dom will complete the rebuild of arch:any packages and send a report to debian-perl
 
  - pochu to check with aurel32 about s390x libc
 
  - dam to bump blocking bugs to serious asap
 
  - dam and gregoa NMU blocking packagaes, others welcome to join
 
Action items, by person
  -  ansgar 
    - ansgar to look into the swig bugs (trying to regenerate stuff during build)
 
  
 
  -  dam 
    - dam to bump blocking bugs to serious asap
 
    - dam and gregoa NMU blocking packagaes, others welcome to join
 
  
 
  -  Dom 
    - Dom to ping #750021
 
    - ntyni and Dom to review Depends/Recommends one last time with all their eyes
 
    - Dom to review the build logs again
 
    - Dom will complete the rebuild of arch:any packages and send a report to debian-perl
 
  
 
  -  gregoa 
    - dam and gregoa NMU blocking packagaes, others welcome to join
 
  
 
  -  ntyni 
    - ntyni looks at embperl
 
    - ntyni and Dom to review Depends/Recommends one last time with all their eyes
 
  
 
  -  pochu 
    - pochu to check with aurel32 about s390x libc
 
  
 
People present (lines said)
  - gregoa (127)
 
  - Dom (111)
 
  - ntyni (74)
 
  - pochu (18)
 
  - mst (17)
 
  - dam (14)
 
  - ansgar (10)
 
  - hlieberman (5)
 
  - MeetBot (4)
 
  - XTaran (2)
 
  - daxim (1)
 
Generated by MeetBot 0.1.4.