19:00:07 <carnil> #startmeeting
19:00:07 <MeetBot> Meeting started Wed Sep  2 19:00:07 2026 UTC.  The chair is carnil. Information about MeetBot at https://wiki.debian.org/MeetBot.
19:00:07 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:00:17 <yunseong[m]> Hello
19:00:20 <waldi> ho
19:00:26 <carnil> #chair bwh carnil ukleinek waldi
19:00:26 <MeetBot> Current chairs: bwh carnil ukleinek waldi
19:00:30 <carnil> hi
19:00:34 <carnil> welcome yunseong[m] and waldi
19:00:45 <carnil> I got excuses from bwh and ukleinek, so I guess we can start
19:01:00 <carnil> the list is long as we skipped one week
19:01:09 <carnil> beforehand is there anything you want to discuss first?
19:01:14 <waldi> i have something
19:01:39 <carnil> ok go ahead, or is it something where it would be beneficial if bwh and ukleinek are around as well?
19:02:11 <waldi> sbat policy. how do you feel about time based revocation? something like we revoke everything after six months. this gives enough time for at least one point release
19:02:18 <helmut> I think the nftables autopkgtest kills 6.12.107+deb13-cloud-arm64: memcpy: detected field-spanning write (size 28) of single field "_Generic(info, const struct ip_tunnel_info * : ((const void *)((info) + 1)), struct ip_tunnel_info * : ((void *)((info) + 1)) )" at include/net/ip_tunnels.h:700 (size 0)
19:02:35 <helmut> (sorry, I only now noticed the meeting will shut up, please defer what I said)
19:03:13 <waldi> helmut: full log please in a bug. this sounds like buffer overflow, which is a problem
19:04:32 <waldi> carnil: just some thoughts, as i realized i dropped the ball on sbat stuff
19:06:16 <carnil> waldi: I guess we will need to think a bit on it, where would we need regularly to bump sbat?
19:06:53 <waldi> carnil: yes, we would need to regularly bump the sbat minimum requirement via an out of band sbat update
19:07:44 <waldi> something we currently can not do. in the kernel we can generate that part of the policy without problems
19:09:02 <waldi> okay, if you have no further ideas, i'll work on the policy text i started and will come back
19:09:04 <carnil> waldi: would you mind summarizing your idea in a mail to the team so we can reference and pick it up after studing your proposal? (or in a but)
19:09:15 <waldi> yes
19:09:25 <carnil> yes I do not have a fresh mind at this hour anymore
19:09:50 <carnil> we have some other proposal in mails recently which we should pick
19:10:25 <carnil> do we skim through the bugs?
19:10:30 <waldi> what proposal do you mean?
19:10:57 <carnil> there is one from you abour further refining packages containing modules from some week ago, which I still have "unread"
19:11:08 <waldi> ah, okay
19:11:20 <waldi> yes, we can skim the bugs
19:11:38 <carnil> I tried to annotate each today, with more or less luck, let's start
19:11:47 <carnil> #topic #1126671: (S, M) linux-image-6.17.13+deb13-amd64: Disconnect root (path=/) during heavy load on NvME, partial corruption on NTFS.crash soon but not yet
19:12:01 <waldi> lets close this
19:12:12 <carnil> no news, bwh followed up, reporter did not followed up, I was suggesting to close the bu
19:12:15 <carnil> g
19:12:38 <carnil> right, then let's close it with a note to reopen if reporter can provide the answers
19:13:03 <carnil> #action carnil will close #1126671 as there was no further feedback from reporter (option to reopen)
19:13:14 <carnil> #topic #1111095: (i, M) firmware-amd-graphics: Radeon HD 8280 : gpu lock, black screen and crash.
19:13:33 <carnil> @ukleinek asked to test newer kernel, no feedback. If issue still present should be forwarded upstream. No upstream report found.
19:13:37 <carnil> -> wait so far
19:13:49 <carnil> #topic #1143500: (i, u) The Lenovo Legion Y9000X 2021 (Realtek ALC287 + Cirrus CS35L41) has no sound output through external speakers, but the headphones work normally
19:13:56 <carnil> this one got a followup from the reporter.
19:14:07 <carnil> tested newer kernels and claiming the issue is still there
19:14:33 <carnil> now this is not super new hardware
19:16:32 <waldi> and we even have a two year of bugzilla entry: https://bugzilla.kernel.org/show_bug.cgi?id=218744
19:17:00 <waldi> but this was a bug without proper logs. and most likely slop generated
19:17:37 <waldi> nothing useful to see right now
19:18:47 <carnil> okay let's just mark forwarded to the bugzilla one so we have some additional reference but let it as it is for now
19:19:19 <carnil> #topic #1143994: (i, M) general: Ethernet driver r8169 is used for RTL8125 chipset by default and disconnects intermittently
19:19:37 <carnil> No news. Do we still consider this bug actionable? Ideas? From earlier meetings @ukleinek will report upstream asking for directions.
19:19:52 <carnil> so I would leave the action with ukleinek here assuming he still wants to forward
19:20:12 <carnil> #topic #1144314: (i, u) refcount_t: addition on 0; use-after-free, regression from 260fbcb92bbe ("cgroup: Move dying_tasks cleanup from cgroup_task_release() to cgroup_task_free()")
19:20:43 <carnil> got this evening a patch to test from upstream, will do and then report back in the bug/to upstream, hopefully the reporter can test as well directly with their usecase
19:21:01 <carnil> #action carnil tests the patch from upstream for #1144314 and reports back
19:21:17 <carnil> #topic #1144857: (i, ) linux-image-amd64: LVDS panel turns off/on every few seconds on VALLEYVIEW graphics
19:21:29 <carnil> reporter did provide a bit more narrow range of versions.
19:21:53 <carnil> Any other ideas here than asking to bisect between 6.11 and 6.12.101?
19:22:16 <waldi> not really
19:23:18 <carnil> okay I will send the instructions from uau on bisecting the problem, this proved helpfull in other cases
19:23:26 <waldi> thx
19:23:33 <carnil> #action carnil sends bisect instructions for #1144857 to the reporter
19:23:45 <carnil> #topic #1145026: (i, M) linux-image-6.12.101+deb13-amd64: [REGRESSION] 6.12.101 breaks AMD SEV, SEV-ES, and SEV-SNP platform initialization
19:23:57 <carnil> reporter bisected problem, asked to forward -> wait
19:24:04 <waldi> maybe fixed upstream
19:24:08 <waldi> in 6.12.104
19:24:48 <carnil> #topic ah there was a followup wtoday which I missed
19:24:54 <carnil> ah there was a followup wtoday which I missed
19:25:08 <carnil> I will close the bug accordingly, it is resolved indeed
19:25:45 <carnil> #topic #1145111: (i, u+) linux: kernel NULL pointer dereference when running snapd testsuite
19:26:03 <carnil> aurel32 bisected the problem, reported upstream, there is a patch submitted but it did not yet land in mainline
19:26:30 <carnil> aurel32 prodded upstream again to point out that it needs to go to stable "soonish"/"sooner"
19:26:52 <aurel32> let's hope so, as it's a an easy way to DoS a system without being root
19:26:53 <carnil> I would prefer to wait until it really lands in mainline before we potentially pick it in advance
19:27:18 <carnil> aurel32: ack yes, you made that clear
19:28:33 <carnil> aurel32: please continue to keep an eye on it, notify when it hits mainline, then we can pick it in advance unless it floats then quickly to stable
19:28:43 <aurel32> ack
19:28:54 <carnil> #topic #1145141: (i, ) trixie-backports: CONFIG_NTFS3_FS disabled, breaks ntfs mount
19:29:25 <waldi> how did we get hardcoded ntfs3 this fast?
19:29:51 <carnil> For this one we need bwh I think. So we switched from ntfs3 to ntfs, but this affects the backports kernels. Either we revert the choice explicitly for bpo kernels or pick up the idea from bwh to make an alias.
19:30:14 <carnil> waldi: yes that is surpising, util-linux for instance got hit by this via as #1145441
19:31:01 <waldi> so util-linux is fixed?
19:31:15 <carnil> ntfs3 is quite badly maintained, there is a LPE issue open for some weeks now (altough upstream does not consider security issues mounting crafted images)
19:31:16 <waldi> but yes, lets just add an alias
19:32:07 <carnil> waldi: in unstable it is fixed yes, so no problem there. But in stable we have the problem that 6.12.y ships with ntfs3, and the bpo kernels ship with ntfs module, so adding an alias seems the most compatible way to not break in both cases
19:32:51 <carnil> waldi: ok I (or you?) will ask bwh on his thoughts?
19:33:15 <carnil> so that the next bpo upload ideally resolves this
19:33:34 <waldi> yeah
19:34:16 <carnil> ok I will ping bwh about it
19:34:55 <carnil> #action carnil asks bwh on opinions on adding an alias for ntfs module to ntfs3 for compatiblity in bpo kernels in stable on #1145141
19:35:03 <carnil> oh well that is not very understandable
19:35:15 <carnil> #topic #1145425: (i, ) linux-image-6.12.101+deb13-amd64: amdgpu Navi 23/W6600 flip_done timeout freezes display and requires hard reset
19:35:28 <carnil> that sounds familiar
19:35:44 <carnil> we had a couple of those, and recently upstream addresed the problem in 7.1.8
19:36:06 <carnil> but I'm not sure if that's the very same problem, but an option is to ask reporter to test the bpo kernel and see if the problem goes away
19:36:17 <carnil> but is running a bpo kernel an option for the user?
19:36:53 <waldi> i'll handle that
19:37:11 <carnil> waldi: thanks!
19:37:31 <carnil> #action waldi will handle/debug #1145425
19:37:45 <carnil> #topic #1145585: (i, ) linux-image-6.12.101+deb13-amd64: kernel panicked twice with timer cancellation
19:38:03 <carnil> reporter provided logs for analyzing
19:38:09 <carnil> I did not look into them
19:38:47 <waldi> weird system. testing, but stable kernel
19:39:31 <yunseong[m]> Can I looking it more?
19:40:05 <carnil> yunseong[m]: sure!
19:40:08 <waldi> you could look at the attached panic logs, see what they tell us. the initial two panics are already unrelated
19:40:53 <carnil> #action yunseong will look into information provided in #1145585 and do further research/debugging with the reporter
19:40:59 <carnil> yunseong[m]: ^^ fine?
19:41:32 <yunseong[m]> Yes, I will ask more about issue. :)
19:41:43 <yunseong[m]> * more about the issue. :)
19:41:43 <carnil> #topic #1145628: (i, u) src:linux: iwlwifi AC 9560 CNVi causes PCH bus deadlock on concurrent TLS traffic with Kernel 6.12
19:42:41 <carnil> slightly weird report. Apparently though newer firmware-iwlwifi fixes the problem, should we reassign there and consider it fixed with the newer version? reporter can use bpo version of firmware-iwlwifi?
19:42:46 <waldi> slop report
19:43:48 <carnil> it is surely generated with AI assistance
19:44:41 <carnil> just not sure if the assertion that just updating firmware fixes the problem for them
19:45:19 <carnil> but I'm bit tired of reading such report, so I basically skipped from the summary part to the "verified workaround"
19:45:39 <carnil> if you asserted to be it invalid let's close it though
19:49:00 <waldi> i have no idea if it is invalid. but it is unusable to find out
19:50:03 <carnil> let's close it and ask to properly fill it with reportbug kernel with full logs
19:50:13 <waldi> i'll do that
19:50:20 <carnil> grazie
19:50:41 <waldi> #action waldi will close #1145628 as unusable bug report and asked to come back with reportbug and all information
19:50:58 <carnil> #topic #1145677: (i, ) riscv64: Boot failure due to incorrect memory map
19:51:13 <carnil> waldi: you were already interacting here with reporter, we can leave it in your hands I guess
19:51:23 <waldi> no response from submitter on the question when it worked last
19:51:58 <waldi> the whole thing is weird as hell. the kernel thinks it runs with EFI, but the firmware does not. the kernel thinks it uses device tree, but the firmware is expected to do ACPI
19:52:48 <waldi> i would call this a firmware problem. completely unrelated to what the submitter thinks
19:53:12 <waldi> okay, yes, i'll ask again and without proper information just close it as well
19:53:43 <carnil> ack
19:54:51 <carnil> okay so we get late, do you still have some energy or do we skip the rest? There are in any case some annotations if someone want to look at the new ones
19:54:58 <carnil> (some are pending, waiting)
19:55:10 <waldi> lets cut it here
19:55:24 <carnil> good, so quickly through the rest
19:55:36 <carnil> #topic migration excuses
19:55:57 <carnil> 7.1.12-1 should migrate soon, would like to upload the final 7.1.13-1 one as well and then switch to 7.2.y to unstable?
19:55:58 <waldi> hmpf, i think i still did not fix the autopkgtest…
19:56:19 <waldi> okay. i uploaded linux-base with the config change
19:56:49 <carnil> waldi: i.e. we would be ready to switch 7.2 then to unsable, but should wait until linux-base migrates to testing
19:58:07 <waldi> just bump the dependency
19:59:21 <waldi> something else?
19:59:31 <carnil> no
19:59:35 <carnil> #topic AoB
19:59:42 <carnil> who will chair next week
19:59:47 <waldi> looks like it is my turn then
19:59:54 <carnil> thanks!
20:00:04 <carnil> #action waldi will chair next team meeting
20:00:08 <carnil> then we are done for today
20:00:12 <yunseong[m]> Thank you. Good night!
20:00:14 <carnil> thanks waldi and yunseong[m] for partecipating!
20:00:17 <carnil> #endmeeting