19:07:43 <ukleinek> #startmeeting
19:07:43 <MeetBot> Meeting started Wed Aug 12 19:07:43 2026 UTC.  The chair is ukleinek. Information about MeetBot at https://wiki.debian.org/MeetBot.
19:07:43 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:07:55 <carnil> \o
19:08:00 <ukleinek> #chair bwh carnil waldi
19:08:00 <MeetBot> Current chairs: bwh carnil ukleinek waldi
19:08:05 <bwh> Hi
19:08:25 <ukleinek> Welcome to our meeting, exceptional here in irc as jitsi doesn't seem to work
19:08:36 <bwh> Oh so not all on my end
19:08:56 <yunseong[m]> Hello
19:08:56 <ukleinek> Does anyone has a topic to talk about before diving into the bug list?
19:09:26 <carnil> nothing from me
19:09:41 <waldi> did someone read my mail about new meta packages?
19:09:51 <carnil> not yet :(
19:09:54 <ukleinek> note I committed some comments just before the meeting
19:10:08 <ukleinek> waldi: I didn't
19:10:08 <bwh> waldi: I flagged it as important! But did not read it yet
19:10:15 <waldi> koay
19:10:30 <ukleinek> ..ooOO(so it's not okay :-( )
19:10:53 <ukleinek> waldi: is that about the grub hook being called in the wrong package?
19:11:05 <waldi> nope. this is about modules
19:11:45 <ukleinek> waldi: is that something to talk about now, or should be postpone until someone else at least read your mail?
19:12:05 <waldi> lets postpone, nothing urgent
19:12:23 <ukleinek> ok, then:
19:12:27 <ukleinek> #topic #1126671
19:12:39 <bwh> Let's keep waiting
19:12:49 <ukleinek> That's our long open bug, this time waiting for the reporter still
19:12:57 <ukleinek> #topic #1111095
19:13:35 <ukleinek> a new workaround, unclear to me, what to do about it.
19:13:42 <bwh> So it seems like the wrong driver is binding to this chip by default
19:14:38 <bwh> (Or, which is the more stable driver depends on not just the GPU version but other supporting chips that the board vendors may change)
19:14:54 <ukleinek> is it amdgpu and radeon both feeling responsible?
19:15:18 <bwh> I believe they claim disjoint sets of devices by default
19:15:52 <bwh> and there are these experimental module parameters to change the default, for some generations that both support to some degree
19:16:42 <ukleinek> hmm, report upstream_
19:16:54 <bwh> It may be worth asking upstream whether changing that default makes sense, though I doubt they want to spend much effort thinking about the older hardware
19:16:57 <ukleinek> wrong keyboard layout, s,_,?,
19:17:29 <ukleinek> #action ukleinek asks reporter of 1111095 to forward upstream
19:17:45 <carnil> +1 thanks ukleinek
19:17:50 <ukleinek> #topic #1116643
19:18:33 <ukleinek> this is also unclear to me, the reporter claims the problem isn't fixed, but it also didn't happen for some time.
19:19:00 <waldi> 6.17.9 is not current
19:19:23 <bwh> Let's mark unreproducible and close
19:19:28 <ukleinek> yes, that was back in December
19:19:53 <ukleinek> #action ukleinek closes #1116643 as unreproducible
19:20:04 <ukleinek> #topic #1131558
19:20:33 <ukleinek> I think the issue is clear, there is a MR
19:20:54 <ukleinek> ... firefox still loading to check for news there
19:20:57 <waldi> i need to do another full cycle test
19:21:00 <bwh> Yes I will try to re-review itthis week
19:21:04 <carnil> ukleinek: short note on #1116643, there is the commit mentioned in the upstream issue which is 342ccffd9f77fc29fe1c05fd145e4d842bd2feaa drm/display/dp_mst: Add protection against 0 vcpi in 7.0-rc1
19:21:12 <carnil> so the reporter might try unstable kernel
19:21:27 <ukleinek> carnil: ok, thanks
19:21:35 <carnil> but the commit has been backported as well to various stable series kernels (6.18.16, 6.12.75, 6.6.128 and 6.1.165)
19:22:03 <ukleinek> #action bwh + waldi will look into linux/base!21 for #1131558
19:22:21 <ukleinek> #topic #1141969
19:22:32 <bwh> carnil: right, I agree that seems to be the fix
19:22:56 <ukleinek> I asked earlier this week if this is still an issue for the reporter, seems to be the case. The other two or three seem to be happy now.
19:23:40 <ukleinek> ah no, Ole is still unhappy, who isn't the original reporter
19:23:53 <bwh> Ask Ole to open a separate report, and close this one?
19:24:48 <ukleinek> #action ukleinek to redirect Ole to a new bugreport, closing kritomas's issue
19:25:05 <ukleinek> #topic #1142158
19:25:17 <yunseong[m]> Reporter sent a mail to me directly. Now, He had a new workaround and it completely solved the issue. No freezing and no hangs since.... (full message at <https://matrix.org/oftc/media/v1/media/download/AdFqJwUxXkaq6KTdhGUoeCgc8IKB4li7TJHimBvhXsHsuugKqpz5IhqUVs4v4QRibh3odks5jA2T372bMrqXDzVCegP4iviAAG1hdHJpeC5vcmcva0VzWmhyRk54eERycmtDYVVxUGtiSVFs>)
19:25:20 <yunseong[m]> He recently updated Debian Kernel to version 7.1.3 from trixie-backports. No hangs or GPU issues so far, and it has been several weeks of stability even with the previous 7.0.13 kernel.
19:26:05 <ukleinek> yunseong[m]: forward to the bug please
19:26:17 <ukleinek> ... and then close?!
19:26:20 <yunseong[m]> Okay, I will do!
19:26:42 <ukleinek> #action yunseong will forward privately recieved mail and close
19:26:50 <bwh> I don't think it can be closed yet
19:26:52 <ukleinek> #action yunseong will forward privately recieved mail and close #1142158
19:27:17 <bwh> The actual fixes haven't landed and there is only a workaround available
19:27:47 <ukleinek> bwh: if 7.1.3 is fine, the fixes have landed?!
19:28:06 <bwh> yunseong[m]: Is it fine *with* the workaround, or fine without?
19:28:53 <yunseong[m]> I will ask it for more clarity. :)
19:29:24 <ukleinek> ok, then next try:
19:29:30 <ukleinek> #action yunseong will forward privately recieved mail and  continue triaging
19:29:45 <ukleinek> #topic #1143741
19:30:43 <ukleinek> I guess that needs checking if there are upstream reports already
19:31:25 <bwh> "BUG: Dentry 000000005e9b3cac{i=18d5,n=Mary Poppins (1964).mkv}  still in use (1) [unmount of cifs cifs]"
19:31:25 <carnil> I think I can look at this if something is known and/or fixed in 6.12.103 maybe
19:31:39 <bwh> Well at least the filename was something wholesome
19:31:49 <carnil> but there are only some random indicents
19:32:08 <carnil> if the reporter cannot really reproduce the issue and only reports to us two cases were some issue was triggered it is difficult
19:32:45 <ukleinek> ..ooOO(No upstream reports about Mary Poppins)
19:33:48 <bwh> I can take an action to look at this, but no promises about how soon
19:34:20 <ukleinek> #action bwh puts looking into #1143741 on his agenda
19:34:40 <ukleinek> #topic #1143921
19:35:22 <carnil> checked on this today to see if the mentioned upstream thread with the quirk patch actually was landed, and it was not yet
19:36:04 <ukleinek> so we wait, right?
19:36:32 <bwh> carnil: Ah, because it was part of a series and the other ones had objections
19:36:44 <ukleinek> hmm, given the upstream thread died in April it might need a ping
19:36:50 <carnil> but then I did run out of time to followup, so my idea was to ask the reporter to test a similar quirk patch so this might be forwarded upstream
19:37:10 <bwh> Right. We have the DMI info in the bug report already
19:37:38 <carnil> should I try to followup on that bug for next week?
19:37:58 <ukleinek> I don't know about should, but it would be awesome
19:38:02 <bwh> carnil: You have a lot on your hands already
19:38:18 <carnil> (and see if I mange to both let the reporter test a patch, and secondly ping the upstream thread which died at some point)
19:39:00 <ukleinek> ..ooOO(This lpss device also has a PWM, but still I don't feel competent about it :-)
19:39:00 <carnil> bwh: I can happily defer it to someone else :) It was just an offer that I can try to see if I manage to get somewhere wit it.
19:39:06 <carnil> But then ok I take the action back to the pool
19:39:17 <carnil> someone else? :)
19:39:31 <bwh> #action bwh will send a patch for #1143921
19:39:39 <ukleinek> \o/
19:39:44 <carnil> bwh: thanks!
19:39:59 <ukleinek> #topic #1143994
19:40:25 <ukleinek> for that user the vendor driver works better than the mainline one
19:40:47 <ukleinek> John Scott started to triage, and got the replies he asked for.
19:41:15 <ukleinek> I don't know who that is though
19:42:18 <bwh> I notice that this is a 2.5 GbE controller and I wonder if r8169 just doesn't support those well yet
19:43:00 <bwh> I don't think the log shows anywhere what the actual link speed is
19:43:26 <ukleinek> Isn't the link speed very irrelevant for the MAC driver?
19:43:51 <bwh> it's very relevant
19:46:09 <bwh> It looks like r8169 has supported some variant of the RTL8125 since 2019, but of course there are a million different revisions with different quirks
19:46:10 <ukleinek> ok, so what do we do with that bug? Wait for John Scott to come back to it?
19:47:07 <ukleinek> maybe ping him, given the reply only went to the bug log and not him, too?
19:47:17 <bwh> right, let's ping him
19:47:48 <ukleinek> #action ukleinek asks John Scott if he want to continue triaging and have seen the reporters reply to #1143994
19:48:07 <ukleinek> #topic #1144113
19:48:30 <ukleinek> a regression on stable for usb on rpi4
19:48:52 <carnil> I asked for both boot logs so we might compare
19:49:52 <ukleinek> And I have 6.12.100+deb13-arm64 on my rpi4 (a cm4 though), I can try plugging in a USB disk later
19:50:11 <ukleinek> #action ukleinek tries to reproduce #1144113 on his cm4
19:50:28 <ukleinek> carnil: I can take over replying to the bug then, too
19:51:02 <ukleinek> #topic #1141407
19:51:31 <bwh> I think I still have an action to handle this from an earlier meeting
19:52:05 <ukleinek> ok to keep it that way?
19:52:15 <bwh> yes
19:52:17 <ukleinek> #topic #1141869
19:52:39 * ukleinek tags moreinfo
19:53:11 <bwh> right, nothing else to do yet
19:53:20 <carnil> ack
19:53:30 <ukleinek> #topic #1143161
19:54:00 <ukleinek> Was forwarded upstream, nothing to do for us currently
19:54:09 <bwh> Is that really the right place to report it?
19:54:27 <waldi> nope, not for nouveau
19:54:31 <ukleinek> oh the kernel BZ, nope
19:55:34 <ukleinek> someone should redirect the reporter to the right list (nouveau@freedesktop?)
19:55:57 <ukleinek> yes, nouveau@lists.freedesktop.org
19:56:10 <carnil> oh right, should proablly go to dri-devel@lists.freedesktop.org + nouveau@lists.freedesktop.org
19:56:13 <carnil> ok
19:56:27 <carnil> I will reply
19:56:45 <ukleinek> #action carnil redirects the reporter to the right upstream contact
19:56:55 <ukleinek> #action carnil redirects the reporter to the right upstream contact (#1143161)
19:57:07 <ukleinek> #topic #1143545
19:58:01 <ukleinek> carnil interacted with the stable guys to get a commit picked into 6.12
19:58:11 <ukleinek> .y
19:59:22 <ukleinek> so wait?
19:59:38 <bwh> right
19:59:47 <ukleinek> #topic #1143942
19:59:51 <carnil> yes it will land in the next 6.12.y upstream stable version, at which point we can add a bug closer for this
19:59:59 <carnil> but no need to pick it in advance
20:01:01 <ukleinek> #action ukleinek enables a few config items on arm64 for #1143942
20:01:12 <carnil> +1
20:01:19 <bwh> right
20:01:32 <ukleinek> Is there still energy to continue on your side?
20:01:44 <ukleinek> three more bugs to go
20:02:20 <ukleinek> #topic #1144054
20:02:34 <bwh> carnil got confused about the version for this one
20:02:39 <ukleinek> the reporter answered carnil's questions a bit
20:02:49 <bwh> I'll fix the versions
20:03:06 <carnil> ugh
20:03:20 <carnil> thanks for fixing bwh
20:04:17 <ukleinek> I think we can wait until we see a test with 6.12?! Or is that request part of the confusion?
20:04:42 <carnil> ukleinek: no my question as plain wrong
20:05:10 <carnil> it is a regression seen in the 6.1.y series, but my finger memory handled 6.12.y versions and did then confuse all
20:05:32 <ukleinek> carnil: You wanna fixup and unconfuse the reporter?
20:05:39 <carnil> my question as to bisect the actual versions in 6.1.y if the reporter can spare a server for bisection
20:06:02 <carnil> yes I should fix my mistake here
20:06:24 <carnil> but then still we got at least a video from the trace the reporter is seeing
20:06:33 <ukleinek> #action carnil replies again to #1144054
20:06:36 <carnil> so we still should look at it and maybe someone has an idea ot of it
20:06:40 <bwh> I see what looks like memory corruption (GPF on non-canonical address that looks like some ASCII text)
20:07:04 <ukleinek> ..ooOO(Mary Poppins again?)
20:07:20 <ukleinek> #topic #1144056
20:08:15 <ukleinek> incompletely redacted AI template :-)
20:08:25 <bwh> yeah
20:09:03 * ukleinek doubts "Severity: important" for not more effect than an error message in the kernel log
20:09:32 <bwh> FWIW I don't see that error message in 7.1.6-1
20:10:42 <ukleinek> is ima = security/selinux/ima.c?
20:10:50 <waldi> no
20:10:57 <bwh> security/integrity/ima
20:11:12 <waldi> this
20:11:31 <bwh> If no-one else sees this let's ask for a full kernel log
20:11:51 <ukleinek> sounds sensbile
20:12:12 <waldi> just enable it
20:12:39 <ukleinek> ..ooOO(CONFIG_CRYPTO_SHA384 doesn't exist in 7.2-rc1)
20:13:06 <waldi> hmm, if this would be actually an option
20:13:15 <waldi> sha384 is a subset of sha512
20:13:38 <waldi> config CRYPTO_SHA512
20:13:38 <waldi> tristate "SHA-384 and SHA-512"
20:13:48 <ukleinek> Let's ask the reporter for a patch 🤣
20:13:54 <waldi> no
20:14:09 <bwh> doesn't exist in 7.1 either
20:14:20 <bwh> Our first fully hallucinated bug report, I think!
20:14:37 <bwh> #action bwh will close #1144056 as nonsense
20:15:05 <ukleinek> if there is some truth in it: Maybe IMA=y cannot see CRYPTO_SHA512=m
20:15:45 <bwh> I don't want to waste more time on this
20:15:52 <ukleinek> #topic #1144085
20:16:02 <ukleinek> oh nice, that's done
20:16:43 <ukleinek> #topic new upstream versions
20:17:15 <ukleinek> there is 7.2-rc5 -> 7.2-rc7 which should be easy
20:17:28 <carnil> linux      | 7.2~rc7-1~exp1    | experimental              | source
20:17:30 <carnil> :)
20:17:43 <bwh> and an update for firmware-nonfree, which I will probably deal with at the weekend
20:17:49 <ukleinek> still easier than I anticipated :-)
20:18:13 <ukleinek> #topic merge requests
20:18:16 <ukleinek> anyone?
20:19:23 <ukleinek> at least 3 MRs about enabling drivers. I already have a big todo list, but maybe I can look at these, too
20:19:51 <ukleinek> #topic AoB
20:20:00 <carnil> would be nice thank you ukleinek
20:20:41 <carnil> preparing meeting: I guess it is my turn and in priciple it would have been IRC :)
20:21:00 <carnil> (not sure though if you want to alter it to Jitsi now)
20:21:01 <ukleinek> your's or bwh's
20:21:04 <bwh> Is it not my turn?
20:21:41 <carnil> bwh: feel free to take, the week after I will be at MiniDebconf in Winterthur
20:21:52 <ukleinek> so lets say next week bwh on Jitsi and then maybe the following week on irc with carnil
20:22:00 <carnil> +1 works
20:22:05 <bwh> OK
20:22:17 <ukleinek> #action bwh chairs on Aug 19
20:22:25 <ukleinek> thanks folks
20:22:28 <ukleinek> #endmeeting