19:00:01 <carnil> #startmeeting
19:00:01 <MeetBot> Meeting started Wed Jun 17 19:00:01 2026 UTC.  The chair is carnil. Information about MeetBot at https://wiki.debian.org/MeetBot.
19:00:01 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:00:09 <waldi> hi
19:00:14 <carnil> #chair bwh ukleinek waldi
19:00:14 <MeetBot> Current chairs: bwh carnil ukleinek waldi
19:00:23 <carnil> hi welcome to todays meeting
19:00:24 <ukleinek> we could just do /exec cat 20260617.md and call it a day :-)
19:00:27 <ukleinek> o/
19:00:36 <eamanu> hello o/
19:00:43 <KGB> 03kernel-sec 05pipeline 06Salvatore Bonaccorso 1110769 * [4 minutes and 3 seconds] 03success (pages: success; issue-syntax: success; python-static: success)
19:00:43 <KGB> 03kernel-sec 05pipeline 06Salvatore Bonaccorso 1110769 * [4 minutes and 3 seconds] running (pages: success; issue-syntax: success; python-static: success)
19:00:47 <KGB> 03kernel-sec 05pipeline 06Salvatore Bonaccorso 1110769 * [4 minutes and 3 seconds] 03success (pages: success; issue-syntax: success; python-static: success)
19:00:48 <carnil> is there anything someone wants to discuss before we go to the planned agenda items?
19:00:55 <ukleinek> idk
19:01:08 <carnil> hi eamanu welcome
19:01:18 <eamanu> thanks! :)
19:01:29 <waldi> nothing from my side
19:01:36 <carnil> let's start with the bugs
19:01:45 <carnil> #topic #1126671: (S, ) linux-image-6.17.13+deb13-amd64: Disconnect root (path=/) during heavy load on NvME, partial corruption on NTFS.crash soon but not yet
19:01:50 * ukleinek looks at eamanu and wonders if their presence means anything for the agenda
19:02:12 <waldi> i time for that
19:02:17 <waldi> s/i/no/
19:02:18 <carnil> I have here in the notes that we wait for an available timeslot from bwh or waldi to look closer
19:02:23 <waldi> yes
19:02:26 <carnil> so we keep that state I guess
19:02:41 <carnil> #topic #1138242: (S, u) linux-image-6.12.90+deb13.1-riscv64-dbg and linux-image-6.12.90+deb13.1-s390x-dbg have an undeclared file conflict
19:02:56 <carnil> The bug has an update from waldi, still ongoing work?
19:03:10 <carnil> (it remains on our radar due to severity)
19:03:13 <waldi> i have patches, but not submitted
19:03:20 <waldi> six architectures affected
19:03:29 <ukleinek> submitted means to salsa or upstream?
19:03:35 <waldi> upstream
19:03:36 <carnil> upstream I guess
19:03:49 <carnil> ok then this is good hands!
19:04:04 <carnil> #topic #1129033: (i, u) iwlwifi: WARNING in _iwl_mvm_sec_key_del with hostapd on 6.12.73+deb13-amd64 (AP mode)
19:04:33 <carnil> Reporter said to have tested 6.1.162-1 which works, and 7.0.10-1 which as well works and do not trigger the problem
19:04:52 * ukleinek suspects a sensitive spam filter at gmx that explains why the reporter didn't get my mail
19:05:20 <carnil> having looked at a git diff between v6.12.73..v7.0.10 in the respecive path for the driver I did not spot something "interesting" which would explain the fix
19:06:01 <carnil> any ideas here?
19:06:18 <ukleinek> #action ukleinek looks into #1129033 and ask for a bisect if he doesn't spot anything in the affected version range
19:06:34 <carnil> thanks ukleinek
19:06:48 <carnil> #topic #1138755: (i, u) Subject: amdgpu: RX 640 hangs right after VCE initialization on kernel 6.12 (i5-11400F, no iGPU) (forwarded: gitlab.freedesktop.org)
19:07:32 <carnil> this is in good hands, upstrema issue contains a tentative patch, which the reporter has tested, so next this should go by them to mainline and we can track the fix (add a closes tag on the respective upload)
19:07:39 <carnil> so wait for us
19:07:44 <ukleinek> ack
19:07:56 <carnil> #topic #1139599: (i, u) linux-base-7.0.10+deb14-amd64: amdgpu (ttm?) two Oops, locking the computer (forwarded: amd-gfx)
19:08:11 <carnil> apparently there were similar/same issues reported. So wait for progress from upstream
19:08:19 <ukleinek> ack++
19:08:27 <carnil> #topic 1140074: (i, ) linux-image-7.0.10+deb13-amd64: excessive "icmp: detected local route for xx" logs
19:08:59 <carnil> Unseen/unreproducible issue so far.  I asked for some details on the networking setup and to ad information from reportbug bugscript to the bug
19:09:16 <carnil> but if someone has additional ideas what we can do or ask here?
19:09:33 <ukleinek> sounds like an issue that is specific to the reporter's local network
19:10:09 <waldi> network routing tables. the source talks about race conditions between route modifications, but this does not make sense
19:11:28 <ukleinek> it's a race between lookup and change
19:11:43 * carnil looks up is ip r output included in the networking part of our bug scripts?
19:12:18 <ukleinek> `ip r` alone might not contain all relevant info
19:13:02 <ukleinek> This is `net_warn_ratelimited("detected local route for %pI4 during ICMP sending, src %pI4\n", ...)`, right?
19:13:43 <ukleinek> the unblackened message might already help ...
19:15:05 <carnil> should I followup to my questions and ask explitily for logs with at most only the ip masked out + routing tables information?
19:15:07 <ukleinek> (in combination with `ip a; ip r showdump`
19:15:28 <ukleinek> we might as well wait
19:15:34 <carnil> ok I will ask that as followup and then wait
19:15:55 <ukleinek> `ip r showdump` does something different than I expected
19:16:04 <ukleinek> so only ask for `ip r` (for now)
19:16:30 <carnil> #action ask as followp to #1140074 to include the log (possibly maksing out the IP) and `ip r` output
19:16:48 <carnil> #topic #1117449: (n, ) linux-image-6.16.9+deb14-amd64: Lots of oom killed processes (merged with #1139567)
19:17:14 <carnil> nothing really new here. We discussed that last week on jitsi meeting.  @benh had action to take keeper look.
19:17:37 * ukleinek nods
19:17:47 <carnil> I suspect we can keep that and as in the first bug wait for an available timeslot with low prio from bwh, but I will ask him is he is fine
19:18:01 <carnil> #topic #1139265: (n, ) linux-image-7.0.10+deb14-amd64: QXL graphics crash, processes stuck in D state, NULL-dereference errors, TTY-subsystem malfunction
19:18:13 <carnil> Followup from reporter (after switching machine type for qemu). But some differences to original report.
19:18:31 <carnil> waldi: do you intend to further look into this again?
19:19:08 <waldi> i will look again
19:19:39 <carnil> #action waldi will look into #1139265
19:19:44 <carnil> thank you!
19:19:45 <ukleinek> "underlying kernel bug that makes unrelated processes hang" is explained by "is deprecated and might be broken", isn't it?
19:20:58 <waldi> nothing unrelated
19:21:03 <waldi> in this bug
19:21:12 * ukleinek nods
19:21:26 <carnil> #topic ok let's move to the next
19:21:36 <carnil> ups
19:21:38 <ukleinek> +1
19:21:45 <carnil> #topic #1139269: (n, M) tpm tpm0: tpm_try_transmit: send(): error -62
19:21:51 <carnil> Wait. @ukleinek asked for more information.
19:21:56 * ukleinek nods
19:22:03 <carnil> #topic #1139676: (n, uM) Multiple drivers/gpu/drm/i915/display/intel_display_power.c kernel log
19:22:10 <carnil> Waiting for reporter to provide requested information.
19:22:20 <carnil> #topic #1139686: (n, +) Please enable CONFIG_NETFILTER_NETLINK_HOOK (forwarded: linux!1976)
19:22:42 <carnil> I think this should be fine to be merged and possibly marked as to be backported
19:23:18 <carnil> if there are no objections then I would merge the change
19:23:31 <ukleinek> MR looks straight forward, fine for me
19:24:00 <carnil> ukleinek: then you can approve it on salsa
19:24:22 <carnil> ok next topics
19:24:31 <carnil> #topic #1139942: (n, ) linux-image-amd64: Desktop reboots upon resume from suspend
19:24:31 <KGB> 03linux 05debian/latest 06Uwe Kleine-König * [approved] merge request !1976: net/netfilter: Enable NETFILTER_NETLINK_HOOK as module * 14https://salsa.debian.org/kernel-team/linux/-/merge_requests/1976
19:25:01 <carnil> New report. Regression between 6.12.88-1 and 6.12.90-2. Asked already for bisection. -> wait
19:25:13 <carnil> #topic #1139950: (n, ) amdgpu carrizo: no display signal after modeset
19:25:34 <carnil> Again a regresion, now between 6.12.63-1 and 6.12.69-1 . Asked as well to bisect
19:25:41 * ukleinek wonders if we need a note in the bisect instruction about unreliable triggers
19:26:18 <carnil> do you want to provide an updated version for the instructions?
19:26:28 <ukleinek> hmm, probably not, when the result looks wrong and we have the bisect log this can be handled
19:26:37 <carnil> ok!
19:26:48 <carnil> #topic #1138985: (w, +) linux-image-amd64: Please enable CONFIG_OXP_EC for OneXPlayer handheld battery charge threshold support (forwarded: linux!1971)
19:26:52 <ukleinek> (but if something like that happens, I can provide the followup instructions)
19:27:10 <carnil> there is a merge request for that as well, which needs to be reviewed
19:28:16 <ukleinek> the updated changelog entry is a different one than the MR above, so one of them needs careful merging
19:28:28 <ukleinek> s/one/at least one/
19:28:46 <KGB> 03linux 05debian/latest 06Uwe Kleine-König * [approved] merge request !1971: [amd64] Enable CONFIG_OXP_EC as module * 14https://salsa.debian.org/kernel-team/linux/-/merge_requests/1971
19:28:57 <carnil> the user has done testing it works afaiu, so we can merge it I would say.
19:29:26 <KGB> 03linux 05debian/latest 06Uwe Kleine-König * [update] merge request !1971: [amd64] Enable CONFIG_OXP_EC as module * 14https://salsa.debian.org/kernel-team/linux/-/merge_requests/1971
19:29:36 <carnil> I can do, will ask to slightly adapt the changelog entry to name as well the "subsystem"
19:29:47 * ukleinek added the backport-6.12 label
19:30:00 <KGB> 03linux 05debian/latest 06Salvatore Bonaccorso * [update] merge request !1971: [amd64] Enable CONFIG_OXP_EC as module * 14https://salsa.debian.org/kernel-team/linux/-/merge_requests/1971
19:30:03 <KGB> 03linux 05debian/latest 06Uwe Kleine-König * [update] merge request !1971: [amd64] Enable CONFIG_OXP_EC as module * 14https://salsa.debian.org/kernel-team/linux/-/merge_requests/1971
19:30:26 <carnil> so we are done with the linux bugs
19:30:45 <carnil> as bwh is not here tonight I would propose we skip the dracut and firmware-nonfree bugs?
19:31:04 <ukleinek> oh cool RCE via dhcp
19:32:16 <ukleinek> carnil: #1139725 only affects netboot setups I assume?
19:33:18 * ukleinek wonders how relevant that is, given that the root-dir can also be set by the dhcp server (at least I think that's the case), that also allows to compromise a machine
19:33:54 <carnil> afaiu is it sas well only in the 35network-legacy, but we haven't looked further so far apart filling a tracking bug as per above
19:34:16 * ukleinek nods
19:34:56 <carnil> ok to move to the last topics?
19:35:00 <ukleinek> hmm, what is isenkram-autoinstall-firmware?
19:35:12 <ukleinek> (only thinking aloud, no need for an answer)
19:36:54 <carnil> #topic Migration excuses
19:36:54 * ukleinek doesn't understand why linux-signed-amd64 doesn't migrate
19:37:38 <ukleinek> "Will attempt migration" means it waits for the next dinstall run?
19:37:47 <carnil> linux not migrating is just release team asking to make a hint to let it in? At least I do not see what is wrong right now
19:38:33 <carnil> but it says already:
19:38:36 <carnil> Migration status for linux (7.0.10-1 to 7.0.12-2): Will attempt migration due to a hint (Any information below is purely informational)
19:38:37 <ukleinek> linux has "Will attempt migration due to a hint"
19:38:51 <ukleinek> so also only waits for next dinstall?
19:39:07 <carnil> right, wait and then otherwise ask release team
19:39:13 <ukleinek> sounds right
19:39:20 <carnil> #topic New upstream versions
19:39:33 <carnil> nothing in the table (apart the usual firmware-free)
19:39:41 <carnil> #topic Merge requests
19:39:54 <carnil> is there any merge request in particular someone wants to discuss?
19:41:15 * ukleinek marks a few for him to look into, nothing to discuss now
19:41:33 <carnil> ok perfect, thanks ukleinek for looking into some
19:41:37 <carnil> #topic AoB
19:41:44 <carnil> who whill chair next week?
19:41:52 <carnil> who will chair next week?
19:41:57 * ukleinek can do that
19:42:13 <ukleinek> #action ukleinek will chair next week
19:42:15 <carnil> 1 ... 2 ... 3 ... asigned :)
19:42:41 <carnil> so we are done for tonight, thanks all for attending and giving input on the topics!
19:42:45 <ukleinek> \o/
19:42:53 <carnil> #endmeeting