#debian-kernel Meeting

Meeting started by carnil at 20:00:04 UTC (full logs).

Meeting summary

  1. (carnil, 20:01:42)
  2. future of iptables-legacy (carnil, 20:01:53)
    1. ACTION: waldi tries to find out what still depends on iptables-legacy (not only as fallback), propose a plan for MBF and dropping legacy binaries ASAP (and kernel support after forky) (carnil, 20:11:14)

  3. Proposal about maintaining firmware-nonfree in old releases (carnil, 20:12:13)
  4. #1119161: (C, ) sudden memory leak/full wipes out all disk partitions (carnil, 20:26:07)
    1. ACTION: carnil responds to #1119161 that we need more actionable information (logs) to help with and are going to close the bug for the time beeing (carnil, 20:30:41)

  5. #1109268: (i, ) ath11k_pci may trigger prompt for nonexistent firmware file during installation (carnil, 20:31:27)
    1. ACTION: ukleinek takes care of #1109268 for further investigation (and adjusting bug severity) (carnil, 20:32:53)

  6. #1112627: (i, u) linux-image-6.16.3+deb14-amd64: Intel audio no longer works: DMAR: [DMA Write NO_PASID] Request device [00:1b.0] ... non-zero reserved fields in PTE (carnil, 20:33:04)
    1. ACTION: bwh will forward #1114557 upstream (bwh, 20:40:21)
    2. ACTION: bwh will forward #1112627 upstream (bwh, 20:40:47)

  7. #1114557: (i, u+) linux-image-6.12.43+deb13-amd64: Jieli touchscreen and stylus no longer supported (carnil, 20:41:02)
  8. #1114884: (i, ) linux-image-6.1.0-39-amd64: AMD Ryzen 9 7950X, linux-image-6.1.0-39-amd64 hangs on boot while 6.1.0-37-amd64 works fine (carnil, 20:41:48)
    1. ACTION: ukleinek discusses with kathara for #1114884 debugging/triaging (carnil, 20:44:16)

  9. #1114912: (i, ) linux-image-amd64: KVM GPU passthrough causes kernel crash and system hang on Debian 13 after VM shutdown (carnil, 20:44:29)
    1. ACTION: ukleinek takes care of further debugging of #1114912 (carnil, 20:45:15)

  10. #1115581: (i, ) linux-image-6.16.3+deb14-rt-amd64: Boot hang with Creative Sound Blaster AE-7 [1102:0010] (carnil, 20:45:26)
    1. ACTION: ukleinek blushes further, will go through #1115581 and maybe ping again (ukleinek, 20:46:21)

  11. #1118465: (i, u) Regression: linux-image-5.10.0-36-arm64 fails to bring up LAN7800 USB NIC: "NO-CARRIER" and "state DOWN" (carnil, 20:47:27)
    1. ACTION: bwh will try to debug #1118465 properly instead of guessing (bwh, 20:49:12)

  12. #1118508: (i, M) linux-image-6.12.38+deb13-amd64: Frequent kernel panic during/just after boot on Lenovo P15v Gen1 with external USB hub in Samsung display (carnil, 20:50:01)
  13. #1118762: (i, ) linux-image-6.16.12+deb14+1-amd64: external monitors disconnect every several seconds (carnil, 20:50:26)
    1. ACTION: carnil will ask Vincent in #1118762 for kernel (full) kernel logs up to when problem triggers; clarification on "disconnection" times (carnil, 20:53:20)

  14. #1119137: (i, ) linux-image-6.12.48+deb13-amd64: CPU stall when Debian Trixie runs as guest in VirtualBox environment (carnil, 20:58:58)
    1. ACTION: bwh will reply to #1119137 to ask about QEMU results, then likely reassign to virtualbox (bwh, 21:06:58)

  15. AOB (carnil, 21:07:41)
    1. ACTION: bwh will chair next weeks meeting (carnil, 21:10:51)


Meeting ended at 21:11:17 UTC (full logs).

Action items

  1. waldi tries to find out what still depends on iptables-legacy (not only as fallback), propose a plan for MBF and dropping legacy binaries ASAP (and kernel support after forky)
  2. carnil responds to #1119161 that we need more actionable information (logs) to help with and are going to close the bug for the time beeing
  3. ukleinek takes care of #1109268 for further investigation (and adjusting bug severity)
  4. bwh will forward #1114557 upstream
  5. bwh will forward #1112627 upstream
  6. ukleinek discusses with kathara for #1114884 debugging/triaging
  7. ukleinek takes care of further debugging of #1114912
  8. ukleinek blushes further, will go through #1115581 and maybe ping again
  9. bwh will try to debug #1118465 properly instead of guessing
  10. carnil will ask Vincent in #1118762 for kernel (full) kernel logs up to when problem triggers; clarification on "disconnection" times
  11. bwh will reply to #1119137 to ask about QEMU results, then likely reassign to virtualbox
  12. bwh will chair next weeks meeting


Action items, by person

  1. bwh
    1. bwh will forward #1114557 upstream
    2. bwh will forward #1112627 upstream
    3. bwh will try to debug #1118465 properly instead of guessing
    4. bwh will reply to #1119137 to ask about QEMU results, then likely reassign to virtualbox
    5. bwh will chair next weeks meeting
  2. carnil
    1. carnil responds to #1119161 that we need more actionable information (logs) to help with and are going to close the bug for the time beeing
    2. carnil will ask Vincent in #1118762 for kernel (full) kernel logs up to when problem triggers; clarification on "disconnection" times
  3. ukleinek
    1. ukleinek takes care of #1109268 for further investigation (and adjusting bug severity)
    2. ukleinek discusses with kathara for #1114884 debugging/triaging
    3. ukleinek takes care of further debugging of #1114912
    4. ukleinek blushes further, will go through #1115581 and maybe ping again
  4. waldi
    1. waldi tries to find out what still depends on iptables-legacy (not only as fallback), propose a plan for MBF and dropping legacy binaries ASAP (and kernel support after forky)


People present (lines said)

  1. carnil (98)
  2. ukleinek (53)
  3. bwh (51)
  4. waldi (27)
  5. santiago (12)
  6. MeetBot (3)
  7. iam_tj[m] (1)


Generated by MeetBot 0.1.4.