#debian-kernel Meeting

Meeting started by carnil at 19:00:01 UTC (full logs).

Meeting summary

  1. Build time and limits in Salsa CI (carnil, 19:01:54)
    1. ACTION: carnil reverts switch to gcc-15 for debian/latest branch (carnil, 19:10:04)
    2. ACTION: bwh will test performance difference of building with gcc 14 vs 15, and open bug if significantly worse with 15 (bwh, 19:12:56)
    3. ACTION: bwh will look for more drivers to disable in cloud configs (bwh, 19:13:20)
    4. ACTION: waldi to test pipeline and slow runtimes (waldi, 19:18:39)

  2. Disabling bcachefs (carnil, 19:19:20)
  3. #1106411: (i, u) linux-image-6.12.27-amd64: kernel NULL pointer dereference in bmc150_accel_core (merged with #1102522, #1112643) (carnil, 19:29:57)
  4. #1111095: (i, ) firmware-amd-graphics: Radeon HD 8280 : gpu lock, black screen and crash. (carnil, 19:36:58)
    1. https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1111095#62 (carnil, 19:37:33)
    2. ACTION: carnil ask reporter of #1111095 to confirm installed state of firmware-amd-graphics and provide full kernel logs (with updated 6.12.48-1) with both firmware installed and not (carnil, 19:46:14)

  5. #1112288: (i, u) amdgpu: GPU hang with 6.12 & 6.16sid, 6.16 liquorix works. (carnil, 19:46:55)
    1. liquorix patches are at https://github.com/zen-kernel/zen-kernel/commits/6.16/fixes/ (waldi, 19:49:41)
    2. https://github.com/zen-kernel/zen-kernel/commits/6.16/fixes/ (waldi, 19:50:00)

  6. #1112627: (i, Mu) linux-image-6.16.3+deb14-amd64: Intel audio no longer works: DMAR: [DMA Write NO_PASID] Request device [00:1b.0] ... non-zero reserved fields in PTE (carnil, 19:50:19)
  7. #1114557: (i, u+) linux-image-6.12.43+deb13-amd64: Jieli touchscreen and stylus no longer supported (carnil, 19:50:31)
  8. #1114884: (i, M) linux-image-6.1.0-39-amd64: AMD Ryzen 9 7950X, linux-image-6.1.0-39-amd64 hangs on boot while 6.1.0-37-amd64 works fine (carnil, 19:50:59)
  9. #1114912: (i, ) linux-image-amd64: KVM GPU passthrough causes kernel crash and system hang on Debian 13 after VM shutdown (carnil, 19:51:47)
    1. ACTION: bwh will forward #1114912 upstream (bwh, 19:53:41)

  10. #1115613: (i, +M) linux: Please enable CONFIG_SOUNDWIRE_AMD=m (carnil, 19:54:00)
  11. #1116065: (i, Mu) linux: kernel oops with rsync on MSI X99A with ntfs3 (carnil, 19:55:51)
    1. ACTION: carnil forwards information from #1116065 to ntfs3 driver upstream (carnil, 20:03:07)

  12. #1116554: (i, ) linux-image-6.12.43+deb12-amd64: hard freeze during normal operation with stacktraces in the syslog (carnil, 20:03:58)
    1. ACTION: waldi to handle #1116554, full log, task info via sysrq (waldi, 20:11:19)

  13. #1116643: (i, ) UBSAN: shift-out-of-bounds in .../drivers/gpu/drm/display/drm_dp_mst_topology.c (shift exponent -1) (carnil, 20:11:36)
    1. ACTION: bwh will look for upstream bug for #1116643 and ask reporter to forward if there is none (bwh, 20:13:58)

  14. AOB? (carnil, 20:14:23)
    1. ACTION: waldi will chair next weeks team meeting (carnil, 20:15:16)


Meeting ended at 20:15:47 UTC (full logs).

Action items

  1. carnil reverts switch to gcc-15 for debian/latest branch
  2. bwh will test performance difference of building with gcc 14 vs 15, and open bug if significantly worse with 15
  3. bwh will look for more drivers to disable in cloud configs
  4. waldi to test pipeline and slow runtimes
  5. carnil ask reporter of #1111095 to confirm installed state of firmware-amd-graphics and provide full kernel logs (with updated 6.12.48-1) with both firmware installed and not
  6. bwh will forward #1114912 upstream
  7. carnil forwards information from #1116065 to ntfs3 driver upstream
  8. waldi to handle #1116554, full log, task info via sysrq
  9. bwh will look for upstream bug for #1116643 and ask reporter to forward if there is none
  10. waldi will chair next weeks team meeting


Action items, by person

  1. bwh
    1. bwh will test performance difference of building with gcc 14 vs 15, and open bug if significantly worse with 15
    2. bwh will look for more drivers to disable in cloud configs
    3. bwh will forward #1114912 upstream
    4. bwh will look for upstream bug for #1116643 and ask reporter to forward if there is none
  2. carnil
    1. carnil reverts switch to gcc-15 for debian/latest branch
    2. carnil ask reporter of #1111095 to confirm installed state of firmware-amd-graphics and provide full kernel logs (with updated 6.12.48-1) with both firmware installed and not
    3. carnil forwards information from #1116065 to ntfs3 driver upstream
  3. waldi
    1. waldi to test pipeline and slow runtimes
    2. waldi to handle #1116554, full log, task info via sysrq
    3. waldi will chair next weeks team meeting


People present (lines said)

  1. carnil (103)
  2. bwh (54)
  3. waldi (48)
  4. MeetBot (3)
  5. yunseongkim[m] (1)
  6. kathara (1)
  7. Santiago[m] (1)
  8. ukleinek (0)


Generated by MeetBot 0.1.4.