19:00:03 <waldi> #startmeeting
19:00:03 <MeetBot> Meeting started Wed Sep  3 19:00:03 2025 UTC.  The chair is waldi. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:03 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:00:11 <waldi> #chair bwh carnil ukleinek
19:00:11 <MeetBot> Current chairs: bwh carnil ukleinek waldi
19:00:11 <KGB> 03kernel-sec 05master f70510e 06Salvatore Bonaccorso 10retired/CVE-2022-49493 * Update status for CVE-2022-49493 * 14https://salsa.debian.org/kernel-team/kernel-sec/-/commit/f70510e
19:00:13 <KGB> 03kernel-sec 05pipeline 06Salvatore Bonaccorso 927117 * pending (python-static: pending; issue-syntax: running)
19:00:14 <KGB> 03kernel-sec 05pipeline 06Salvatore Bonaccorso 927117 * running (issue-syntax: running; python-static: running)
19:00:17 <carnil> hi
19:00:21 <waldi> welcome
19:00:27 <carnil> waldi: thanks for taking over the meeting preparation
19:00:46 <waldi> i tried my best
19:00:54 <bwh> Hi
19:01:19 <waldi> anything we should talk about first?
19:01:31 <yunseongkim[m]> Hi 😃
19:01:40 <carnil> there is this version sorting question which was raised
19:02:00 <KGB> 03kernel-sec 05pipeline 06Salvatore Bonaccorso 927117 * [1 minute and 46 seconds] 03success (issue-syntax: success; python-static: success)
19:02:06 <waldi> #topic version sorting
19:02:41 <waldi> #info related as well https://uapi-group.org/specifications/specs/version_format_specification/
19:02:44 <bwh> I just replied to suggest using either '.' or a letter instead of the second '+'. I didn't yet test whehter test-patches handles that properly
19:04:35 <bwh> We could of course go back to including a serial number in all cases, but I think waldi wanted to get away from that, and I think we will not often have multiple Debian uploads with the same upstream version and target release
19:05:13 <carnil> just in urgent cases, the normal case would be to rebase to a new upstream version
19:05:20 <bwh> right
19:05:46 <carnil> but we need to be able to handle that, we had a couple of security updates or followup bugfixes in point releases to fix e.g. a regression without a new upstream version
19:06:13 <waldi> a letter might work, have not checked however
19:06:53 <waldi> it's just way less visible
19:07:05 <bwh> What is less visible?
19:07:11 <waldi> . might do weird things, as we have three version sorting algorithms
19:07:20 <waldi> "deb13a" vs "deb13+1"
19:07:59 <bwh> Ah, yes I didn't propose that but e.g. deb13u1
19:08:10 <waldi> ah
19:08:29 <waldi> this might break after 9
19:08:43 <bwh> I don't think so
19:08:49 <waldi> because not all version sorting algorithms split between text and digits
19:08:59 <bwh> then they didn't work with our old ABI naming
19:09:28 <waldi> they did, because there was a - in front
19:09:38 <bwh> oh, you mean between letters and digits (instead of punctuation and digits)
19:09:41 <waldi> yes
19:10:01 <waldi> debian version comparison works with that, but others not
19:10:25 <waldi> deb13u9 vs deb13u10 i meant
19:10:30 <bwh> So we need to check with: linux-version sort, dpkg --compare-versions, and sort -V, right?
19:10:48 <waldi> yes. or assume we will never get over 9
19:11:24 <bwh> #action bwh will test sorting of the alternative version suffixes and report back
19:11:28 <waldi> thx
19:11:47 <waldi> anything else?
19:12:09 <carnil> not from my side
19:13:01 <waldi> okay
19:13:02 <bwh> no
19:13:06 <waldi> #topic #1112208
19:13:33 <bwh> I took an action for this last week
19:13:42 <bwh> or it's a duplicate bug
19:13:56 <waldi> ah, was filled on wednesday
19:14:05 <waldi> #topic #1111184
19:14:12 <waldi> this just needs a close i think
19:14:55 <carnil> in the ideal case we get as well a result on the fixing commit so it might be backported to 6.12.y
19:15:00 <bwh> We discussed this last week. It stil needs to be fixed in trixie.
19:15:36 <waldi> seems like the bts misses version information from trixie
19:15:38 <bwh> The BTS doesn't show it because it doesn't know about security uploads
19:15:47 <waldi> ah, security, yes
19:15:54 <carnil> but as bts can handle multiple closes I think it is fine to close, but then tag it + trixie. I got distracted by other things but sitll can provide the reporter instructions on how to bisect
19:16:36 <carnil> i.e. I had an action to help the reporter doing the last steps of bisection
19:17:28 <carnil> #action carnil sends reporter instructiond to do the bisection on upstream versions to pinpoint fixing commit
19:17:29 <bwh> So let's leave that with you?
19:17:33 <bwh> OK
19:17:37 <waldi> #topic #1108860
19:17:51 <waldi> nothing to do right now
19:17:58 <carnil> we still need a reproducer for upstream from reporter
19:18:01 <carnil> ack
19:18:13 <waldi> #topic #1110419
19:19:02 <bwh> Nothing new in any Debian report or upstream
19:19:18 <waldi> #topic #1111016
19:19:51 <bwh> Nothing new, I just added the moreinfo tag last week
19:20:20 <waldi> #topic #1111095
19:20:36 <bwh> We discussed this last week...
19:20:56 <waldi> #topic #1111722
19:21:04 <bwh> I have an action to ask for more tests on the previous bug
19:21:42 <waldi> nothing new on this. submitter asked for more information
19:21:44 <bwh> right
19:21:53 <waldi> #topic #1112288
19:22:48 <bwh> I guess someone should look for patches and config changes in Liquorix (whatever that is)
19:24:54 <carnil> I guess this is this one? https://liquorix.net/
19:25:05 <bwh> and there is package source at https://github.com/damentz/liquorix-package
19:25:14 <carnil> (the install instructions are shoking ...)
19:25:56 <bwh> but I only see one huge patch there: https://github.com/damentz/liquorix-package/blob/6.16/master/linux-liquorix/debian/patches/zen/v6.16.4-lqx1.patch
19:26:34 <bwh> I guess https://github.com/zen-kernel/zen-kernel is the actual source
19:28:04 <bwh> Anyway, I think the best we can do is ask the Liquorix devs to get fixes upstream, and forward this bug report upstream too
19:30:51 <waldi> noone seems to be currently willing to work on that. so it can wait
19:31:30 <bwh> OK
19:31:32 <carnil> not necessarily, I think I would prepfer to focus on other things
19:31:32 <waldi> #topic #1112333
19:31:49 <waldi> no log information whatsoever
19:32:27 <bwh> No log, no lspci, somehow they managed to bypass the bug script
19:32:49 <bwh> Oh, no it turned into an attachment
19:33:29 <bwh> So I see timeouts and GPU reset in the kernel log
19:34:39 <bwh> So I think this needs to be forwarded upstream too. Maybe after testing 6.12.43 if that has amdgpu fixes
19:35:26 <bwh> yes it has some
19:35:35 <bwh> When is the point release?
19:35:41 <carnil> on weekend
19:35:44 <waldi> next weekend
19:35:49 <bwh> OK
19:35:52 <waldi> so lets wait until then
19:36:20 <carnil> ok
19:36:21 <bwh> #action bwh will ask submitter of #1112333 to test 6.12.43-1 after the point release
19:36:26 <waldi> #topic #1112627
19:38:00 <bwh> (Upstream bug report is from 2022, so unrelated)
19:38:56 <waldi> this is iommu, so broken firmware. and we enable iommu by default, while others don't
19:39:07 <bwh> No, it's a regression from 6.12 to 6.16
19:39:32 <carnil> we might ask Francesco to bisect and report back on the breaking commit
19:39:44 <bwh> right
19:40:29 <bwh> The driver is snd_hda_intel which I thought would be quite old and stable, but maybe someone broke DMA mapping there...
19:40:40 <bwh> carnil: Can you do that?
19:40:53 <carnil> bwh: yes
19:41:20 <carnil> #action carnil will ask reporter of #1112627 to bisect upstream changes to identify breaking commit
19:41:56 <waldi> #topic #1112643
19:43:25 <bwh> Possibly related to #1112048 but that is known to be a very recent regression
19:43:48 <bwh> and we still have to get more info for that other report
19:44:18 <bwh> Well the kernel log shows multiple oopses
19:44:38 <bwh> Did we see this before? Oops in bmc150?
19:45:17 <waldi> i don't think i have devices with this sensor
19:45:54 <carnil> yes the oops bmc150 is familiar
19:45:57 <carnil> wait a second
19:47:29 <carnil> https://lore.kernel.org/linux-iio/aDtZqwjKtpyguppg@eldamar.lan/ , #1106411
19:47:44 <carnil> we do not have yet a patch which got accepted upstream
19:47:49 <carnil> and discussion stalled
19:48:04 <carnil> patch proposal was at https://lore.kernel.org/linux-iio/20250613124648.14141-1-marek.vasut+bmc150@mailbox.org/
19:49:14 <carnil> disabling iio-sensor-proxy service and see if the problem still happens
19:49:49 <bwh> OK, so I think we should ask to blacklist this driver and see if that also fixes the suspend
19:50:21 <carnil> yes sounds good
19:51:02 <bwh> #action bwh will ask reporter of #1112643 to test blacklisting bmc150 driver
19:51:25 <waldi> #topic #1113765
19:52:03 <waldi> fix is expected via stable@
19:52:08 <waldi> nothing to do
19:52:25 <bwh> Seems like it might be serious enough to merit cherry-picking it, if it's not in the stable queue
19:52:49 <waldi> no, it only applies to broadcast, which is used in exactly one location: dhcp server
19:53:53 <bwh> So many VM hosts?
19:53:53 <waldi> and it is in the review for next release
19:53:56 <bwh> OK
19:54:51 <carnil> whatever you want, I said to upload 6.16.4 to unstble, I can pick the commit if it already in the stable review vqueues, https://bugzilla.kernel.org/show_bug.cgi?id=220484#c28 though sounds like it is not yet
19:54:58 * carnil can check
19:55:04 <bwh> It is in the queues
19:55:12 <waldi> [PATCH 6.16 028/142] net: ipv4: fix regression in local-broadcast routes
19:55:13 <bwh> I don't know if it went out for release
19:55:17 <bwh> review
19:55:17 <carnil> ah that is the one I already picked
19:55:18 <bwh> OK
19:55:33 <carnil> [ Salvatore Bonaccorso ]
19:55:33 <carnil> * net: ipv4: fix regression in local-broadcast routes
19:55:41 <carnil> so will just add a bug closer before uploading
19:55:51 <waldi> good
19:56:13 <waldi> #topic AoB
19:56:48 <waldi> i started a secure boot policy for linux: https://salsa.debian.org/-/snippets/815, comments welcome
19:56:51 <bwh> Nothing from me
19:57:00 <KGB> 03linux 05debian/6.16/forky b71c3c6 06Salvatore Bonaccorso 10debian/changelog * Add Bug closer for #1113765 * 14https://salsa.debian.org/kernel-team/linux/-/commit/b71c3c6
19:57:33 <waldi> who wants to chair next week?
19:57:55 <carnil> since I had to pass it this week, I can try again for next week
19:58:03 <waldi> #action carnil to chair next week
19:58:12 <waldi> i have nothing else
19:58:19 <waldi> thank you all for joining
19:58:21 <carnil> me neither, just a thank you to waldi again :)
19:58:24 <waldi> #endmeeting