19:00:15 <carnil> #startmeeting
19:00:15 <MeetBot> Meeting started Wed Aug 14 19:00:15 2024 UTC.  The chair is carnil. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:15 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:00:31 <carnil> hello, anybody around for the meeting?
19:00:49 <waldi> i am
19:01:16 <carnil> \o/
19:01:54 <carnil> I have not much more than the usual going trough the open bug list, so let's start (maybe bwh is joining, some will concern him, e.g. initramfs-tools)
19:02:26 <waldi> sounds good
19:02:27 <carnil> #chair carnil waldi
19:02:27 <MeetBot> Current chairs: carnil waldi
19:03:01 <carnil> #topic initramfs-tools autopkgtests failures
19:03:35 <carnil> I wanted to ask on this actually bwh if he knows if there was some progress of Benjamin needs to be approached who has written those autopkgtests TTBOMK
19:03:46 <bwh> Hi, sorry, got carried away reading a bug report
19:03:46 <carnil> if bwh is not around we can skip this
19:03:51 <carnil> ah good hello
19:04:34 <bwh> I have not got anything done this week, sorry
19:04:50 <bwh> but we do have a bug report highlighting what went wrong in the initramfs-tools  autopkgtest
19:05:01 <bwh> so I think I know how to fix it
19:05:04 <carnil> bwh: I guess you are fine if we define again an action to have a look assigned to you?
19:05:08 <bwh> yes
19:05:40 <carnil> #action bwh will have a look at the initramfs-tools autopkgtest failures preventing testing migration
19:06:19 <carnil> there are two longer standing bugs to quickly look at:
19:06:34 <carnil> #topic #1072004: linux: regression in the 9p protocol in 6.8 breaks autopkgtest qemu jobs (affecting debci).
19:07:05 <bwh> I just updated that report - the fix is now upstream
19:08:01 <carnil> ok pefect, so that will likely flow automatically in the 6.11-rcX upload to experimental and into 6.10.y stable series as well
19:08:17 <bwh> Yes
19:08:34 <carnil> #topic #1050256: AppArmor breaks locking non-fs Unix sockets.
19:09:06 <carnil> for this just a status update: I pinged as well offlist again John. He mentioned "patches will be submitted for stable this week"
19:09:22 <carnil> so looking forward that the solution will flow in the next 6.1.106 update.
19:09:50 <carnil> I'm not very in favour of picking one of his proposed approaches and not waiting for this stable submission.
19:10:00 <bwh> OK
19:10:19 <carnil> Given the report is now almost one year old, I assume we continue to wait and then have it at some point. Or someone prefers to still try to push that more?
19:10:50 <bwh> No, let's wait for it to go through stable
19:11:20 <carnil> I will continue monitoring it and then close the bug once it hits 6.1.y for real and included in an update
19:11:36 <carnil> ok now to the longer list of bugs which are current
19:12:08 <carnil> #topic #1063754 fat-modules: SD corruption upon opening file on Linux desktop
19:12:23 <bwh> I'm still composing a reply to this one
19:13:06 <bwh> so, leave it with me
19:13:35 <carnil> ok, I was asking bcause the last reply from the reporter seems he got upset
19:14:01 <carnil> #action bwh is taking care of writing to the followup of the reporter of #1063754
19:14:29 <carnil> #topic #1076372 linux-image-6.5.0-0.deb12.4-amd64: ext4 file corruption with newer kernels
19:15:00 <bwh> Just looking at the last message, we now have a test case but we also know that it's hardware-dependent
19:15:29 <carnil> this was paritally with me last week. I followed up to the bug as we discussed last time (but I was late). Stefan provided more information on what it already did. He still wants to test other HW combinations.
19:15:35 <carnil> bwh: correct
19:16:01 <carnil> so here I would say we have no further actions for now and wait another round for Stefans. if nothing happens at the next meeting we might just do a re-ping.
19:16:10 <bwh> I agree
19:17:09 <carnil> #topic #1078168 initramfs-tools: failing autopkgtest prevents testing migration
19:17:17 <carnil> this is the one discussed above, so
19:17:43 <carnil> #action bwh takes care of handling #1078168: initramfs-tools: failing autopkgtest prevents testing migration
19:18:03 <carnil> I skip the next one as we discussed it now already
19:18:15 <carnil> #topic #1078702 Please re-add the AHCI driver in the cloud kernel
19:18:34 <carnil> waldi: I think this is best in your hands. I tried to get an idea why zigo says "re-add"
19:18:43 <carnil> but it was never added in the cloud images AFAIU
19:18:52 <carnil> but maybe I'm wrong.
19:18:59 <waldi> it was never
19:19:07 <carnil> Is it correct that this is out of scope for the images and can we reply so?
19:19:37 <waldi> yes. i'll respond
19:20:04 <carnil> #action waldi will respond to the #1078702 bug requesting addition of AHCI driver in the cloud kernel
19:20:07 <carnil> thanks waldi
19:20:53 <carnil> topic #1062421 linux-image-6.5.0-5-686-pae: [iwlegacy] kernel oops
19:20:59 <carnil> #topic #1062421 linux-image-6.5.0-5-686-pae: [iwlegacy] kernel oops
19:21:31 <bwh> I said I would investigate this and I haven't yet, so give me that as an action again
19:21:38 <carnil> Nothing new here in the upstream report, just Thorsten Leemhuis responded with hints how to report the regression
19:22:04 <carnil> #action bwh will investigate the #1062421 issue
19:22:28 <carnil> #topic #1078030 lpfc: lost all san paths
19:22:44 <carnil> waldi: we had last time as action that you might be a good one to ask the correct questions
19:23:10 <carnil> do you have time for it? Or should we try to redirect the reporter somewhere more specific? Any other ideas?
19:23:14 <waldi> yes, i did not manage to do that
19:24:33 <carnil> keep the action, or would you feel more to put it on hold?
19:24:49 <waldi> i'll keep the action
19:25:39 <carnil> #action waldi might figure out the questions to ask for tackling #1078030 and takes care to repond to the bug followup
19:26:25 <carnil> #topic #1013211 System freeze followed by kernel panic or blank screen
19:27:31 <carnil> an update on this one: this was on the list of bugs I did close as housekeeping, the reporter quickly responded back that the problem persist. I suggested to report the problem upstream. It seems reproducible under other distro kernels as well.
19:27:56 <carnil> so propose no action, but as a general note it seems worth to try to close older bugs and see to which reporters still respond :)
19:28:26 <bwh> Right. This seems like some weird hardware-specific problem that we can't debug
19:29:02 <carnil> #topic #1070159 i915: CPU usage spikes with monitor powered down or unplugged
19:29:18 <carnil> same story here: but in this case the reporter did already reported the issue upstream
19:29:26 <bwh> That got some response upstream but no fix proposed yet
19:30:11 <carnil> correct, reference: https://gitlab.freedesktop.org/drm/i915/kernel/-/issues/11919#note_2526367
19:30:36 <carnil> -> no action for now
19:30:59 <bwh> right
19:31:14 <carnil> #topic #1077827 even with [[featureset]] name = 'rt' enable = false in config.local/defines.toml, linux-headers-*-common-rt is still getting built
19:31:20 <carnil> I think we can close this?
19:31:26 <bwh> yes
19:31:35 <waldi> seems i forgot to close this
19:31:41 <iam_tj[m]1> waldi: Late to the party and catching up, but for 1078030 (Emulex LightPulse) could be an HBA firmware version; there is a known workaround for frame drop issues similar to that shown in the log
19:32:07 <carnil> #action close the bug as this not a Debian bug per se and modifications are pushed to the packaging
19:32:24 <carnil> #action close the bug #1077827 as this not a Debian bug per se and modifications are pushed to the packaging
19:32:46 <carnil> #topic #1078109 linux-image-6.10.3-amd64: No WiFi When Booting with linux-image-6.10.3-amd64
19:33:02 <carnil> turns out that it was the wl module not building here because of missed installation of the kernel-headers
19:33:39 <carnil> before closing the bug I wanted to ask about if someone has idea on what happened here behind the scene
19:34:02 <carnil> it might have been the usaal race between the signed packages not yet available, and maybe the user had installed manually the unsigned kernel images?
19:35:03 <waldi> i would assume the user does not have the headers meta package installed
19:35:03 <bwh> We could ask for a dpkg.log from that time if it's still present
19:35:42 <iam_tj[m]1> Those issues are often due to someone wanting to 'clean up' / 'tidy up' packages they think are not needed
19:35:53 <bwh> Actually, no the apt log would be more meaningful
19:36:50 <carnil> ok we might ask for this additional information.
19:36:55 <bwh> If someone wants to spend time investigating this they can, but I would ignore it unless we see multiple reports where linux-headers got uninstalled
19:38:10 <carnil> Let's close the bug then with a note that if logs form that time to further investigate the issue are still prepsent it is welcome to attach it to the bug, but other than that we think the bug can be closed
19:39:20 <carnil> #action carnil does a final followup to #1078109 asking if apt logs form that time are still  present and close the bug
19:39:35 <carnil> #topic #980555 Missing ec_sys module
19:39:43 <carnil> I need help with this one
19:40:01 <carnil> I closed it beeing an old bug, and with our rationale that it looks more as a debugging and development help
19:40:11 <carnil> bakc from the time as question from waldi
19:40:19 <iam_tj[m]1> I think the upstream links are quite clear; the functionality should be integrated into the appropriate driver
19:40:20 <carnil> one of the contributors disagrees
19:40:45 <carnil> but I think we stay on our position and would not enable it. So tag it wontfix, add again this rationale and close it again?
19:40:55 <carnil> (suspect it will be reopened though)
19:41:28 <iam_tj[m]1> I read through all the threads earlier in the week and it the module can poke the hardware directly from userspace and is said to potentially be able to open up security holes
19:41:55 <bwh> Sure, but this is in debugfs which becomes read-only if Secure Boot is enabled
19:42:17 <bwh> and is root-only otherwise
19:42:26 <bwh> unless this driver does something very wrong
19:42:37 <iam_tj[m]1> There was also some good upstream sub-system maintainer support for integrating functionality this can be used to affect into the appropriate driver
19:43:46 <bwh> That's obviously what should happen long-term. I think the question is whether it is useful to let people experiment using this before doing so
19:45:20 <bwh> This comment is interesting: https://bugzilla.redhat.com/show_bug.cgi?id=1943318#c12
19:46:49 <iam_tj[m]1> bwh:  personally I'd enable it but that is because I always want to tinker!  Also, Ubuntu has it enabled and I don't recall seeing any complaints about it being abused there
19:47:56 <iam_tj[m]1> bwh: he follows up in comment #19 though, when told it is in the kernel-debug package 🙂
19:48:13 <carnil> does someone wants to have a closer look if it would be safe to enable for our Debian builds?
19:48:16 <bwh> right, so seems like Fedora does have it as an option
19:48:25 <bwh> carnil: I will try to do that
19:48:35 <carnil> Thank you Ben
19:48:44 <bwh> (I just had a look and it is really tiny...)
19:49:11 <carnil> #action bwh will try to have a closer look for #980555 and if it's safe to enable the module build in Debian.
19:49:47 <carnil> so we are almost running out of time, let's skip the next two bugs and just mention the IPU6 support one
19:49:58 <carnil> #topic #1078170 linux-image-6.10.3-amd64: Please enable CONFIG_VIDEO_INTEL_IPU6 for Intel IPU6 based webcams
19:50:10 <carnil> there is as well a proposed merge request for this.
19:50:36 <carnil> I asked the merge request author if he could test the combination of enabled config options to verify support works
19:50:50 <carnil> but other than that and the missing descriptions of the changes it should be fine
19:51:33 <carnil> Merge request: https://salsa.debian.org/kernel-team/linux/-/merge_requests/1157
19:51:39 <bwh> I will look at the MR at some point, but I don't promise it will be this week
19:51:55 <carnil> ok thanks
19:52:12 <carnil> along with the 6.11-rcX upload for experimental I guess?
19:52:21 <carnil> or can the later happen earlier already?
19:52:58 <bwh> I need to fix the blhc complaint for 6.11. If I have time I will go through relevant MRs before uploading.
19:53:04 <carnil> https://salsa.debian.org/kernel-team/linux/-/merge_requests/1153 there are tough failures from blhc test, but not looked exactly
19:53:14 <carnil> bwh: ok thank you
19:53:49 <carnil> #action bwh will try to go along those MRs (but no promise) before uploading 6.11 if time permits
19:53:56 <carnil> not perfectly formulated, sorry
19:54:03 <carnil> #topic AOB
19:54:13 <carnil> anything else or some other comments?
19:54:14 <waldi> nothing from me
19:54:37 <bwh> Nothing from me
19:54:40 <carnil> waldi: are you taking the chair for next week (meeting on Jitsi)?
19:55:14 <waldi> i will do that
19:55:18 <carnil> thank you
19:55:28 <carnil> so thanks all for contributing to todays meeting
19:55:46 <bwh> Thank you for chairing
19:56:02 <carnil> #endmeeting