#debian-kernel Meeting
Meeting started by rperier at 18:33:28 UTC
(full logs).
Meeting summary
- 
  - meeting agenda at
    https://salsa.debian.org/kernel-team/kernel-team/wikis/meetings
    (ana,
    18:35:28)
 
  - meeting agenda at
    https://salsa.debian.org/kernel-team/kernel-team/wikis/meetings
    (bwh,
    18:37:44)
 
 
- Feedback from DebConf 18 (bwh, 18:37:52)
  - ACTION: bwh to send
    list of interesting DebConf talks (bwh,
    18:43:59)
 
 
- What is the focus for buster? what is the targeted version and features? (bwh, 18:44:40)
  - AGREED: We will use
    Linux 4.19.y in buster (bwh,
    18:48:58)
 
  - ACTION: Corsac will
    review kconfig options for hardening (bwh,
    18:52:34)
 
  - ACTION: bwh to review
    kconfig options in general (bwh,
    18:54:57)
 
 
- What is the state of the next (pending) stretch 9.6? Do we bump firmware-nonfree? (bwh, 18:58:33)
  - ACTION: bwh to review
    MR for 4.9.130 in stretch (bwh,
    19:00:07)
 
  - https://www.openwall.com/lists/oss-security/2018/10/02/2
    should probably first released as well as DSA, then mergend (carnil,
    19:00:10)
 
  - ACTION: bwh/carnil to
    upload linux to stretch (bwh,
    19:00:29)
 
  - ACTION: bwh to apply
    relevant security fixes to firmware-nonfree/stretch and
    upload (bwh,
    19:04:35)
 
  - https://security-tracker.debian.org/tracker/source-package/firmware-nonfree
    issues look bad indeed (Corsac,
    19:04:56)
 
 
- Management of stretch-security and stretch-pu updates (timing, ABI bumps, changelogs...) (bwh, 19:11:34)
  - ACTION: Team should
    rebase and upload to stable-pu at least once a month (bwh,
    19:23:43)
 
 
- Can we improve handling of embargoed updates? (bwh, 19:34:53)
  - https://oss-security.openwall.org/wiki/mailing-lists/distros#handling-of-embargoed-information
    (jcristau,
    19:42:02)
 
  - https://oss-security.openwall.org/wiki/mailing-lists/distros#handling-of-embargoed-information
    (Corsac,
    19:42:11)
 
  - ACTION: bwh to create
    Salsa group for embargoed updates (bwh,
    19:46:43)
 
 
- Do we close old bugs for kernel < a specific version ? (for very old kernels) (bwh, 19:50:01)
  - ACTION: rperier will
    triage older bugs (bwh,
    19:54:43)
 
 
- Potential use of dgit & git-debrebase (bwh, 20:01:17)
  - https://debconf18.debconf.org/talks/60-git-debrebase-new-tool-for-managing-debian-packaging-in-git/
    (bwh,
    20:06:03)
 
  - https://salsa.debian.org/benh/linux/tree/use-dgit
    (bwh,
    20:07:44)
 
  - ACTION: bwh to create
    linux-with-dgit repo under kernel-team for team to experiment
    with (bwh,
    20:16:14)
 
  - ACTION: bwh to send
    mail to debian-kernel explaining workfow changes for linux-with-dgit
    repo (bwh,
    20:16:30)
 
 
- Create a shared roadmap for the current development release that contains all the expected technical goals or actions to complete until the next release (in addition to existing opened bugs) (bwh, 20:17:34)
  - ACTION: Corsac and
    waldi to create issues/milestones on Salsa for planned work
    (bwh,
    20:27:23)
 
 
Meeting ended at 20:32:52 UTC
(full logs).
Action items
  - bwh to send list of interesting DebConf talks
 
  - Corsac will review kconfig options for hardening
 
  - bwh to review kconfig options in general
 
  - bwh to review MR for 4.9.130 in stretch
 
  - bwh/carnil to upload linux to stretch
 
  - bwh to apply relevant security fixes to firmware-nonfree/stretch and upload
 
  - Team should rebase and upload to stable-pu at least once a month
 
  - bwh to create Salsa group for embargoed updates
 
  - rperier will triage older bugs
 
  - bwh to create linux-with-dgit repo under kernel-team for team to experiment with
 
  - bwh to send mail to debian-kernel explaining workfow changes for linux-with-dgit repo
 
  - Corsac and waldi to create issues/milestones on Salsa for planned work
 
Action items, by person
  -  bwh 
    - bwh to send list of interesting DebConf talks
 
    - bwh to review kconfig options in general
 
    - bwh to review MR for 4.9.130 in stretch
 
    - bwh/carnil to upload linux to stretch
 
    - bwh to apply relevant security fixes to firmware-nonfree/stretch and upload
 
    - bwh to create Salsa group for embargoed updates
 
    - bwh to create linux-with-dgit repo under kernel-team for team to experiment with
 
    - bwh to send mail to debian-kernel explaining workfow changes for linux-with-dgit repo
 
  
 
  -  carnil 
    - bwh/carnil to upload linux to stretch
 
  
 
  -  Corsac 
    - Corsac will review kconfig options for hardening
 
    - Corsac and waldi to create issues/milestones on Salsa for planned work
 
  
 
  -  rperier 
    - rperier will triage older bugs
 
  
 
  -  waldi 
    - Corsac and waldi to create issues/milestones on Salsa for planned work
 
  
 
People present (lines said)
  - bwh (134)
 
  - Corsac (70)
 
  - waldi (38)
 
  - rperier (34)
 
  - carnil (21)
 
  - jcristau (11)
 
  - ukleinek (6)
 
  - vagrantc (6)
 
  - MeetBot (3)
 
  - Mithrandir (2)
 
  - ana (2)
 
  - Cryptobytes (1)
 
Generated by MeetBot 0.1.4.