12:07:46 <apo> #startmeeting
12:07:46 <MeetBot> Meeting started Sat Aug 17 12:07:46 2013 UTC.  The chair is apo. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:07:46 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
12:08:05 <apo> Hi all, welcome to our little Games Team meeting
12:08:06 <Baby> I've already sent an email to the least from this morning's BoF here in Vaumarcus
12:08:11 <apo> #topic Introduction
12:08:26 <apo> who is who, please introduce yourselves
12:08:45 <Baby> who starts?
12:08:57 <apo> you :)
12:09:00 <Zhenech> you
12:09:13 <arand> Hmm, oh, seems I happened to check IRC at the right time :)
12:09:18 <mongrol> irc is sequential, does it matter?
12:09:35 <Baby> :P
12:10:03 <apo> Hi, my name is Markus Koschany, I have updated some games for the team and introduced FreeOrion, Bullet, Drascula and Lure of the Temptress already!
12:10:23 <Baby> well I'm Miriam, I'm in Vaumarcus atm and I'm this ex-blonde girl who has been involved in the team for a while :)
12:10:37 <Calinou> le games meeting
12:10:47 <Sicness> Hi, my name is Anton Balashov. I'm a maintainer of curseofwar package and a new team member
12:11:02 <Baby> welcome :)
12:11:08 <bdefreese> Welcome
12:11:09 <Sicness> Thx )
12:11:18 * pabs Paul Wise, maintaining warzon2100, some art games and a board game. initiated some things like IRC meetings and thought up some ideas like work/screenshots parties
12:11:19 <ansgar> I'm Ansgar. I maintain also a few games in the team, but am not that active.
12:11:24 <mongrol> G'day, I'm Steve Hamilton, adopter of Powder (roguelike) and packager of Mr Rescue. New team member.
12:11:27 <arand> Martin Werner, I'm somewhat inactive at the moment, but I maintain redeclipse, lugaru(openlugaru) and lierolibre.
12:11:30 <ansgar> I spend too much time with other stuff :)
12:11:31 * pabs semi-inactive
12:11:54 <berenm> Hi, Beren Minor here and I've been invited by Paul Wise to the team a few weeks ago to help maintaining GemRB
12:11:54 <bdefreese> I am Barry deFreese.  I am just a clean up man because I don't know anything.. :)
12:12:01 <apo> ^^
12:12:22 <Baby> :)
12:12:25 <bdefreese> Welcome mongrol berenm
12:12:29 <Zhenech> he is also bdefreese who is to ask about hurd fuckup, even if he does not know thing
12:12:30 <mongrol> ta
12:12:49 <bdefreese> heh
12:13:30 <Zhenech> I'm Evgeni Golov, waaaay to inactive in the last time, maintaining pokerth and some other small things :)
12:13:51 <debianer_> Hi, I´am new at Debian (since one year) and I´ve done some work on the wiki page: https://wiki.debian.org/Games/Suggested
12:14:14 <Baby> cool :)
12:14:17 <arand> debianer_: welcome
12:14:24 <apo> it seems more people are present than expected, but Bas and Vincent Prat seem to be missing and Stephen
12:14:34 <bdefreese> Welcome debianer_
12:14:35 <apo> anyway welcome on board everyone
12:15:09 <apo> ok let's move to our first agenda topic
12:15:19 <apo> #topic New member recruitment
12:15:32 <Baby> can someone send the log later to the list or something, or making some minutes, in case someone else wants to read it afterwards?
12:15:54 <pabs> meetbot is doing that :)
12:15:54 <MeetBot> pabs: Error: "is" is not a valid command.
12:16:00 <apo> I will link the log on this page later, https://wiki.debian.org/Games/Meetings/2013-08-17
12:16:21 <Baby> lol
12:16:25 <Baby> thanks pabs
12:16:34 <Baby> thnaks apo :)
12:17:14 <apo> ok, we are always looking for new members. But what can we do to find even more vic..ehm members?
12:17:46 <apo> I thought about posting "advertisements" in game forums to make the Games Team more visible to the community
12:17:58 <bdefreese> Well first could we say what the "team" actually means?  A group of individuals maintaining their pet packages is no "team" IMWO
12:18:08 <apo> that's true!
12:18:31 * Baby nods
12:18:34 <mongrol> good point, what does it mean?
12:18:50 <mongrol> I've yet to get any packages sponsored so I'm not sure where the "team" bit is
12:19:17 <bdefreese> mongrol: Sorry, hit me up in IRC for sponsoers, I have a hard time keeping up with e-mail. :(
12:19:28 <mongrol> np
12:19:35 <Baby> yup, I don't think we're doing too well in that sense, sponsoring and mentoring, mea culpa too
12:19:41 <bdefreese> To me, it means if I have a package and haven't taken care of it or if someone can fix a bug in my package, please update/upload/etc
12:19:42 <debianer_> i think the point is: first we need more people, who package games for debian
12:19:54 <Calinou> as if packaging was too easy, and games were too free
12:19:59 <Calinou> (@debianer_)
12:20:10 <Calinou> and as if FOSS games had too many players
12:20:17 <mongrol> as a n00b, I've taken to looking at all the teams packages and fixing up what I can, leanring as I go.
12:20:38 <mongrol> so I have the view that we don't have "pet" packages as such, but we're free to improve any of the packages under our tag
12:20:38 <apo> From the point of new of a newcomer: I think a team is more inviting if we have a working sponsors queue, at least we should have sponsors for fixing RC bugs
12:20:43 <apo> view
12:20:52 * pabs goes to DebConf13 lightning talks
12:20:55 <arand> My impression, and how the the games team has helped me is: finding sponsors, finding help on game-specific topics, and getting patches from helpful team members.
12:20:58 <pabs> bye folks
12:21:08 <bdefreese> debianer_: Agreed to a point.  However, we have a ton of games already that are not being maintained well so are we just compounding the problem if we keep adding new members/packages?
12:21:16 <bdefreese> Later pabs
12:21:19 <apo> bye
12:21:35 <Baby> I think there are still a lot of new games that need to be added
12:21:41 <bdefreese> mongrol: That is my thought as well.  However, some do get touchy if you touch their packages.
12:22:11 <mongrol> let's not get off track
12:22:24 <bdefreese> Hence apparently why we stopped the "Team Uploads" ??
12:22:25 <berenm> if there are ton of games to maintain, wouldn't it worth it to try prioritize them, like by popularity ?
12:22:52 <mongrol> there's been a resurgence in linux gaming sites recently, we should "infiltrate" their ranks and pilfer victims
12:22:52 <Baby> you mean manually or automatically? like sorted by popcon?
12:22:53 <debianer_> bdefreese all: Is the main problem that we have enough people, who maintain games in debian, but not in the games team?
12:23:07 <mongrol> lgdb.org, linuxgamingnews.com, rootgamer.com
12:23:17 <mongrol> all very active and LGN in particular has a community gathering
12:23:56 <debianer_> Baby: I agree with you :)
12:24:01 <bdefreese> debianer_: No, I don't think so.
12:24:57 <berenm> not sure how to prioritize, and it's maybe a subjective feeling, but for example I was very surprised not to find an active gemrb package already, whereas it's a must-have if you want to play Baldurs Gate game series
12:25:11 <mongrol> arf, gamingonlinux.com is the growing one
12:25:17 <berenm> although it was very easy to package, working very well, with an active upstream
12:25:20 <arand> berenm: Since it's volunteer work, priorities tends to land on games that the maintainers are interested in, not necessarily those which are popular (though it can often correlate).
12:25:33 <bdefreese> I think we all have different strengths and weakness and we need to play off of those.  For example, I touch a lot of packages but I am not a hardcore developer and my time is limited to small chunks.
12:25:52 <bdefreese> arand: Exactly
12:26:05 <Baby> I think that we're lacking more coordination than anything else
12:26:10 <bdefreese> Yep
12:26:32 <berenm> arand: sure but I would guess that maintaining a game that people actually play is more rewarding and more useful
12:26:41 <Baby> so any suggestion on how to improve coordination inside the team?
12:26:45 <pabs> shall we hire Anreas Tille?
12:26:58 <mongrol> appoint a leader
12:27:03 <apo> bdefreese: yeah, but you are one of the people who get a lot of things done, you have fixed so many packages in the past two months, I think we just need 1-3 more DDs who can sponsor the work of other team members
12:27:05 <berenm> and the debian game team, as a team, should probably focus on games that Debian users would like to play, not games that maintainers like to play on their side
12:27:52 <Baby> maybe we could benefit of having someone coordinating, that would also be a good place to have someone who could help Debian in a different way than packaging
12:28:00 <mongrol> hold up, aren't we drifting off the agenda topic?
12:28:05 <Baby> yup
12:28:12 <arand> AS
12:28:15 <arand> ups
12:28:37 <apo> true, the questions is how can we attract more people for the games team but also how can we attract more sponsors who help with sponsoring?
12:29:09 <mongrol> ok, for new members I suggest promoting the games team within the currently growing linux gaming ecosphere
12:29:10 <apo> I think having sponsors is crucial to every team
12:29:29 <bdefreese> Agreed.
12:29:37 <Baby> for promoting the team, some things were debated this morning, I sent an email to the list about it
12:29:42 <Calinou> mongrol: linux non-free gaming ecosphere*
12:29:53 <mongrol> there are a number of sites popping up and while this is on the back of Steam, they are still covering FOSS gaming and growing the community
12:29:56 <Calinou> FOSS games are getting more and more hated on, this is a serious issue
12:30:02 <arand> As for reqruiting, I think that the most effective is to try to pull in people from upstream, I'm not sure if such "outreach" could be improved somehow?
12:30:13 <debianer_> Are any DDs here?
12:30:15 <Baby> more hated on in what sense?
12:30:18 * Baby is DD
12:30:25 <Calinou> read random forums, reddit, and such
12:30:28 <bdefreese> But we need to attract some generalists too that don't mind working with multiple packages, not just their pets
12:30:35 <bdefreese> Baby: Don't feed the troll
12:30:36 <debianer_> When we need some sponsors and the other DDs do some other work for debian (not sponsoring packages) - why not somebody of you become a DD for sponsoring packages?
12:30:38 <bdefreese> debianer_: I am a dd
12:30:39 <Calinou> also look at the amount of players, we don't have more than before
12:30:50 <Calinou> bdefreese: trollcalling is 1) an insult, 2) ad hominem
12:31:02 <Calinou> insults are bad. don't do them
12:31:03 <apo> Calinou please stop that, thank you
12:31:06 <mongrol> in the interests of bedtime, I'll take an action to audit potential sites to promote on, and knock up a promotion draft.
12:31:12 <Calinou> apo: what do you have against me?
12:31:13 <bdefreese> Calinou: Sorry, I don't like to be mean but you bring nothing to this group.
12:31:14 <Baby> they are free to choose anything differnent than Free Software, we can't fight that
12:31:16 <ansgar> debianer_: There's the danger of ending up doing other stuff once you are a DD too ;)
12:31:29 <bdefreese> Aye
12:31:49 <apo> #action mongrol  take an action to audit potential sites to promote on, and knock up
12:31:52 <apo> a promotion draft.
12:31:53 <apo> ups
12:32:09 <bdefreese> I well tell you that part of the problem I have a sponsor is not knowing who is actually on our team when e-mails come through.  Hence why I prefer IRC
12:32:18 <Baby> I think we should concentrate of providing the best games we can, in the best conditions we can, and promoting that
12:32:31 <Baby> outside of that scope, I don't think it's in our hands
12:32:40 <bdefreese> Plus I don't know if someone is already looking at it, so to Baby's point about coordination
12:32:53 <apo> #action mongrol will take an action to audit potential sites to promote on and knock up a promotion draft
12:32:59 <arand> That's true, gaming sites might be good to attract generalists, whereas upstream projects is for specialsts :) I guess
12:33:00 <mongrol> another target I think is to encourage upstream to package there games for debian.
12:33:24 <Baby> some are already doing for Ubuntu
12:33:25 <debianer_> ansgar: Yes. But I think we need DDs who only or most sponsor games packages.
12:33:32 <Baby> if we had Debian PPAs , that would help
12:33:39 <apo> #info encourage upstream to package their games for debian
12:33:48 <ansgar> Baby: PPAs would help with?
12:34:02 <Baby> upstream packaging their games for debian
12:34:23 <Baby> many are already doing that for Ubuntu
12:34:25 <ansgar> Ah, those might take ${longtime} until we get them.
12:35:06 <Baby> so, how do we improve coordination, or how do we manage to get a person who can act as coordinator?
12:35:34 <apo> I think the mailing list is a good place for coordination
12:35:34 <mongrol> vote?, nominations?
12:35:54 <mongrol> role of coordinator needs to be defined
12:36:14 <Baby> after being in contact with communities like mozilla, gnome or ubuntu, I think that a person doing that task explicitly might help
12:36:41 <Baby> and it might be a task that a non-coder might be able to do quite successfully
12:36:53 <mongrol> speaking as a new team member, having someone tell me what to do would be beneficial
12:37:02 <bdefreese> I would be glad to but I don't think I can commit the time.  My RL job may take me out of pocket for long periods. :(
12:37:35 <bdefreese> mongrol: I can give you plenty to do. :)
12:37:50 <Baby> well, we don't need to have an answer right now, it might just a thing to think about
12:38:33 <apo> #info does the team needs a coordinator who steers the team?
12:38:41 <Baby> so we need: a) more coordination b) a better sponsoring workflow
12:38:48 <debianer_> yep
12:39:07 <apo> agreed
12:39:52 <Baby> maybe the sponsoring workflow might benefit from peer reviewing, that is the most time consuming part for me when sponsoring something
12:40:07 <bdefreese> Is there any type of e-mail integration with the wiki?  It's hard to remember to check the wiki and there is so much stuff intermingled in the mentors ML stuff gets lost to me
12:40:25 <ansgar> bdefreese: You can subscribe to wiki pacges and get mail when they change.
12:40:46 * mongrol points at the topic
12:40:55 <bdefreese> Ah, OK, maybe I should do that.  Are people actually using the queue?
12:40:58 <Sicness> "encourage upstream to package their games for debian" everyone wants to package his game for Ubuntu. And there is only one way to get in official Ubuntu - via Debian. We gets new members here. Maybe we should inform some them how what that can easy do the same for Debian -> Ubuntu.
12:41:32 <mongrol> as in if you target Debian you get Ubuntu for free
12:41:39 <Baby> yup
12:41:46 <Nemoder> Hi, I'm only a debian user here but I wanted to mention something that's been a problem for some time: multiplayer game packages lag behind upstream so often that they are mostly unplayable on the majority of servers.  Has the game team put any thought into hosting their own servers to be compatible with debian versions and possibly using that as a recruitment tool?
12:41:47 <bdefreese> Sicness: Aye, that is another thing we need to tackle.  The perception that it is hard to get stuff into Debian.  Which in many cases is true. :(
12:42:36 <debianer_> Nemoder: When you are using stable, you can use the backports.
12:42:44 <Zhenech> Nemoder, i did so with pokerth, but the traffic was extremely low on them
12:43:01 <Baby> Nemoder: Even though the idea is very attractive, I don't think anyone has already stepped in offering to manage the servers needed for that
12:43:13 <apo> ok, thanks for the brainstorming so far.
12:43:20 <mongrol> another idea. Is it possible to reach out to community members of popular games (e.g. Xonotic) to help packaging of their fave title
12:43:21 <Zhenech> debianer_, not always, sometimes you need a new heavy lib and thats not really backportable
12:43:36 <Nemoder> debianer_: even with backports or expirimental they are often too far behind as upstream updates daily and most of the other platforms update directly from upstream
12:43:52 <Nemoder> well maybe not daily, but often enough to be an issue
12:43:55 <apo> let's summarize this topic and define tasks how we can improve the whole "new member recruitment" process
12:44:11 <Baby> as a side note
12:44:37 <Baby> we might want to coordinate ourselves with the currently being created welcoming team
12:45:05 <bdefreese> Is that going anywhere?
12:45:15 <Baby> it seems so
12:45:29 <Baby> at least the efforts that are being put on that seems reasonable
12:45:42 <apo> #idea we might want to coordinate ourselves with the welcoming team
12:46:02 <Baby> paulproteus is leading that, and I'm involved in the welcoming team too
12:46:22 <bdefreese> Cool
12:46:35 <Calinou> mongrol: I guess few players would know how to help?
12:47:08 <mongrol> cal: I'm talking about modding communities. These guys are usually very technical
12:47:38 <Baby> my impression is that if we kept making some noise about the team (weekcly news?) and provided a comfortable entry path and sponsoring process, that would be all we needed to get many more people
12:48:18 <mongrol> agreed, "comfortable entry path and sponsor process" needs work
12:48:27 <bdefreese> In fairness to Calinou he does have a point about games in general.  Many of the "cool" games would need to go into contrib/non-free which is inherently against what Debian stands for.  Do we want to promote that?
12:48:36 <debianer_> weekly need sounds great :)
12:48:48 <debianer_> but somebody must create them
12:48:54 <apo> Baby: I agree. I volunteer to help you with reviewing packages.
12:48:57 <bdefreese> We need a non-developer media person. :)
12:49:10 <debianer_> who had contact with the packaging status of the games
12:49:24 <Baby> apo: thanks!
12:49:39 <Baby> bdefreese: yup, that would be the best
12:49:43 <apo> #action apo helps with reviewing team maintained packages
12:50:02 <debianer_> you who had contact with the packagers, so he knows the packaging status**
12:50:03 <captnfab> (hi games-team) I was wondering, is there a community of debian gamers? There are a lot of communities/forums of debian users, which naturally produces/selects powerusers, but isn't that the kind of thing that would be of great help to the game team ?
12:50:13 <mongrol> while I'm talking to the news sites I'll enquire as to their appetite for news updates
12:50:30 <captnfab> this would ensure the arrival of newcommers and give to the team a feedback about the games
12:50:45 <bdefreese> BTW, is there a good place we can post tasks?  To mongrol's point, I have a bunch of things that I could use help on but not sure where to put them.  IRC seems to be mostly quiet most of the time. :(
12:51:17 <mongrol> a kanban wall!
12:51:26 <Baby> bdefreese: we would need something for that, wiki doesn't seem to work too well for that
12:51:44 <mongrol> doesn't alioth handle tasks/assignment?
12:51:47 <apo> bdefreese: I'm reading the list and it is far easier for me to follow mails than to observe the IRC channel. Why don't we simply use the list for all coordination work?
12:52:18 <bdefreese> apo: Understood but ML's aren't real-time enough sometimes :(
12:52:47 <Baby> bdefreese: maybe we could setup something in alioth, we can put code there right?
12:52:57 <bdefreese> Yep
12:53:11 <Baby> and it shouldn't be that difficult
12:53:27 <ansgar> Alioth has a issue tracker.
12:53:34 <ansgar> Or one could be lazy and use a Wiki page.
12:53:51 <Baby> the wiki we have tried using for some time
12:53:54 <Zhenech> gforge issue tracker is… wiki is better
12:54:02 <Baby> I don't have the feeling that it's the best tool for that
12:54:24 <ansgar> Installing application on Alioth is sometimes not so great as people tend not to update them.
12:54:42 <ansgar> And then one ends with Wikis full of spam there (random example).
12:54:54 <Zhenech> ask don to get us a pseudopackage at bugs.d.o?
12:54:57 <mongrol> whats wrong with the issue tracker?
12:55:21 <Zhenech> mongrol, i always saw it as an unusable piece of website
12:55:26 <Zhenech> maybe its just me
12:55:35 <mongrol> fair enough, I've never seen it used
12:55:38 <Baby> I never tried it
12:56:07 <bdefreese> I don't necessarily mean code I just wants tasks.  For example, I have "I need help updating pyracerz to create a local config file."
12:56:20 <Baby> yup, tasks don't mean code
12:56:39 <bdefreese> Or "Fix dawn to not use fixed paths for data"
12:56:46 <bdefreese> :)
12:56:51 <Baby> and for example the tasks I need for debian kids, mostly of them don't involve code at all, it might be the same for tasks here
12:56:55 <bdefreese> mongrol: There is two ^^ ;-)
12:57:12 <ansgar> bdefreese: That's bugs.d.o stuff? :)
12:57:14 <mongrol> bugs or tracker
12:57:32 <apo> #info use an issue tracker or wiki page to coordinate tasks within the team
12:57:49 <mongrol> someone take an action to investigate the best fit?
12:58:04 <bdefreese> ansgar: dawn isn't in the repo yet so can't use bugs :(
12:58:36 <apo> mongrol: yeah, that would be great. Any volunteers for setting up a issue tracker or to investigate if this is useful for the team?
12:59:24 <apo> not all at once ^^
12:59:41 <mongrol> I'll do it if noone else does
12:59:50 <mongrol> might not have rights though, will need to hassle admin
13:00:09 <Zhenech> what kind of rights do you want? :)
13:00:23 <Baby> something lightweight like mantis might do
13:00:27 <ansgar> bdefreese could enable Alioth's issue tracker :)
13:00:30 <Baby> doesn't need to be too big
13:00:55 <ansgar> Baby: I'm sure Alioth admins will be much happier if there's no custom stuff installed. :)
13:00:56 <mongrol> ok, leave it with me
13:01:01 <Baby> but maybe trying to work on tickets for coordination might work
13:01:13 <ansgar> Also, most issue trackers would need db access.
13:01:25 <apo> #action mongrol investigates if a issue tracker is useful for team, team DDs support him where necessary
13:01:35 <Baby> in any case, I'd prefer it to be easy, simple and lightweight
13:01:41 <Baby> no bugzilla please :P
13:01:46 <mongrol> doh!
13:01:56 <Zhenech> jira? :)
13:01:56 <apo> ok folks, what about moving to the next topic?
13:02:05 <Baby> jira would work
13:02:24 <debianer_> great idea
13:02:43 <Zhenech> Baby, nooooooooooooooooo
13:02:49 <Baby> :P
13:02:59 <ansgar> github :>
13:03:00 <apo> #topic Release goal for Jessie
13:03:36 <apo> A team release goal for Jessie would be nice. What should be our goal?
13:03:37 <Baby> one of my goals since a lot of time would be to move as much packages as possible to xdg base directory standard
13:03:56 <bdefreese> ++
13:04:04 <debianer_> We need some great games (e.g. Xonotic, Speed Dreams) in Debian Jessie :)
13:04:05 * SynrG blinks
13:04:05 <Baby> which might not be an easy task to do for some games, but might be a valid goal for say 80%
13:04:17 <Baby> SynrG: hi! :)
13:04:20 <bdefreese> That's what I want to do with gravitywars and pyracerz
13:04:36 <SynrG> Baby: hi. kinda waiting for the blends topic :)
13:04:39 <bdefreese> But I don't know that I have the skills :(
13:04:52 <Baby> SynrG: we're finally taking over debian-jr :)
13:05:08 <Baby> bdefreese: I can help you with that
13:05:10 <SynrG> Baby: yay :)
13:05:19 <Baby> bdefreese: I already did that for many games
13:05:20 <ansgar> SynrG: Will it blend?
13:05:29 <SynrG> ahaha. well
13:05:36 <bdefreese> Baby: You haven't exactly been around until recently ;-P
13:05:47 <Baby> bdefreese: I know I haven't
13:06:02 <Baby> but I guess this is not the place nor the time to say my reasons :)
13:06:10 <bdefreese> I was gone for close to two years too :(
13:06:15 <Zhenech> mongrol, you should have tracker admin rights now
13:06:21 <apo> #info move as much packages as possible to xdg base directory standard
13:06:37 <mongrol> thyanks
13:06:44 <Baby> lets say that for some personal reasons I was quite demotivated for some time
13:07:09 <bdefreese> I hear ya
13:07:17 <apo> I'm in favour of choosing an easy, doable and concrete release goal, something like, adding desktop and menu files to every team maintained package, add screenshots to every game package and so on
13:07:28 <Baby> and debtags
13:07:31 <apo> !
13:08:07 <bdefreese> apo: That is some good stuff for new members!
13:08:19 <apo> bdefreese: absolutely :)
13:08:28 <Baby> would translations fit in there too?
13:08:52 <apo> Baby: yes, that might be more complicated to realize though
13:09:09 <SynrG> since you mention debtags, and debian-jr at the same time, revive the OpenRatings idea?
13:09:17 <bdefreese> Aye, I only know very little Spanish and Bulgarian :)
13:09:23 <Baby> yup, I know, we've already done that with some games, like hex-a-hop for exampke
13:09:32 <Baby> SynrG: absolutely
13:09:35 <SynrG> https://wiki.debian.org/OpenRating
13:10:07 <Baby> just for the record, my latest vocabulary is available at http://miriamruiz.es/tags/
13:10:17 <Calinou> about screenshots, I could help, I did a few already.
13:10:20 <Calinou> (minetest)
13:10:34 <mongrol> I'm fading, bedtime for me
13:10:41 <mongrol> cya folks
13:10:56 <apo> do we all agree that we should make this a release goal (adding screenshots, debtags, desktop and menu files to all packages) ?
13:10:59 <bdefreese> Gnight mongrol, thanks
13:11:04 <apo> bye mongrol
13:11:14 <bdefreese> apo: Sure.
13:11:42 <Baby> SynrG: though the OpenRating project, I've started to move it again inside debian-jr
13:11:55 <Rhonda> hmm, solveig not here anymore …
13:12:01 <apo> #agreed Release goal for Jessie 1: Add screenshots, debtags, desktop and menu files to all team maintained packages
13:12:57 * SynrG nods
13:13:15 <apo> does anybody know how we can easily find packages which have no desktop and menu files or do we have to dig through all of them manually?
13:13:47 <Baby> I don't know, but I can find out
13:13:58 <Baby> I did something similar years abou about fonts
13:14:11 <Rhonda> The manually digging through them can be automated if we have a list of binary package names.
13:14:14 <Sicness> maybe there is lintian db reports?
13:14:15 <apo> #action Miriam finds out how we can easily track packages without desktop and menu files
13:14:43 <bdefreese> Oh yeah, UDD may have lintian output also
13:14:55 <Sicness> I mean it's a lintial warning
13:14:56 <bdefreese> But I don't think lintian complains about no desktop file does it?
13:15:07 <Sicness> does AFAIK
13:15:09 <Baby> no, I don't think it does
13:15:12 <Baby> it does?
13:15:18 <Baby> never noticed it
13:15:23 <bdefreese> Aye, I think it is ionly if it is broken or missing tags
13:15:26 <Sicness> I can be wrong
13:15:53 <apo> I would like to use http://screenshots.debian.net/packages/games_without_screenshots for finding packages without screenshots? How can we omit packages which doesn't need screenshots like libraries or -dbg packages?
13:16:10 <Baby> when goneri was still in the team, I kind of remember he suggested adding our own lintian rules
13:16:19 <Baby> but I kind of have no clue about how that's done
13:16:38 <Zhenech> thats easy
13:17:05 <Baby> apo: maybe having some script analizing the dependencies?
13:17:21 <Baby> from the dependencies, it's easy to see if it's console or not
13:17:24 <Sicness> api, we can write easy script that will search menu files in git.debian.org and will report about packages without they
13:17:43 <Sicness> apo* )
13:17:53 <apo> Sicness: are you interested in writing such a script?
13:18:07 <Sicness> I think so..
13:18:14 <Sicness> I can )
13:18:34 <apo> Sicness: that's great, just ask for help here or on the list, I think it would be great to have it
13:18:43 <Sicness> ok
13:19:43 <apo> #action Sicness writes a script to analyze which packages need screenshots or not
13:19:58 <Sicness> not screenshots.
13:20:07 <Sicness> menu files and desktop
13:20:08 <Baby> after thinking about that, I'm pretty sure that finding out the packages without menuy and/or  desktop files is pretty easy
13:20:26 <apo> Sicness: oh sorry
13:20:56 <apo> #undo
13:20:56 <MeetBot> Removing item from minutes: <MeetBot.items.Action object at 0x103ad10>
13:21:33 <apo> #action Sicness writes a script to analyse which packages need desktop and menu files
13:22:49 <Baby> just download any ftp://ftp.debian.org/debian/dists/sid/Contents-*.gz file and all the contents of every package is already there
13:22:50 <apo> more ideas for a release goal or how we can track the existing release goal?
13:24:15 <debianer_> we can create a wiki page which packages have no screenshots, desktop files ans menu files
13:24:36 <Baby> why wiki?
13:24:42 <Baby> I would prefer something automatic
13:25:14 * bdefreese likes PET a lot
13:25:20 <bdefreese> Could we integrate with that somehow?
13:26:43 <Baby> what's PET?
13:26:50 <Clint> "package entropy tracker"
13:26:57 <Baby> ow
13:27:00 <Baby> thanks :)
13:27:07 <Clint> looks like http://pkg-haskell.alioth.debian.org/cgi-bin/pet.cgi
13:27:08 <bdefreese> OMG.. :)
13:27:30 <debianer_> we also could create a bug for every missing file and check the status via udd
13:27:48 <bdefreese> Aye, that is probably better
13:28:01 <Baby> maybe we could start using http://blends.alioth.debian.org/games/tasks/
13:28:10 <Baby> and integrate it there
13:28:16 <ansgar> It's http://pet.debian.net/pkg-games/pet.cgi
13:28:43 <ansgar> (which also has packages in Git)
13:28:50 <Baby> I'm sure Andreas Tille would help us
13:29:12 <apo> any volunteers who would like to investigate this issue a little more and report back how we can use it for the release goal?
13:29:31 <bdefreese> Why does everyone keep bringing up Andreas?  Where does he fit in?
13:29:54 <Baby> bdefreese: here: http://blends.alioth.debian.org/games/tasks/
13:30:05 <apo> bdefreese: he is very active in the Blends project, that's topic number 3 :)
13:30:17 <bdefreese> Ahhh
13:30:27 <ansgar> Because he wants to push Blends everywhere (or so it seems).
13:30:46 <bdefreese> Sorry I just don't quite understand the point of blends
13:30:51 <Baby> well, it seems to work
13:30:51 <ansgar> He mentioned it in every talk where I heard him. Or quite close to it ;)
13:30:56 <Baby> so it's okay for me
13:31:08 <ansgar> "seems to work" meaning?
13:31:08 <Sicness> I suggest to add a new check to lintian: if there is a /usr/games/<bin> then check is there a desktop and menu file. I suggest to file the bug to lintian about that.
13:31:50 <apo> #info we need to investigate how we can track our release goal for jessie (PET, wiki etc.), no volunteers yet
13:32:13 <Rhonda> apo: Hmm, that there are -dbg packages listed there seems a bit wrong, because they are in Section: debug and not Section: games?
13:32:16 <Rhonda> (sorry for late response)
13:32:17 <apo> #idea add a new lintian check for our release goal
13:32:53 <Rhonda> So I rather would consider screenshots.d.n to get fixed to not list packages that aren't in Section: games.
13:33:03 <apo> Rhonda: yes, you're right. I always wondered if we could trim the list a little
13:33:41 <apo> or we could link existing screenshots simply to -dbg packages?
13:34:13 <apo> I mean we could use the openarena screenshot and simply link it to the dbg package for example
13:34:20 <Baby> Rhonda: at least it should skip the packages in debug
13:35:22 <apo> ok, I see that needs further investigation, let's move to topic 3
13:35:40 <apo> #topic Debian Games Pure Blend
13:36:09 <apo> #link http://blends.alioth.debian.org/games/tasks/simulation Games Blend main page
13:37:06 <Baby> I'd say the main page is http://blends.alioth.debian.org/games/tasks/
13:37:12 <apo> I'm working on a Blend page for the games team, basically I add all games to some text files and the appear on this site
13:37:15 <Baby> that one you put is just simulation games
13:37:33 <apo> I would like to promote games and this project seems like the way to achieve it
13:37:46 <apo> Baby: yeah, sorry
13:38:11 <Baby> np :)
13:38:36 <Baby> yup I think that working together with the blends team would help
13:38:37 <apo> my question is what do you think about promoting all games in Debian via the Blends project, what should be implemented?
13:39:25 <Baby> not much really
13:39:32 <Baby> just keeping the config files up to date
13:40:05 <apo> My goal is to automate this process, there is a GSoC project ongoing and I hope it will help to achieve this goal
13:40:18 <Baby> cool
13:42:00 <Baby> one thing that was mentioned this morning
13:42:14 <apo> as a side note: I heavily rely on debtags, so please debtag all your packages, that helps a lot in categorizing games :)
13:42:58 * SynrG blinks again
13:43:05 <SynrG> ah, finally, The Topic
13:43:05 <Baby> it seems that there's gonna be a mini debconf in cambridge in a few months.... those of us who are in europe might wanna meet there to do some coordination and stuf
13:43:35 <Baby> sorry I forgot to mention it, I just remembered
13:44:35 <Baby> tags are indeed important
13:44:44 <Baby> I rely on them for openrating too
13:44:59 <Baby> even though we have been discussing whether an extension to desktop files might be better
13:45:27 <SynrG> before we get into implementation too heavily, i would like to stress that i think the most important aspect of a blend is "Debian as used by your target audience", i.e. defining who your users are and explicitly setting yourselves up to address that community. all the rest is just a small matter of code
13:45:42 * Baby nods
13:45:50 <apo> On a side note: if we properly maintain this blend project we can quite easily create live usb images which depend on meta packages for games, is anyone interested in helping to create such a "Live CD/USB version" (besides SynrG) :)
13:46:48 <Rhonda> Is there actually enough common base for our target audience?  I mean, different people enjoy different type of games, obviously.
13:46:51 <Baby> there is interest on thatm, and might be achieavable at some point, but I don't think the blends are capable of that yet
13:46:56 <SynrG> and since you mention me in that capacity, i have always said i am here to help with the live technology and not particularly interested in making the package selections / tweaks to game configurations for the live image. that would be the job of whoever steps up to the plate to help.
13:46:57 <ansgar> apo: Don't you just need a flat list of packages for that?
13:47:11 <ansgar> apo: I mean, there's no point for meta-packages to get stuff into live images.
13:47:44 <SynrG> why is there no point for meta-packages? that is *the* recommended way of doing package lists for live-build
13:47:54 <Rhonda> That's what I meant.  I don't think that we could find a common base of games to make a meta package useful, is there?
13:48:01 <apo> ansgar: I categorize all games into different sections and one benefit of Blends is we get meta packages for free with this approach
13:48:09 <SynrG> that way you can have the live image match what a user can also have by just "apt-get install task-whatever"
13:49:16 <SynrG> debian-jr tried to solve the "can't find a common base" issue by modularizing package lists. decide who your sub-audiences are and have tasks focused per subgroup. this isn't expected to put *all* games in their hands, just a sufficient set of them to make them happy to get started.
13:49:48 <Baby> yup
13:50:45 <debianer_> Do you mean something like SparkyLinux which include a lot of free games (debian based)? http://sparkylinux.org/
13:50:53 <SynrG> back to my earlier comment: decide who you're catering to :)
13:51:07 <SynrG> (and that needn't be just *one* group)
13:53:39 <Baby> yup, it certainly won't be just one group
13:53:53 <apo> Do you need more information what Blends really is or shall I assume that nobody besides SynrG is really interested in the topic and we call it quits for today ? :)
13:54:12 <Baby> I have enough information for the moment :)
13:54:54 <SynrG> did we identify clear action items and who is doing them?
13:55:39 <apo> #action apo works on the Debian Blends Pure Blend and reports back to the mailing list
13:56:17 <apo> #action SynrG provides assistance for all Blend and live image related questions
13:56:21 <apo> ok? :)
13:56:43 <Baby> :)
13:56:55 <apo> #topic Next meeting
13:57:21 <SynrG> apo: sounds good :)
13:58:01 <apo> I volunteer for organizing the next meeting. When shall we meet again. I suggest 2 meetings per year should be usually enough, we can use the list and this channel for further discussions
13:58:26 <apo> so next meeting in February 2014?
13:58:39 <Baby> we could try that
13:59:01 <Baby> it wouldn't be hard to put an intermediate meeting before if we feel we need it
13:59:11 <Baby> maybe 4 a year could also be an option
13:59:14 <apo> Baby: *nods*
13:59:35 <Baby> but well, we'll see, it's easy to set up one if we decide
14:00:15 <bdefreese> Aye, quarterly would probably be nice
14:00:37 <Calinou> 4 a year, yes
14:00:44 <Calinou> or maybe 3 :P
14:02:51 <apo> ok, just ping me if you I should organize a meeting at the end of the year, otherwise I assume February 2014 will do
14:03:06 <apo> #endmeeting