18:02:28 <zack> #startmeeting
18:02:28 <MeetBot> Meeting started Tue Jan 8 18:02:28 2013 UTC. The chair is zack. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:02:28 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:02:39 <zack> so, the deb.li is playing tricks on me
18:02:42 <zack> agenda URL in topic doesn't work
18:02:47 <zack> try http://anonscm.debian.org/gitweb/?p=dpl/dpl-helpers.git;a=blob_plain;f=meetings/agenda.txt
18:02:52 <Diziet> wfm
18:02:56 <nhandler> Strange, wfm too
18:03:07 <zack> weird...
18:03:16 <zack> anyway, who's around?
18:03:22 <Diziet> Hi.
18:03:25 <Ganneff> .
18:03:26 <nhandler> Hello
18:03:56 <zack> first point in agenda: Happy New Year everyone!
18:04:03 <zack> (and yes, I know Ganneff is hating me for pingall...)
18:04:12 <Ganneff> yes
18:04:15 <zack> :)
18:04:20 <zack> #topic next meeting
18:04:42 <zack> sorry for last meeting, connection was really too crappy for any interactive usage...
18:05:00 <zack> next meeting in two weeks, as usual?
18:05:03 <zack> that would be date -d @1358877600 (January 22)
18:06:01 <nhandler> Sounds good to me
18:06:21 <zack> #agreed next meeting @1358877600
18:06:32 <zack> let's move to pending action items
18:06:37 <zack> #topic pending action items from last meeting
18:06:45 <zack> looks like quite a lot has been done...
18:07:16 <zack> ... but not the first one "check with bugs.d.o if a DPL-ish pseudopackage", which I'd like to drop for the time being
18:07:45 <zack> I'd rather prioritize writing down a common todo list than anything else on that front
18:07:52 <zack> paultag: around?
18:08:37 <paultag> zack: yessir.
18:08:38 <paultag> Howdy!
18:08:44 <zack> paultag: heya!, happy new year!
18:08:50 <paultag> Happy new year, zack!
18:08:52 <zack> any news about "** TODO paultag to do the README for the dpl magic ical script " ?
18:08:58 <moray_> hi, I'm somewhat around too
18:08:58 <paultag> :(
18:09:02 <zack> moray_: hi!
18:09:04 <paultag> zack: No, but it's again on my queue, sorry!
18:09:13 <paultag> ← emailing self
18:09:16 <zack> paultag: np, and it's really minor too :-), please reaction it
18:09:35 <paultag> #action TODO paultag to do the README for the dpl magic ical script (for real)
18:09:48 <zack> the next one, global TODO list is now done
18:09:59 <zack> as per my mail of a couple of weeks ago, there is now todo.txt at the top-level
18:10:15 <zack> I think it'll be pretty important to hand-off stuff to the next DPL, in case he/she wants to pick anything up
18:10:15 <Maulkin> (Somewhat here)
18:10:20 <zack> Maulkin: heya!
18:10:37 <zack> but it's also the ideal place if any of you is in boredom and wants to proceed on pending stuff :-P
18:10:54 <zack> I personally use a GTD-like time management approach, so there's stuff tagged with :next_action:
18:11:09 <zack> the markup is org-mode, but should be decently readable in any text editor
18:11:24 <nhandler> zack: Feelings about us adding items that you have mentioned in the past as being TODO but that got omitted?
18:11:27 <zack> I've more stuff to digest from my personal agenda and move there, but it's happening (slowly)
18:11:31 <zack> nhandler: by all means!
18:11:50 <Diziet> Sorry to grump, but can we speed this up a bit ? Or I may have to go and read random web pages or something ? IRC meetings are death if they turn randomly discursive.
18:11:54 <zack> it's git, it's easy to change/undo, so I see no reason not too
18:12:08 <zack> Diziet: sorry, ok
18:12:27 <zack> lucas passed on the next item, so someone please re-actionize it
18:12:36 <zack> Diziet: next too are yours
18:12:41 <Diziet> zack: Right.
18:12:47 <Diziet> Both done, but only this afternoon.
18:12:58 <Diziet> I will try to shepherd the trademarks discussion.
18:13:02 <zack> Diziet: also the secretary one?
18:13:09 <Diziet> #action TODO Diziet Keep an eye on the trademark discussion
18:13:31 <zack> #action zack to update the DMCA draft directly with the identified changes rationale
18:13:32 <Diziet> If we don't get a reply by next meeting it will be obvious and we can't go forward with the trademark thing without it, so I propose to leave it off our todo list for now.
18:13:49 <zack> (I'll pick the DMCA up from algernon, as I'd want to complete it ASAP now)
18:14:00 <zack> #action zack to contact debconf-team to draft a "job description" for future delegation
18:14:04 <KGB-1> 03nhandler 05master 3c13884 06dpl-helpers 10todo.txt * Add Declassification of debian-private to TODO * 14http://deb.li/rhCz
18:14:17 <zack> Diziet: sorry to bother, but can you please confirm you contacted secretary too?
18:14:22 <Diziet> Sorry yes I did.
18:14:26 <zack> cool
18:14:35 <Diziet>
18:13 <Diziet> Both done, but only this afternoon.
18:14:42 <Diziet> I meant both action items :-)
18:14:52 <zack> ok, fair enough
18:14:57 <zack> #topic new stuff
18:15:06 <zack> I'll pick stuff out of order
18:15:15 <zack> I've posted the new trademark policy
18:15:30 <zack> if no objections show up, I'll propose a patch to www.d.o/trademark next week
18:15:34 <zack> so that that will be completed too
18:16:01 <zack> Diziet: then there's the DFSG-free license discussion, you participated in too
18:16:21 <zack> Diziet: seen my last mail about interpretation of Ganneff's call for volunteers?
18:16:59 <Ganneff> well. we always look for volunteers into ftpteam too
18:17:10 <Ganneff> but what i wrote in the mail was people helping with the ikiwiki thing and not deciding, yes
18:17:12 <Diziet> Ganneff: Heh yes.
18:17:18 <zack> Ganneff: thanks for confirming
18:17:39 <zack> I wasn't exactly in the mood of making, right now, a revolution into how we decide DFSG-freeness
18:17:40 <Diziet> Oh I see.
18:17:47 <Diziet> Right.
18:17:47 <Diziet> Good.
18:17:50 <Diziet> Sorry to misunderstand.
18:17:53 <zack> (it could be done if needed :-), but that's another aspect)
18:18:07 <Diziet> No, it's not needed. If ftpmaster don't want things to change then great.
18:18:17 <Diziet> I will say that in the email thread.
18:18:22 <zack> Diziet: thanks
18:18:31 <zack> I'll mention need for volunteers with the ikiwiki part in next bits
18:18:34 <Ganneff> uh, just n ow reading Diziets mail.
18:18:49 <Diziet> Ganneff: I'm not sure you should bother...
18:18:51 <Ganneff> .oO(and looking where i stored my chainsaw. or uzi. or so)
18:18:53 <Ganneff> yeah.
18:19:23 <zack> Ganneff: I've some open questions in the thread, but there's no hurry
18:19:41 <zack> mainly, the point is knowing which kind of workflow you'd like to work with the people hacking on ikiwiki to keep track of decisions
18:20:08 <zack> should be something viable for both teams (assuming the "documentation" one shows up, that is)
18:20:14 <Ganneff> ay.
18:20:29 <zack> oki doki
18:20:30 <Ganneff> i see it somewhat as a "sub" of ftp* actually, documenting this.
18:20:37 <Ganneff> as it takes what we do day-by-day and writes it down.
18:20:44 <Diziet> Ganneff: Sounds sensible.
18:20:46 <Ganneff> possibly in the format we have now.
18:20:57 <Ganneff> (or probably? whatever).
18:20:58 <Diziet> Is there a list we can subscribe to where these things get announced so we can subscribe to that ?
18:21:03 <Diziet> FSVO announced.
18:21:12 <Diziet> I mean one that doesn't get every reject decision...
18:21:15 <zack> Diziet: that's part of the point, some decisions are currently only sent to maintainers
18:21:28 <Ganneff> well. what we have now is a short work burst we had in 2009 for a proof-of-concept. which was done inside the team. so nothing spethial setup yet.
18:21:31 <Diziet> (ideally)
18:21:38 <Ganneff> when we get a team i think it will be an irc channel coupled with a mailinglist.
18:21:48 <Diziet> Sounds reasonable to me.
18:22:01 <Ganneff> starting with our channel (#-ftp) and probably -dak first as list. or an alias on @ftp-master.d.o dont know.
18:22:08 <zack> Ganneff: you mean a channel/ML only for the license part or more general for ftp* work?
18:22:10 <Diziet> The point being to document ftpmaster's collective decisions and views.
18:22:25 <Ganneff> zack: license foo. we have it all for the usual ftp* work
18:22:32 <Ganneff> Diziet: yep.
18:22:35 <zack> ok, good
18:22:42 <Ganneff> and the project can yell at us if it disagrees. as usual.
18:22:43 <Diziet> Ganneff: Do you want us to hang around the general ftpmaster fora then ? They are quite high volume I guess...
18:22:59 <Ganneff> Diziet: depends on what you see as volume.
18:23:10 <Diziet> Dunno. I'm trying to be less irc attentive, not more :-)
18:23:13 <zack> Diziet: I guess the timing is: 1) are there enough volunteers for the license (doc) part? if yes, then 2) irc/ML setup, 3) announce their existence
18:23:19 <Ganneff> though irc is easy to make new, and -dak - well, see https://lists.debian.org/debian-dak/2012/12/threads.html
18:23:44 <Diziet> Right, -dak pretty manageable.
18:24:12 <Ganneff> i think i wouldnt notice an extra irc channel having >90 windows anyways, and if it gets too much for -dak we can ask listmasters for a new list, but right now its so low volume...
18:24:29 <Diziet> Ganneff: I guess the thing is wait and see if you get enough volunteers and if so you get to specify the workflow.
18:24:40 <Ganneff> just not using -legal, as yes, we mostly ignore the list (on a day-to-day thing. it gets used using google search mainly). its too bonkers for following it always
18:24:49 <paultag> I don't think volunteers will be the problem (IMHO)
18:25:09 <paultag> I think if there's a workflow and a way to suck in new REJECTs, it'll be easy work
18:25:17 <Ganneff> make that "volunteers that actually stay around, with a never-ending-not-much-getting-back task
18:25:22 <Diziet> It will be necessary to be very clear that volunteering for this is _not_ a way to change decisions, nor to "spin" them in the docs.
18:25:29 <zack> Diziet: ack
18:25:31 <Ganneff> ay
18:25:50 <zack> Ganneff: would it work for ftp* to say, if there's a decision about a new license, please remind to Cc: $list ?
18:25:54 <Ganneff> if an ftp* overwrites your opinion in the docs, you are not reverting the change. or you are out...
18:25:57 <zack> or is it too prone to be forgotten?
18:26:04 <Diziet> Ganneff: Right.
18:26:07 <Ganneff> thats prone, but i think we can work somethng out.
18:26:18 <zack> I think it's similar to what happens on -policy
18:26:20 <Diziet> Ganneff: OK. Well think about what works for you.
18:26:20 <zack> there are delegates
18:26:25 <zack> and other people doing wording polishing
18:26:32 <zack> with clear distinction in responsibilities
18:26:35 <Ganneff> we just had a proposal in our private chan for a code change.
18:26:46 <Diziet> Yeah, turning individual decisions into a coherent doc is a wordsmith editing task.
18:26:47 <Ganneff> something like bayes based NEW reject license validation :)
18:27:00 <Ganneff> well.
18:27:10 <Ganneff> there are delegates. then there are the people actually doing the work.
18:27:13 <Diziet> What's the next step then ?
18:27:18 <Ganneff> as it will DIE if it ends up just being with ftp*
18:27:25 <Diziet> (As we've agreed here where we're going.)
18:27:34 <zack> wait, what? :)
18:27:35 <Ganneff> sad but true, but its not so imporetant that we can divert too much time.
18:27:37 <zack> Diziet: I guess "finding volunteers", the only way I can make it actionable is mentioning it in next "bits" mail
18:27:41 <zack> if you've other ideas... shout!
18:27:44 <Ganneff> yep, get volunteers
18:27:49 <Ganneff> rest is easy to do then.
18:28:00 <Diziet> zack: -project is probably a good place to ask. Mentioning it in a bits is good too.
18:28:07 <Diziet> But -project is full of people who like writing words.
18:28:25 <Ganneff> the ikiwiki isnt hard to give others access to. irc is easy. -dak list too.
18:28:28 <zack> Diziet: I think I've done the call for volunteers on -project already, but I can stress it more if you think it's needed
18:28:32 <Ganneff> now, get volunteers that arent crazy, please :)
18:28:40 <Diziet> Up to Ganneff I guess.
18:28:44 <zack> Ganneff: now you're raising the bar :-P
18:28:49 <Ganneff> well
18:28:50 * Diziet <- offended. fx: Rolls crazy eyeballs.
18:28:53 <Ganneff> i dont want chealer :)
18:29:00 * Diziet drools.
18:29:07 <zack> anyway, looks like we can move on?
18:29:09 <Ganneff> and we might see if i or Diziet has the bigger arsenal :)
18:29:10 <Ganneff> yeah
18:29:29 <zack> so, just one brief mention on Debian/FSF relationship
18:29:40 <zack> I've been informed that they're still discussing their public stance internally
18:29:48 <zack> so, ball in their camp
18:29:53 <Diziet> And we thought we made decisions slowly...
18:29:58 <zack> eh :-)
18:30:18 <zack> but I appreciate they invited me at LibrePlanet, it would be a good sign
18:30:23 <zack> and occasion to work F2F too
18:30:47 <paultag> zack: if you need to lobby the FSF, I seem them on a pretty regularish basis.
18:30:48 <Diziet> Mmmm.
18:30:49 <Diziet> I think that will help a lot.
18:31:36 <zack> anyway, I'll keep you posted as soon as something "real" happens
18:31:55 <zack> then, the final point (which can get discoursive again, I fear...)
18:31:58 <zack> Maulkin: around?
18:32:06 <zack> I wanted to pester the RT a bit :)
18:32:20 <Maulkin> Ish....
18:32:23 <Maulkin> Go ahead
18:32:35 <zack> Maulkin: 1) any news on the next update mail?
18:33:22 <Maulkin> zack: Outline being done at the moment
18:33:27 <zack> \o/
18:33:32 <zack> Maulkin: 2) I (and I guess the project at large) have no idea if you started already with the ignore/wouldblock/etc triage. If you've news on that, I'd *love* that
18:34:09 <Maulkin> http://titanpad.com/debian-release
18:34:22 <Maulkin> zack: Nope, not got those yet.
18:34:35 <zack> I guess it's the next "big step", right?
18:34:48 <zack> given that the RC bug count has been going down steadly, even though slowly
18:34:56 <Maulkin> We'd probably not be able to do that >200 bugs
18:35:20 <Maulkin> Basically, when the rate starts to flatline, then those tags are useful
18:35:38 <Maulkin> (As it helps concentrate people on the right bugs)
18:36:11 <zack> ok
18:36:27 <zack> Maulkin: last one (3): any plans for non-leaf removals? it's something I discussed with Niels a while ago
18:36:40 <zack> I mean, automatic finding of targets for that
18:36:45 <zack> although, it's probably related to (2)
18:36:46 <Maulkin> zack: Niels will know more then :)
18:36:57 <zack> I take you didn't discuss it then :)
18:37:00 <Maulkin> Hrm, I think it's much harder to do non-leaf.
18:37:21 <Maulkin> I imagine that simply doing the above will happen instead.
18:37:23 <Maulkin> ie: tags
18:37:38 <zack> sure, the right metrics is the key → I'll check with Neils
18:38:17 <zack> ok, for me that'd be all, any other matters people would like to discuss?
18:38:49 <zack> (one action forgotten:
18:38:54 <zack> #action lucas to wrap-up the salvaging/orphaning thread and submit dev-ref patch
18:38:57 <zack> )
18:39:00 <zack> as requested by himself
18:39:57 <zack> good, let's close the meeting then
18:39:58 <zack> #endmeeting