19:00:35 <Emperor> #startmeeting
19:00:35 <MeetBot> Meeting started Tue May 27 19:00:35 2025 UTC.  The chair is Emperor. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:35 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:00:45 <Emperor> #topic Roll Call
19:00:48 <Emperor> Matthew Vernon
19:00:50 <Myon> Christoph Berg
19:00:52 <paultag> Paul Tagliamonte
19:01:00 <tumbleweed> Stefano Rivera
19:01:14 <roehling> Timo Röhling
19:01:36 <seeS> Craig Small
19:02:35 <Emperor> helmut / mjg59 you around?
19:03:05 <Emperor> I'll give them a couple of minutes
19:04:44 <Emperor> I'll take the previous actions next, in case they're a little late
19:04:54 <Emperor> #topic Review previous meeting's actions
19:05:13 <Emperor> For the record, these were all done, thanks! I don't think any of them need follow-up here.
19:05:20 <Emperor> #topic Welcome to Paul
19:05:32 <Emperor> we'll do this on jitsi (see the topic in -private for the URL)
19:06:42 <doko> o/
19:07:41 <doko> who's Paul?
19:08:52 <Emperor> doko: paultag our new TC member
19:09:24 <doko> sorry, what's that about? jitsi, and private?
19:09:39 <tumbleweed> we are welcoming a new TC member in a jitsi call
19:10:10 <doko> ahh, so only one topic in private
19:10:27 <doko> I hope you grill paultag very well ;p
19:11:49 <helmut> Sorry, for being late.
19:11:53 <helmut> Helmut Grohne
19:16:48 <paultag> doko: <3
19:17:01 <Emperor> #topic Debconf session
19:17:35 <Emperor> We have a slot at Debconf. Do we want to basically update the talk from 2024, or do something different?
19:17:55 <tumbleweed> Link: https://debconf25.debconf.org/talks/22-meet-the-technical-committee/ (all the proposed BoFs are now public)
19:18:12 <Emperor> https://salsa.debian.org/debian/tech-ctte/-/blob/master/talks/202408-Meet-the-TC.pdf?ref_type=heads <-- 2024 slides
19:19:01 <Myon> I don't really see what else we could do
19:19:14 <Myon> perhaps less historical stuff and more current matters
19:19:34 <Emperor> I think the traditional outline is reasonable, but I wonder if it'd be worth having either a "best practice in bringing an issue to the TC" and/or a "What would you like to see the TC do differently?" slide
19:19:45 <helmut> I find the format pretty boring, but it probably is useful to new people.
19:20:07 <Emperor> I've not been to DebConf in years (but I will be at this one), so I don't know what people have or haven't been engaged with in the past.
19:20:25 <tumbleweed> it's never been a very lively Bof, in my memory
19:20:31 <seeS> I've never been to a DebConf, but I'm going this year
19:20:46 <paultag> I'm also planning on going, although planning for how long and when is the big question here
19:20:48 <helmut> I'm there
19:20:59 <tumbleweed> I'll be there
19:21:00 <Myon> I'll be there
19:21:01 <roehling> me too
19:21:08 <paultag> full house :)
19:21:23 <roehling> helmut is not listed as a speaker for the BoF
19:21:36 <Emperor> he's only going to turn up to heckle ;)
19:21:44 <tumbleweed> I'll fix that
19:21:47 <seeS> I suspect the nature of the BoF doesn't make it lively. Most BoFs are about things people are involved in so its more two-way
19:21:58 <tumbleweed> added paultag too
19:22:15 <Emperor> OK, I'll try and update the slides a bit, but maybe also put my couple of slides in and see if anyone bites (if not, we can skip them again next year). Seem reasonable?
19:22:39 <tumbleweed> yeah
19:22:41 <seeS> I like the idea of Emperor's slides
19:22:48 <roehling> I like the "best practice" and feedback slide ideas
19:22:56 <helmut> how about taking time discussing matters of the day with the audience?
19:23:05 <tumbleweed> +1
19:23:32 <helmut> and how about seeking feedback on process improvements citing moderation as one example where we tried?
19:23:52 <Myon> +1 on discussing matters of the day
19:24:02 <roehling> +1 on pretty much all ideas :)
19:24:12 <tumbleweed> yep
19:24:17 <Emperor> also sensible. I might not bother with the "list of things we decided last year", then, unless there are ones we particularly want to highlight?
19:24:28 <roehling> The slides should probably serve as a 10 to 15 minute warm-up/introduction.
19:24:32 <seeS> How much description went into the completed decisions? To me an example would help
19:24:58 <Emperor> seeS: sorry, I can't parse that question
19:25:09 <helmut> cut it down to 10 minutes and leave time for questions. if the audience is too silent, we're many enough to just discuss stuff among ourselves
19:25:14 <tumbleweed> the Diziet issues where he didn't engage with us directly are also probably worth asking opinions on
19:25:27 <Myon> last year's decisions is probably interesting to have, but I've always found the listing of the past 100 members and the constitution bits boring
19:25:28 <seeS> I saw there was a slide like "things that were decided" wondered how much discussion  there was
19:25:30 <tumbleweed> (I mean, any better ideas of how to handle that situation)
19:25:51 <Emperor> seeS: I think that was basically a summary of the TC resolutions from the past year
19:26:10 <tumbleweed> last year's talk video, if you want to see engagement: https://debconf24.debconf.org/talks/6-meet-the-technical-committee/
19:26:16 <Emperor> Oh, sorry, now I understand your question. Sorry, long day!
19:26:48 <mjg59> Hey, sorry, am present now
19:26:55 <seeS> Ah, to me using a (non-contraversal, if it exists) example might help. This was the issue, these were the options, we looked at X and decided on Z because reasons
19:27:04 <Emperor> So I think: try and make a shorter deck to provide introduction and some questions for discussion in the Bof?
19:27:12 <Emperor> hi mjg59
19:27:16 <tumbleweed> +1
19:27:18 <helmut> btw, in talking to various people privately about our last decisions, my takeaway was that we took too long implementing it. once a decision is formed, enacting it should be faster or it undermines project procedures.
19:27:18 <roehling> +1
19:27:58 <Emperor> #action Emperor to prepare a shorter set of DC25 slides to be a starting-point for discussion
19:28:04 <helmut> Emperor: +1
19:28:19 <roehling> If I find some spare time, I might prepare a few summary slides on past decisions. Not for the talk, but as "backup" if the audience wants to revisit certain decisions
19:28:26 <Emperor> #topic Bug#1106402: dpkg-source, native source package format with non-native version
19:28:39 <helmut> a possible way to trigger interaction is to propose three starting topics to the audience and let them straw poll which one to start with
19:28:43 <Emperor> roehling: sure thing, if we put them at the end of the talk we can flick to them if needed
19:29:39 <Emperor> This bug arrived recently, and I attempted to summarise in email, but only about half an hour ago, sorry!
19:31:03 <Emperor> But basically we previously said under 6.1.5 ("Offer advice") that "It is not a bug of any severity for a package with a non-native version number to use a native source package format." and thus that dpkg should stop complaining about a non-native version used with a 3.0 (Native) format package.
19:32:07 <Emperor> We have now been asked to declare under 6.1.1 "Decide on any matter of technical policy." that dpkg should actually do as we said then, under the power to decide on "behaviour of non-experimental package building tools"
19:32:52 <Emperor> (a member of the RT have said they will not approve such a change for trixie given the freeze)
19:32:54 <Myon> sramacher just said that it's too late for trixie. If we decide NOW, it's non-actionable until after the release
19:33:00 <paultag> possibly late breaking, Sebastian (with his release hat on I think) said it was too late for a change to trixie
19:33:02 <paultag> ah dang 3x in a row
19:34:24 <Emperor> I broadly think that it would make sense for us to do as asked here, notwithstanding it'll likely only come into effect for forky.
19:34:25 <helmut> I've seen very few arguments in favour of Guillem's view thus far.
19:34:47 <roehling> Turning the hard error into a warning would be reasonable
19:35:09 <Emperor> helmut: also, the TC doesn't usually overturn its previous decisions. Which is not to say we never could do.
19:35:31 <paultag> I'm pretty sympathetic to Guillem's POV here (I have found the debian version component of a version helpful), there is a prior TC ruling and I don't see any reason to reopen that given the prior decision
19:35:33 <Emperor> but I think here I would want to see some new and very compelling argument to do so.
19:36:03 <paultag> s/of a version helpful/to determine when a package is native helpful/g
19:37:05 <Emperor> Anyone inclined to suggest we shouldn't make a declaration under 6.1.1 ?
19:37:42 <seeS> I don't understand the contraversy. Maybe dpkg maintainers don't like that format but that shouldn't stop the change
19:38:32 <Emperor> OK, would anyone be kind enough to draft a ballot to that effect?
19:38:38 <paultag> I *think* the issue is that the version disambiguating native/non-native is load-bearing somewhere, rather than looking into source/format, but I also have a hard time understanding it, I didn't see a lot of reasons against in the last TC decision thread
19:39:05 <helmut> Emperor: I think talking to Guillem at least once before drafting would be prudent.
19:39:12 <tumbleweed> it can't be *that* load-bearing, considering some packages have been violating it for as long as I remember (python3-defaults for example)
19:39:18 <seeS> Yeah if the dpkg maintainers said, look if we do that then there is a mega drama in dpkg and it will fail in these odd ways
19:39:29 <seeS> I see no evidence besides "dont like it"
19:39:31 <Emperor> helmut: would you be prepared to do so?
19:39:59 <helmut> My biggest concern here is my own capacity atm.
19:40:15 <Emperor> OK, I don't want to overload you.
19:40:30 <Emperor> I also don't want all the actions :)
19:40:47 <helmut> But yeah, me doing it is probably wise.
19:41:13 <Emperor> OK, thanks.
19:41:26 <Emperor> #action helmut to talk to Guillem re #1106402
19:41:43 <helmut> Would anyone have the capacity to research and summarize Guillem's earlier answers on that matter?
19:42:19 <paultag> I'm curious, so I can scrub the last few threads and try and write it down
19:42:24 <Emperor> helmut: I looked at his messages in #737634 before sending my mail today, did you want more than that?
19:42:37 <paultag> ^ or what Emperor said :)
19:42:42 <helmut> Emperor: the bug numbers from your mail are a good starting point
19:42:59 <Emperor> sounds like paultag is happy to have a bit more of a look (I like to think I covered the bases, but...)
19:43:30 <Emperor> #action paultag to review previous input from dpkg maintainers re #1106402
19:43:37 <Emperor> thanks both.
19:43:50 <Emperor> #topic Bug #1065416: linux-libc-dev claims to provide linux-libc-dev-ARCH-cross, but it doesn't do that completely
19:44:10 <tumbleweed> So, let me summarize where we stand
19:44:27 <helmut> [dpkg] one aspect is that Guillem considers the native/non-native distinction and implementation aspect rather than Debian policy
19:44:52 <tumbleweed> since the last meeting, IRC discussion between me and doko and waldi led to a plan to have a ctte-mediated discussion on the topic
19:45:07 <tumbleweed> sadly, it can't be at debconf (no waldi present)
19:45:34 <tumbleweed> and I still need to talk to aurel32, because the same concerns apply to glibc
19:46:13 <doko> will aurel be at debconf?
19:46:31 <tumbleweed> I think so
19:46:50 <helmut> can we throw Debian money at the problem to make a meeting happen?
19:47:25 * Emperor has no idea how geographically remote these folk are
19:47:42 <tumbleweed> everyone involved is in Western Europe, I think
19:48:03 <Emperor> OK, so if's done virtually at least TZs won't be too hard.
19:48:04 <Myon> waldi is Western .de, aurel ... .be ?
19:48:19 <tumbleweed> yeah, and virtual is a possiblitiy too
19:48:24 <doko> it's a one day travel on grund, or a half day flying
19:48:35 <Emperor> if doko and aurel and some TC people talk at Debconf, will we end up making waldi unhappy?
19:48:43 <tumbleweed> or a video call from debconf, if that's where we make progress. But I don't like the dynamic of 1 side being remote
19:49:06 <helmut> Myon: not fr?
19:49:14 <doko> how do you make waldi not unhappy?
19:49:15 <Emperor> tumbleweed: I would be against that, if we can't have all the relevant people present, it's better to be all-remote I think.
19:49:22 <tumbleweed> Emperor: yeah
19:49:36 <tumbleweed> I'll talk to waldi and aurel
19:49:36 <Emperor> doko: with my winning personality ;p
19:50:07 <doko> if it works, I'e fine :-)
19:50:51 <Myon> helmut: true, I misremembered
19:50:56 <helmut> if it comes to a meeting, do you prefer me to attend (adding a bootstrap view) or do you consider that less relevant? I'm happy either way.
19:51:48 <tumbleweed> I think you have a useful contribution to make. No doubt your requests have inflamed the situation in the past, by triggering change, but I don't see that as a problem
19:51:48 <Emperor> I suggest find a time that waldi & aurel & doko & tumbleweed can all make, and then see which if any TC members are free then.
19:52:05 <doko> please attend. bootstrap issues are important but not a priority
19:52:06 <helmut> +1
19:52:16 <helmut> doko: agreed
19:52:48 <Emperor> OK, cool. Sounds like we're agreed on a waldi / aurel / doko / tumbleweed / helmut meeting (probably virtual) to try and find a way forwards?
19:54:01 <Emperor> #action tumbleweed to facilitate meeting with waldi / aurel / doko / helmut re #1065416
19:54:07 <tumbleweed> thanks
19:54:18 <Emperor> Cool
19:54:24 <Emperor> Thank you for that update
19:54:28 <Emperor> #topic AOB
19:54:35 <Emperor> Anything else? we have 5m left if we need it
19:56:00 <helmut> did we pick a moderator for dpkg?
19:56:07 <helmut> the native issue
19:56:11 <Emperor> Oh, no, we didn't.
19:57:01 <Emperor> do we have someone who could do this? Probably shouldn't be me
19:57:17 <helmut> https://salsa.debian.org/debian/tech-ctte/-/blob/master/procedures/moderation.md?ref_type=heads
19:57:59 <roehling> I can do that, unless paultag wants to assume that role, given that he's looking into summarizing the issue anyway
19:58:23 <Emperor> I think unless he feels strongly, I'd suggest not making paultag the moderator of his first TC bug
19:58:42 <paultag> i was going to basically say that I feel like I should perhaps learn from the side to get my feet wet :)
19:58:49 <paultag> although I'd be super happy to be active/help
19:59:08 <Emperor> #action roehling to become moderator for #1106402
19:59:11 <Emperor> thanks :)
19:59:34 <Emperor> OK, any other any other business? We have about a minute unless it's really urgent :)
19:59:47 <helmut> the moderation procedure is fairly recent and this is the fourth(?) issue we try to use it on
20:00:31 <Emperor> yeah, so it's not set in stone if we want to adjust it.
20:01:20 <Emperor> Last call for AOB.
20:01:32 <Emperor> #endmeeting