#debian-boot Meeting

Meeting started by bubulle at 20:00:13 UTC (full logs).

Meeting summary

  1. see who's around (bubulle, 20:00:28)
  2. alpha release - grub status (bubulle, 20:04:01)
    1. http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=477094 (bubulle, 20:12:39)
    2. AGREED: Despite issues reported in #477094 (bubulle, 20:13:14)
    3. AGREED: we do not consider GRUB2 issues as a blocker for an *alpha* release (bubulle, 20:13:33)

  3. alpha release - schedule (bubulle, 20:16:01)
    1. AGREED: we wait for kernel udebs to enter testing (ageing asked to RMs already) and then otavio builds D-I (bubulle, 20:21:31)
    2. AGREED: bubulle prepares the errata file (bubulle, 20:26:45)

  4. git migration (bubulle, 20:29:15)
    1. AGREED: git migration needs more discussion and addressing concerns (bubulle, 20:34:15)

  5. Release goals overview (bubulle, 20:36:11)
    1. http://wiki.debian.org/DebianInstaller/SqueezeGoals (bubulle, 20:36:32)

  6. Release goals - Persistent device naming for disks (bubulle, 20:39:08)
    1. Release goal nearly achieved: only needs support in non grub2 bootloaders (bubulle, 20:42:36)
    2. AGREED: cjwatson or fezize should add a mention about missing bits in grub2 for persistent device naming support (bubulle, 20:44:12)
    3. AGREED: s/fezize/fezie (bubulle, 20:44:25)

  7. Release goals - Switch to udhcpc DHCP client from busybox (bubulle, 20:44:49)
    1. no progress (bubulle, 20:45:17)

  8. Release goals - Switch from console-data to console-setup (bubulle, 20:45:32)
  9. Release goals - Switch to udhcpc DHCP client from busybox (bubulle, 20:48:06)
    1. : last meeting; "otavio should decide about switching to udhcpc by default instead of dhcp3" (bubulle, 20:48:21)
    2. AGREED: we change netcfg to use udhcpc by default and either otavio or luk__ upload. We keep this in dailies as of now (bubulle, 20:54:48)

  10. Release goals - Add ext4 support (bubulle, 20:55:19)
    1. AGREED: document lack of 64bit support with ext4 in grub2: fezie just volunteered..:-) (bubulle, 20:58:02)
    2. AGREED: --> in the errata file (bubulle, 20:58:17)
    3. AGREED: add a whitelist for ext4 on / and /boot for archs that have grub/grub2 as listed in sc research (mvz will try) (bubulle, 21:01:57)

  11. Additionnal topics (bubulle, 21:08:25)
    1. from mvz: git migration guide: I sort of started, but haven't written much yet. gnome has excellent material for their own migration, I'll see if we can use some of that. would still appreciate if people could point me to specific questions they have, else I run risk of trying to document everything (bubulle, 21:08:59)
    2. d-i wiki is confusing and could use a restructuring; anyone interested please contact franklin and/or debian-boot (mvz, 21:15:03)


Meeting ended at 21:19:23 UTC (full logs).

Action items

  1. (none)


People present (lines said)

  1. bubulle (108)
  2. mvz (52)
  3. otavio (38)
  4. fezie (30)
  5. Ryan52 (9)
  6. youpi (9)
  7. otavio_ (5)
  8. otavio__ (5)
  9. MeetBot (2)
  10. xeon-enouf (2)
  11. CIA-6 (1)


Generated by MeetBot 0.1.4.