16:01:00 <olasd> #startmeeting DebConf Video Team meeting - 2025-06-05
16:01:00 <MeetBot> Meeting started Thu Jun  5 16:01:00 2025 UTC.  The chair is olasd. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:00 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:01:05 <olasd> #chair paddatrapper
16:01:05 <MeetBot> Current chairs: olasd paddatrapper
16:01:11 <olasd> #link https://storm.debian.net/shared/gPV23Wz8jCZpdj5gQDshkD-IoPH6TGkvziusj3nW265
16:01:17 <olasd> #topic 1. Roll call
16:01:28 <wouter> o/
16:01:29 <paddatrapper> 0/
16:01:33 <ivodd> hi
16:01:35 <lenharo> hi o/
16:01:36 <olasd> please say hi if you're here for the meeting
16:01:43 <wouter> not sure how long I can stay though, might not be until the end
16:01:44 <Giyeonbang[m]> o/
16:01:51 <olasd> </pollo>
16:06:24 <wouter> and then it got quiet?
16:06:44 <olasd> yeah
16:07:02 <olasd> moving on :)
16:07:14 * disaster2life[mds] is here dazed
16:07:17 <olasd> #topic 2.1 DC25 - Computer Decision
16:07:49 <olasd> I wanted to send numbers but I haven't heard back from the rental companies I've asked for quotes, which is annoying
16:09:18 <wouter> I take it that means we need to postpone the decision?
16:09:19 <olasd> all I've seen in terms of publically available information for computers to rent are cheap but old computers (like, older than the cube), which we know is asking for trouble, or expensive (50+ eur / day) gaming rigs with the latest CPUs.
16:10:05 <wouter> So what FOSDEM did to remedy that is to buy 2nd hand hardware, and then sell it at the end of the conf to attendees
16:10:06 <olasd> I'll call more companies tomorrow...
16:10:17 <wouter> which seems like crazy but actually worked very well for them
16:10:28 <wouter> and it tends to also be cheaper than rent if you don't end up being able to sell
16:10:34 <wouter> should we maybe consider that?
16:11:00 <olasd> we've discussed it a bit last week. my main concern with this option is that it would work in France where purchasing 2nd hand gear is cheap, but it doesn't scale well for future years with confs in random places
16:11:15 <olasd> so it's a similar headache to rental
16:11:26 <wouter> but we're not planning for a future conf, we're planning for France
16:11:39 <wouter> perhaps for a future conf we might revert back to renting -- I'm not suggesting we give that up altogether
16:11:42 <wouter> just for this edition
16:12:02 <wouter> anyway, just a suggestion; if we've considered it and discounted, then that's fine
16:12:04 <olasd> the other option we discussed last week was purchasing some transportable hardware
16:12:18 <wouter> yeah, then you're stuck with shipping fees and carnets etc
16:12:27 <wouter> rather buy or rent locally, I'd say
16:12:37 <olasd> which we already have to handle for everything we're not renting
16:12:39 <wouter> anyway, happy to move on if it's been discussed
16:12:42 <wouter> true
16:12:50 <ivodd> olasd: did you look at prices for new machines?
16:13:57 <tumbleweed> hello!
16:16:02 <olasd> ivodd: yes. I found my logins for the lenovo portal and the best option there looked like the P14s AMD Gen5, which has two Thunderbolt 4 ports, and decent all around specs for 800 euros (ryzen 5 CPU with 16GB of RAM and 512 GB of storage); the frame.work option for similar specs comes out to 1200 EUR (buying RAM and storage separately)
16:16:51 <olasd> the "peripherals" (a thunderbolt hub, two TB capture cards) come out to 600 eur / machine
16:17:30 <olasd> so an overall budget of ~ 5000 euros
16:18:13 <wouter> that sounds not too insane, although I don't know what our budget is
16:18:29 * tumbleweed has memories of people bumping firewire cables that we had taped to the side of laptops
16:18:56 <olasd> tumbleweed: yeah, that's my main concern with that idea too
16:19:09 <ivodd> people also bumped power cables etc
16:19:33 <dwfreed> laptops at least have built in UPSes
16:19:37 <tumbleweed> firewire was fairly close to the palm, and the bump typicallyr equired a reboot
16:19:54 <tumbleweed> the location of these TB ports will probably be critical
16:20:28 <tumbleweed> anyway, yeah, 5000 eur sounds acceptable
16:20:39 <olasd> for the lenovos, it's the left hand two ports furthest from the palm rest. the frameworks have one on either side of the laptop
16:21:23 <tumbleweed> yeah, that's fairly out of the way
16:21:28 <tumbleweed> just need them to stay nice and tight
16:22:27 <olasd> we could 3d-print a direct cable enclosure for the frameworks (and use the port that's recessed within the extension port to connect the thunderbolt cable)
16:22:29 <dwfreed> olasd: also consider tuxedo computers; they're german, and use ODMs like clevo, but they're great pricing and they officially support linux (the distro they usually ship is ubuntu based, but debian works well on the one I have)
16:22:46 <olasd> dwfreed: yeah, I'll check them out
16:23:04 <olasd> (FWIW the lenovo price is a 50% "DD" discount from sticker price)
16:23:13 <dwfreed> ah, nice
16:23:32 <wouter> it's nice to be able to use perks :)
16:23:54 <wouter> (unfortunately they're still not available in SA AFAIK :-( )
16:24:39 <olasd> #agreed ~5000 EUR budget seems okay for new computers and capture gear. Try rental companies harder for a few days, if that fails, get budget approval for purchases
16:24:57 <olasd> I'll probably parallelize, actually.
16:25:25 <olasd> (for now all the hardware in question is available for next day shipping...)
16:25:45 <olasd> anything else?
16:25:53 <lenharo> is it time enough to buy and be delivery on time?
16:26:45 <olasd> yeah, everything I've been considering can ship and be delivered within a few days
16:27:04 <tumbleweed> nice
16:27:27 <olasd> (the lenovo machines are a stock config, the frameworks are in stock, the blackmagic stuff is available on amazon, etc.)
16:27:27 <tumbleweed> are you planning to bring the paris equipment too?
16:27:38 <olasd> yeah
16:27:56 <tumbleweed> including all the audio gear and cube
16:28:03 <olasd> yeah
16:28:10 <tumbleweed> great
16:28:24 <olasd> which brings us to (not really)
16:28:32 <olasd> #topic 2.2 - DC25 stack
16:29:01 <olasd> maybe we can take advantage of wouter being around for sreview deployment questions :)
16:29:07 <wouter> hah
16:29:09 <wouter> sure, shoot
16:29:21 <ivodd> we won't have an on-site storage servers or encoders
16:29:31 <ivodd> so we won't have encoder with nfs access to the input
16:29:41 <wouter> as luck would have it
16:29:51 <wouter> I ran encoders over sshfs for FOSDEM
16:30:05 <wouter> and that worked well after an aborted attempt to implement something with libssh (that didn't work very well)
16:30:13 <wouter> so we can redo that
16:30:23 <wouter> I'll just have to ask basti for the sshfs details (he did those)
16:30:29 <tumbleweed> we're planning to use infomaniak cloud for anything offsite
16:30:38 <tumbleweed> we could have an sreview there
16:30:40 <tumbleweed> or do sshfs...
16:30:45 <tumbleweed> to vittoria
16:30:46 <wouter> but I also think that we should be able to get away with running everything on vittoria
16:31:03 <ivodd> if we can get a private vlan at infomaniak, we can also just use nfs :)
16:31:07 <wouter> now that it's been upgraded and its ffmpeg can do AV1
16:31:17 <wouter> right
16:31:20 <tumbleweed> I guess we could ask if they could lend us cores, too
16:31:24 <wouter> anyway, there are plenty of options
16:31:29 <tumbleweed> or some worker VMs in grnet
16:31:29 <wouter> I'm not worried :)
16:31:29 <olasd> wouter: av1 for 3 rooms on vittoria sounds a bit like we'll still be transcoding in 2027 ;-)
16:31:39 <wouter> olasd: nope
16:31:47 <ivodd> wouter: will you be available to get stuff working?
16:31:55 <wouter> olasd: we encoded all of FOSDEM 2024 and later in av1...
16:32:09 <wouter> ivodd: that's the big question, isn't it :)
16:32:24 <wouter> I have to admit that I've not been very active recently
16:32:27 <ivodd> well, if you're not, then I understand why you're not worried ;-b
16:32:27 <DLange> just a suggestion: consider renting in Paris if you lug around the equipment from there by car anyways
16:32:39 <wouter> (a whole DPL vote passed by and I didn't even notice it had *started*)
16:32:41 <DLange> stored laptops tend not to work well after some time
16:32:51 <DLange> batteries need maintenance etc.
16:33:02 <wouter> so, july, hrm
16:33:14 <wouter> I don't think it'll be a problem, provided I'm able to start setting up things earlyish
16:33:24 <wouter> as in, not from debcamp but a week or maybe two before
16:33:49 <wouter> that gives me more time to do it at a slower pace, and then I don't foresee issues
16:34:02 <olasd> the advantage of offsite infra is that there's nothing preventing us from setting it up now
16:34:24 <wouter> there is that too, yes
16:34:31 <olasd> (generic "us", not me "us" :D)
16:34:35 <tumbleweed> speaking of... I really need to do an etherpad
16:34:51 <wouter> except for the cloud costs that we would need to pay if infomaniak isn't sponsoring them
16:34:55 <tumbleweed> yeah, I'll take the action of getting some things up
16:35:14 <olasd> #action tumbleweed to get some things up (etherpad, ...)
16:35:24 <ivodd> wouter: we should pick a timeslot to look at the current state of sreview on vittoria and clean it up
16:35:31 <ivodd> wouter: we could plan for debconf at the same time
16:35:44 <tumbleweed> wouter: zigo said they'll sponsor
16:35:46 <olasd> #action wouter and ivodd to look into setting up sreview off-site within the next weeks
16:35:53 <tumbleweed> I just need to check that we've still got working credentials...
16:35:54 <wouter> tumbleweed: cool, no prob then
16:35:58 <tumbleweed> and sufficient capacity
16:36:21 <olasd> tumbleweed: my credentials that I used to connect to your account got pruned, at least
16:36:22 <ivodd> it would be nice if we can get something small to start testing fairly soon
16:36:27 <wouter> ivodd: yeah, we can do that. Can you ping me later with a date that would work for you? preferably a weekend or some such
16:36:36 <ivodd> we don't need a lot of capacity right now anyway
16:36:56 <ivodd> wouter: ok, will do. did you recover your laptop/key?
16:37:15 <olasd> #action tumbleweed to check that infomaniak can be used
16:37:41 <wouter> ivodd: I'm waiting for the parts to be shipped to Zetes South Africa's headquarters in Johannesburg, after that I need to wait for it to be shipped to Cape Town and then I'll need to drive an hour to hand it in... "not yet"
16:37:58 <wouter> ivodd: but there is termux and a mac that I use for eID software support on that os...
16:38:17 <ivodd> wouter: can you log in to vittoria?
16:38:29 <ivodd> (we can discuss this later)
16:38:32 <olasd> anything else on stack matters for the meeting?
16:38:33 <wouter> ... maybe? didn't check yet.
16:38:39 <olasd> (:))
16:38:45 <wouter> let's discuss that when we're looking at things together
16:38:53 <olasd> #topic DC25 - kit list
16:39:45 <wouter> (have to leave now, sorry -- later)
16:39:54 <tumbleweed> I guess stack = Vocto 1, unless we can bring all the inputs to the mixing PC
16:40:07 <tumbleweed> so we get to make that decision during debcamp, again
16:40:10 <olasd> we've discussed it last week
16:40:18 <lenharo> I couldn't finish the kit list. (sorry)
16:40:44 <olasd> we decided to assume vocto 2 and revert to vocto 1 if we couldn't get it to work reliably by DebCamp Friday
16:41:02 <tumbleweed> OK
16:41:06 <paddatrapper> I had a look at the draft list on salsa
16:41:15 <paddatrapper> It looks like it's all there
16:41:15 <olasd> in terms of kit list: I'm waiting for feedback on what exact audio gear we can borrow from the student union. I think we need to make a contingency plan for renting everything we're not getting from the venue or from Paris
16:41:26 <JonathanWiltshire[mds]> o/
16:41:30 <paddatrapper> Sounds good
16:42:08 <tumbleweed> err where is the draft list on salsa?
16:42:25 <paddatrapper> olasd: the supplement if necessary column - is that we have, but don't want to use?
16:42:37 <paddatrapper> tumbleweed: https://salsa.debian.org/debconf-team/public/data/dc25/-/tree/main/video?ref_type=heads
16:42:45 <tumbleweed> ah, in git
16:43:45 <olasd> let me refresh my memory
16:45:22 <olasd> paddatrapper: yes and no. at this stage the shipping plan is to take a van from Paris, so I can bring all our extra boxes of crap
16:45:24 <tumbleweed> I don't see the bits for jitsi
16:45:42 <tumbleweed> (USB cameras, audio interfaces)
16:46:03 <olasd> please add
16:46:16 <paddatrapper> Will do
16:46:40 <paddatrapper> #action paddatrapper to add remote participation equipment to list (USB cameras, audio interfaces)
16:46:51 <tumbleweed> thanks
16:47:12 <paddatrapper> We've got audio interfaces or are we needing to hire?
16:47:24 <olasd> we've got 2 steinbergs and 2 behringers
16:47:28 <paddatrapper> Cool
16:47:29 <olasd> I don't remember which you prefer
16:47:35 <tumbleweed> IIRC they all worked-ish
16:47:57 <olasd> there was a sample rate weirdness on one of the four
16:48:00 <JonathanWiltshire[mds]> They're all fine and all have quirks
16:48:24 <olasd> ok, so we can keep 2 and 2 is what I'm hearing
16:48:26 <JonathanWiltshire[mds]> We just have to remember which quirk is on which
16:49:19 <JonathanWiltshire[mds]> I think we even labelled them last time
16:50:11 <JonathanWiltshire[mds]> (the cameras definitely got quirk labels)
16:50:26 <olasd> #action olasd to request a quote and how much lead time they want from audiolite for the audio gear that we may need to rent (mixing desks etc.)
16:50:32 <tumbleweed> do we still have enough cameras with working audio input?
16:51:03 <olasd> we did last year, and AFAIK we didn't blow more preamps
16:51:11 <tumbleweed> :)
16:52:04 <olasd> #action olasd to find a purveyor of video equipment for tripods & SDI cable
16:52:20 <olasd> (I'll get a quote from where we bought the cameras, I think)
16:52:48 <tumbleweed> sounds good
16:52:49 <olasd> anything else?
16:53:17 <tumbleweed> HDCP strippers?
16:53:33 <tumbleweed> try the amazon lotter again?
16:53:48 <olasd> the ouhs-102s have been unobtainium since we got it last year
16:54:57 <wouter> o/ from termux now... won't be very chatty ;-)
16:55:31 <lenharo> how many cameras video team have?
16:55:39 <olasd> lenharo: 6 cameras
16:56:07 <lenharo> nice.. that's enough for 3 rooms.
16:57:53 <JonathanWiltshire[mds]> https://amzn.eu/d/dySFOgI is recommended to me but no personal experience
16:59:01 <tumbleweed> I also see the internet recommending https://www.amazon.com/dp/B00LM4IJ60
16:59:55 <olasd> the generic recommendation thread is https://www.reddit.com/r/VIDEOENGINEERING/comments/xme482/hdmi_1x2_splitter_to_bypass_hdcp/
17:00:01 <lenharo> tumbleweed, we used a similar at maceio and works fine.
17:00:32 <olasd> #action olasd to add a couple of hdcp strippers to the purchase pile
17:01:07 <phls> this one: https://www.mercadolivre.com.br/splitter-hdmi-para-dois-monitores-tv-projetor-duplicador-1x2/p/MLB36751117?pdp_filters=item_id:MLB3937359331
17:01:43 <olasd> ack, good to know
17:02:58 <olasd> anything more?
17:03:15 <olasd> #topic 3. Sprint?
17:03:20 <olasd> Not sure there's more to add from last week
17:03:43 <olasd> I'll probably skip the topic for further meetings
17:03:52 <olasd> #topic 4. MiniDebConf Maceió
17:04:15 <tumbleweed> I assume the videos are all done?
17:04:23 <tumbleweed> Shall we publish them?
17:04:29 <olasd> I believe we've forwarded the original recordings to samueloph so that he could try to clean the audio
17:04:56 <tumbleweed> ah
17:05:01 <tumbleweed> OK, we wait then
17:05:06 <phls> I didn't have time to ask more details about how to import the metadata. But I will :-)
17:05:11 <olasd> we also had an action for phls to run the metadata importer to get the publication ready
17:05:13 <olasd> :)
17:05:18 <phls> yes, this
17:05:43 <olasd> #action phls to (ask how to) run the metadata importer to get the videos ready for publication
17:05:56 <olasd> #action samueloph to let us know how the audio de-noising is going
17:06:15 <olasd> #topic 5. Camera
17:06:22 <olasd> phls: that's you, I believe :)
17:06:39 <phls> We would like to know If we could have the video team budget to buy a camera to use here in Brazil for our events. It has been hard to deal with different rented cameras every event.
17:06:49 <phls> Or at least, If we can keep this idea openned for further discussion
17:06:53 <olasd> I think it makes sense, yes
17:06:59 <tumbleweed> +1 yeah
17:07:38 <tumbleweed> the next question is how good the camera needs to be
17:07:51 <tumbleweed> probably anything that has a clean HDMI output could be used
17:08:09 <phls> Would be easier you buy a new one for the video team, and we get one of the used you have there?
17:08:17 <tumbleweed> we got mid-range cameras to have good low light performance
17:08:35 <tumbleweed> are our cameras still even available?
17:09:03 <wouter> tumbleweed: only the follow up, I believe
17:09:03 <phls> not sure
17:09:34 <olasd> yeah, the pxw-z90 is current
17:11:12 <phls> I have no idea how much is a new camera here in Brazil
17:11:22 <tumbleweed> those cameras are $3k each
17:11:27 <phls> I need to looking for
17:11:49 <tumbleweed> and the audio preamps are easily killed, we've broken a few
17:12:01 <olasd> yeah
17:12:08 <tumbleweed> so if you only have 1, you won't have a backup if you break it
17:12:21 <phls> I see
17:12:21 <olasd> (replacement top handles are something like 600 euros, too)
17:12:32 <tumbleweed> (the preamp is in the top handle)
17:12:35 <lenharo> around 22k BRL. ~3500EUR
17:13:09 <tumbleweed> I assume you usually use the XLR in?
17:13:26 <phls> this year we used XLR
17:13:27 <JonathanWiltshire[mds]> I mean the pre amps _shouldn't_ get killed if they're treated properly, but...
17:13:28 <tumbleweed> if you don't need that, there are certainly much cheaper cameras that have clean-HDMI out
17:14:38 <tumbleweed> JonathanWiltshire[mds]: I've known venues to provide speaker output (post-amplifier) by mistake instead of a clean line-level feed
17:14:42 <phls> This year was: Panasonic AGCX-350
17:14:47 <JonathanWiltshire[mds]> Exactly
17:16:15 <phls> the broken part on the camera is the XRL in?
17:17:32 <tumbleweed> yes
17:17:35 <JonathanWiltshire[mds]> The amplifier connected to the XLR, yes
17:17:45 <phls> We will start to looking for cameras here and we will send to next days to get your opinion
17:17:51 <olasd> I think with Brazil having at least one videoed event per year, having some video team kit in residence there makes sense, and it makes sense to have it similar to the europe-based kit
17:18:05 <JonathanWiltshire[mds]> yeh
17:18:43 <olasd> I wonder how we can make the audio input "less fragile". I assume there will be similar issues with other cameras with XLR inputs
17:19:23 <tumbleweed> always use a DI
17:19:39 <tumbleweed> in practice we almost always need one to lift the ground, anyway
17:19:41 <JonathanWiltshire[mds]> Adding a compressor/limiter in the chain is really the only option, but that's still open to human error
17:19:58 <phls> we already have 1 DI lol
17:21:03 <olasd> #agreed video team to request budget to add one camera in the Brazil kit
17:21:17 <olasd> #action phls to circulate camera options for review
17:21:20 <olasd> I guess that's it?
17:21:25 <phls> yes
17:21:44 <olasd> sounds good!
17:21:51 <olasd> #topic 6. Any other Business?
17:22:09 <phls> Probably you know that, but yesterday on the content team meeting we realized the first day of talks will be Monday, not Sunday.
17:22:19 <phls> So, just a note for one day more for video team tests, comparing to previous years
17:22:28 <wouter> I don't know if I've said this yet, but I won't be at debconf this yeae
17:22:45 <wouter> no available holidays for me...
17:23:09 <wouter> *year (silly android keyboard...)
17:23:11 <olasd> at least I was aware of the first talks day being Monday (and it was factored into my suggestion to make the vocto1/2 decision on Friday) ;-)
17:23:24 <JonathanWiltshire[mds]> I think I will be a couple of days earlier than arrival day this year; how soon do we have a space to get working in?
17:23:46 <JonathanWiltshire[mds]> Or is it Monday earliest?
17:23:56 <tumbleweed> JonathanWiltshire[mds]: I think we expect to have our working space at the start of debcamp
17:24:04 <olasd> I believe the public statement is that we have space starting Monday
17:24:08 <JonathanWiltshire[mds]> Ok
17:24:10 * tumbleweed will be there early too
17:24:58 <bensmrs> the venue won’t be available before debcamp
17:25:16 * lenharo arriving at july 7 after lunch
17:25:21 <olasd> ssh, we woke him up
17:25:49 <olasd> #topic 7. next meeting
17:25:56 <wouter> woke who up, dropbear?
17:26:05 <olasd> #agreed next meeting 2025-06-12 @ 16:00 UTC
17:26:18 <olasd> #endmeeting