16:00:48 <olasd> #startmeeting
16:00:48 <MeetBot> Meeting started Thu May 29 16:00:48 2025 UTC.  The chair is olasd. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:48 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:00:53 <olasd> #chair paddatrapper
16:00:53 <MeetBot> Current chairs: olasd paddatrapper
16:01:05 <olasd> #topic Roll Call
16:01:10 * highvoltage is present
16:01:19 <ivodd> hi
16:01:19 <phls[mds]1> Hi
16:01:20 <olasd> o/
16:01:21 <Giyeonbang[m]> o/
16:02:22 <olasd> cc. paddatrapper tumbleweed lenharo
16:02:34 <paddatrapper> o/
16:02:48 <olasd> do we have an agenda?
16:02:57 <lenharo> hi
16:03:04 <lenharo> i'm here now
16:03:19 <olasd> (I haven't been able to log in to storm.d.n in ages...)
16:03:35 <paddatrapper> https://storm.debian.net/shared/gPV23Wz8jCZpdj5gQDshkD-IoPH6TGkvziusj3nW265
16:03:46 <olasd> thanks
16:04:00 <paddatrapper> The email takes forever to arrive to log in and I haven't had time to work out why
16:04:58 <disaster2life[mds]> o/
16:05:08 <eamanu> o/
16:05:26 <olasd> alright, let's get started I guess
16:05:33 <olasd> #topic 2.1 DC25 - Team
16:06:02 <olasd> so, who expects to be here?
16:06:12 <olasd> (and have time to do video stuff :p)
16:06:24 <lenharo> i will
16:06:29 <JonathanWiltshire[mds]> yuss
16:06:30 <eamanu> I will be there
16:06:41 <JonathanWiltshire[mds]> (not really here just got phone notifications...)
16:06:54 <paddatrapper> I'm still trying to get a visa appointment, but hope to be there
16:07:02 <eamanu> I'm part of the DC26 org-team so I pretend to learn as much as possible :-)
16:07:03 <ivodd> I intend to be there
16:07:24 <olasd> I will be there but my attention will be pretty split
16:07:25 <highvoltage> I'm there, don't have many concrete plans yet due to recent work surge
16:08:06 <olasd> phls[mds]1 has previously said he'd be here but arriving at the end of debcamp
16:08:22 <olasd> I'm expecting tumbleweed to be here but busy
16:10:01 <olasd> this time around I hope we'll be able to spread a bit more of the knowledge of "core" stuff, especially to lenharo
16:10:18 <lenharo> yes
16:10:24 <olasd> #topic 2.2 DC25 - Stack
16:11:31 <olasd> there's a few things here to discuss. The first one is voctomix 1 vs voctomix 2; I don't think we want a replay of DC24's first day, so as we've not had a sprint if we move something to voctomix 2 it should probably be one room max
16:11:54 <paddatrapper> ++
16:12:05 <ivodd> and it would require someone to spend most of debcamp on testing it
16:12:08 <olasd> yes
16:12:15 <olasd> CCC has done a few Voctomix 2 events since then, and I think our bug reports have been getting attention
16:12:21 <ivodd> I guess that will depend on how well room prepation/setup is going during debcamp
16:12:37 <paddatrapper> Do we have access to talk rooms from the beginning of DebCamp?
16:12:48 <olasd> paddatrapper: I believe so
16:12:53 <highvoltage> sweet.
16:13:04 <olasd> we should check that with bensmrs off meeting
16:13:21 <BenjaminSomers[mds]> We do
16:13:23 <olasd> perfect
16:13:24 <ivodd> olasd: do you know if we will be allowed to move stuff (like mic receivers) during debcamp already (assuming we are allowed to do that at all)
16:13:31 <BenjaminSomers[mds]> Everything is fully booked for the whole 2 weeks
16:13:35 <ivodd> nice
16:13:36 <olasd> #info Video Team will get access to talk rooms for the whole 2 weeks
16:13:45 <JonathanWiltshire[mds]> So we could aim for 2, but should be prepared to revert much earlier?
16:14:23 <ivodd> if setup goes fine, we could allow people to do 'test' talks in the rooms during debcamp, and see how well it goes
16:14:27 <ivodd> with vocto2 that is
16:14:41 <olasd> mmm
16:15:07 <BenjaminSomers[mds]> French Culture 101
16:17:10 <olasd> #agreed We will aim to get a realistic room setup up early in DebCamp so we can get voctomix 2 through its paces (including test talks, making sure it runs fine unattended for the duration of a day, etc.); We will decide between 0, 1 or 3 rooms using voctomix2 a couple of days before the first talks
16:17:27 <olasd> does that make sense?
16:17:38 <ivodd> +1
16:17:40 <lenharo> for me it's make sense
16:17:42 <paddatrapper> sounds good
16:17:53 <disaster2life[mds]> question-
16:18:07 <olasd> ask it
16:18:32 <disaster2life[mds]> if theres multiple versions of voctomix, wouldnt that make it harder to train / let volunteers use it
16:18:38 <lenharo> what's the point to decide if we use voto 1 or 2?
16:18:48 <disaster2life[mds]> or would the training then be for both the systems?
16:19:09 <JonathanWiltshire[mds]> They are similar enough to cross train if we do end up there
16:19:49 <ivodd> we wanted to move to vocto2 last time, but that failed horribly (mainly because the machines weren't powerful enough for the config we used)
16:20:01 <olasd> lenharo: I think we should decide on Friday of DebCamp, so we can do trainings on Saturday/Sunday before talks start on Monday
16:20:02 <ivodd> so the next debconf might be a good time to try again (hopefully with more success)
16:21:14 <olasd> so, next up in the stack is sreview. We had agreed, a while ago, to avoid having a storage server / encoder farm on site
16:21:43 <disaster2life[mds]> JonathanWiltshire[mds]: i dont remeber much just remember keyboard shortcuts beinf better in vocto2 i think, so if someone trained on two goes to try 1 there might just be a slight hiccup, should be fine though one guesses
16:22:13 <ivodd> I don't know how well sreview supports a setup without an nfs server, but I'm confident we'll make it work
16:22:25 <olasd> #agreed vocto1/2 decision point on Friday of DebCamp so we can handle training on the weekend before talks start
16:22:31 <ivodd> worst case the review/publishing will be delayed by a few days
16:22:32 <olasd> (just recording that)
16:22:35 <JonathanWiltshire[mds]> agree
16:23:03 <olasd> ivodd: I believe fosdem runs voctomix that way?
16:23:09 <olasd> er, not voctomix, sreview
16:23:34 <ivodd> olasd: yeah, wouter said something about that, so there's a good chance we will be able to use something like that, but I don't know the deatils
16:23:37 <ivodd> details
16:23:38 <disaster2life[mds]> ~vocto on the mind~
16:23:41 <olasd> ivodd: do you mind if I #action you to look at these details?
16:24:30 <ivodd> olasd: I don't know if I will look at that before debcamp, but I intend to get review working during debcamp/debconf *somehow*, so you can action me on that
16:24:35 <olasd> ok
16:24:38 <ivodd> olasd: and I'm assuming we won't have a local storage server
16:25:16 <olasd> #action ivodd to look at the details of running sreview without a local storage server (maybe during DebCamp :P)
16:25:19 <lenharo> as i saw... we use infomaniak servers
16:25:59 <olasd> the last item I'm thinking of in terms of stack, is computers
16:27:48 <olasd> borrowing or renting computers has been a recurrent pain point and expense for DebConfs, and for (European) miniconfs the current video mixing computer (the "cube") is starting to show its age (we don't think it'll be able to reliably run Voctomix 2)
16:29:02 <highvoltage> olasd: didn't you mention something small and powerful a few weeks ago that might be suitable for following video team around?
16:29:09 <olasd> the cube was purchased in 2016 so it has lived long enough to see an upgrade; we can use it as one of the PCs for DebConf if we do Vocto1
16:29:48 <ivodd> in the past, we didn't have a good option for camera capture (via sdi or maybe hdmi) on laptops
16:29:59 <olasd> in Hamburg we started looking at options with ivodd and it seems that laptops with a thunderbolt port (or several) and blackmagic thunderbolt capture hardware should be workable now to do 1080p capture
16:30:25 <olasd> I've bought a blackmagic thunderbolt card and tried it with an old laptop that happens to have a TB3 port, it just works
16:30:42 <ivodd> olasd: with the same drivers as the current pci cards, right?
16:30:47 <olasd> yeah, same stack
16:30:59 <CarlFK[m]> I have a whole vocto system running on an orage pi
16:31:08 <JonathanWiltshire[mds]> Is Mark at Lenovo worth a tug to get some small but not tiny things to tour around?
16:31:13 <CarlFK[m]> with about 50% cpu
16:31:21 <ivodd> so the idea would be to buy 6 of those thunderbolt cards, and get laptops
16:31:34 <ivodd> well, 5, because we already have 1
16:31:45 <olasd> (I've actually returned it now :P)
16:31:54 <ivodd> ah, ok...
16:31:58 <CarlFK[m]> I'm not sure I would  bet a debconf on it today, but seems relevant
16:32:52 * CarlFK[m] uploaded an image: (162KiB) < https://matrix.org/oftc/media/v1/media/download/AZ4-nKizD8jB_4Ey7ErAWUeHw1kIAbi1f_kA2jVTPBv5XQRQcfzKJ3NvRUV3HNaVs3RLe1CPODBecB5u9i7Uq-tCeXZPy2jgAG1hdHJpeC5vcmcvaGV5TmFWTXhsTGdrUktzQXdxRUJyd25H >
16:33:12 <olasd> heh
16:33:41 <CarlFK[m]> that box will capture, camera, audio (both mic and analog in) mix save and streem.
16:34:00 <CarlFK[m]> no network cable needed
16:34:54 <olasd> looking at laptop options, there's a few that would work. Lenovo definitely has models that would make sense for that application, the framework laptop 13 would work as well (the amd versions have 2 usb4 ports with PCI support, the intel versions have all ports that are thunderbolt compatible)
16:35:39 <olasd> JonathanWiltshire[mds]: the "problem" with small PCs (aside from the general scarcity of PCI ports) is that you still have to procure screens, keyboards, mice
16:36:21 <olasd> laptops give you a baseline screen, keyboard and mouse-ish (then if you can find a screen you have 2 screens, which makes mixing plus something else like IRC way nicer)
16:36:31 <JonathanWiltshire[mds]> True
16:36:53 <JonathanWiltshire[mds]> I was thinking shipping robustness as well
16:37:09 <olasd> the main drawback of laptops is making sure the ports don't fail
16:37:26 <JonathanWiltshire[mds]> Eg https://www.lenovo.com/gb/en/c/desktops/thinkcentre/m-series-tiny?srsltid=AfmBOopYc2qjnm5WEeJiWAifDPXiEizM4PNbvcY_dauhj8ST-gzss8_Y plus external capture
16:37:48 <olasd> yeah, that's something to think of
16:38:10 <olasd> I have started pricing pc rentals anyway but I haven't heard back yet (it's a holiday weekend...)
16:38:57 <CarlFK[m]> I like the fosdem model of buying a lot of used laptops, using them and selling them to attendees at the end of the event
16:39:51 <olasd> doesn't work all that well when you have to buy a lot of used laptops in a random place in the world every year
16:39:56 <JonathanWiltshire[mds]> That has hassle written all over it
16:40:07 <olasd> (rather than "in Brussels")
16:40:07 <CarlFK[m]> good point
16:41:27 <JonathanWiltshire[mds]> BYOD for speakers (no not a serious suggestion)
16:42:12 <olasd> so what I propose is: pricing a couple of laptop options; pricing a mini-pc option; pricing the pc rentals for 2025, and getting to a decision at the next meeting?
16:42:36 <olasd> (or, I guess, before the next meeting :P
16:42:38 <JonathanWiltshire[mds]> Just about to suggest this is becoming a task force thing but no time to volunteer
16:42:38 <olasd> )
16:42:43 <JonathanWiltshire[mds]> So yes
16:43:06 <CarlFK[m]> +1
16:43:12 <olasd> #action olasd to price PC/laptop/rental options
16:43:48 <olasd> anything else in terms of stack? we had a meeting yesterday about what we'd use in terms of venue a/v equipment
16:44:33 <CarlFK[m]> im curious: has anyone tried ingesting camera video over usb?
16:44:59 <CarlFK[m]> the blackmagic card somehow hooked to a laptop makes me grumpy
16:46:07 <CarlFK[m]> the hdmi grabber I am using seems to work, but I haven't put any time into any level of testing
16:46:20 <olasd> #link https://www.blackmagicdesign.com/products/ultrastudio (we're looking at the UltraStudio Recorder 3G)
16:46:53 <olasd> we can chat about it more after the meeting
16:47:02 <olasd> #topic 2.3 DC25 - kit list
16:47:05 <JonathanWiltshire[mds]> Oh I thought black magic was a description not a brand lol
16:48:54 <olasd> a long long time ago I had done a basic inventory of the kit needed and what was available in Paris. the venue has a bunch of A/V equipment in all the rooms that we intend to video, and is working with us to borrow that equipment and adopt it into our setup
16:49:40 <olasd> ben is working with the student union to see if their audio equipment (especially mixing desks) is available and whether we could borrow it
16:51:08 <JonathanWiltshire[mds]> Consistency between rooms is a desirable quality if it can be done
16:52:43 <disaster2life[mds]> just curious, do we not have those fancy audio mixers from busan which could be remotely adjusted?
16:52:47 <olasd> lol
16:52:52 <olasd> we're not made of money
16:52:56 <JonathanWiltshire[mds]> They were local hires
16:53:09 <JonathanWiltshire[mds]> Although those desks are surprisingly reasonable these days
16:53:31 <paddatrapper> Would be amazing, but not really feasible to ship to every debconf
16:53:36 <olasd> hiring these in France is a stupid amount (several hundred a day)
16:54:00 <olasd> hiring any gear with the local supplier looks like you're covering its cost within two weeks, basically
16:54:16 <disaster2life[mds]> olasd: /me puts back piece of olasd I broke off
16:54:52 <disaster2life[mds]> JonathanWiltshire[mds]: ahhhh-
16:54:59 <olasd> but anyway, we'll need to have a firm list of what we have and what we need to hire before next meeting
16:55:48 <olasd> paddatrapper, lenharo: can you finalize the kit list before next meeting?
16:56:03 <paddatrapper> I think so, yes
16:56:14 <lenharo> i guess so
16:56:16 <olasd> #action paddatrapper and lenharo to finalize the kit list
16:56:30 <olasd> #action olasd to confirm with bensmrs the list of local equipment borrowed
16:56:46 <olasd> #action olasd to confirm what equipment to bring from Paris
16:57:08 <olasd> #topic DC25 - AoB
16:57:13 <olasd> anything else on DC25 ?
16:58:34 <olasd> okay then
16:58:48 <olasd> #topic 3 - Sprint?
16:59:00 <olasd> I have no time to organize it
16:59:19 <paddatrapper> I don't either
16:59:41 <paddatrapper> And probably wouldn't be able to attend one (assuming the goal is before debconf)
17:00:46 <olasd> I also have a union training session the week before DebCamp, so, yeah, attendance would be challenging :P
17:01:01 <JonathanWiltshire[mds]> must dash have fun
17:01:01 <disaster2life[mds]> debconf25 cdg -> bre train sprint?
17:01:16 <disaster2life[mds]> * train sprint? :)
17:01:26 <olasd> #agreed no meaningful time to do a sprint before DebCamp
17:01:44 <olasd> #topic 4 - MiniDebConf Maceió
17:02:19 <olasd> are there any followup tasks to the MiniDebConf that you're thinking of?
17:02:23 <olasd> lenharo, phls[mds]1?
17:02:52 <lenharo> phls[mds]1, that was looking it. But i guess everything is OK.
17:03:19 <olasd> I see the videos pulled from OBS were ingested into sreview and reviewed (and published), so, yay
17:04:11 <olasd> for publication (on DebConf Video channels at least), we're missing the import into https://salsa.debian.org/debconf-video-team/archive-meta
17:04:50 <olasd> which I think is exported from sreview (https://salsa.debian.org/debconf-video-team/archive-meta/-/blob/main/tools/sreview.py?ref_type=heads)
17:05:01 <phls> sorry, All good with MiniDebConf Maceió
17:05:32 <phls> I mean, with the video files
17:05:37 <olasd> ok, great
17:05:50 <olasd> can you look into running the metadata import, phls ?
17:06:08 <phls> yes
17:06:12 <phls> is there a file?
17:06:33 <phls> I can see hamburg
17:06:54 <olasd> it's not been imported from sreview yet
17:07:12 <phls> ok
17:07:23 <olasd> #action phls to try to run the metadata import for Maceió :-)
17:07:49 <olasd> #action tumbleweed to upload Maceió and Hamburg to DebConf Video channels
17:08:02 <olasd> #topic 5. - Any other business?
17:08:38 <tumbleweed> whoops, sorry, forgot about this
17:08:44 <olasd> #topic 6. - next meeting
17:08:56 <olasd> I think we should consider weekly?
17:08:59 <highvoltage> I know sprints is a previous topic but is it worth while organising one later on?
17:09:20 <highvoltage> like perhaps before or after FOSDEM again? or close to some other Debian event?
17:09:41 * highvoltage has a backlog of video projects but will probably work around it over December holidays and probably a little over DebCamp anyway)
17:09:49 <olasd> yes, surely we'll have leftovers from DebCamp
17:09:54 <olasd> #undo
17:09:54 <MeetBot> Removing item from minutes: <MeetBot.items.Topic object at 0x7f393865a0a0>
17:10:19 <olasd> I'm not sure I can commit much time for organizing, though
17:10:57 <highvoltage> well, I suppose we'll have some time to discuss this during DebCamp/DebConf anyway, I'll check how things go towards the end of the year and if I can, I'll step up for organising somethign
17:11:10 <samueloph> Where can I get the whole day recording from MiniDC Maceió?
17:11:12 <olasd> in Paris I'm sure April would have us again if we ask
17:11:30 <samueloph> Oh, sorry, ongoing meeting here
17:11:34 <samueloph> I'll wait
17:11:44 <olasd> #topic 6. - next meeting
17:11:51 <olasd> so, let's do next week?
17:11:55 <paddatrapper> ++
17:11:56 <lenharo> yes
17:12:01 <phls> ok
17:12:11 <olasd> #agreed next meeting: 2025-06-05 @ 16:00 UTC
17:12:19 <olasd> #endmeeting