18:00:50 <tumbleweed> #startmeeting DebConf Video Team Meeting
18:00:50 <MeetBot> Meeting started Tue Nov 17 18:00:50 2020 UTC. The chair is tumbleweed. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:50 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:01:01 <tumbleweed> #link http://deb.li/oNCD Agenda
18:01:04 <tumbleweed> #topic Roll Call
18:01:06 <pollo> i'm here but I might have to leave at any moment
18:01:12 * wouter waves
18:01:40 <tumbleweed> and we don't have an agenda for today
18:01:44 <tumbleweed> scribble scribble scribble
18:01:57 <wouter> that makes it a very short meeting? ;-)
18:02:04 <wouter> (actually not I would guess)
18:05:04 <tumbleweed> OK, moving on
18:05:13 <wouter> just the three of us then?
18:05:14 <tumbleweed> #topic miniconfs - MDCO2 - SReview
18:05:22 <tumbleweed> wouter: you've been setting things up?
18:05:30 <wouter> I just imported the schedule
18:05:37 <wouter> I haven't seen logos or a .svg file yet
18:05:47 <paddatrapper> Sorry, just finished supper
18:05:47 <wouter> I see from last week's meeting that highvoltage was working on that
18:06:07 <tumbleweed> yeah, it's been available for a couple of weeks now
18:06:08 <wouter> so I'll ask him; if he doesn't have anything, I'll make something myself
18:06:12 <tumbleweed> but conference schedules always change :)
18:06:12 <wouter> oh, okay
18:06:38 <wouter> my schedule parser can run repeatedly if there is a parseable schedule with unique identifiers
18:06:41 <wouter> wafer provides that
18:06:54 <wouter> so I could just have set that up, and that would've worked... ah well
18:07:28 <tumbleweed> are we running current sreview master?
18:07:30 <wouter> I'll look at making the gridengine stuff work after the meeting
18:07:32 <wouter> yes
18:07:40 <tumbleweed> is bs1770gain gone? :)
18:07:50 <wouter> eh, I think so, but I'll double check that :)
18:07:55 <pollo> I don't think we have any encoder nodes for the moment
18:08:05 <wouter> don't need them, vittoria can be encoder node
18:08:11 <wouter> it's how we always did miniconfs
18:08:17 <wouter> (vittoria has 8 virtual CPUS)
18:08:47 <tumbleweed> looks like bs1770gain is commented out, in an uncommitted change
18:09:03 <tumbleweed> (which is how we did dc20)
18:09:06 <wouter> right
18:09:22 <wouter> I'll keep using it that way then
18:09:36 <tumbleweed> anything else you need? SVGs are presumably the big thing
18:09:47 <tumbleweed> highvoltage had an action on them
18:09:48 <wouter> my long term plan is to make the normalization configurable, and then also plug in an ffmpeg-based one
18:09:56 <wouter> yeah, just the SVGs I think
18:10:09 <tumbleweed> when we get them, what's the process to add a test talk to sreview?
18:10:16 <tumbleweed> (so that we can run it through the pipeline)
18:10:31 <wouter> direct database calls :)
18:10:40 <wouter> or you can use the API that I added
18:10:45 <tumbleweed> just the talks table?
18:11:00 <wouter> yes, though that doesn't give you a speaker
18:11:07 <tumbleweed> probably good enough
18:11:09 <wouter> but that's okay, it won't die if you don't add speakers
18:11:10 <wouter> yup
18:11:13 <highvoltage> tumbleweed: oh yes, thanks for the reminder I'll try to get them tonight
18:11:15 <tumbleweed> yeah, we can link to a speaker
18:11:24 <tumbleweed> highvoltage: as soon as you get them done, let's try a test
18:11:27 <wouter> which is in speakers_talks
18:11:38 <tumbleweed> yeah, I've done that before
18:11:44 <wouter> right
18:12:13 <wouter> I had plans to add an admin interface so you would be able to enter a talk through a form this year, but then we had to do an online debconf so it's on the backburner now :)
18:12:23 <tumbleweed> :)
18:12:41 <tumbleweed> moving on, then
18:12:47 <tumbleweed> oh
18:12:54 <wouter> at least there's API and I learned about Vue, so it should be doable now
18:12:59 <tumbleweed> how are we going to get video files to vittoria
18:13:06 <tumbleweed> do we need DSA to add a public key?
18:13:13 <tumbleweed> or do we have a private one somewhere we should use?
18:13:23 <wouter> either that, or we can make vittoria pull
18:13:32 <wouter> which is probably easier
18:13:49 <wouter> there's a key in ~sreview/.ssh which *should* be in ansible already
18:14:22 <tumbleweed> OK, I'll look at that
18:14:35 <tumbleweed> #action highvoltage to create title slides for SReview
18:14:41 <tumbleweed> #action tumbleweed to get video to sreview
18:14:46 <wouter> (afk for a minute, brb)
18:14:49 <tumbleweed> #action tumbleweed to do an all-up test through sreview
18:15:00 <tumbleweed> #topic miniconfs - MDCO2 - Static Loops
18:15:05 <tumbleweed> highvoltage: you've got another hanging action here
18:17:14 <tumbleweed> I'll carry it over
18:17:26 <tumbleweed> #action highvoltage to generate statics loops
18:17:36 <tumbleweed> #topic miniconfs - MDCO2 - Training
18:17:38 <tumbleweed> Training is done
18:17:48 <tumbleweed> Docs are updated to be closer to MDCO2
18:17:52 <tumbleweed> anything more to say here?
18:18:06 <wouter> (back)
18:18:34 <paddatrapper> Is the volunteer system up and working?
18:19:13 <terceiro> hi - I couldn't make the volunteer system work yet. is it a blocker?
18:19:33 <terceiro> being a small event, I would suggest just using the wiki or an etherpad
18:19:35 <tumbleweed> it could be scheduled in a pad instead
18:20:25 <paddatrapper> Either way, we need to publish something soon
18:20:47 <tumbleweed> so, we need somebody to create a pad/something and email all the registered volunteers
18:20:54 <tumbleweed> any volunteers?
18:20:59 <pollo> I can
18:21:44 <tumbleweed> #action pollo to create a pad/something and email all the registered volunteers
18:22:04 <tumbleweed> #topic miniconfs - .br mini
18:22:12 <tumbleweed> there was an agenda item last weekt o schedule a meeting the the BR team
18:22:17 <tumbleweed> has anything happened there?
18:22:37 <tumbleweed> I assume somebody needs to start a framadate / something and let people know
18:22:41 <tumbleweed> phls: ^^
18:22:45 <pollo> tumbleweed: phls came in during our meeting afterall
18:23:16 <tumbleweed> yes
18:23:28 <tumbleweed> I take it there are no more details that need to be hammered out, then
18:23:32 <pollo> he said we didn't need to meet
18:23:34 <wouter> might still be good to have a a proper meeting though?
18:23:37 <wouter> oh, nvm then :)
18:24:00 <wouter> terceiro: do you think there's something still necessary? or are you not involved?
18:24:09 <tumbleweed> there are actions to carry over here
18:24:18 <tumbleweed> #action phls (or someone from mcdobr) to provide a slide with sponsor logos + a general logo for the conf
18:25:07 <terceiro> I am involved, but won't be available during at least the Saturday
18:25:46 <tumbleweed> wouter: I assume we should be setting up sreview for that mini, too
18:25:52 <terceiro> AFAICT things are in place
18:25:54 <tumbleweed> they have a published schedule
18:26:00 <wouter> oh, cool
18:26:03 <wouter> let me do that now then
18:26:11 <tumbleweed> #action wouter to set up sreview for the .br mini
18:26:29 <tumbleweed> terceiro: did we train enough .br volunteers last weekend, or are we going to need to organise more training?
18:27:03 <terceiro> tumbleweed: I don't know, I didn't really follow this
18:27:18 <tumbleweed> I imagine we're going to need more .in training - the time slots we had weren't great for them. And nobody pitched for the one we added at the last minute
18:27:53 <tumbleweed> terceiro: anyone we should be relaying that question to? or drop it?
18:28:20 <terceiro> tumbleweed: phls and lenharo
18:28:51 <pollo> I'd be curious to know how pre-recording has been going and where the videos are stored atm
18:29:14 <terceiro> tumbleweed: I *think* they have a call for volunteers happening atm
18:29:18 <tumbleweed> well they're both here. No need for me to repeat that to them
18:29:29 <terceiro> they should have news on that Soon(TM)
18:29:59 <wouter> schedule for mdcobr has been imported into SReview
18:30:02 <tumbleweed> OK, well if the .br team needs anything, let us know
18:30:08 <tumbleweed> #info mdco.br has been imported into sreview
18:30:16 <wouter> (but mdco2 is still the default)
18:30:55 <tumbleweed> #topic mdco.br - infra
18:31:20 <tumbleweed> I'll be around for some of the .br mini timezone. If you run into problems I'm here
18:31:27 <wouter> am I wrong in assuming we just use the same infra we used for mdco2, with changed configs?
18:31:36 <pollo> that's the plan yes
18:31:38 <tumbleweed> I don't know if anyone will be for the first few sessions of the day, though?
18:32:16 <tumbleweed> I've offered phls access to the machines, in case he needs them. But he needs to take me up on that offer and provide his ssh key
18:32:21 <pollo> I can try, I haven't actually looked at the schedule yey
18:32:33 <tumbleweed> Don't know if .br needs more than that
18:33:20 <tumbleweed> #link https://mdcobr2020.debian.net/schedule/ mdcobr2020 schedule
18:33:34 <wouter> the schedule starts at 14:30 local time for me
18:33:35 <pollo> I mean, it's early but I guess I can take the first slots
18:33:49 <tumbleweed> it's less early on the sunday, at least
18:33:54 <wouter> I *should* be able to look at things, but I'm not confident enough that I'll be able to actually fix things if they're broken
18:34:35 <tumbleweed> let's move on
18:35:00 <tumbleweed> #info wouter may be around during mdcobr2020 mornings
18:35:07 <tumbleweed> #info pollo should be around during mdcobr2020 mornings
18:35:19 <tumbleweed> #info tumbleweed should be around during mdcobr2020 afternoons
18:35:40 <tumbleweed> #topic video archive documentation
18:35:43 <tumbleweed> pollo: carry over?
18:35:49 <pollo> yup
18:36:09 <wouter> what do you want documented there?
18:36:18 <wouter> it's just a big file dump that gets rsync'd
18:36:29 <tumbleweed> migrating https://wiki.debconf.org/wiki/Videoteam/Archive to the debian wiki and updating
18:36:30 <wouter> and some git annex that nobody uses anymore, I think
18:36:32 <pollo> it uses git-annex for one
18:36:33 <olasd> locations, who owns what, how does it get rsynced, etc.
18:36:48 <wouter> mm, okay
18:37:06 <olasd> (the git-annex is still used for integrity checking)
18:37:20 <tumbleweed> and if we got access to those s3 bucket credentials, it could be backed up there
18:37:27 <olasd> (at least it was when the archive was moved)
18:37:45 <wouter> okay, fair enough
18:37:45 <tumbleweed> I have committed dc20 to it
18:39:09 <tumbleweed> #topic AoB
18:39:46 <wouter> should I keep doing VP8 encodes?
18:40:03 <pollo> I don't think so
18:40:04 <wouter> we currently do an "lq" version of everything, which is scaled down and at lower bitrate
18:40:13 <tumbleweed> we could do av1 and vp9
18:40:18 <wouter> (so it's not *just* vp8)
18:40:24 <wouter> av1 encoding is still *very* slow with ffmpeg
18:40:34 <wouter> takes multiple seconds to encode just one frame
18:40:34 <pollo> ah, lq is vp8?
18:40:38 <wouter> I'd rather wait with that
18:40:38 <tumbleweed> pollo: yep
18:40:39 <wouter> pollo: yes
18:40:44 <pollo> then I'd say yes
18:40:58 <pollo> why isn't lq also vp9, but with different settings?
18:41:09 <wouter> historic reasons :)
18:41:24 <wouter> I think urbec complained once that her old laptop couldn't handle vp9
18:41:41 <wouter> so I decided to make at least one encode usable on older hardware
18:41:53 <wouter> I could convert that one to VP9 too, easily
18:42:19 <tumbleweed> That urbec laptop issue should have been resolved a couple of years ago now
18:42:30 <wouter> I know, hence "historic"
18:42:33 <tumbleweed> +1 on vp9
18:42:45 <tumbleweed> ah, I also have an AoB
18:42:53 <tumbleweed> currently we just have the instance storage on the voctomix and backend machines
18:43:05 <tumbleweed> should we add extra volumes for recordings?
18:43:14 <wouter> how much space is available currently?
18:43:33 <tumbleweed> I guess I should look at 140G on voctomix1
18:43:38 <tumbleweed> oops
18:43:44 <tumbleweed> 140G on voctomix1
18:44:14 <wouter> 140G might be a bit tight
18:44:19 <tumbleweed> only 34G on backend
18:44:24 <tumbleweed> which is certainly going to be tight
18:44:30 <wouter> I'd be more comfortable with twice that
18:44:37 <wouter> definitely need more than 34G, yes :)
18:44:53 <wouter> so yeah, I'd add some storage if you can make that happen
18:45:05 <wouter> I think you need to assume 300G for a miniconf
18:45:18 <wouter> (for all the recordings of that miniconf, obviously)
18:45:35 <wouter> that's a bit more than what we actually need, but you want some margin
18:46:05 <tumbleweed> OK, I'll give them both 250G volumes and we can see how it goes after mdco2
18:46:06 <wouter> minidc hamburg 2019 used 224G
18:46:10 <wouter> marseille used 158G
18:46:14 <wouter> vaumarcus 95
18:46:20 <tumbleweed> they'll cost €10/month each
18:46:28 <wouter> yeah, that should work
18:46:55 <wouter> actually, those all used MPEG2
18:47:02 <wouter> mdco1 used 4.4G, in mpeg4
18:47:14 <wouter> so we might not need extra storage after all
18:47:33 <wouter> then again, €10 is not *that* much
18:47:47 <wouter> maybe do it for now, we can always remove it if we don't end up needing it
18:48:29 <tumbleweed> dco20 looks like it was < 8G / day / room, every day
18:48:48 <tumbleweed> so voctomix1 should be fine
18:49:12 <tumbleweed> it's the backend that's risky. I'll give it 50G or something
18:49:22 <wouter> sounds good
18:50:00 <tumbleweed> #topic next meeting
18:50:07 <tumbleweed> this time next week, as usual. I presume
18:50:11 <wouter> +1
18:50:13 <wouter> no need to change
18:50:21 <tumbleweed> #agreed same time, next week
18:50:26 <tumbleweed> #endmeeting