17:59:06 <paddatrapper> #startmeeting
17:59:06 <MeetBot> Meeting started Tue Mar 17 17:59:06 2020 UTC. The chair is paddatrapper. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:59:06 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:59:09 <olasd> hi if you're here for the meeting
17:59:11 <paddatrapper> #topic rollcall
17:59:18 <tumbleweed> hi
17:59:20 <olasd> oops, too early :P
17:59:33 * tumbleweed recaffinates
17:59:34 <paddatrapper> Agenda: http://deb.li/oNCD
17:59:37 <paddatrapper> heh
17:59:55 <paddatrapper> please add stuff to the agenda if you want to talk about it
18:00:49 <CarlFK> here
18:01:46 <paddatrapper> #topic Upcoming MiniConfs
18:02:03 <paddatrapper> #info Aberdeen MiniConf has been postponed
18:03:03 <nattie> hi kids
18:03:19 <olasd> sad, but the only sensible choice at this point; fyi the videoteam hardware is in my office, and my office is out of bounds as France is being confined for at least the next 15 days
18:03:40 <olasd> (access cards disabled and everything)
18:03:49 <paddatrapper> #info no access to video team equipment for at least the next 15 days
18:04:16 <tumbleweed> we could use this time to buy more equipment, of course :)
18:04:24 <olasd> we should
18:04:28 <paddatrapper> well we do have a shopping list :)
18:04:37 <nattie> Hamsterkäufe!
18:04:54 <olasd> my insurance claim for Brussels is still in the pipeline. I should probably give them a poke
18:05:32 <paddatrapper> #action olasd to poke insurance about Brussels
18:05:39 <olasd> heh
18:06:14 <paddatrapper> with a sharp stick
18:06:39 <olasd> well not too sharp, I'd like them to pay up ;)
18:06:44 <paddatrapper> heh
18:07:01 <paddatrapper> is there someone willing to spearhead the new gear purchase?
18:07:51 <olasd> quite frankly, not in the next few weeks
18:08:28 <nattie> i'm happy to help, if someone points me
18:08:38 <nattie> for what that's worth (i have no idea of the requirements)
18:08:42 <paddatrapper> nattie: sure happy to
18:08:53 <paddatrapper> it should largely be emailing people at this point
18:08:53 <nattie> cool, let's do that then
18:09:12 <paddatrapper> #action nattie and paddatrapper to get quotes and approval for gear purchase
18:09:32 * tobi is sorry for being late
18:10:05 <nattie> no worries, tobi
18:10:29 <paddatrapper> Any other miniconf updates that we know about?
18:10:48 <nattie> nothing to my knowledge that anyone's mentioned to me
18:10:55 <nattie> i guess we're the nearest, temporally
18:11:12 <nattie> Montreal? pollo?
18:11:16 <tumbleweed> safe to say no other in-person miniconfs happening any time soon
18:11:30 <olasd> paddatrapper: I should be able to give you creds to the thomann account so you can dupe the old card
18:11:33 <olasd> cart*
18:11:42 <paddatrapper> olasd: thanks that would be helpful
18:11:43 <pollo> we haven't decided anything yet, since Aug is in a while
18:11:50 <nattie> fair enough
18:12:15 <paddatrapper> #topic BillowConf
18:12:28 <nattie> the other two that i'm aware of are september/october (Bordeaux was going to be May, but then decided to set later dates even before this)
18:12:41 <paddatrapper> #undo
18:12:41 <MeetBot> Removing item from minutes: <MeetBot.items.Topic object at 0x138cd10>
18:12:46 <olasd> (we also need to figure out a better flight case before ordering again)
18:13:14 <paddatrapper> #info there are two MiniConfs in September/October
18:13:32 <paddatrapper> Definitely need a better flightcase
18:13:42 <paddatrapper> #info need a better flight case this time
18:13:50 <paddatrapper> #topic BillowConf
18:14:01 <tobi> I'm the one gulty for the one in september … ;-)
18:14:11 <paddatrapper> This came out of remote participation for DebConf and State of the Map becoming virtual
18:14:40 <paddatrapper> would appreciate thoughts/changes
18:14:47 <paddatrapper> https://gitlab.com/billowconf/billowconf
18:14:49 <tumbleweed> paddatrapper: you going to make that storm doc public?
18:14:52 <paddatrapper> not much there yet
18:15:51 <paddatrapper> tumbleweed: it should be fixed in master, otherwise
18:15:52 <paddatrapper> https://storm.debian.net/shared/ZN57brpgW2dVu87tYl2KBBhs9iX7er7hS01Wv9M6jN3
18:16:15 <olasd> when is SOTM?
18:16:25 <paddatrapper> End of July
18:17:19 <paddatrapper> #info paddatrapper has started working on a virtual conference system
18:17:20 <tumbleweed> seems ambitious. But ambitious is good :)
18:17:49 <paddatrapper> Luckily I'm not doing much at work :)
18:18:30 <tumbleweed> any areas that need help?
18:18:38 <paddatrapper> the tricky thing is making it front-end agnostic so that native and web will work
18:18:55 <paddatrapper> having never really worked with frontend stuff before
18:19:16 <paddatrapper> And then all the RTMP manipulation behind the scenes
18:19:45 <tumbleweed> are you buliding the RTMP bits on top of anything existing?
18:20:02 <paddatrapper> I haven't looked yet, but I would prefer to, yes
18:20:30 <tumbleweed> if you get the API design right, supporting multiple front-ends shouldn't be too bad
18:20:48 <tumbleweed> the trickyness there is probably in specific requirements for web frontends
18:21:17 <paddatrapper> yeah
18:21:53 <tumbleweed> I've been trying to think if there are ways to break this problem into smaller pieces, that can reuse existing things (e.g. jitsi) until you get to those areas
18:22:27 <tumbleweed> because this seems kind of reinvent-the-world, all-or-nothing. Which is very high risk for not being ready in time for whatever you need it for
18:22:34 * highvoltage arrives (ran late)
18:23:19 * tumbleweed throws dc16 at peertube
18:23:30 <paddatrapper> I have briefly looked into trying to tie in jitsi, but need to do more digging
18:23:40 <highvoltage> tumbleweed: thanks for bug filing
18:24:08 <paddatrapper> #topic Any other business
18:24:21 <tumbleweed> I doubt jitsi would scale to a BoF
18:25:44 * highvoltage has business
18:25:55 <tumbleweed> https://peertube.debian.social/ now exists
18:25:58 <olasd> tumbleweed: depends on the size and the attendee discipline
18:26:02 <tumbleweed> busy uploading our archive to it
18:26:03 <highvoltage> can we talk about a virtual minidebconf too?
18:26:11 <olasd> (we did 16 people today on jitsi meet)
18:26:19 <olasd> (audio-only obvs)
18:26:22 <paddatrapper> highvoltage: that would be a great stress test
18:26:37 <tumbleweed> I got 2 GPU lockups this morning, thanks to (google meet) video conferences :(
18:26:44 <paddatrapper> #info https://peertube.debian.social/ now exists
18:26:50 <highvoltage> yeah I would do do that with the goal of testing ot current collaboration tools and filing bugs for the next
18:27:00 <pollo> olasd: wouldn't mumble be simpler and scale better for audio-only?
18:27:02 <highvoltage> tumbleweed: ouch
18:27:24 <highvoltage> pollo: probably less convenient if one person wants video or wants to screenshare
18:27:24 <olasd> pollo: when you have a server
18:27:34 <tumbleweed> neither recovered gracefully, although sometimes they do
18:27:44 <olasd> anyway
18:27:53 <tumbleweed> jitsi type things can be nice with 1 person sharing a screen, and video, and everyone else being audio only
18:27:55 <highvoltage> I guess in a bof video could be highly optional
18:28:02 <highvoltage> yeah exactly
18:29:01 <highvoltage> we need a local team for an online miniddebconf, anyone here interested? :)
18:29:19 <nattie> who here is extremely online?
18:29:26 <tumbleweed> when are you thinking?
18:29:36 * tumbleweed is local to the internet :P
18:29:53 <highvoltage> don't have an exact date yet, but I was thinking perhaps 1.5-2 months from now
18:30:00 <paddatrapper> I would be keen
18:30:01 <CarlFK> tonight my chicago hackerspace will be doing the weekly meeting online. using zoom.
18:30:08 <highvoltage> one and a half to two months
18:30:19 <CarlFK> I am up for imposing a differet solution every week
18:30:36 <highvoltage> so I'm counting nattie, tumbleweed and paddatrapper for local team :)
18:30:45 <highvoltage> clearly we won't be using zoom
18:31:17 <highvoltage> anyone volunteering to create a link for it on https://wiki.debian.org/MiniDebConf ?
18:31:58 <highvoltage> (otherwise I'll go ahead and do it)
18:32:12 <paddatrapper> Go ahead
18:32:25 <CarlFK> if you queue up some things, I'll try to use them (not up to me what gets used, but hopefully the group would be open to being a gunipig
18:33:12 <highvoltage> CarlFK: great, I'll add a 'testers' section to the minidebconf page and add you
18:33:37 <paddatrapper> #agreed Vritual MiniDebConf happening 1.5-2 months from now
18:33:39 <CarlFK> the meeting is superfulous
18:33:49 <highvoltage> which one CarlFK?
18:33:58 <paddatrapper> #info nattie highvoltage tumbleweed paddatrapper volunteered for local team
18:34:00 <CarlFK> so it doesn't matter if I tank it (ps1 weekly hackerspace meeting
18:34:17 <highvoltage> ah right, gotcham when is that meeting?
18:34:27 <paddatrapper> #info CarlFK will try be a gunipig
18:34:47 <CarlFK> every tuesday, 8pm Central time
18:35:10 <paddatrapper> #info trials every Tuesday 20:00 Central time :)
18:36:03 <CarlFK> I'll encourage anyone here to be a guest. help get a feel for how well things go
18:36:12 <highvoltage> https://wiki.debian.org/DebianEvents/internet/2020/MiniDebCamp#preview
18:36:38 <tumbleweed> \o/
18:37:00 <tumbleweed> highvoltage: you want to talk about your plans for the debian.social peertube?
18:37:19 <olasd> can we get #topics please?
18:37:40 <paddatrapper> #topics debian.social Peertube
18:37:49 <paddatrapper> #topic debian.social Peertube
18:37:54 <paddatrapper> second times the charm
18:38:02 <paddatrapper> #chair olasd
18:38:02 <MeetBot> Current chairs: olasd paddatrapper
18:38:04 <highvoltage> ah yeah tumbleweed mentioned that already
18:38:21 <highvoltage> but I'm very excited about it, it's been 4 years in the making with lots of pushes to make it happen
18:38:21 <tumbleweed> sure, but what use are expecting?
18:38:40 <highvoltage> and I'm very glad tumbleweed took care of all the uploading stuff
18:39:02 <tumbleweed> I mean, aside from mirroring our archive, I assume we'll get people using it for other stuff
18:39:22 <highvoltage> tumbleweed: you mean peertbube.debian.social?
18:39:34 <tumbleweed> I do
18:40:08 <highvoltage> yeah the idea is to use it for all kinds of debian stuff. at DC19 I spoke to a bunch of different people who have uploaded debian content to youtube (or never uploaded it anywhere)
18:40:40 <highvoltage> I can't remember that guys name but he helped with video team and his name starts with an L, he said they made tons of Spanish Debian content that's online nowhere and only on hard drives
18:40:42 <paddatrapper> #info peertube.debian.social intended for all kinds of Debian stuff, as well as mirroring the video team archive
18:41:11 <highvoltage> so I'm hoping we can get all of that on there, and also encourage people who currently make debian howtos for youtube to license it freely and upload it to peertube as well
18:42:03 <tumbleweed> I assume we should try to get some of that into our apu archive too
18:42:11 <highvoltage> it might take off or not, if it doesn't, it will at least be useful for the debconf videos, but I think we can build some community around this. I hear frustration from linux video makers uploading to exising sites that the encoding waiting is too long
18:42:24 <highvoltage> (like 2 or 3 days wait)
18:42:31 <highvoltage> our machine does a whole debconf in less than a day
18:42:50 <tumbleweed> I don't know what the the cutoff point for our archive should be
18:43:08 <highvoltage> cutoff point? in terms of what kind of content we accept?
18:43:22 <paddatrapper> #info our machine encodes a whole debconf in less than a day
18:43:42 <tumbleweed> highvoltage: so, if someone uploaded a miniconf to peertube, I'd say: Can we have this for our primary archive, please
18:44:03 <tumbleweed> I don't really want peertube to become that
18:44:15 <highvoltage> tumbleweed: ah right, I guess we should have a workflow where all minidebconf videos come to the debconf video team for processing
18:44:36 <highvoltage> and then it gets uploaded through the debconf channel channels
18:44:46 <highvoltage> channels channel
18:44:48 <highvoltage> whatever :)
18:45:13 <highvoltage> tumbleweed: I'm not 100% sure I follow, you mean peertube shouldn't become something where minidebconf upload vidoes theirselves?
18:45:42 <tumbleweed> my concern is that if we do that, we don't get this content somewhere that we can usefully *archive* it
18:45:55 <tumbleweed> (that = self uploading)
18:46:08 <highvoltage> ah, so you're talking about non-debconf content
18:46:18 <highvoltage> right?
18:46:26 <tumbleweed> yeah, miniconfs
18:46:38 <highvoltage> yeah but I don't think minidebconf should self-upload anything
18:47:11 <highvoltage> they should provide it to the debconf video team for uploading to all the archive.org, youtube, peertube, etc
18:47:19 <highvoltage> or am I completely misunderstanding you?
18:47:34 <tumbleweed> that's what I'm saying, yes
18:47:41 <CarlFK> pyvideo struggedl with this: don't allow "garbage" but then how is that defined and who gets to decide.
18:47:56 <tumbleweed> although I'd really like to not have us be in the middle of this, it seems unavoidable
18:48:07 <tumbleweed> CarlFK: right
18:48:24 <tumbleweed> the line could be as simple as: we'll take any content from debian-focussed events
18:48:39 <highvoltage> tumbleweed: ok agreed then, paddatrapper you know what to do
18:49:23 <paddatrapper> #agreed we will take any content from debian-focussed events. MiniConfs should provide the video to the video team to upload to all archives
18:49:36 <highvoltage> tumbleweed: it's going to be simpler than for a minidebconf local team to work it out from scratch every time. maybe we can source some volunteers to help out with this. it's at least trivial when all the scripts are in place
18:49:50 <tumbleweed> yeah
18:49:57 <highvoltage> tumbleweed: maybe we could recruit to video team from all the minidebconf at the same time for this
18:50:32 <paddatrapper> #agreed try build a team for minconf video and content uploading
18:51:18 <paddatrapper> any volunteers to lead this?
18:51:40 <highvoltage> sure, will need tumbleweed's help but sure that won't be a problem
18:51:49 <paddatrapper> #undo
18:51:49 <MeetBot> Removing item from minutes: <MeetBot.items.Agreed object at 0x12bf050>
18:51:59 <paddatrapper> #action highvoltage to try build a team for minconf video and content uploading
18:52:08 <paddatrapper> #info with help
18:52:45 <paddatrapper> Any other things we need to talk about?
18:52:48 <tumbleweed> there's still lots of work to do, documenting existing miniconfs in our archive
18:53:06 <tumbleweed> I'm happy to help people with that
18:53:09 <highvoltage> tumbleweed: I suppse explaining this stuff is a nice way of getting it documented
18:53:12 <paddatrapper> #info there is a lot of work to do, documenting existing miniconfs in our archive
18:53:21 <highvoltage> tumbleweed: we could have a BoF about documenting minidebconf uploads at minidebconf online
18:53:23 <tumbleweed> it helps if you can script web scrapers
18:53:29 <highvoltage> (that's an action yes)
18:53:40 <tumbleweed> highvoltage: absolutely
18:53:55 <paddatrapper> #agreed have a BoF about documenting minidebconf uploads at minidebconf online
18:54:23 * highvoltage has nothing else for now
18:54:44 <tumbleweed> neither
18:54:50 <paddatrapper> #topic Next meeting time
18:54:55 <paddatrapper> 21 April 2020 @ 18:00 UTC?
18:55:42 <olasd> sounds fine to me
18:55:57 <nattie> sure
18:56:04 <nattie> it's not like we're going anywhere
18:56:11 <tumbleweed> heh
18:56:15 <paddatrapper> #agreed Next meeting 21 April 2020 @ 18:00 UTC
18:56:18 <paddatrapper> #endmeeting