19:59:39 <edrz> #startmeeting
19:59:39 <MeetBot> Meeting started Tue May 11 19:59:39 2010 UTC.  The chair is edrz. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:59:39 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:59:59 <edrz> http://wiki.debconf.org/wiki/Videoteam/Meetings
20:00:02 <edrz> has the agenda
20:00:15 <edrz> everyone say "hi" or something if you're here
20:00:19 <vicm3> hi
20:00:28 * MrBeige adding things to agenda (stuff I can use for venue stuff)
20:00:44 <hermanr> hi
20:00:47 * p2-mate lurks
20:00:54 <edrz> #topic computer hardware needed for videoteam
20:01:10 <edrz> so. we plan on doing 2 rooms as usual.
20:01:12 * jeremyb is half here
20:01:44 <karora> Howdy :-)
20:02:13 <h01ger> hola
20:02:23 <bwh^> hi
20:02:47 * karora has to head off in a little while to take the kids to school, but I expect there's not too much I can contribute to the discussion really.
20:02:48 <edrz> we'll need 2 machines that can handle dvswitch, 2 additional grabbing machines, a large file storage machine, and stream encoders. at a minimum
20:03:11 <edrz> anything else I'm missing in that list?
20:03:17 <h01ger> how many cams do you plan?
20:03:30 <hermanr> FWIW: LAC2010 used _three_ out-of-spec very long DV cables.  Only one of four DV sources had a normal length firewire.
20:03:31 <h01ger> i'd suggest to try to get one computer per dv source
20:03:31 <edrz> 2 per rrom
20:03:33 <edrz> room
20:03:48 <edrz> hermanr: interesting.
20:04:09 <hermanr> One of them had a repeater.
20:04:28 <edrz> would be best if we can test them all in advance with the particular machines, firewire cards, cables and cams.
20:04:41 <p2-mate> hermanr: did you decide that before or after tyou want to the coffeeshop ?:P
20:05:05 <hermanr> If there are extra "nice to have" cameras, used for unmanned wide shots, a longish cable would be acceptable.
20:05:05 <jeremyb> edrz: what equipment do we already have?
20:05:40 <bwh^> I have a Lindy firewire repeater which worked nicely at DC9
20:06:30 <edrz> jeremyb: we own several audio mixers, vga-dv converters, wireless handheld and headset mics, and wired condenser mics.
20:06:41 <edrz> and various cables.
20:06:52 <hermanr> p2-mate: We had a hardware DV mixer, which made the longish DV cables the most practical solution.
20:06:58 <edrz> we do not own cameras, tripods or PCs/laptops.
20:07:36 <h01ger> edrz, maybe be can borrow pcs from (#)debian-nyc?
20:07:43 <bwh^> Actually I think there are 1 or 2 tripods that belong to Debian
20:07:52 <edrz> much of the videoteam gear is already in the US with Hydroxide (and hopefully with me by the end of the week)
20:07:57 <edrz> h01ger: yes.
20:07:59 <edrz> ideally.
20:08:11 * hermanr reiterates his statement about the important of really good tripod heads
20:08:19 <hermanr> importance*
20:08:39 * jeremyb was thinking about computers
20:08:44 <edrz> everyone can feel free to liberally use the #info, #idea, #link, etc meetbot commands
20:08:51 <h01ger> edrz, are you setting up wiki pages to track all this? a diagram is also really useful :)
20:09:07 <bwh^> I have one good and one OK tripod that I can lend, if anyone going over there has the luggage space
20:09:14 <edrz> jeremyb: we own no computers and will need to borrow them from various people.
20:09:29 <edrz> h01ger: yes, i've mostly copied wiki pages from last year.
20:09:38 * h01ger nods
20:09:39 <h01ger> cool
20:09:39 <edrz> and will get the hardware page in shape RSN
20:09:46 <edrz> http://wiki.debconf.org/wiki/DebConf10/Videoteam
20:09:52 <h01ger> #info http://wiki.debian.org/Teams/DSA/non-DSA-HW lists our audio & video gear
20:10:00 <hermanr> Any thoughts on intercom from the video mixer to the camera ops?
20:10:23 <h01ger> bwh^, maybe you can ask sledge / debian-uk crowd?
20:10:24 <edrz> would be nice, but not a priority, imho
20:10:35 <edrz> #topic audio hw
20:10:56 <edrz> Q_: has the other set of gear that was left in europe for fosdem use.
20:11:19 <edrz> he is supposed to be sending to berlin for the mini-debconf, but hasn't responded to pings here about the lately.
20:11:26 <edrz> has anyone been in touch with him?
20:11:38 * h01ger sends mail to Q_ now
20:11:51 <vicm3> #help
20:12:23 <edrz> vicm3: http://wiki.debian.org/MeetBot
20:12:48 <edrz> as for the venue, I think we will probably need to rent at least 1 PA system.
20:13:09 <edrz> but, should be able to cover the rest of the audio needs with our own gear.
20:13:12 <h01ger> are there maps of the venue already?
20:13:17 <edrz> h01ger: yes
20:13:24 <h01ger> cool
20:13:27 <h01ger> url?
20:13:29 <edrz> of the campus, but not the inside of the rooms
20:13:32 <h01ger> ah
20:13:37 <h01ger> booring :)
20:13:50 <MrBeige> I scratched stuff on some paper I could scan
20:14:09 <edrz> link: http://wiki.debconf.org/wiki/DebConf10/Resources
20:14:22 <h01ger> thx
20:14:44 <edrz> assuming I make it up to NYC for the localteam meeting thursday evening + we can get into the rooms, I'll bring a tape measure.
20:15:07 <edrz> i also have pictures of the rooms, but need to find them.
20:15:15 <edrz> MrBeige might also have some pics
20:15:22 <h01ger> http://rkd.zgib.net/http/hidden/dc10map.pdf uses meters \o/ ;)
20:15:45 <edrz> #action edrz will find his venue pictures and make room drawings RSN.
20:16:00 <edrz> #topic budget
20:16:08 <MrBeige> overall layout: rkd2.zgib.net/hidden/dc10map.pdf
20:16:13 <edrz> do we have any money?
20:16:22 <MrBeige> (oops, that's what h01ger had)
20:16:43 <h01ger> edrz, how much do we need?
20:17:10 <h01ger> i guess if we have a reasonable budget, we'll get that granted (either from dc10 or debian)
20:17:22 <edrz> so, Davis auditorium and interschool lab are the 2 main rooms.
20:17:50 <edrz> h01ger: good question. what did we use last year?
20:18:19 <h01ger> edrz, interschool lab, is that clic lab ?
20:18:24 <edrz> no
20:18:38 <edrz> 7th floor, same building as Davis Auditorium
20:18:57 <h01ger> edrz, 2000e ish. we rented the PA, air-condition, bought cable and paid shipping after dc9
20:19:28 <h01ger> what floor is davis auditorium?
20:19:29 <edrz> ok. I'll need to look into PA rental costs.
20:19:38 <p2-mate> so the map is incomplete ?
20:19:41 <edrz> it is the entrance level
20:19:52 <edrz> the campus is several levels up from the street
20:20:21 <edrz> so I think that is actually the 3rd or 4th floor of the building, but "ground level" from the perspective of where most people will enter
20:20:29 <p2-mate> h01ger: last year the PA was part of the building no ? Or did we pay for it seperatly ?
20:20:30 <jeremyb> PA?
20:20:39 <edrz> public address
20:20:46 <MrBeige> yes, map is just the relevant rooms and buildings among many
20:20:58 * jeremyb is surprised that's not included
20:21:00 <edrz> the speakers at the front of the room to make the presenters audible to the audience.
20:21:25 <edrz> jeremyb: there are things in both rooms, but their quality and state of function is in question.
20:21:28 <vicm3> #info need better maps of venue
20:21:35 <CarlFK> edrz: how many attendees per room, or how powerfull amp/speakers do you expect ?
20:22:03 <edrz> davis holds about 200, i think.
20:22:16 <edrz> and interschool maybe half that. (very roughly speaking).
20:22:27 <h01ger> p2-mate, we paid seperatly for some parts iirc
20:22:56 <h01ger> edrz, ok, so the floor distance is managable by walking :)
20:23:01 <edrz> #action edrz needs to obtain better info on venue capacity, room size, PAs
20:23:18 <edrz> h01ger: between the 2 talk rooms?
20:23:27 <edrz> actually, there are no stairs that go up.
20:23:31 <MrBeige> I sketches with dimensions
20:23:40 <edrz> elevators must be used.
20:23:43 <h01ger> edrz, hah
20:24:05 <p2-mate> euh ? there must be stairs for emergency use no ?
20:24:12 <MrBeige> (note: dc10map.pdf is to scale, note the "10 meters" bar
20:24:13 <edrz> yeah. going down.
20:24:18 <edrz> no one goes up during a fire.
20:24:26 <edrz> anyway.
20:24:29 <MrBeige> (and exits alarmed if you go out)
20:25:08 <hermanr> How do elevators elevate 200 people at one time?  FAIL?
20:25:10 <edrz> #info about 2000 euros was spent last year.
20:25:38 <edrz> nothing else really on budget at this time.
20:25:41 <edrz> #topic penta
20:25:51 <edrz> did it work well enough last year?
20:26:09 <edrz> what permissions do I need to be sure to request for v-t people?
20:26:30 <p2-mate> hermanr: it's a huge elevator :)
20:26:37 <edrz> as far as I know, we are using the same version + debconf patches as last year.
20:26:59 <MrBeige> hermanr: and, there are four (plus one large freight elevator)
20:27:00 <h01ger> edrz, i'm happy to click permission bits again this year :) (but i think you should be able to do so too)
20:27:31 <edrz> i have a few notes somewhere about minor workflow additions bwh^ would like for the review process.
20:27:47 <h01ger> regarding how well the workflow went, bwh can probably better comment
20:27:48 <edrz> h01ger: please say so to Ganneff or other admins@
20:27:58 * h01ger is admin
20:28:03 <edrz> yah
20:28:08 <bwh^> If there is a dev version I can work on, I will try to find time to do that
20:28:30 <edrz> bwh^: yes. cletus.debconf.org, i believe, has the same code running
20:28:31 <h01ger> edrz, last year we lost the backup of the streams as it was made ad-hoc and someone didnt knew about it and "cleaned it up"
20:28:47 <edrz> with a sanitized/annonymized database copy.
20:29:00 <edrz> h01ger: backups?
20:29:09 <h01ger> edrz, the live stream we streamed
20:29:10 <p2-mate> we didn't have enough tapes
20:29:11 <edrz> meaning stream encodings captured?
20:29:13 <edrz> ok
20:29:16 <h01ger> someone dumped it, as a bacjup
20:29:25 <edrz> i am intending to have a complete settup running and tested here
20:29:30 <h01ger> and someone else deleted it, after dc9, before we arrived home...
20:29:41 <edrz> as well as workflow documented before we start
20:29:52 * h01ger cheers edrz
20:30:01 <edrz> we also have much more bandwidth from the venue than we usually do,
20:30:15 <hermanr> SD streams, finally?
20:30:18 <edrz> so i have the idea that we might be able to send the DV offsite during the conf.
20:30:20 <h01ger> bwh^, if you need access to cletus etc, ask Hydroxide
20:30:27 <h01ger> edrz, nice
20:30:46 <p2-mate> hermanr: :)
20:30:49 <edrz> assuming we have other ends with sufficient connection + storage to receive them.
20:31:12 <edrz> anything more on penta at this point?
20:31:23 <edrz> #info cletus is the dev/testing penta instance
20:31:44 <edrz> #info ask admins or -team for access if needed.
20:31:56 <edrz> #topic streaming setup.
20:32:07 <edrz> i also want this up and tested well before the conf.
20:32:12 <edrz> for a number of reasons.
20:32:15 <h01ger> edrz, you are "video-admin" in penta now
20:32:18 <edrz> berlin mini-conf can use it.
20:32:25 <h01ger> neat!
20:32:25 <edrz> h01ger: thank you.
20:32:40 * h01ger bows to edrz
20:32:57 * h01ger will be in berlin
20:32:58 <edrz> also, from a pkg-multimedia-maint perspective it would be good to have clients well tested before squeeze goes out.
20:33:08 <edrz> and also for our viewers, of course.
20:33:25 <edrz> h01ger: save your bows for when I've done more than just expresss my aspirations.
20:34:00 <edrz> main thing I need to know is do I just talk to -admin about the streaming servers?
20:34:23 <h01ger> edrz, basically yes.
20:34:28 <edrz> good, good.
20:34:32 <h01ger> on some hosts, icecast is still set up
20:34:39 <h01ger> so you just need to adapt the configs
20:34:46 <edrz> right.
20:34:47 <edrz> good.
20:34:52 <h01ger> or provide -admin with copies
20:35:18 <h01ger> is Ganneff aware of streaming of mini-debconf-berlin? i think he will be there - huhu Ganneff :)
20:35:21 <edrz> they will be in svn and I'll just tell them "pull that"
20:35:30 <edrz> Ganneff: ^^
20:35:46 <edrz> ok. next topic.
20:36:05 <edrz> #venue stuff: stream dump, etc.
20:36:10 <edrz> #topic venue stuff: stream dump, etc.
20:36:51 <edrz> 100mbit will suffice for the live streams during the talks. but gigabit would be nice to speed up transfers during breaks & over night
20:37:28 <MrBeige> so the plan isn't hand-carrying over again?
20:37:37 <edrz> hand carrying?
20:37:42 <edrz> when did that occur?
20:37:53 <bwh^> DC6 I think
20:37:58 <edrz> pycon has done it that way.
20:38:06 <bwh^> yes
20:38:07 <MrBeige> I though I heard that somewhere they moved hard drives by hand... maybe dc9?  anyway, agreed it's not ideal
20:38:12 <edrz> because they've used venues without wired lan access.
20:38:24 <bwh^> MrBeige: Not since DC6 AFAIK
20:38:45 <edrz> MrBeige: pycon definitely does that.
20:38:53 <edrz> we really want network.
20:38:56 <edrz> imoho
20:38:59 <edrz> grr
20:39:00 <MrBeige> exact details don't matter here, the rooms will have net
20:39:01 <edrz> imho
20:39:05 <edrz> right
20:39:06 <edrz> good
20:39:23 <edrz> #topic venue stuff: #  Number of servers to be hosted/space needed
20:39:51 <MrBeige> I guess we can also ask, how much can we piggyback off what's already here
20:40:00 <MrBeige> if we could get debian-running machines loaned
20:40:11 <edrz> dc8 data I brought home amounted to 800G for DV and archival quality ogvs.
20:40:47 <edrz> we need a file server, 1 or more encoding machines and an icecast server.
20:40:58 <edrz> at minimum.
20:41:25 <MrBeige> probably best to do is to make a list of machines / services needed, we can email it to groups around here and people can offer what they have
20:41:32 <edrz> it's best if we can have full control of machines as it's helpful to control all videoteam machines' configs via FAI.
20:41:43 <jeremyb> fai?
20:41:54 <hermanr> Re: intercom: Using PCs as dvsources, no extra hardware, except headphones is needed.
20:41:56 <bwh^> Fully Automatic Installer
20:42:01 <edrz> #action edrz will make list of machines needed, check it with v-t and get it to MrBeige
20:42:13 <MrBeige> I wouldn't be surprised if some group would say "oh, here's our rack, take A and B and C machines, reinstall, and have fun"
20:42:24 <edrz> that would be awesome.
20:42:27 <bwh^> FAI really needs some expert to configure it
20:43:00 <edrz> h01ger will be around, and I'll try to become enough familiar with it before then.
20:43:07 <bwh^> good
20:43:08 <edrz> if I'm not, then we can live with out it.
20:43:35 <edrz> next item we've already basically covered.
20:43:59 <edrz> #topic venue stuff: Links to any easy-to-read lists that can be given to various columbia tech people (setup needed, room requirements, ...)
20:44:17 * h01ger thinks about creating fai usbsticks for berlin...
20:44:31 <MrBeige> this is basicalyl what I said before: stuff that we can show people and say "here's what we are planning, can you offer anything?"
20:44:36 * h01ger suggests to create one pdf for them ;)
20:44:46 <h01ger> or one wikipage
20:45:15 <edrz> i thought we had a "venue needs" videoteam page in the wiki .. but can't find it at the moment.
20:45:30 <MrBeige> I have a pretty good idea of what is needed, but I don't know what all people have around here...
20:45:39 <edrz> #action venue needs wiki page or pdf for CU tech people needs to be generated or found.
20:46:21 <edrz> #topic venue stuff: What you'll have, at the least: plenty of power, ethernet 100Mbit for live steaming, space for control booth, cameras, etc
20:47:03 <MrBeige> this just lists the minimum a room should have to be considered acceptable for the video team use
20:47:14 * jeremyb wonders why that was #topic
20:47:30 <edrz> i don't know. it's in the agenda
20:47:35 <MrBeige> if there's nothing else to add, we can move on...
20:47:36 <bwh^> MrBeige: coffee on tap
20:47:46 <edrz> anything more on venue stuff for this meeting?
20:47:51 <MrBeige> (I just was dumping stuff in the agenda in a hurry)
20:47:57 <edrz> MrBeige: no worries.
20:48:00 <MrBeige> if not, you all know how to find me...
20:48:01 <p2-mate> s/coffee/club-mate/
20:48:04 <edrz> i'm glad you came. :)
20:48:05 <bwh^> MrBeige: and beer in the evening
20:48:32 <MrBeige> what about "making a video team workshop for columbia peolpe to get them interested" ?
20:48:33 <edrz> stimulate/sedate/stimulate/sedate/stimulate/sedate
20:48:44 <edrz> #topic any other business
20:48:54 <CarlFK1> I have arrived at venues with sound systems to find out that there was no way to hook into it
20:48:55 <h01ger> next meeting?
20:49:10 <edrz> h01ger: hold on. that's the next item. ;)
20:49:19 <MrBeige> h01ger had some slides to use as a starting point for video team workshops/hook email for CU people
20:49:26 <CarlFK> like a wireless mic and no access to the receiver / amp
20:49:32 <edrz> what MrBeige said is something i've been wanting to do ...
20:50:09 <edrz> CarlFK: yeah. i hope to make 1 or 2 more trips up to NYC before the event an get into the rooms and check that stuff.
20:50:16 <p2-mate> yeah, pictures of availabe equipment are useful
20:50:31 <edrz> we also have a full week of DebCamp prior to the conf to set up.
20:50:32 <edrz> and test
20:50:35 <edrz> on site.
20:50:54 <edrz> p2-mate: there are some in my previously mentioned to be located pictures
20:51:00 <CarlFK> oh yeah, projectors hung in the ceiling - how/where do you all hook up the twinpact?
20:51:09 <bwh^> edrz: though that week goes quickly
20:51:18 <p2-mate> indeed
20:51:19 <edrz> there is a lecture station at the front of each room
20:51:30 <edrz> the projector vga cable is accessible there.
20:51:37 <p2-mate> CarlFK: there is a VGA input smewhere at a desk ?
20:51:46 <MrBeige> note: an event is using the main auditorium two days early in the week of DebCamp
20:52:01 <edrz> MrBeige: monday-tuesday-ish?
20:52:10 <MrBeige> something like that, maybe tuesday-wednesday
20:52:13 <edrz> ok
20:52:18 <edrz> good to know
20:52:19 <CarlFK> so that gets signal to the twinpact - how do you get that to dvswitch box?
20:52:30 <MrBeige> but we'll get access before for checking out in advance or in the evenings, I'm sure
20:52:42 <edrz> some machine near that with ethernet to to the dvswitch-er
20:52:49 <edrz> MrBeige: yup
20:52:55 <edrz> any other business?
20:53:00 <CarlFK> good answer :)
20:53:16 <CarlFK> was affraid of the 75m firewire cable
20:53:19 <edrz> (what made me think a meeting could be done in 30 minutes. ;)
20:53:37 <edrz> ok
20:53:44 <edrz> #topic next meeting
20:54:10 <edrz> it's always tough to ask the people who couldn't be here if this is a good time & day of the week.
20:54:27 <edrz> i guess another doodle poll can't hurt.
20:54:32 <edrz> any thoughts on time frame?
20:54:41 <edrz> 3 weeks perhaps?
20:55:22 * h01ger nods
20:56:01 <edrz> #action edrz will create a doodle poll for some days & times in the week of June 1st
20:56:06 <edrz> #endmeeting