16:00:41 <h01ger> #startmeeting
16:00:41 <MeetBot> Meeting started Wed Feb 18 16:00:41 2015 UTC. The chair is h01ger. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:41 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:00:52 <h01ger> #chair intrigeri
16:00:52 <MeetBot> Current chairs: h01ger intrigeri
16:00:57 <h01ger> #chair MoC
16:00:57 <MeetBot> Current chairs: MoC h01ger intrigeri
16:01:04 <h01ger> #topic agenda
16:01:18 <h01ger> what topics do we have to discuss?
16:04:02 <intrigeri> catching up.. I'll be here in 3-6 minutes.
16:04:09 <MoC> moin h01ger
16:04:27 <MoC> topics : done, todo, next meeting?
16:04:28 <h01ger> hi intrigeri! - cool
16:04:35 <h01ger> draft d-d-a post
16:04:43 <h01ger> MoC: so basically yes
16:04:52 <h01ger> +hi to you too! :)
16:05:08 <intrigeri> just replied to the email threads I had unread on this topic.
16:05:50 <intrigeri> and read https://wiki.debian.org/AppArmor/Progress#TODO
16:05:53 <intrigeri> I'm ready.
16:06:07 <intrigeri> no topic to add
16:06:26 <h01ger> #topic done
16:06:47 <intrigeri> only one thing to say: \o/ (and i'll code review the script later today)
16:06:57 <h01ger> regarding "done" i wonder if there was a reply from planet maintainers and whether the post showed up
16:07:12 <MoC> intrigeri: great for reviewing
16:07:12 <intrigeri> h01ger: MoC said there was no reply.
16:07:32 <h01ger> and \o/ indeed. project progress continues to be impressive :)
16:07:47 <MoC> h01ger: no reply, and the post never showed up
16:08:15 <h01ger> hm, /me will send a followup
16:08:24 <MoC> h01ger: thanks
16:08:28 <h01ger> i was also considering doing a short blog post just linking to MoCs
16:08:43 <MoC> h01ger: sure
16:08:46 <MoC> good idea
16:09:27 <MoC> intrigeri: about the code review. i have one problem with the script. i did not use the is module and so, when you run "python udd.py" it reads and creates a state text file in the same folder
16:09:29 <h01ger> ok, will do
16:09:34 <MoC> but cron creates the file in my $HOME
16:10:03 <MoC> so this part is a bit stupid and i did not research it further because it works for me
16:10:15 <MoC> but maybe you have a hint
16:10:29 <h01ger> MoC: besides asking here, i think asking on #debian-qa is helpful in such cases. even better than #alioth (and IMO both channels are good)
16:10:44 <intrigeri> I say let's just add a cmdline argument to the state file, and default to $HOME/.local/share/ (whatever xdg-compliant these days) if not passed?
16:10:45 <h01ger> #agreed h01ger will blog and link MoCs post so it shows up on planet
16:10:48 <MoC> h01ger: about the cron job? or planet?
16:10:51 <h01ger> cron
16:11:10 <h01ger> (though intrigeris suggestions seems good enough here.)
16:11:13 <MoC> h01ger: yes, i asked there for some details (#alioth) and friendly people helped me out :)
16:11:20 <h01ger> s#enough##
16:11:23 <MoC> h01ger: but i'll ask for the other specific question too
16:11:24 <intrigeri> :)
16:11:26 <h01ger> MoC: ah cool!
16:11:44 <MoC> h01ger: they just helped me set up the cron job
16:11:56 <MoC> which was a piece of cake once i knew how to do it
16:12:07 <h01ger> :)
16:12:27 <MoC> ok, so, is there anything else for the DONE topic?
16:12:40 <MoC> is there any documentation i still need to write?
16:12:49 <MoC> i think yes: the migration documentation
16:13:00 <intrigeri> nothing to add on the done topic.
16:13:11 <intrigeri> #topic next steps
16:13:17 <h01ger> wait or no
16:13:25 <intrigeri> wow, it works (1st time I tell MeetBot such a thing)
16:13:27 <h01ger> so migration documentation is next? :)
16:13:32 <h01ger> intrigeri: \o/
16:14:10 <h01ger> intrigeri: your chance to use #agreed too ;)
16:14:26 <h01ger> (and #save to update the logs on meetbot.d.n immediatly)
16:14:28 <intrigeri> hmmm
16:14:32 <intrigeri> I would say:
16:15:16 <MoC> (there are only 3 weeks left now, right?)
16:15:26 <intrigeri> 1. finish existing doc: Document branch name for contributing to upstream bzr repository on blog post / how to contribute to upstream doc
16:15:26 <intrigeri> 2. Contact package maintainers who already ship AppArmor profiles.
16:15:26 <intrigeri> 3. announce workflow on blog and debian-devel-announce
16:15:26 <intrigeri> 4. Import my upstream bugfixes on pidgin-prefs to the apparmor-profiles-extra package through Git
16:15:27 <intrigeri> 5. Document "Migrate a profile to the package that ships the confined application" on AppArmor/PackageMaintainers
16:15:43 <intrigeri> anything after #3 can wait for post-OPW IMO.
16:16:03 <MoC> and #702030?
16:16:04 <h01ger> intrigeri: in 4. "my" refers to you, intrigeri ?
16:16:09 <MoC> no, me, h01ger
16:16:09 <intrigeri> MoC: and maybe we can do #5 together some day with a real package.
16:16:21 <MoC> intrigeri: that sounds good (#5)
16:16:22 <intrigeri> h01ger: no, just pasting stuff MoC wrote on the progress page.
16:16:29 * h01ger nods
16:16:51 <intrigeri> MoC: I say once #3 is done, switch to Debian#702030. the rest can wait.
16:17:00 <h01ger> sounds like a reasonable plan to me
16:17:24 <h01ger> +3 weeks sounds about right
16:17:35 <intrigeri> MoC: just need to find a maintainer that'll be happy to take the profile. e.g. irssi, iirc rhonda was keen to take it.
16:17:50 <MoC> intrigeri: ack
16:17:57 <MoC> all ack.
16:18:05 * h01ger also thinks any documentation is more important than 702030 because that latter is rather longterm anyway and the former is priceless to have
16:18:12 <MoC> yep
16:18:21 * intrigeri will be contacted as he already ships profiles in his packages :)
16:18:45 <h01ger> #agreed 1. finish existing doc: Document branch name for contributing to upstream bzr repository on blog post / how to contribute to upstream doc
16:18:51 <h01ger> #agreed 2. Contact package maintainers who already ship AppArmor profiles.
16:18:59 <h01ger> #agreed 3. announce workflow on blog and debian-devel-announce
16:19:17 <h01ger> #agreed 4. Import my upstream bugfixes on pidgin-prefs to the apparmor-profiles-extra package through Git
16:19:26 <h01ger> #agreed 5. Document "Migrate a profile to the package that ships the confined application" on AppArmor/PackageMaintainers
16:19:37 <h01ger> #agreed anything after #3 can wait for post-OPW
16:19:47 <h01ger> #agreed documentation is more important than 702030 because that latter is rather longterm anyway and the former is priceless to have
16:19:59 <h01ger> right?
16:20:25 <MoC> great
16:20:53 <intrigeri> so it's rather 1. finish existing doc, 2. contact pkg maints, 3. announce, 4. doc migration, 5. #702030 and 6. import pidgin-prefs, no?
16:21:08 <intrigeri> taking into account "doc is more important than"
16:21:29 <MoC> #agreed migration documentation can be based on work to be done together with intrigeri on a package (maybe irssi)
16:21:45 * h01ger agrees with intrigeri and would amend the #agreement
16:21:50 <intrigeri> (and the cross-distro thing won't be covered yet, but that was a bonus optional bit of the project iirc)
16:21:51 <MoC> intrigeri: yes, but the pidgin prefs thing will take may an hour
16:22:00 <intrigeri> ok
16:22:23 <intrigeri> anyway. we're on the same page. good.
16:22:30 <MoC> h01ger: can you update the agreements then?
16:22:42 <h01ger> #agreed so it's rather 1. finish existing doc, 2. contact pkg maints, 3. announce, 4. doc migration, 5. #702030 and 6. import pidgin-prefs
16:22:56 <h01ger> #info < MoC> intrigeri: yes, but the pidgin prefs thing will take may an hour
16:23:04 <h01ger> #agreed ok :)
16:23:19 * h01ger nods the thing with being on the same page is good :)
16:23:27 <MoC> oki
16:23:33 <MoC> what else?
16:23:36 <intrigeri> next topic?
16:23:40 <h01ger> party in 3 weeks? :)
16:23:43 <MoC> hehe
16:23:46 <h01ger> #topic next meeting
16:24:08 <MoC> maybe we can have a meeting in between?
16:24:12 <h01ger> wednesday the 4th of march, 1700 CET?
16:24:18 <h01ger> MoC: like when?
16:24:21 <MoC> maybe earlier?
16:24:32 <MoC> 2nd of march
16:24:34 <h01ger> march? february?
16:24:47 <intrigeri> 2nd of march works for me.
16:24:49 <h01ger> i'd prefer the 1st, actually
16:24:53 <h01ger> but 2nd works
16:25:06 <MoC> and you intrigeri?
16:25:10 <MoC> 1st is a sunday
16:25:18 <intrigeri> 1st works too.
16:25:44 <MoC> ok why not
16:25:47 <MoC> 17h cet?
16:25:50 <h01ger> 1st i'd like 1800 but 1700 would be fine too
16:25:59 <intrigeri> go for 6pm CET then.
16:26:09 <h01ger> very ok with me
16:26:12 <h01ger> MoC: ?
16:26:18 <MoC> 6pm cet, ok
16:26:29 <h01ger> #agreed next meeting, sunday, march 1st, 2015, 1800 CET
16:26:36 <h01ger> #save
16:26:37 <MoC> ok, done?
16:26:42 <intrigeri> I think so.
16:26:42 <h01ger> yippieyay!
16:26:47 <MoC> we're getting faster at this.
16:26:48 <intrigeri> \o/
16:26:48 <MoC> :)
16:26:59 <MoC> #endmeeting