13:58:13 <hiro> #startmeeting WWW
13:58:13 <MeetBot> Meeting started Thu Mar 26 13:58:13 2020 UTC.  The chair is hiro. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:58:13 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:58:32 <hiro> ok emmapeel want to start with the first topic?
13:58:36 <hiro> #topic glossary
13:59:22 <emmapeel> yeah, i was wondering if you are still thinking on working on the glossary this week
13:59:33 <hiro> you mean the script?
13:59:42 <emmapeel> yeah, moving the words to the new location
13:59:43 <hiro> to import all the terms?
13:59:48 <hiro> yeah I can do that
13:59:52 <hiro> I was going through tickets and so
13:59:59 <antonela> buenas
14:00:04 <hiro> #action hiro works on the glossary script
14:00:06 <emmapeel> oh, i understood that you were leaving this work for the docshackathon week
14:00:16 <hiro> isn't this the docshackaton week?
14:00:26 <ggus> hi
14:00:29 <emmapeel> yes, that is why i ask
14:00:50 <hiro> that's ok so yeah I'll see if I manage to do that
14:01:39 <hiro> I think that's something that can be done rel quickly so I'll just do that
14:02:18 <hiro> oooook
14:02:30 <hiro> #topic running lektor locally
14:02:45 <hiro> I think the issue are with some of our plugins
14:03:14 <hiro> there might be some python version mismatch there. so I'll try to fix those
14:03:41 <emmapeel> have been trying to improve the docs but i amnot very sure sometimes. also i think nobody knows how to do it in windows
14:03:41 <hiro> I don't think we can do anything else that try to document more
14:03:47 <ggus> this is the main issue for outreachies running lektor in windows
14:03:53 <pili> yup
14:04:05 <pili> I don't think any of us have a machine to try it out on either
14:04:13 <emmapeel> not sure if we need to learn to do it, or maybe find a way for the contributors to be able to review their cahnges without running in local (but before we review them)
14:04:30 <hiro> uhm
14:04:44 <hiro> I can have something setup for gitlab or github ci
14:05:10 <emmapeel> i think it is a big barrier for the contributions, and also for people that manages to contribute, the quality may suffer
14:05:20 <emmapeel> because they cannot test before
14:05:51 <antonela> what is the problem in windows?
14:05:59 <hiro> running lektor in windows
14:06:08 <hiro> I have no idea about pythons in windows to be honest
14:06:31 <emmapeel> i think people running other OSs also have problems
14:06:41 <hiro> mac works
14:06:42 <emmapeel> but yeah, windows is the worst atm
14:07:02 <ggus> i was having issues using debian, but then following the instructions with virtual env worked
14:07:04 <emmapeel> well, maybe it works, but the contributors cannot make it work with our documentation
14:07:05 <antonela> do we know what is the issue? exactly?
14:07:39 <ggus> python problems
14:07:45 * antonela never compiled lektor in windows
14:07:46 <ggus> very generic errors
14:07:50 <emmapeel> i added the point thinking the problem is 'contributors cannot install it with our documentation', i think this is our problem
14:07:54 <hiro> I see
14:08:09 <ggus> antonela: https://gitlab.torproject.org/torproject/web/support/issues/81
14:08:09 <antonela> https://stackoverflow.com/questions/39941130/issue-while-running-lektor-server-command-on-windows
14:08:34 <emmapeel> i feel we coudl save time and frustration if people can do it by themselves... maybe some peopl eis shy and dont want to come to irc to ask, etc
14:08:51 <hiro> sure
14:08:59 <hiro> I think this need to be fixed
14:09:03 <hiro> I will review the docs
14:09:31 <hiro> but I think it shouldn't be just me
14:09:44 <hiro> I think we should just all review the docs and see if we can spot something that doesn't work
14:10:26 <ggus> i could rent a windows vps so we could try to debug, what do you think?
14:10:40 <emmapeel> i am trying ti improve it, and i also did the previous documentation on trac, but to be honest i have no idea of the errors people gets and i only have it in debian.
14:11:00 <emmapeel> i dont run windows, for religious reasons
14:11:02 <hiro> yeah in debian it works for me .. I spin a container and have no issues
14:11:09 <hiro> but like kushal had issues in fedora
14:11:23 <hiro> I can check fedora too since #qubeslife
14:11:52 <pili> I feel like we had a contributor in the past that managed to get it working in windows
14:11:59 <pili> but maybe that's just wishful thinking
14:12:15 <ggus> i think cleopatra also has windows
14:12:23 <kulloveth__> I use windows and have experienced issues that have stopped my contributions. I wake up everyday trying something new hoping to get a solution
14:12:31 <emmapeel> but cleopatra is not compiling atm i think
14:12:42 <ggus> emmapeel: yeah, but we could ask her
14:13:07 <emmapeel> i offered to help her the other day, lets see if we find a moment together.
14:13:08 <hiro> kulloveth__: is it a problem with our projects or with lektor in general?
14:13:30 <hiro> if you try to install following the instructions of getlektor.com do you have the same issues?
14:14:05 <kulloveth__> hiro: the project itself, I can create and run new ones but once I install i18n plugin the build starts failing with several errors
14:14:07 <hiro> #link https://www.getlektor.com/downloads/
14:14:20 <hiro> ok! then! it's the i18n plugin!!!
14:14:38 <hiro> I'll try to update the plugin.. maybe that's the issue
14:14:47 <hiro> #action update i18n plugin in lego <- hiro
14:15:22 <pili> yeah, that rings a bell
14:15:22 <hiro> so let's try this and see how it gos
14:15:29 <hiro> *goes*
14:15:31 <pili> I also have problems with the i18n plugin
14:15:40 <hiro> what error do you get?
14:15:47 <pili> none right now
14:15:50 <hiro> oooook
14:15:57 <pili> but in the past if I have issues it's always because of it :)
14:16:11 <pili> do we actually need to install it if we're not localising locally?
14:16:19 <pili> I think we discussed this in the past
14:16:33 <hiro> uhm I think the project is configured to install it
14:16:46 <hiro> because you would have to change too many things otherwise
14:16:53 <hiro> so yeah we might have to
14:17:40 <hiro> ok antonela has a few more topics
14:17:45 <antonela> o/
14:17:59 <emmapeel> we can also say that it is not possible to install in windows and you need a linux VM if you run windows
14:18:00 <hiro> #topic onion-location vs alt-sv headers for tpo websites
14:18:06 <antonela> i'm not cleaning my house during this pandemia but i'm trying to clean trac
14:18:08 <antonela> #33705
14:18:24 <hiro> ^emmapeel that's a possibility but I'd like to fix this
14:18:28 <antonela> very nice ticket, i wonder if we can implement both and see how it goes
14:18:29 <hiro> and if I can't we will do that
14:18:40 <antonela> hiro: if you document your process it will go to the /onion-services portal
14:18:55 <hiro> we can implement both if we wanted... does it make sense?
14:19:06 <antonela> hiro: if you have problems doing it, please can you describe it in the ticket for the future?
14:19:13 * antonela does the future exist?
14:19:28 <hiro> I don't think we can have problems adding a header
14:19:29 <antonela> yes, makes sense
14:19:40 <ggus> i'm using it here-> https://gus.computer
14:19:56 <hiro> using both ggus?
14:20:00 <antonela> which one ggus?
14:20:07 <ggus> onion location meta
14:20:18 <kulloveth__> emmapeel: I installed virtualbox because of that and I'm running ubuntu on it the same issue occurs. I think i18n needs to be updated on the project or something
14:20:45 <antonela> ggus: which tb are you using for testing?
14:20:53 <ggus> antonela: acat tb
14:21:25 <antonela> ggus: oki, is working? :)
14:21:29 <ggus> yess
14:21:34 <antonela> (:
14:21:35 <antonela> very nice
14:21:42 <hiro> ooook
14:21:51 <hiro> so we implement both is that the decision?
14:21:54 <antonela> did you try alt-svc ggus?
14:22:13 <acat> note: making alt-svc work will not be just adding a header, i think
14:22:24 <ggus> antonela: yes, but i didn't find enough online resources to implement alt-svc
14:22:48 <acat> you'll need the .onion to serve the same tls certificate as https://torproject.org
14:22:54 <acat> the .onion in alt-svc
14:23:11 <pili> ggus: we should document this in community portal
14:23:12 <pili> as in, figure it out and document it
14:23:13 <pili> I can also take a look and play around
14:23:18 <hiro> ahhhh so we cannot do alt-svc
14:23:27 <ggus> pili: yep, that's why i was testing yesterday :)
14:23:46 <pili> I will bow to your experience in this then :D
14:23:46 <hiro> acat does it meen it needs a EV certificate?
14:23:55 <emmapeel> yes. maybe also other ways, dgoulet does it with nginx IIRC
14:24:03 <emmapeel> (i mean about documentation)
14:24:07 <acat> hiro: i think we would need either a new .onion, or to serve it in current .onion:443 (which is unused i think)
14:24:34 <acat> hiro: no, just the same certificate that the site which is serving the alt-svc header
14:24:55 <hiro> and that would give a certificate issue?
14:25:08 <acat> ah ok, if you navigate directly yes
14:25:09 <hiro> *wouldn't*
14:25:19 <hiro> ah ok
14:25:30 <acat> so the .onion in alt-svc would not be possible to navigate directly to
14:25:31 <antonela> which will fade when ev certificates are available
14:25:36 <acat> but that happens also with facebook alt-svc
14:25:39 <antonela> acat: good point
14:26:04 <hiro> ok then I think we will do the onion-location because there are people that visit directly our onions
14:26:10 <acat> https://facebook2futmrduts5uqn3ahwg4qyqoks6h3alxf5drhsgyhzujyqad.onion/
14:26:15 <acat> gives a cert error
14:27:14 <hiro> ok thanks for clarifying
14:27:41 <hiro> ok next topic?
14:27:50 <acat> i think there could be ways to make it work, but more complicated than just adding a header :)
14:28:23 <hiro> acat I am not sure we want to mess with the certificates atm
14:28:27 <hiro> I think we will do onion-location
14:28:32 <acat> +1
14:28:36 <antonela> would be really nice to have this ticket done for when we release tb 9.5a9
14:28:54 <antonela> so institutional urls work with the new feature :)
14:29:13 <hiro> when is the release scheduled?
14:29:15 <pili> +1
14:29:18 <antonela> pili? ^
14:29:20 <ggus> i could reach out to some orgs saying about this before releasing
14:29:27 <ggus> *we
14:29:58 <antonela> ggus: that'd great, we should coordinate this comunication with steph
14:30:01 <pili> hmm, I had a  release due this week, but it's not the right one
14:30:08 <pili> 04.07
14:30:12 <ggus> antonela: i think it's a good topic for vegas meeting.
14:30:19 <pili> is the likely date
14:30:22 <antonela> ggus: bring it :)
14:30:28 <pili> yup!
14:30:51 <hiro> is that a eu or us date?
14:31:01 * antonela next items are also mine
14:31:03 <antonela> hiro: april
14:31:11 <pili> so in 2 weeks for the release
14:31:15 <hiro> ok doable
14:31:24 <ggus> if pili or you add this to vegas agenda, would make more sense since i don't know when is going to be release, which sponsor, who is talking with onion operators, etc.
14:31:31 <pili> yeah, sorry, I hated myself for doing US date format :P
14:31:49 <hiro> #topic show banner on tpo to alert users they need to update
14:31:55 <pili> ggus: sure
14:32:10 <antonela> #23721
14:32:21 <pili> I'm going to get a slap on the wrist for bringing a discussion topic less than 24h before ;P
14:32:44 <hiro> oook do we get this infor for tb?
14:32:47 <antonela> hiro: do we want to do it? should we move that one to gl?
14:32:57 <emmapeel> that will be two slaps if we count the date :P
14:34:02 <pili> :D
14:34:16 <hiro> ok you can move it to gitlab
14:34:26 <hiro> but the question is do we get this info from tb?
14:34:35 <pili> not sure
14:34:39 <pili> what's the user agent?
14:34:45 <hiro> isn't it windows?
14:34:52 <emmapeel> Gecko windows something
14:34:54 <emmapeel> lemme see
14:35:01 <hiro> yeah that I think
14:35:05 <antonela> we can ask boklm about it
14:35:06 * emmapeel gos to panopticlick
14:35:11 <pili> that's the only place I can think it might be
14:35:15 <ggus> Your user agent: Mozilla/5.0 (Windows NT 10.0; rv:68.0) Gecko/20100101 Firefox/68.0
14:35:26 <emmapeel> yeah
14:35:27 <ggus> if you type 'user agent' in ddg, it shows you^
14:35:28 <Jukana> hello pili
14:35:42 <Jukana> can i create an issue on github?
14:36:05 <pili> Jukana: no, it's not possible
14:36:21 <pili> best to discuss this in #tor-www :)
14:36:42 <hiro> oooook
14:36:45 <Jukana> alright
14:37:06 <hiro> #action ask boklm how to get tb version from user agent or something else <- antonela?
14:37:08 <Jukana> *gitlab i mean
14:37:10 * antonela l337 time, next
14:37:16 <antonela> #31660
14:37:36 <hiro> #action release logs
14:37:41 <antonela> so i want to feature new tor browser features in a web page
14:37:52 <antonela> is not release logs is a differnet content BUT we can use the same idea
14:38:18 <hiro> well we can do whatever we want
14:38:30 <hiro> we just need mockups
14:38:47 <antonela> release logs at the moment are living _inside_ the browser in about:tbupdate
14:39:01 <antonela> what i'm suggesting is going _outside_ the browser to a webpage
14:39:13 <antonela> because it gives us more flexibility to announce this stuff
14:39:26 <emmapeel> also we can change after release
14:39:43 <antonela> yes, we will need the "latest" one and we will need historicals for each release
14:39:51 <antonela> for sure point stable release will have that page
14:40:15 <hiro> the problem is not having this content in the website
14:40:19 <antonela> maybe there is not features highlights in alphas all the time so we can simply link that page to the release blogpost
14:40:20 <hiro> the problem is making sure it gets updated
14:40:33 <antonela> hiro: why not?
14:40:42 <antonela> we should update it before the release
14:40:50 <antonela> (i will i think)
14:41:09 <hiro> yeah if you or the devs or ggus does it, it's ok, but it is extra work
14:42:09 <antonela> it is given the onboarding is currently dead x_x
14:42:28 <antonela> it is a fast and convenient solution to inform future features
14:42:40 <hiro> sounds good to me
14:42:45 <ggus> why the onboarding is dead?
14:43:11 <pili> we should discuss with the browser team on monday also
14:43:26 <antonela> pili: yes, we can
14:43:40 <antonela> pili: im trying to figure out what is doable before asking for opinions
14:43:50 <pili> sounds good :)
14:43:58 <pili> and makes sense
14:44:08 <antonela> ggus: is a lost patch after the last migration
14:44:47 <ggus> :( i believe the onboarding should also live in the web.
14:44:56 <ggus> the onboarding content
14:45:16 <antonela> yes, i'm back thinking about it
14:45:33 <ggus> maybe in community.tpo/outreach/why-tor-browser
14:45:38 * antonela back thinking is when my brain pings me about something multiple times per week but i keep delaying it because some other things became urgent
14:45:54 <ggus> but, yes, i like the idea of having a page listing the features
14:46:14 <antonela> super
14:46:31 <antonela> so i'll bring this to the browser meeting on monday and move forward with a demo
14:47:06 <antonela> oooooook
14:47:08 <antonela> im done :)
14:47:54 <hiro> ok!
14:47:58 <hiro> I think we can end this meeting?
14:48:10 <antonela> is groot
14:48:21 * hiro is groot
14:48:26 <ggus> i'm good
14:48:38 <emmapeel> #metoo
14:48:39 <ggus> de boa :)
14:48:52 <antonela> thanks folks!
14:49:08 <hiro> #endmeeting