17:59:13 <ahf> #startmeeting Network team meeting, 13 January 2020
17:59:13 <MeetBot> Meeting started Mon Jan 13 17:59:13 2020 UTC.  The chair is ahf. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:59:13 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:59:18 <ahf> hello network-team!
17:59:21 <dgoulet> hi
17:59:24 <ahf> our pad is at https://pad.riseup.net/p/tor-netteam-2020.1-keep
17:59:29 <catalyst> hi
17:59:56 <gaba> hi!
17:59:58 <nickm> hihi
18:00:27 <ahf> let's start out with roadmap:
18:00:31 <ahf> Let's check and update our roadmap: What's done, and what's coming up? Use: https://dip.torproject.org/torproject/core/tor/boards
18:01:20 * gaba needs to update the board with stuff from trac that we agreed on roadmap meeting.
18:01:35 <mikeperry> I briefly got a 503. did we overwhelm dip all at once?
18:01:48 <ahf> ugh, actually, i think i promised to do that last week, and i have completely forgot to move some stuff over to dip there
18:02:03 <ahf> mikeperry: it sometimes happens :-/ we are working on doing a big makeover of the gitlab instance
18:02:27 <gaba> #network-team-roadmap-2020Q1  us the keyword I used in trac to mark the tickets for roadmap until march.
18:02:43 <gaba> s/us/is
18:03:19 <ahf> cool!
18:03:38 <nickm> there are a bunch of lines on the spreadsheet that are still pink, indicating that they have no ticket
18:03:42 <nickm> is that up-to-date?
18:04:00 <ahf> i am missing some tickets for sure
18:04:03 <gaba> nickm: those need tickets
18:04:54 <nickm> (spreadsheet on nc, referenced from gaba's email "[network-team]
18:04:55 <nickm> roadmap january/february [some issues need tickets]"
18:04:56 <nickm> )
18:04:59 <gaba> mostly from mikeperry, dgoulet or catalyst
18:05:35 <nickm> can you three take care of making tikets for those, or would you like to offload?
18:06:10 <dgoulet> should I open a ticket on things I haven't started to work on? As in, what if I never do in the next months afterall?
18:06:34 <mikeperry> so the process is make tickets for those lines in trac with tag network-team-roadmap-2020Q1, and then they will be automatically xferred to dip?
18:06:35 <ahf> i'd say yes, such that it can be seen in the roadmap
18:06:36 <dgoulet> I was under the impression I would put in the ticket there for things I'm actually working on as in "work will get out of it"
18:06:37 <nickm> having a ticket still lets us do the dip roadmap
18:06:40 * catalyst tries to load the roadmap
18:06:58 <nickm> mikeperry: yeah, and if you enter them on the roadmap spreadsheet, it'll be easier to crossref
18:07:07 <gaba> catalyst: this is the spreadsheet https://nc.torproject.net/s/TGeW5CX4GqaagMN
18:07:21 <gaba> mikeperry: yes
18:07:51 <nickm> #action mikeperry catalyst and dgoulet open tickets for their roadmap items that currently lack them
18:07:54 <gaba> dgoulet: if you never do it then we can look at it for the future if those are things that need to happen
18:08:00 <nickm> #action ahf puts roadmapped tickets on dip
18:08:18 <gaba> ahf, teor: there are 2 lines without a ticket for you too.
18:08:39 <ahf> yes!
18:08:41 <catalyst> ok doesn't look like it'll be too hard for me to open tickets for mine
18:09:00 <ahf> cool!
18:09:31 <ahf> okay, i think next item is reviews. are everybody doing okay there? and dgoulet, are things looking ok to you and asn there?
18:09:42 <dgoulet> we haven't assigned them yet
18:09:49 <ahf> ah, ack!
18:10:38 <ahf> okay, looks like there is a few new ones in the queue and some older ones that is still pending review
18:11:20 <ahf> we now have an 0.4.3 status page that we have added as a weekly item. it's at: https://trac.torproject.org/projects/tor/wiki/org/teams/NetworkTeam/CoreTorReleases/043Status
18:11:42 <ahf> nickm: how do we want to run this for a new status page? we need the 043-must to have people assigned to them?
18:12:09 <nickm> there's that, but for now the most important is to make sure we don't lose anything in the feature freeze
18:12:38 <nickm> we're probably going to be deferring everything in the list at the bottom of the page unless it gets tagged with 043-should or 043-must or 043-can
18:12:39 <ahf> what do you want from the team to ensure that doesn't happen?
18:13:00 <nickm> so folks should look over that list and see if any of it should really _not_ be deferred
18:14:14 <nickm> doesn't have to be right now, but by next week, I think we'll want to scrub out that list
18:14:47 <ahf> ok
18:14:58 <ahf> here at the weekly meeting or at some side meeting like the triage one?
18:15:03 <gaba> dgoulet: you are paying attention to the s27 (mostly must tickets) from that list, right? not sure if any of those need to get in.
18:15:18 <gaba> like #31632
18:15:41 <nickm> I thnk some side meeting would make sense; right now it's just important for us to tag the stuff we're saving
18:15:46 <dgoulet> gaba: I'm very much aware of s27 must for 043 yes ;)
18:15:57 <gaba> nice :) I assumed so
18:15:59 <ahf> so next network team meeting we cna talk about doing a small cut down of that list
18:16:02 <ahf> cool!
18:16:45 <ahf> okay, we have a discussion item:
18:16:48 <ahf> January 20th is a TPI holiday; do we want to move that week's meeting to Tuesday? or Wednesday at patch party time? [ahf: let's do it Wednesday at the "late" time such that Teor can participate?]
18:17:10 <ahf> i suggest we move it to our wednesday time slot such that we alternate between those two as much as possible when we need to
18:17:27 <ahf> anybody against that? :-)
18:17:30 <nickm> no objection here
18:17:47 <gaba> ok
18:18:14 <dgoulet> data point: the Wed time is impossible for me unfortunately but that is fine, having a teor is important :)
18:18:17 <ahf> ok, next meeting is wednesday the 22nd at 2300
18:18:36 <ahf> dgoulet: yeah, i think it's okay when we have those different times that some people will miss one of them :-/
18:18:49 <dgoulet> I have one "discussion" item I need to raise
18:18:51 <ahf> we wont have a time that is well for everybody
18:19:00 <ahf> oki, we are at discussions now, so go ahead
18:19:33 <dgoulet> the test practracker script is still failing with errors for me here... which makes me unable to push/commit anything upstream without a --no-verify
18:19:44 <nickm> what's the ticket?
18:19:58 <dgoulet> nickm: can't recall, you made me put in the trace in a ticket some months ago
18:20:22 <dgoulet> but it is also exploding for me on non-master branch ... so
18:20:31 <nickm> Is it #32705 ?
18:20:31 <dgoulet> dunno if on purpose but right now, I have to disable it by hand
18:20:58 <dgoulet> nickm: yes!
18:21:00 <dgoulet> exactly that
18:21:30 <nickm> looks like teor has questions for you in their most reent comment?
18:21:52 <nickm> I'll look at it too
18:21:54 <dgoulet> oh ! ok will go for that
18:22:04 <ahf> cool
18:22:35 <ahf> i will send out 1:1 schedules to folks who have replied tomorrow such that we can begin having those again here in 2020
18:23:14 <ahf> catalyst have a request to have #32846 merged by a merger since it's blocking our gsod contributor
18:24:13 <nickm> the branch to merge is PR 1643?
18:24:26 <dgoulet> that ticket doesn't have a milestone
18:24:37 <dgoulet> that fell off my radar because of that
18:24:45 <catalyst> nickm: yes
18:24:59 <nickm> merging now.  Do I close when I'm done?
18:25:26 <ahf> thanks nickm
18:25:35 <nickm> done
18:25:36 <catalyst> nickm: thanks
18:25:54 <catalyst> nickm: go ahead and close it; i just checked that the new tickets are linked properly
18:26:29 <ahf> i don't see any other discussion points?
18:26:45 <ahf> does anybody have anything else we need to chat about today?
18:26:50 <dgoulet> yes
18:26:57 <ahf> go
18:27:00 <dgoulet> ah nvm, I can do it after meeting,
18:27:10 <dgoulet> (was just about to point something to someone)
18:27:15 <ahf> okay!
18:27:23 <ahf> if nobody else have anything i'm gonna close the meeting log
18:27:46 <ahf> ok!
18:27:48 <ahf> #endmeeting