15:59:40 <ggus> #startmeeting Community Team meeting 08/12/2019
15:59:40 <MeetBot> Meeting started Mon Aug 12 15:59:40 2019 UTC.  The chair is ggus. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:59:40 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:59:58 <ggus> hi all! let's start updating our pad: https://pad.riseup.net/p/tor-community-team-2019-keep
16:06:50 <emmapeel> hmmm i cannot seem to load that page
16:06:56 <emmapeel> to be able to
16:09:58 <ggus> it's working here
16:10:19 <ggus> try to refresh
16:11:13 <emmapeel> hmm
16:13:00 <ggus> emmapeel: it gives you an error message?
16:13:17 <emmapeel> not srue. i changed circuits, identity, restarted the browser, disabled ublock
16:15:11 <emmapeel> ooh, nice
16:15:28 <ggus> worked?
16:15:29 <emmapeel> now it works. just another random reload, i havent done anything else
16:19:00 <ggus> let's go, today we have ticket triage for the docshackathon
16:19:08 <ggus> https://trac.torproject.org/projects/tor/ticket/30923
16:19:46 <ggus> as you can see, I migrated this one to dip.
16:19:52 <antonela> \o/
16:20:16 <antonela> what is your plan? pick yes/no tickets for the docshakaton or assign tickets to someone?
16:20:29 <clash> possible to include a link to support.tpo source in that ticket?
16:20:30 <ggus> https://dip.torproject.org/web/support/issues?label_name%5B%5D=DocsHackathon
16:20:49 <ggus> antonela: yes/no tickets
16:20:54 <antonela> ggus: perfect
16:21:09 <ggus> so we can check what else we need to create
16:24:12 <ggus> https://trac.torproject.org/projects/tor/ticket/20537
16:24:19 <emmapeel> if we could make sure that everybody can open an account in dip.tpo before the hackathon that would be great, because we could do merge requests there and not having to use github
16:24:26 <emmapeel> maybe i should open a ticket about that
16:25:35 <ggus> emmapeel: let me open inside community meta repo
16:25:44 <clash> Oh so dip houses the source code as well. That's so much better than trac
16:26:17 <ggus> emmapeel: but people need to ask
16:26:34 <emmapeel> clash: yes but it is only a mirror repo, the canonical repos are still https://gitweb.torproject.org/project/web/community.git etc
16:26:45 <clash> got it
16:26:51 <ggus> https://trac.torproject.org/projects/tor/ticket/27621
16:26:55 <ggus> i'm closing this one
16:27:02 <emmapeel> ggus: people need to ask to who?
16:27:56 <ggus> emmapeel: pili/gaba
16:28:44 <clash> is that scalable? If there's a lot of requests initially then it might be very slow
16:29:18 <emmapeel> yeah. i rather send people to fork on github then
16:29:53 <clash> the github ones are a mirror too?
16:30:26 <clash> most people are familiar with github so that might not be so bad from user perspective
16:30:35 <ggus> https://trac.torproject.org/projects/tor/ticket/28776
16:31:37 <emmapeel> ggus: so, are you just copying the isssue from one bugtracker to the other? do you have a list of issues somewhere?
16:31:42 <emmapeel> to sort?
16:32:37 <ggus> emmapeel: yes for your first question
16:32:46 <ggus> for example: https://trac.torproject.org/projects/tor/ticket/28776#comment:1
16:33:12 <ggus> I'm picking from: https://trac.torproject.org/projects/tor/report/57?asc=True&page=25
16:33:42 <emmapeel> ah ok!
16:33:57 <emmapeel> so, we can choose from that list the ones we think should go for the hackathon?
16:34:04 <emmapeel> and we propose here?
16:34:52 <ggus> yes
16:35:36 <emmapeel> i propose #20928 for the hackathon
16:36:04 <emmapeel> it has a lot of information on the ticket and can keep a contributor busy for a while :D
16:36:12 <clash> I was going to post that too :P
16:36:23 <emmapeel> ha!
16:36:58 <emmapeel> btw ggus maybe we can close https://trac.torproject.org/projects/tor/ticket/30312 ?
16:37:20 <clash> https://trac.torproject.org/projects/tor/ticket/25198 this one maybe?
16:37:22 <ggus> emmapeel: but how an outside person will write about internal sysadmin configuration?
16:37:35 <emmapeel> by reading the links there
16:37:40 <emmapeel> and finding out
16:37:45 <emmapeel> it is public i think
16:38:04 <ggus> IMHO, out of scope, we should focus on our users
16:38:23 <emmapeel> #30900 for the bridge quide too
16:38:44 <emmapeel> relay guide sorry
16:39:04 <ggus> tor#30312 < let's close this one
16:39:12 <ggus> tor#25198 +1!
16:39:17 <ggus> tor#30900 +1
16:39:26 <clash> #23809 could be done
16:40:15 <clash> https://trac.torproject.org/projects/tor/ticket/28475 this is quite valid as well since there's TBA now.
16:42:24 <ggus> https://trac.torproject.org/projects/tor/ticket/28475#comment:3
16:42:44 <emmapeel> #30690 is easy too, i think, if you are a gpl person...
16:43:33 <antonela> we can do it in the repo, will take it
16:43:48 <emmapeel> ok!
16:44:16 <ggus> clash: the problem framing with "raspberry" is that it's a platform and not an operating system
16:44:17 <emmapeel> yeah we should add more licensing information everywhre
16:45:12 <clash> ggus: might work for Raspbian then
16:46:32 <ggus> https://trac.torproject.org/projects/tor/ticket/30083
16:46:54 <emmapeel> i have done some of this, but more cleaning up should be done
16:47:02 <emmapeel> or maybe we dont need to have duplicated questions
16:47:19 <emmapeel> i mea, we have one question in misc and faq.... not sure that is needed
16:47:34 <emmapeel> like, the same question
16:47:45 <ggus> yep, we need to review for duplicated questions
16:48:00 <emmapeel> i am not sure that ticket is for somebody that is new to the whole body of content we have
16:48:23 <emmapeel> it would be something more suitable for somebody that knows more the different support pages, etc... a long term volunteer i think
16:48:31 <ggus> yep
16:48:54 <ggus> https://trac.torproject.org/projects/tor/ticket/28154
16:49:12 <antonela> +1
16:49:23 <cy63113> emmapeel:  i can do this.... but how?
16:49:36 <antonela> i can provide good looking .pngs for #28154
16:50:15 <ggus> https://dip.torproject.org/web/support/issues/9
16:51:22 <emmapeel> cy63113: well if you see something repeated, delete one option! :D and look if there are any broken links or similar on other pages afterwards... i dont know. maybe we should ask for ideas. but duplicated content is not good
16:52:08 <ggus> https://trac.torproject.org/projects/tor/ticket/27514
16:55:31 <ggus> ok, we have more 5 minutes
16:56:30 <ggus> #action continue support ticket triage to docshackathon https://trac.torproject.org/projects/tor/query?status=accepted&status=assigned&status=merge_ready&status=needs_information&status=needs_review&status=needs_revision&status=new&status=reopened&component=Community%2FTor+Support&order=priority
16:56:49 <antonela> and
16:56:50 <antonela> https://trac.torproject.org/projects/tor/query?status=accepted&status=assigned&status=merge_ready&status=needs_information&status=needs_review&status=needs_revision&status=new&status=reopened&component=Community%2FTor+Browser+Manual&order=priority
16:57:22 <emmapeel> #24872 looks cool
16:57:30 <ggus> #action and tb manual https://trac.torproject.org/projects/tor/query?status=accepted&status=assigned&status=merge_ready&status=needs_information&status=needs_review&status=needs_revision&status=new&status=reopened&component=Community%2FTor+Support&order=priority
16:58:03 <ggus> let's continue in #tor-www
16:58:20 <ggus> emmapeel: IMHO, trac fix is out of scope too
16:58:25 <antonela> thanks ggus! exciting that we are moving this forward!
16:59:04 <ggus> thanks all! :)
16:59:07 <ggus> #endmeeting